probleme installation version anterieure itunes

jeanboiteux

Nouveau membre
24 Août 2007
1
0
salut,

j'ai entrepris de reinstaller une ancienne version d'itunes ainsi que l'ipod software updater, j'ai trouve les 2 programmes mais quand j'installe itunes 6.0.4, au moment d'installer, juste apres le choix de la destination, je ne trouve que des coquilles vides et un message d'erreur: "impossible... rien a installer".
Peut etre que j'ai fait une connerie en effacant de mon ordi tous les repertoires Itunes, je sais pas.

J'espere que j'ai ete clair et que quelqu'un comprendra et sera en mesure de m'aider...

Merci d'avance
 

pascalformac

Légende
Club MacG
23 Novembre 2003
58 699
1 814
bonjour

verifier et enlever les receipts itunes

dans systeme/ bibliotheque/ Receipts

normalement il y a au moins itunesX.pkg
 

hippo sulfite

Papy gateau
Club MacG
12 Avril 2003
7 101
1 456
Eaubonne (Meilleur le vin)
salut,

j'ai entrepris de reinstaller une ancienne version d'itunes ainsi que l'ipod software updater, j'ai trouve les 2 programmes mais quand j'installe itunes 6.0.4, au moment d'installer, juste apres le choix de la destination, je ne trouve que des coquilles vides et un message d'erreur: "impossible... rien a installer".
Peut etre que j'ai fait une connerie en effacant de mon ordi tous les repertoires Itunes, je sais pas.

J'espere que j'ai ete clair et que quelqu'un comprendra et sera en mesure de m'aider...

Merci d'avance
Salut et bienvenue sur le forum.

Si tu fais référence aux fichiers .pkg qui sont dans Library/receipts, c'est normal, ce ne sont que des coquilles vides qui sont utilisées pour identifier les mises à jour déjà effectuées.

Par contre, si tu souhaites revenir en arrière, il faut, à l'inverse, retirer, de Receipts, les .pkg des versions supérieures ou égale à celle de l'application que tu veux réinstaller et la télé-charger sur le site Apple.

Edit : décidément, je vais user mon grille-pain. et coup de boule toujours refusé.
 

vertefille

Membre junior
4 Mai 2006
15
2
36
Salut et bienvenue sur le forum.

Si tu fais référence aux fichiers .pkg qui sont dans Library/receipts, c'est normal, ce ne sont que des coquilles vides qui sont utilisées pour identifier les mises à jour déjà effectuées.

Par contre, si tu souhaites revenir en arrière, il faut, à l'inverse, retirer, de Receipts, les .pkg des versions supérieures ou égale à celle de l'application que tu veux réinstaller et la télé-charger sur le site Apple.

Edit : décidément, je vais user mon grille-pain. et coup de boule toujours refusé.

Bonjour!

J'ai le même problème mais même en enlevant les receipts cela ne fonctionne pas. Peut-être est-ce parce que je n'ai pas vidée la corbeille? Sinon j'ai regardé sur le site apple et impossible de trouver les anciennes versions de itunes (je les ai trouvées sur un autre site)...

Mon problème est que j'ai téléchargé la dernière version de itunes et qu'à présent celui- ci ne veut plus fonctionner car je cite "itunes requiert mac os x 10.4.7". :mouais:
J'aimerai retrouver une version itunes compatible avec mon système d'exploitation mais après l'installation de l'ancienne version, itunes conserve la plus récente...

Quelqu'un peut-il m'aider?
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 489
4 286
58
St Germain en Laye - FRANCE
Quelle version de MacOS X utilises-tu?

Si tu es en 10.4.x, je te suggère de faire les mises à jour pour passer en 10.4.11

Si tu es en 10.3.x, je suis surpris du message... car j'ai un vieux POwerbook en 10.3.9 et j'ai pu installer iTunes 7.5 (pas encore essayé 7.6)
 

hippo sulfite

Papy gateau
Club MacG
12 Avril 2003
7 101
1 456
Eaubonne (Meilleur le vin)
Bonjour!

Sinon j'ai regardé sur le site apple et impossible de trouver les anciennes versions de itunes (je les ai trouvées sur un autre site)...
Tss Tss, regarde mieux le site d'Apple comme par exemple ici. ;)

Quand à l'installation d'une ancienne version, il faut bien sur déplacer le paquet hors du dossier receipts mais il faut aussi avoir désinstallé complètement la version dont on veut se débarrasser.
 

hippo sulfite

Papy gateau
Club MacG
12 Avril 2003
7 101
1 456
Eaubonne (Meilleur le vin)
Quelle version de MacOS X utilises-tu?

Si tu es en 10.4.x, je te suggère de faire les mises à jour pour passer en 10.4.11

Si tu es en 10.3.x, je suis surpris du message... car j'ai un vieux POwerbook en 10.3.9 et j'ai pu installer iTunes 7.5 (pas encore essayé 7.6)
Bien sur, remy a raison, sur le site d'Apple, la 7.5 est donnée comme fonctionnant avec Panther minimum 10.3.9.
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 489
4 286
58
St Germain en Laye - FRANCE

pascalformac

Légende
Club MacG
23 Novembre 2003
58 699
1 814
coucou remy
Que trouves tu d'ambigu?
C'est clair non?
OS panther ou tiger ou leopard à jour

tu te souviens avoir vu des requirements récents avec des infos genre 10.3.4 , 10.4 .5 etc?

ceci dit c'est du bon sens d'assumer un OS à jour

ps la 7.6 (29) marche sans souci sur panther

( quoique je me demande si la gestion niveau sonore n'a pas changé,
comparé avec d'autres media players il me semble devoir, sur itunes, monter le curseur volume plus haut pour avoir le même volume percu
Rien de sûr encore , faudra que je teste en détail )
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 489
4 286
58
St Germain en Laye - FRANCE
ce que je trouve curieux c'est que ça marche avec 10.3.9, mais a priori ça ne marche plus avec 10.4.0, 10.4.1 etc jusqu'à 10.4.8... quant à Leopard, ils n'en parlent même pas.Il eut été logique d'indiquer 10.3.9, or 10.4.9, or 10.5.0

Mais bon de toutes façons on a intérêt à avoir une version soit de Panther soit de Tiger à jour donc 10.3.9 ou 10.4.11 ou 10.5.4 (enfin quand elle sera disponible bien sûr)
 

pascalformac

Légende
Club MacG
23 Novembre 2003
58 699
1 814
relis
il est dit 10.4.9 and above
or qu'y t il above?
10.4.10
10.4.11
et...
la serie leopard
( sauf si tu consifdère que 10.5 serait sous tiger :D )

Quant à ta remarque- judicieuse- du 10.3.9 et 10.4.9

une des hypothèses possibles
que cette version d'itunes necessite un élément apporté par une mise à jour apparue à 10.4.9 et pas avant
et je songe par exemple à mise à jour génerale touchant tout l'OS , du genre " os x" ou "de sécurité"
( et à ce titre bien que 10.3.9 n'évolue plus comme OS , il y a toujours des mises à jour génerales qui lui sont appliquées)
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 489
4 286
58
St Germain en Laye - FRANCE
Tu es d'une logique implacable mon cher Pascal. :up:
 

vertefille

Membre junior
4 Mai 2006
15
2
36
Bonjour!

Merci beaucoup pour ces réponses! et désolée de ne réagir que si tard. Je m'attendais à recevoir un message lorsque quelqu'un me répondrai. Je ferai plus attention maintenant.


Remy:
Apparement mon système d'exploitation est 10.4.4 mais j'ai un souci pour les mises à jour et un aveu à faire:
j'ai tiger mais piraté et je suppose que je ne peux donc pas faire de mises à jour. Je ne peux m'en prendre qu'à moi-même c'est vrai...

En tout cas je suis parvenue à récupérer l'ancienne version de Itunes en effaçant complètement l'ancienne (sauf la bibliothèque biensûr).
À ce sujet, y a t-il un autre moyen pour désinstaller que de jeter tout les fichiers liés à Itunes? Cela me parait risqué mais en me renseignant j'ai lu que c'était le seul moyen...


Hippo sulfite:
Effectivement Itunes est dispo en versions antérieures sur le site de mac... mais à ma décharge j'avais vraiment cherché!
 

pascalformac

Légende
Club MacG
23 Novembre 2003
58 699
1 814
Bonjour!

Merci beaucoup pour ces réponses! et désolée de ne réagir que si tard. Je m'attendais à recevoir un message lorsque quelqu'un me répondrai. Je ferai plus attention maintenant.
Mais tu peux !
Si tu le demandes
(voir en haut outils de discussion et les modes d'abonnement, par réponse ou par jour etc)

À ce sujet, y a t-il un autre moyen pour désinstaller que de jeter tout les fichiers liés à Itunes? Cela me parait risqué mais en me renseignant j'ai lu que c'était le seul moyen...
Dans un premier temps ne PAS jeter
mais déplacer vers un dossier ailleurs ( genre "réparation de l'appli bidule")
Et après réparation si tout roule tu jettes
 

vertefille

Membre junior
4 Mai 2006
15
2
36
Mais tu peux !
Si tu le demandes
(voir en haut outils de discussion et les modes d'abonnement, par réponse ou par jour etc)


Dans un premier temps ne PAS jeter
mais déplacer vers un dossier ailleurs ( genre "réparation de l'appli bidule")
Et après réparation si tout roule tu jettes

Oui j'ai vu que je pouvais demander ça après coup. J'ai changé mes préférences mais j'ai dû faire une erreur car je n'ai encore pas reçu de message...

Ok je ferai un dossier "réparation" la prochaine fois. Heureusement tout fonctionne quand même! :D

Merci pour tes réponses!