Problème RewriteEngine

loganblack

Nouveau membre
22 Janvier 2007
3
0
Bonjour, voici mon problème.

Sous tiger avec config apache de base et php 5.2.2 d'entropy.ch, lorsque que je met un .htaccess dans un répertoire sous http://localhost/~nom_user/rep_avec_htaccess et que je met le code suivant dedans :

Bloc de code:
RewriteEngine on
RewriteRule .* index.php

php_flag magic_quotes_gpc off
php_flag register_globals	 off

j'ai une erreur 403 - you don't have permission... lorsque j'essai d'accéder à ce répertoire.
Par contre je peux accéder a http://localhost/~nom_user/autre_site/ sans problème.

Si je met RewriteEngine Off, alors je peux accéder au répertoire !!
Je n'arrive pas à comprendre d'ou peut provenir le problème, si quelqu'un a une idée, encore merci.
 
A

Anonyme

Invité
Je ne m'y connais pas en mod_rewrite mais ta règle m'a l'air éronnée... Si je comprends bien tu fais un truc du genre : prendre tout ce qui dans le répertoire et en faire un index.php. Alors forcément ça déconne... ;)
 
A

Anonyme

Invité
Tiens voici un exemple avec dotclear dont le index.php a été renommé en blog.php et on veut le faire disparaître :

Bloc de code:
RewriteEngine On
RewriteCond %{REQUEST_URI} !dotclear
RewriteCond %{REQUEST_URI} !blog
RewriteRule (.*)$ /blog.php/$1

Source

P.S. : j'ai dit une connerie dans mon post précédent à propos de ta règle... :rose: Mais elle est fausse quand même... ;)
 

loganblack

Nouveau membre
22 Janvier 2007
3
0
Merci pour ta réponse mais la règle m'est donné par un tutorial sur le Zend Framework donc pas de soucis de ce côté la ;) .

Par contre dans mon error log apache il em dit que sans l'option followSymLink le rewrite rules ne peut fonctionner. Donc je l'ai rajouté, et les message d'erreur change :D

Maintenant il ne trouve pas le fichier demandé.

Enfait il recherche maintenant mon fichier dans la racine complete documentRoot + userdocument root.
Je m'explique :p, mon document root apache est dans /Library/WebServer/Documents/ alors que mon documentRoot en tant que user est dans /Users/nom_user/Sites/ or ici il recherche mon fichier index.php dans /Library/WebServer/Documents/Users/nom_user/Sites/ au lieu de /Users/nom_user/Sites/.

Je vais continué de chercher, mais si une idée vous vient :love: