Problème SMTP sous Mavericks

grippin

Nouveau membre
21 Octobre 2005
3
0
Bonjour,

Je viens d'effectuer la mise à jour et j'ai un problème avec l'envoi de mes mails sous Mail. Ma messagerie est hébergée chez OVH et à priori mes anciens paramètres SMTP ne fonctionnent plus! Quelqu'un a-t-il rencontré ce problème et surtout a-t-il une solution ?

Merci !

Hervé.
 

Herve747

Nouveau membre
24 Août 2012
7
1
Salut

Idem. Migration de Moutain Lion vers Mavericks le 23. Et depuis mail fonctionne mal. Pire mes smtp OVH restent perpétuellement déconnectés. Un peu gênant quand même pour répondre à ses clients :mad:
Heureusement qu'il y a d'autres ibidules.
De plus la synchro se fait mal entre le mac et les autres ibidules sachant que je suis sur mes 3 comptes en imap.
J'espère qu'ils vont s'activer pour résoudre la question et prévoir une mise à jour.
Très déçu par ailleurs que Mavericks n'intègre toujours pas d'accusés de réception voire de lecture dans mail comme c'est le cas dans Outlook. Un peu gênant pour les pro.

Un pb de Hervé peut être ? ;-P
 

creapple

Nouveau membre
29 Octobre 2013
3
0
Hello,

La solution qui a fonctionné pour moi (étant également chez ovh) a consisté à supprimer tous mes serveurs SMTP dans les préférences de Mail (y compris tous les gmail, qui même s'ils fonctionnaient bien, affichaient quand même une erreur de connexion smtp).

Dans Mail : Préférences > Onglet Comptes > Données du compte > dans le menu déroulant Serveur d'envoi (SMTP) > Modifier la liste des serveurs SMTP.

Dans la nouvelle fenêtre, supprimer un par un tous les serveurs SMTP. (Pour assurer un peu mes arrières et parce que ça ne mange pas de pain, j'ai quitté et redémarré Mail). Dans cette même fenêtre recréer vos serveurs d'envoi.

Chez OVH :
- nom du serveur : ns0.ovh.net
- certificat TLS : aucune
- port : 587
- authentification : mot de passe

En espérant que cela fonctionnera aussi pour vous :up:
 

jcezanna54

Membre confirmé
3 Septembre 2005
301
9
69
Une solution consiste à utiliser les serveurs SMTP de votre fournisseur d'accés internet.
Certain FAI l'exige pour pouvoir mieux répondre éventuellement à une requête des forces publiques. Ils pose alors un filtre sur les envoi SMTP.
 

creapple

Nouveau membre
29 Octobre 2013
3
0
De mon côté, décocher le SSL n'a pas suffi.
Ni créer un autre serveur d'envoi avec les mêmes spécificités que les autres (en testant différents ports quand même).
Seule la suppression de toutes les anciennes configs smtp et la création de nouvelles a fonctionné pour ma part :confused:
 

Herve747

Nouveau membre
24 Août 2012
7
1
Merci à tous. J'ai opté pour la solution de Creapple et ça a fonctionné.
Effectivement si on re-coche SSL ça ne fonctionne plus. Je vais donc essayer de voir directement avec OVH s'ils travaillent sur une solution pour régler la question.
 

job_paris

Nouveau membre
29 Octobre 2013
1
0
42
Hello à tous,

Pour ma part, après une ré-install complète de tous mes comptes e-mail (une dizaine), seuls les comptes gmail fonctionnent.
J'ai tout essayé, (avec/sans ssl, avec changement de port...), mais j'ai 4 comptes hébergés chez Claranet, Oxyd et Infomaniak dont le smtp ne répond plus.
Ce qui me choque le plus, c'est que je ne trouve rien sur le support d'Apple...
C'est sensé être la boite la plus pro du monde, on dépense des fortunes dans leur hard et leurs soft, et ils sont pas f**** de sortir des versions clean... c'est hallucinant...
en attendant une solution, je continue de cracher mon venin...
vous me direz, un serpent qui crache sur une pomme, la boucle est bouclé
 

creapple

Nouveau membre
29 Octobre 2013
3
0
As-tu bien complètement supprimé tous tes serveurs smtp qui étaient dans ton Mail avant de les configurer à nouveau ?
Je sais que lorsque j'ai voulu créer une nouvelle config smtp, sans supprimer les anciennes, ça ne marchait pas, d'où ma question ...
 

fdboucher

Nouveau membre
6 Octobre 2008
2
0
Le protocole SMTP se présente sous deux formes dont une avec un " ID d'autorisation " où vous envoyez un nom d'identification, et un mot de passe. Sous Mavericks, Mail essaie toujours la forme avec autorisation d'abord, avec l'ID d'autorisation identique à la personne qui envoie le courrier ( j'ai vérifié le RFC et c'est effectivement très bien). Si cela échoue, il tente à nouveau de l'autre façon.

Exim, un serveur SMTP très populaire, ne permet que la deuxième forme, sans ID, de sorte qu'il génère une erreur sur le premier essai, mais réussit au suivant. Donc, à chaque fois qu'un message est envoyé, et/ou que Mavericks vérifie si le serveur SMTP fonctionne (ce qu'il semble faire souvent ), une erreur est générée par Exim, puis il réussit la fois suivante.

De nombreux FAI utilisent un programme tel que fail2ban, qui limite le nombre d'échecs SMTP autorisé par adresse IP. Donc, après un moment, fail2ban bloque le port SMTP de votre adresse IP (parfois temporairement, ce qui rend de ce problème si difficile à traquer).

Si le courrier sortant fonctionne à l'occasion, vous pouvez confirmer que vous avez ce problème en allant dans Fenêtre> Diagnostic de connexion et vérifier en cliquant sur "réessayer" à plusieurs reprises: après un certain temps, vous verrez les connexions défaillantes par intermittence.

Solution: Vous devrez convaincre votre FAI de reconfigurer Exim ou d'éteindre fail2ban. Je ne pense pas que Apple va corriger ce problème, puisque Exim semble être en cause ici. J'ai réussi à convaincre mon FAI de modifier Exim , mais cela a pris énormément de temps . Bonne chance à tous .