Problèmes de configuration réseau Airport Extreme + Express

Pat1763

Membre émérite
11 Août 2008
507
17
La Rochelle (17)
Bonjour à tous,

Je précise tout de suite que je ne connais pas grand chose à l'installation de réseaux... :shy:

Je dispose de deux bornes Airport Extreme 802.11n de 5ème génération (dixit Airport) ainsi que d'une borne Airport Express 802.11n de 2ème génération (même source).

J'ai configuré mon réseau de manière entièrement automatique... du fait de mon ignorance technique en la matière. J'habite aux Emirats (Dubai); nous n'avons pas de box comme en Europe, mais des connexions murales reliées à un routeur installé dans l'entrée de l'appartement (le tout appartenant au FAI). Ce routeur est ensuite relié au réseau du FAI.

La configuration est la suivante :

  1. Dans la chambre principale se trouve une des deux bornes Extrême. Reliée en RJ45 à la prise murale, le Mac Mini que j'utilise le plus souvent étant relié à la borne Extrême en filaire.
  2. Dans le salon, à l'autre bout de l'appartement, se trouve la borne Express; je l'ai achetée récemment pour bénéficier de AirPlay. Elle est également branchée à une prise murale en RJ45.
  3. Dans la chambre d'amis, la deuxième Extrême, reliée en WiFI à la première extrême (mode étendu). L'imprimante réseau lui est connectée en RJ45.

Les trois bornes sont reliées sur le même réseau, que j'ai nommé moi-même.

Les difficultés rencontrées sont les suivantes :
  • Parfois (mais pas souvent), l'imprimante n'est plus reconnue sur le réseau. Il suffit habituellement de déconnecter et reconnecter l'Extrême pour que cela rentre dans l'ordre.
  • Souvent l'iPhone 6 ne capte pas le réseau dans le salon, ne reconnaissant par l'Express (qui pourtant s'allume en vert). L'iPad lui n'a pas de souci.
  • L'enceinte sans file (B&W Zepellin Air), également dans le salon, a parfois du mal à se connecter sur le réseau.
  • Lors que je souhaite écouter la radio en streaming, il m'est impossible de me connecter à la fois à l'app et à l'enceinte sans fil : c'est soit l'un, soit l'autre...
  • En revanche, il n'y a jamais de difficultés liée à l'Extrême installée dans la chambre principale.

J'ai l'impression qu'il y a un conflit quelque part, mais une fois encore je n'y connais rien. Quand je vais sur Airport Utility, tout semble normal...

Pouvez-vous m'indiquer comment procéder pour essayer d'identifier la source du problème, et comment le régler ?

Merci d'avance ! :merci:
 
Dernière édition:

Ma Dalton

Membre d’élite
4 Avril 2015
1 284
269
64
Bonjour,

il est indispensable que pour chaque borne, tu fournisses les informations concernant :

1. le mode "sans fil" : "Créer un réseau" ou "Etendre un réseau" ou "Rejoindre un réseau"

2. la configuration "réseau" : "Mode routeur : "

3. les canaux wifi utilisés si plus que une borne "crée un réseau".

Je suppose que pour "Internet" tout est en DHCP.
 

Pat1763

Membre émérite
11 Août 2008
507
17
La Rochelle (17)
Bonjour Ma Dalton, merci pour ton aide ! :merci:

Je comprends donc qu'il vaut mieux reprendre mon réseau à zéro (réinitialisation en "Factory Default Reset") et ensuite :
  • Pour l'extrême et l'express reliées en filaire (RJ45), les déclarer en mode routeur / bridge mode.
  • Pour l'extrême en wi fi, la brancher en "étendre un réseau".

Par ailleurs, j'ai lu en farfouillant sur le net que si les laptops et les iPads se branchaient sans problème, c'était un peu plus difficile pour les iPhones à moins de passer en 2.5 Ghz. Est-ce exact ? Cela se produit chez moi en tout cas... Il me semblait que les Airports fonctionnaient sur les deux fréquences à la fois ? Est-ce qu'il y a un risque d'interférence avec les téléphones fonctionnant en DECT?

Désolé si mes questions sont stupides, mais je suis une vraie quiche quand il s'agit de réseaux... :dead:
 

Ma Dalton

Membre d’élite
4 Avril 2015
1 284
269
64
Je comprends donc qu'il vaut mieux reprendre mon réseau à zéro
Bonjour,

je n'ai rien dit de tel, je t'ai proposé de fournir les informations sur la configuration actuelle pour comprendre où est le problème.

Pour chaque borne il y a 3 paramètres essentiels, qui sont :

- le mode wifi
- le mode "réseau"
- la configuration "Internet"

Si on a pas ces infos, on ne peut rien dire.
 

Pat1763

Membre émérite
11 Août 2008
507
17
La Rochelle (17)
OK, désolé de ma méprise... :muted:

De mémoire, la création du réseau s'est faite à partir de l'Extrême reliée en filaire (à laquelle mon Mac Mini est également relié en filaire). Je pense que pour l'extrême en WiFi, j'avais du étendre le réseau. Je l'avais placée près de l'Extrême, pour en faciliter la "découverte", et je l'ai ensuite replacée dans la chambre d'amis une fois configurée.

Concernant l'Express en filaire... je ne suis pas sûr en fait. Est-ce qu'il y a un moyen de déterminer a posteriori comment la déclaration dans le réseau a été faite ?

Merci de ton aide... et de ta patience... :merci:
 

Ma Dalton

Membre d’élite
4 Avril 2015
1 284
269
64
Il faut que tu ouvres Utilitaire Airport.

Pour chaque borne, tu regardes dans les onglets : Internet, Sans fil, et Réseau.
(clique sur "modifier" pour y accéder)

Les infos à relever :

Internet : Connexion via : ?
Sans fil : Mode réseau : ?
Réseau : Mode routeur : ?

Signale si une borne ou plus montre un point rouge dans Utilitaire Airport, et si oui, de quelle alerte il s'agit.
Par exemple : "Double NAT".
 

Pat1763

Membre émérite
11 Août 2008
507
17
La Rochelle (17)
Après vérification, certains points sont communs à toutes les Airport :
  • les 3 bornes sont à jour au niveau du Firmware (7.6.4).
  • les 3 bornes sont en mode WPA2 personnel.
  • les 3 bornes sont déclarées en France (à mon avis, cela peut être un problème car les fréquences dispos ne sont pas forcément les mêmes aux Emirats). J'ai essayé de changer en "Emirats Arabes Unis" sur l'une d'entre elle, mais cela revient toujours sur "France".

Ensuite, certains points varient :
  • la principale (première, Extrême), ainsi que la troisième (Express) toutes deux reliées en filaire, sont en "Créer un réseau sans fil". La deuxième (Extrême), en mode Wifi, est en "étendre une réseau sans fil".
  • la première (Extrême RJ45) est en "mode routeur", "DHCP et NAT"; "activer NAT-PMP" est actif.
  • la deuxième (Extrême WiFi)est en DHCP.
  • la troisième (Express RJ45) : "mode routeur désactivé", "AirPlay" activé.
J'espère avoir relevé toutes les informations nécessaires... Merci par avance pour toute suggestion sur la marche à suivre ! :merci:
 
Dernière édition:

Ma Dalton

Membre d’élite
4 Avril 2015
1 284
269
64
Coucou,

Wifi : les deux bornes reliées par Ethernet "créent un réseau" : c'est OK
Il faut que les 2 bornes utilisent :
- le même nom du réseau sans fil
- la même sécurité (WPA2 personnel)
- le même mot de passe
- des canaux wifi différents et éloignés les uns des autres : laisse sur Automatique et ça se fera tout seul
(Options d'accès sans fil)

Pour Extreme 2, tu conserves "étendre".

Internet :
- connexion via : DHCP pour les 3 bornes
Plus tard si tu veux optimiser tu pourras mettre des IP fixes, mais c'est facultatif.

Réseau :
C'est là qu'il y a une erreur.

Dans ton réseau tu as déjà un routeur (celui du FAI), qui route et est serveur DHCP (donne des adresses IP aux appareils connectés).
En ayant la première Extrême en mode routeur DHCP + NAT, tu introduis un deuxième routeur qui lui aussi distribue des adresses IP (*)... pataques...

Donc : pour Extreme 1 et Express : mode routeur désactivé (mode pont).

Tu n'as pas besoin de reseter la borne, tu fais la modif dans utilitaire Airport et tu appliques ("Mettre à jour").

Tu peux laisser les bornes "en France", ce n'est pas un problème.

(*) normalement tu devrais voir dans UA la mention "double NAT" (= 2 routeurs en cascade)
 
Dernière édition:

Pat1763

Membre émérite
11 Août 2008
507
17
La Rochelle (17)
Merci Ma Dalton... :coucou:

La seule chose qui n'était pas conforme par rapport à ton descriptif était l'Extrême 1, dont j'ai désactivé le mode routeur. Cela a complètement bloqué le réseau... Heureusement que mon Mini est connecté en filaire, j'ai pu revenir sur le changement. J'ai d'abord essayé le mode routeur en DHCP seul, ce qui m'a donné un message d'erreur m'empêchant de valider. Je suis revenu au mode DHCP + NAT; et c'est rentré dans l'ordre... Sans bien sûr régler mes problèmes pré-existants.

Peut-être faut-il préciser que l'accès à Internet est censuré aux Emirats : les FAI ont installé des proxys en amont de l'accès aux utilisateurs, pour permettre de filtrer les sites interdits. Est-ce que ceci pourrait expliquer cela ?

Je suis perdu... :(
 

Ma Dalton

Membre d’élite
4 Avril 2015
1 284
269
64
Avant d'éclaircir tout, une remarque : si l'Extreme 1 ne peut pas être utilisée autrement qu'en mode routeur, ça veut dire que l'Express, qui n'est pas en mode routeur, ne fonctionne pas non plus...

Si tu connectes le Mac directement dans la prise Ethernet murale, as-tu accès à Internet ?

Le "routeur" du FAI, c'est bien un routeur ? A-t-il du wifi ?
 

Pat1763

Membre émérite
11 Août 2008
507
17
La Rochelle (17)
L'Express fonctionne mais mal. La LED est verte, donc reçoit Internet, mais elle le transmet mal...

Pour le Mini, oui, il fonctionne si directement raccordé à la prise murale.

En y réfléchissant bien, ce que j'ai appelé un routeur est plutôt un switch, qui permet de raccorder les différentes prises murales au réseau du FAI. Nous pouvons en avoir 6 de raccordée : 2 pour Internet, 2 pour la télé par câble (qui nécessite un décodeur à part), et 2 pour la téléphonie filaire (du bon vieux PSTN).

Ledit switch n'a pas de Wifi, donc tu as eu raison de soulever ce point... il ne s'agit pas d'un routeur. Mea culpa... :banghead:
 

Ma Dalton

Membre d’élite
4 Avril 2015
1 284
269
64
Evidemment je ne connais pas particularités des EAU.

Normalement, si tu as un switch et plusieurs prises Ethernet murales disponibles, il y a un routeur en amont.

Tu pourrais connecter le Mac directement dans la prise murale, et donner copie de Préférences système / Réseau pour voir les paramètres de la connexion, ça aidera à comprendre.

Ensuite, j'ai oublié de dire : comme tu vas modifier Extreme 1, il faut que éteignes les autres bornes.

Normalement, si tu as Internet connecté direct dans le mur, tu dois l'avoir AUSSI connecté à Extreme 1 en mode pont.
Pourquoi ?
Parce que une Extreme en mode pont, c'est un switch Ethernet + un point d'accès wifi.
Donc je répète : éteins les autres bornes, configure EXTR1 en mode pont, tu dois avoir accès à Internet avec le mini en filaire.

Est-ce le cas ?

(pause diner jusqu'à 21H locale)
 

Pat1763

Membre émérite
11 Août 2008
507
17
La Rochelle (17)
J'ai configuré l'Express comme l'Extrême 1, en "mode routeur", "DHCP et NAT". Cela marche... J'arrive à connecter l'iPhone à l'enceinte AirPlay. Au passage, quand je suis revenu sur mon Mini (donc relié à l'Extrême 1), il a indiqué qu'il y avait eu une autre connexion utilisant la même adresse réseau. J'ai cliqué dessus (j'aurais du noter ce qui était indiqué), et j'ai ressayé sur l'Express, qui semble toujours bien marcher. Je n'ai plus eu le message d'erreur, j'imagine que les Airports ont du s'arranger entre elles.

Je vais laisser pour ce soir (22h13 en heure locale) et je re-essairai demain pour voir si tout va bien. Sinon, je suivrai ta procédure...

Merci pour tout ! :merci:
 

Ma Dalton

Membre d’élite
4 Avril 2015
1 284
269
64
Tu as configuré Extreme 1 et Express comme routeurs, et oui ça peut marcher comme ça.

Mais tu as créé 2 réseaux distincts, indépendants, ce n'est pas ce qu'on cherche à faire dans un réseau domestique.
Par exemple, tu ne vois pas l'Airplay depuis le Mac mini.
Un client wifi connecté à Extre 1 ne voit pas Airplay.
Les clients connectés à un réseau ne voient pas les clients connectés à l'autre.
NB : si ça devait rester comme ça, il faudrait faire en sorte que les 2 routeurs n'utilisent PAS la même plage d'adresses IP (Réseau / "Options du réseau).

L'objectif à atteindre (si techniquement possible) est la configuration "normale", càd les 2 bornes en mode pont, de façon à unifier le réseau.
Ca te permet d'utiliser pleinement le "réseau d'itinérance" créé par les 3 points d'accès wifi, et supprime toute restriction dans l'usage du partage, et de Airplay.

Il faut absolument que tu testes ce qui est dit au post précédent.
Attention, après avoir passé Extr 1 en mode pont, attends un peu, pour que le mini retrouve une nouvelle adresse IP.
Ou même, reboote-le. Idéalement, reboote tout : switch, Extreme 1, Mac.
Si vraiment ça ne fonctionne pas, alors ça veut dire que le système en amont ne permet que UNE adresse IP par prise murale.
Ca expliquerait aussi que l'Express est connectée mais n'arrive pas à accepter la connexion d'un client.
Bizarre et peu probable à mon avis, but who knows.

Si c'était le cas, la solution pour unifier le réseau serait :
- Extreme 1 en routeur (DHCP + NAT)
- Express en mode pont, reliée par Ethernet à Extrême 1
 
Dernière édition:

Pat1763

Membre émérite
11 Août 2008
507
17
La Rochelle (17)
Bonjour Ma Dalton, :coucou:

J'ai vérifié ce matin avant de partir travailler, et en fait j'arrive à utiliser AirPlay à partir de mon Mac Mini : essai à partir de iTunes, la connexion est rapide. Cette technologie m'impressionne d'ailleurs : arriver à transporter un signal audio complexe (j'utilise du FLAC en 192) sur une distance d'une quinzaine de mètres avec des murs en béton au milieu, c'est quand même un tour de force.

D'ailleurs, je me demande comment ça marche : car AirPlay n'est disponible que sur l'Express, que mon Mini ne peut pas voir; et pourtant ça marche alors que les Extrême ne sont pas faites pour. J'imagine qu'Apple a réussi à les rendre compatibles à posteriori, ce qui ne doit pas être une mince affaire...

Je vais tester sur les jours à venir pour voir si la bonne nouvelle se confirme : j'ai souvent eu des améliorations très temporaires.

Il me semble que je n'ai qu'un réseau; en tout cas, au niveau utilisateur, il s'agit du même partout : même nom, même mot de passage; il est possible bien sûr qu'en interne ce soit géré différemment. En tout état de cause, si ça fonctionne, je préfère éviter d'y toucher...

En revanche, l'assignation de différentes adresses IP pour les deux bornes configurées en routeurs me semble être nécessaire. As-tu une recommandation sur les plages à utiliser ?

Merci infiniment pour ton aide très précieuse ! :merci:
 

Ma Dalton

Membre d’élite
4 Avril 2015
1 284
269
64
J'ai vérifié ce matin avant de partir travailler, et en fait j'arrive à utiliser AirPlay à partir de mon Mac Mini
Mais tu dois activer le wifi du Mini pour ça, alors que si ton réseau était configuré normalement, tu n'aurais PAS besoin du wifi : Airplay ça fonctionne aussi par Ethernet.
Avec ta configuration actuelle à 2 routeurs, le mini n'a pas accés à l'Airplay de l'Express via Ethernet.

D'ailleurs, je me demande comment ça marche : car AirPlay n'est disponible que sur l'Express, que mon Mini ne peut pas voir; et pourtant ça marche alors que les Extrême ne sont pas faites pour.
Les Extreme n'ont PAS la fonction Airplay.
Mais tout client connecté via une Extreme qui dépend d'un réseau contenant une borne Express peut utiliser l'Airplay de la borne Express.
Quand tu actives le wifi du mini, il se connecte au réseau wifi de l'Express OU au réseau de l'Extreme 2 qui étend le réseau de l'Express : dans les 2 cas, Airplay est disponible.

Il me semble que je n'ai qu'un réseau; en tout cas, au niveau utilisateur, il s'agit du même partout : même nom, même mot de passage
Bien sûr, puisque tu as mis les mêmes paramètres aux 2 réseaux wifi.

En tout état de cause, si ça fonctionne, je préfère éviter d'y toucher...
Je peux comprendre, mais sache que ta configuration actuelle est scabreuse et inefficace : pas d'itinérance, pas de partage possible.
En effet, si il y a 2 routeurs dans le réseau, ça n'a plus aucun sens de créer un "réseau d'itinérance" (wifi unique) puisque ça ne fonctionne PLUS comme un réseau d'itinérance.

En revanche, l'assignation de différentes adresses IP pour les deux bornes configurées en routeurs me semble être nécessaire. As-tu une recommandation sur les plages à utiliser ?
Dans Réseau / Options du réseau, tu peux choisir la plage d'adresse DHCP IPV4 et mettre 2 plages différentes pour Extreme 1 et Express.

Dernière tentative de ma part : essaie ce que je t'ai proposé dans les posts précédents...
Ca ne t'engage à rien.

A ce propos, pour en avoir le coeur net sur le fonctionnement de ton installation, voici le test que je ferais si j'étais sur place :
- configurer l'Express en mode pont.
- éteindre TOUT le réseau
- rallumer seulement le "switch" et l'Express
- L'Express a-t-elle le point vert : oui
- connexion d'un iPhone au réseau de l'Express : que se passe-t-il :

1. iPhone obtient une adresse IP et a accès à Internet = il y a un routeur en amont qui a donné une adresse IP à l'Express ET à l'iPhone, donc il est possible d'avoir plus que UNE adresse IP par borne Ethernet murale = ton réseau peut fonctionner "normalement" avec les bornes en mode pont.

2. iPhone n'obtient pas la connexion = le système n'autorise qu'un adresse IP par prise (?) donc il faut que les bornes soient en mode routeur DHCP + NAT.
Et la je répète :
Si c'était le cas, la solution pour unifier le réseau serait :
- Extreme 1 en routeur (DHCP + NAT)
- Express en mode pont, reliée par Ethernet à Extrême 1
- Extreme 2 en extension et DHCP
Le réseau d'itinérance fonctionne.
Airplay pour tous y compris en Ethernet.
Pas de limite aux partages.
 
  • J’aime
Réactions: Pat1763

Pat1763

Membre émérite
11 Août 2008
507
17
La Rochelle (17)
Merci (encore et toujours) Ma Dalton, ton aide est très précieuse. :merci:

Pour le moment cela fonctionne, et je laisserai comme tel s'il n'y a pas de problèmes. Cela ne veut pas dire que je ne procéderai pas aux tests / changements que tu décris : j'attends simplement que mon épouse parte quelques jours pour m'y atteler en toute sérénité. Les problèmes rencontrés jusqu'à présent ont créé quelques tensions récemment, inutile de les ranimer trop vite ! :rolleyes:
 

Pat1763

Membre émérite
11 Août 2008
507
17
La Rochelle (17)
Petite mise à jour... J'ai finalement demandé à mon FAI de venir voir comment régler le système. Ils n'ont rien pu faire, car ils n'assurent aucune service sur du matériel Apple (chose qu'évidemment personne ne m'a indiqué lorsque j'ai pris rendez-vous)... :rolleyes:

Le plus important est qu'ils m'ont indiqué officieusement comment procéder. Il n'est pas possible selon eux d'avoir deux Airport "câblées" sur leur switch ; leur réseau donne des IP dynamiques indépendantes à chacune des connexions utilisées...

Deux solutions selon lui :

  1. câbler l'Airport Express à la première Airport Extrême. Solution préconisée par Ma Dalton, mais infaisable en pratique (la configuration de l'appartement ne s'y prête pas).
  2. se contenter d'un réseau étendu, où seule l'Extrême reliée à mon Mini est reliée par câble ethernet au réseau du FAI, les deux autres étant en WiFi.

Je pense m'orienter vers la deuxième solution donc. Moins satisfaisante, relativement contraignante (puisqu'il faut que l'Express soit visible de la principale, située à l'autre bout de l'appartement), mais finalement la seule qui ait une chance de fonctionner...
 
Dernière édition: