10.11 El Capitan Reboot en pleine veille

QuickPwn

Membre junior
22 Septembre 2016
65
2
23
Hello,

J'ai un petit soucis qui m'arrive de temps en temps...
Je me demande même si j'ai déjà réussi à faire un stand by sans problème avec mon imac... (ça la fou mal hein ? Oui effectivement :cool:)
j'ai un imac late 2015, avec el capitan.
Lorsque je lance un "suspendre l'activité", et bien dans la nuit il n'est pas rare que mon imac sort de sa veille, fasse quelque chose, puis se rendorme... (ce qui fait réveiller également les disques externes)
Quelques fois, il pète un cable, et redémarre comme ça, avec le bon gros dong, histoire de te prévenir qu'il est là :dead:
Avez vous une piste pour élucider ce phénomène ?
De même, suite au redémarrage, lorsque je clique sur éteindre le mac, et bien il va redémarrer... encore et encore...
Du coup obligé de cliquer sur redémarrer, pour ensuite cliquer sur éteindre ou d'ouvrir ma session pour l'éteindre.

Merci ;)

ps : j'ai déjà fait un reset nvram et smc.
 
Dernière édition:

Fullcrum

OS Collector
Club MacG
5 Janvier 2016
4 086
1 013
Dole 39
  • J’aime
Réactions: QuickPwn

Fullcrum

OS Collector
Club MacG
5 Janvier 2016
4 086
1 013
Dole 39
#2 est pour attirer l'attention ...:coucou:

Néanmoins peut-être pourrais tu ré-appliquer la MAJ " El Capitan " qui doit être dans > App Store > achats ?
 

QuickPwn

Membre junior
22 Septembre 2016
65
2
23
Je vais voir ce que je peux faire :D

Je suis pas trop friand de ce genre de réinstallation... j'ai plus peur que ça fasse plus de casse qu'autre chose...
Tu as eu de bonnes expériences en faisant cela ?

De toute manière, je pense partir sur une clean install sous Sierra...
 

Fullcrum

OS Collector
Club MacG
5 Janvier 2016
4 086
1 013
Dole 39
Je suis pas trop friand de ce genre de réinstallation... j'ai plus peur que ça fasse plus de casse qu'autre chose...

Ré-appliquer une MAJ ne touche en rien les données présente sur la machine, mais si la peur est plus grande que l'effet escompté ... fait un Clone avant ;)

De toute manière, je pense partir sur une clean install sous Sierra...

Fait un Clone avant bis répétita :D ( là tu peux te louper ... )
 

Fullcrum

OS Collector
Club MacG
5 Janvier 2016
4 086
1 013
Dole 39
Ça ne peut pas être un truc du style "powernap" ?

Il faudrait dans ce cas, qu'un Terminalleux ce joigne à nous pour faire un listing de ton Mac via le Terminal...

Y'a deux incantations :

1- @macomaniac :coucou:

2- @jeanjd63 :coucou:

C'est d'ailleurs bien étonnant que leurs doigts griffus ne se soient pas déjà manifestés ... ( c'est les fêtes )

Le Titre est pourtant très attractif ;) ( pour certain )
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
77 067
23 692
Forêt de Fontainebleau
:coucou: les amis

C'est d'ailleurs bien étonnant que leurs doigts griffus ne se soient pas déjà manifestés ... ( c'est les fêtes )

Détrompe-toi : ce genre de titre --> « Reboot en pleine veille » n'a rien d'attractif (du moins pour moi) > parce que le facteur à incriminer est toujours aussi flou que les ombres de la nuit qui abritent son action sournoise. En résumé : ce genre de problème invite à une chasse au Dahu - espèce par définition élusive.

Dans le Terminal, QuickPwn, passe la commande (informative) -->
Bloc de code:
pmset -g custom

  • qui retourne le tableau des paramètres de la gestion d'alimentation de ton iMac

Poste le ici dans une fenêtre de code - au cas où tu aurais oublié le procédé -->

  • dans la page de ce fil de MacGé > presse le bouton (carré avec un + inscrit - juste au milieu de la largeur de la fenêtre totale) dans la barre de menus au-dessus du champ de saisie d'un message > menu  : </> Code > par ⌘V colle dans la fenêtre Code > presse le bouton Insérer (ce procédé permet un affichage fenêtré qui économise l'espace de page en respectant la mise en forme des tableaux du «Terminal» --> d'où une plus grande lisibilité)

Mais pour éviter de lancer une chasse au Dahu (voire à la Baleine Blanche) > je t'invite en parallèle à aller à : Menu  > Préférences Système > Partage --> pour scruter si des cases louches comme : "Apple Events distants" ou "Partage d'imprimantes" [ou autres...] ne seraient pas cochées, par hasard. Il faut bien, en effet, qu'il y ait une porte d'entrée pour que des événements nocturnes fassent intrusion dans le sommeil de ton iMac.
 

QuickPwn

Membre junior
22 Septembre 2016
65
2
23
Hello !

Voilà le retour de la commande :

Bloc de code:
AC Power:
Sleep On Power Button 1
autopoweroff         1
autopoweroffdelay    14400
standbydelay         10800
standby              1
ttyskeepawake        1
hibernatemode        3
powernap             0
gpuswitch            2
hibernatefile        /var/vm/sleepimage
womp                 1
displaysleep         10
networkoversleep     0
sleep                0
halfdim              1
autorestart          0
disksleep            10

Rien n'est activé dans les partages ;)

Merci !
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
77 067
23 692
Forêt de Fontainebleau
  • autopoweroff (sommeil profond) activé - avec un délai de 4 heures de sommeil simple --> inutile pour un Mac de bureau
  • standby (hibernation) activé - avec un délai de 3 heures de sommeil simple --> inutile pour un Mac de bureau
  • hibernatemode 3 (sauvgarde de la RAM à une sleepimage avant virage au sommeil) --> inadapté pour un Mac de bureau où le défaut = hibernatemode 0 (pas d'écriture à une sleepimage)
  • sleep (sommeil du kernel ou simple sleep classique) désactivé --> il faudrait au contraire lui fixer une valeur de 15 minutes d'inactivité en session - par exemple
  • displaysleep (sommeil ou obscurcissement de l'écran) = après 10' d'inactivité en session --> correct
  • disksleep (décélération du disque) = après 10' d'inactivité en session --> correct aussi.
Comme le tableau des paramètres de départ se trouve archivé dans ce fil > il n'y a aucun problème à passer une commande de modifications (réversible - au sens où une autre commande peut à tout moment éditer une valeur ou faire revenir globalement au tableau primitif). Ces préférences sont enregistrées dans le fichier suivant : /Library/Preferences/ com.apple.PowerManagement.plist.

Passe la commande :
Bloc de code:
sudo pmset -a autopoweroff 0 standby 0 hibernatemode 0 sleep 15

  • après validation avec la touche "Entrée" --> une demande de password s'affiche (commande sudo) --> tape ton mot-de-passe de session admin en aveugle - aucun caractère ne se montrant à la frappe - et valide de nouveau avec "Entrée"
  • cette commande désactive l'autopoweroff et le standby > vire l'hibernatemode à 0 (pas d'emploi de la sleepimage) > et règle le passage au sleep (sommeil du kernel ou sommeil-Système) sur 15' d'inactivité en session. Les autres paramètres restent intouchés.

=> après passation de la commande > re-démarre une fois pour que les paramètres soient chargés par le kernel. Tu n'auras qu'à dire si tu constates une amélioration du comportement.
 

QuickPwn

Membre junior
22 Septembre 2016
65
2
23
Merci @macomaniac !

Je vais tester cela plus tard (car je n'ai pas le mac sous la main).
Par contre c'est bizarre, certains paramètres ne semblent pas être par défaut, et pourtant, je n'ai jamais modifié ses paramètres...
Peut-être le hibernatemode suite à un test et que manifestement j'ai dû zapper de le remettre à 0.

je te tiens au courant demain matin ;)

En attendant, bonne fête à tous !

ps : c'est correcte pour un portable ? :D
Bloc de code:
Battery Power:
lidwake              1
autopoweroff         1
autopoweroffdelay    28800
standbydelay         10800
standby              1
ttyskeepawake        1
hibernatemode        3
powernap             0
gpuswitch            2
hibernatefile        /var/vm/sleepimage
displaysleep         10
sleep                10
tcpkeepalive         1
halfdim              1
acwake               0
lessbright           1
disksleep            10
AC Power:
lidwake              1
autopoweroff         1
autopoweroffdelay    28800
standbydelay         10800
standby              1
ttyskeepawake        1
hibernatemode        3
powernap             1
gpuswitch            2
hibernatefile        /var/vm/sleepimage
displaysleep         10
womp                 0
networkoversleep     0
sleep                0
tcpkeepalive         1
halfdim              1
acwake               0
disksleep            10
 

QuickPwn

Membre junior
22 Septembre 2016
65
2
23
  • sleep (sommeil du kernel ou simple sleep classique) désactivé --> il faudrait au contraire lui fixer une valeur de 15 minutes d'inactivité en session - par exemple

Alors pour cette règle, c'est moi même qui préfère la désactiver... Pourquoi ?
J'ai pour habitude, lorsque je laisse un téléchargement, de verrouiller mon écran en utilisant la commande maj + control + eject.
Ainsi, je verrouille mon imac tout en le laissant en activité et en évitant de devoir attendre par exemple l'économiseur d'écran (chose que je n'utilise pas) ou encore la mise en veille de l'écran au bout de 10' par exemple pour qu'il se verrouille.

Est-ce que du coup, ceci à un impact avec le sleep présent dans le menu  ?
Il me semble que non, car lorsque je cliquais sur sleep j'entendais le disque dur interne s'arrêter. (ce qui me disait qu'il s'était endormi)
 

Fullcrum

OS Collector
Club MacG
5 Janvier 2016
4 086
1 013
Dole 39
J'ai pour habitude, lorsque je laisse un téléchargement, de verrouiller mon écran en utilisant la commande maj + control + eject.

Tient je ne connaissais même pas ce raccourci clavier, préférant les choix des " coins actifs " .

Capture d’écran 2018-01-01 à 22.29.12.png
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
77 067
23 692
Forêt de Fontainebleau
Grâce à FULLCRUM qui a remonté ce fil (déjà légèrement enfoui sous l'avalanche des pannes de fin d'année) --> je peux revenir sur le sujet.

Il doit être possible de désactiver aussi bien l'autopoweroff > le standby > et le sleep (sommeil du kernel) - en tant que fonctionnalités programmées. Dans ce cas --> le Mac ne se met jamais automatiquement en sommeil > mais uniquement si on déclenche manuellement l'état de sommeil avec l'option : "Suspendre l'activité".

La suspension d'activité-Système (sleep ou sommeil du kernel) implique automatiquement & instamment la mise en sommeil du disque et de l'écran (dont les délais rapportés à une inactivité en session se trouvent donc surclassés par cette action).

Il doit être aussi possible de désactiver le womp (wake_on_magic_packet) susceptible de réveiller le Mac à l'état de sommeil.

Ce qui donne la commande d'édition :
Bloc de code:
sudo pmset -a sleep 0 womp 0

=> vérifier le rendu de ce paramétrage combiné au précédent.

----------

Quant aux paramètres pour un portable > tout dépend du type d'usage qui en est fait --> exclusivement sédentaire (équivalent d'un Mac de Bureau fonctionnant sur secteur) ? - ou nomade (sur batterie) ? - une combinaison des 2 (à la maison sur secteur / nomade sur batterie) ? - quelle sorte d'usage nomade, alors ?
 
  • J’aime
Réactions: FULLCRUM

Jannot83

Membre junior
31 Août 2011
56
4
Var
Merci pour ce post très interessant.
Question bête, mais s’il s’agit d’un SSD dans l’IMac,les mêmes réglages s’appliquent ?
Merci
 

QuickPwn

Membre junior
22 Septembre 2016
65
2
23
Hello à tous !
Désolé du retard :dead:

je vais tester ceci
Bloc de code:
sudo pmset -a sleep 0 womp 0
, ce soir ! ce que je cherche vraiment, c'est genre je clique sur "suspendre l'activité" pour qu'il s'endorme et qu'il le reste quoi qu'il arrive... En gros, comme si il était éteint.
Sauf que ça m'évite d'attendre un boot quand je veux le relancer.

Pour le portable t'embête pas, il est très bien comme ça !