restaurer un paquet Fink manquant

xzulien

Membre junior
10 Octobre 2004
36
1
49
J'ai installé Fink sur mon G5
pas de problème

j'ai installé Fink sur mon G4
problème

je voulais installer mime-base64-pm581 et mime-base64-pm581
impossible sur le G4 là om sur le G5 je vois le paquet actif et "provided"
ici je ne vois pas le menu "install" from binaries" et lorsque je lance "install from source" il me dit "Failed: no version available for mime-base64-pm586" ou 581

donc je veux récupérer et installer ces paquets , que dois je faire ?
Help
Thx :)
 

Thierry6

Membre émérite
29 Avril 2003
865
29
Ailleurs
(je tente sans filet, peut être est ce une connerie)
mime-base64 n'a t il pas besoin d'un processeur 64 bits (vu son nom) ce qui expliquerait que tu l'installes sur un G5 et pas un G4 ?
 

PA5CAL

Vétéran
Club MacG
21 Juillet 2005
9 228
597
Île-de-France
Thierry6 a dit:
(je tente sans filet, peut être est ce une connerie)
mime-base64 n'a t il pas besoin d'un processeur 64 bits (vu son nom) ce qui expliquerait que tu l'installes sur un G5 et pas un G4 ?
Non, raté. Bien tenté, pourtant :D ...

"base64", c'est le nom du codage (et ça marche aussi sur les processeurs 8 bits).

Pour répondre à la question, je n'ai pas trop d'idée. Je suis moi aussi souvent englué dans les problèmes de Fink...
 

xzulien

Membre junior
10 Octobre 2004
36
1
49
PA5CAL a dit:
Je suis moi aussi souvent englué dans les problèmes de Fink...
c'est bon de se sentir moins seul ;)

bon partons du principe acquis que j'ai réalisé les mêmes opérations sur les deux bécannes,
le G5 pas de problème :

le G4 :


à première vue, on pourrait croire que d'autres paquets non-gérés par Fink sont affichés comme "virtual packages" on été installés.

que nenni ! en faisant une recherche dans les libs, impossible de trouve ce module en version perl 586
d'ailleurs la majorité des paquets 'noyaux' de perl sont impossibles à installer dans Fink, car pas dispo.

Il affiche qu'il existe une version 3.00-12 que je ne trouve pas et qui est incomplète si elle existe, car le module peril auquel je fais appel me renvoie un erreur

Can't locate MIME/Base64/Perl.pm in @INC (@INC contains: /sw/lib/perl5/5.8.6/darwin-thread-multi-2level /sw/lib/perl5/5.8.6 /sw/lib/perl5/5.8.6/darwin-thread-multi-2level /sw/lib/perl5/5.8.1 /sw/lib/perl5/5.6.0 /sw/lib/perl5 /sw/lib/perl5/darwin /sw/lib/perl5-core/5.8.6/darwin-thread-multi-2level /sw/lib/perl5-core/5.8.6 /sw/lib/perl5/site_perl/5.8.6/darwin-thread-multi-2level /sw/lib/perl5/site_perl/5.8.6 /sw/lib/perl5/site_perl/5.8.6/darwin-thread-multi-2level /sw/lib/perl5/site_perl .)

donc sans chercher à comprendre d'où vient le malaise, comment dire à Fink "écoute, je suis fatigué, j'ai eu une rude semaine, je te force donc à remplir ta mission pour installer le module mime-base64-pm 586 ?"
 

Thierry6

Membre émérite
29 Avril 2003
865
29
Ailleurs
(là je sais que c'est pas une connerie, pas sûr cependant que ça aide !)
quand j'ai des problèmes avec Fink, refaire un petit Scanpackages avant les classiques selfupdate et update-all a parfois résolu des soucis (essentiellement en cas d'erreurs de compilation mais peut être que ça peut servir aussi ici ?
 

xzulien

Membre junior
10 Octobre 2004
36
1
49
bé non, ce n'est pas une connerie, une idée pour aider permet toujours d'avancer ;)

alors j'ai fais tout ça, update, update all, scanpackage, selfupdate, selfupdate cvs, index, etc... (dans le désordre) ... toujours rien.

je pose la question différement : je vois le package à cette adresse sur le site de Fink
http://pdb.finkproject.org/pdb/package.php/mime-base64-pm586

donc je souhaite l'installer.. que fais-je pour ce faire ?
 

xzulien

Membre junior
10 Octobre 2004
36
1
49
bon je crois comprendre ce qui se passe sans pouvoir trouver une solution
j'ai un dossier perl 5.8.1 qui est complet. mais il y a un bug qui indique d'aller chercher dans la lib perl 5.8.6 que je n'ai pas et que je ne parviens pas à installer en plus ! ça doit sûrement venir d'un path mal renseigné au niveau du système. Si quelqu'un a une idée : soit pour installer perl core 5.8.6 (Fink refuse complètement de l'installer, pas de description de package), soit pour indiquer que la lib perl en cours est la 5.8.1.
Sur le G5 : /library/per/5.8.6
Sur le G4 : /library/perl/5.8.1

et tous les appels de mes fichiers échouent dans le terminal comme indiqué plus haut, sur le G4

De tout coeur, merci.
 

FjRond

Membre émérite
16 Février 2004
797
14
62
Vendée
homepage.mac.com
À tout hasard, est-ce que les autorisatios sont correctes sur le G5 ? j'ai eu il y a quelque temps un petit problème analogue parce que certains fichiers de mon /sw n'étaient plus à root:admin. Solution :
Bloc de code:
$ sudo chown -R root:admin /sw
D'autre part, mime-base64-pm581 étant un unstable, il faut bien sûr que le fichier /sw/etc/fink.conf soit configuré en conséquence.
 

xzulien

Membre junior
10 Octobre 2004
36
1
49
FjRond a dit:
D'autre part, mime-base64-pm581 étant un unstable, il faut bien sûr que le fichier /sw/etc/fink.conf soit configuré en conséquence.
tu voulais sûrement dire la 5.8.6...et le G4 ... mais oui effectivement le paquet est instable, sauf sur le G5 : fink l'affiche bien dans les paquets installés (cf écran plus haut), mais il n'est pas configuré pour montrer les instables.

et je te remercie chaleureusement pour ton aide, car ça fonctionnne maintenant !
:up:

merci à tous !:zen:
 

PA5CAL

Vétéran
Club MacG
21 Juillet 2005
9 228
597
Île-de-France
Chez moi, j'ai un Mac Mini (G4, donc), et ça apparaît comme sur ton G5.

Par acquis de conscience, j'ai fait une essai. J'ai d'abord tout viré (suppression de /sw, comme indiqué dans la doc), j'ai retéléchargé la dernière version de Fink et de FinkCommander, et j'ai tout installé. Et c'est pareil qu'avant, comme sur ton G5.

Il y a peut-être eu un problème en cours de route chez toi, parce que par défaut, ça marche.
 

FjRond

Membre émérite
16 Février 2004
797
14
62
Vendée
homepage.mac.com
xzulien a dit:
tu voulais sûrement dire la 5.8.6...et le G4 ... mais oui effectivement le paquet est instable, sauf sur le G5 : fink l'affiche bien dans les paquets installés (cf écran plus haut), mais il n'est pas configuré pour montrer les instables.

et je te remercie chaleureusement pour ton aide, car ça fonctionnne maintenant !
:up:

merci à tous !:zen:
À la bonne heure !
Y'a pas de quoi ;)