Ruby on Rails - Aide installation

Gsgsd

Membre junior
31 Mai 2008
54
0
www.phpboost.com
Bonjour,

J'ai un petit problème avec rails. Je souhaiterais désisntaller rails et autres afin de le réinstaller proprement. J'ai suivi des tutoriels de mauvaise qualité !

De plus, comment mettre à jour subversion de mac os x (j'ai macport) ?


Merci
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 926
3 160
Avec MacPorts, in suffit de faire sudo port upgrade subversion.
Pour RoR, il faudrait déjà savoir ce qui est installé ...

J'envoie côté UNIX.
 

Gsgsd

Membre junior
31 Mai 2008
54
0
www.phpboost.com
Salut,

Merci de me répondre...

Alors pour subversion je ne comprend pas voilà ce que j'ai :

Bloc de code:
sudo port upgrade subversion
Password:
Error: subversion is not installed
Poutant j'utilise la ligne de commande :

Bloc de code:
svn up
qui fonctionne sans problème.

De plus RoR, voilà ce que j'ai :

Bloc de code:
gem list

*** LOCAL GEMS ***

actionmailer (2.3.2)
actionpack (2.3.2)
activerecord (2.3.2)
activeresource (2.3.2)
activesupport (2.3.2)
rails (2.3.2)
rake (0.8.7)
rubygems-update (1.3.4)
Et :

Bloc de code:
ruby --version
ruby 1.8.7 (2009-04-08 patchlevel 160) [i686-darwin9]
Ce qui me pose le plus de problème c'est les base de donnée j'ai installé mysql et là je bloque...


Merci.
 

heroe

Membre confirmé
6 Mai 2000
368
18
Paris
J'envoie côté UNIX.
Pourquoi côté unix ??? ça marche même sur Window$ et c'est carrément du dev web rails....


Salut,
Alors pour subversion je ne comprend pas voilà ce que j'ai :

Bloc de code:
sudo port upgrade subversion
Password:
Error: subversion is not installed
Poutant j'utilise la ligne de commande :

Bloc de code:
svn up
qui fonctionne sans problème.
Pourquoi mettre a jour subversion ? Tu l'as de base sur os x, si vraiment tu veux l'installer alors le message est clair, avec mac port il te dis "subversion is not installed" donc plutot que de faire
Bloc de code:
sudo port upgrade subversion
, tu fais
Bloc de code:
sudo port install subversion

De plus RoR, voilà ce que j'ai :

Bloc de code:
gem list

*** LOCAL GEMS ***

actionmailer (2.3.2)
actionpack (2.3.2)
activerecord (2.3.2)
activeresource (2.3.2)
activesupport (2.3.2)
rails (2.3.2)
rake (0.8.7)
rubygems-update (1.3.4)
Et :

Bloc de code:
ruby --version
ruby 1.8.7 (2009-04-08 patchlevel 160) [i686-darwin9]
Ce qui me pose le plus de problème c'est les base de donnée j'ai installé mysql et là je bloque...


Merci.
Quel est le problème? tu as mysql, rails d'installé... maintenant tu n'as plus qu'a creer ton appli!!!
 

Gsgsd

Membre junior
31 Mai 2008
54
0
www.phpboost.com
Salut,

J'utilise svn fréquemment etlors que j'ai fais svn --version ma version date de 2007. C'était pour le mettre à jour.

De plus, comment savoir si mysql est installé car lorsque je tape mysql --version il me répond unknow mysql !:confused:
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 926
3 160
Reprenons :

1/ @heroe : UNIX ? parce qu'il s'agit ici de la partie darwinienne d'OS X. Et que le forum OS X est plus axé sur du classique Mac (c-a-d l'interface graphique avec un peu de Terminal éventuellement saupoudré dessus).

2/ @Gsgsd : pour les logiciels, tu ne fais qu'utiliser les versions installées avec le système. Si tu veux utiliser MacPorts, installe les versions de MacPorts ; elles seront disponibles dans une autre partie de l'arborescence et tu pourras en gérer les versions selon ton gré. Pense à vérifier les chemins d'accès aux exécutables et bibliothèques. Quant à MySQL, il n'est apparemment pas installé [en tous cas pas livré avec Leopard, ça me paraît sûr]. Tu peux l'installer avec MacPorts ou directement ou le recompiler à la main, c'est selon.
 

Gsgsd

Membre junior
31 Mai 2008
54
0
www.phpboost.com
Bon j'ai résolu à moitié mes problèmes, j'ai réinstallé MAC OS X et je suis à jour.

Désolé de faire l'assisté mais que dois je faire pour mettre à jour ruby et disposer de Mysql sachant que j'utilise MAMP pour le PHP qui inclut Mysql puis je utiliser celui ci ?