macOS Big Sur Session perso a disparu

banane623

Membre junior
18 Novembre 2020
19
0
39
Bonsoir à tous

Depuis plus d'une heure, j'ai mon MacBook Pro M1 qui n’affiche qu'une session "Invité" lors du redémarrage, ma session perso a complètement disparu.

Au moment de ce souci, j'avais téléchargé la dernière mise à jour Big Sur, mais pas encore installé. J'ai voulu redémarrer mon Mac et depuis plus moyen de voir ma session. En plus, sur la session invité aucun mot de passe ne fonctionne.

Si quelqu'un a une idée

Merci
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
84 979
25 557
Forêt de Fontainebleau
Bonjour banane

Si tu démarres > les 2 touches ⌘R (command R) tenues pressées = démarrage sur l'OS de secours local -->

- est-ce qu'après un temps de chargement tu obtiens un écran affichant 4 Utilitaires macOS = écran de la session de secours ?​
 

banane623

Membre junior
18 Novembre 2020
19
0
39
Si tu démarres > les 2 touches ⌘R (command R) tenues pressées = démarrage sur l'OS de secours local -->
Salut oui j’ai fait le mode récupération

Je suis sur MacBook m1 donc juste à maintenir sur le bouton allumer. Après j’ai mon icône de mon disque dur et une autre icône d’option. Quand je clique sur mon dd et que je redémarre j’ai toujours le même souci. Quand je vais dans option j’ai bien accès au 4 icônes dont utilitaire de disque

Dans l’utilitaire de disque, j’ai interne avec mon disque et image disque macos base system
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
84 979
25 557
Forêt de Fontainebleau
Voici comment tu vas pouvoir fournir ici les informations de base (tuto) -->

- dans la session de secours > aucune option de la fenêtre de 4 Utilitaires macOS lancée => va à la barre de menus supérieure de l'écran > menu : Utilitaires > sous-menu : Terminal.​

Dans la fenêtre ouverte > saisis la commande informative (ce qui est inscrit sous Bloc de code) :
Bloc de code:
diskutil list internal
et ↩︎ (presse la touche "Entrée" du clavier pour exécuter la commande)

  • tu vas voir s'afficher en mode texte la configuration interne seule

Voici comment tu vas pouvoir poster ici ce tableau sans avoir besoin de prendre de photo -->

  • tu sélectionnes le tableau > ⌘C pour le copier dans le presse-papier > ⌘Q pour quitter le «Terminal» > option  : "Obtenir de l'aide en ligne" (dans la fenêtre des 4 Utilitaires) > ce qui lance un navigateur «Safari»
  • page Apple par défaut > un clic sur l'adresse de haut de page pour l'éditer > saisis  : macgénération (tout court  : c'est une barre de recherche Google) et valide > tu atteins le site MacGé > Forums > te connectes > ce fil
  • en bas de cette page des forums MacGé => utilise le menu (le 16è depuis la gauche = vers le milieu de la barre) dans la barre de menus au-dessus du champ de saisie d'un message > sous-menu : </> (= Bloc de code) => tu fais ton coller dans la fenêtre de code et Continuer.

=> ces informations montreront la configuration logique de ton disque.

Note 1 : si tu ne peux pas poster via le Safari de la session de secours (ça arrive) --> poste une photo du tableau (à partir du commencement = le disque /dev/disk0 ou disque physique interne) - tu as un bouton : "Joindre un fichier" en bas de cette page.

Note 2 : dans la session de secours > les applications se lancent en mode "alternatif" et pas parallèle. Il faut quitter le Terminal pour lancer Safari. Vice-versa > quitter Safari pour récupérer l'écran général de la session de secours et pouvoir relancer le Terminal. Aucun redémarrage n'est requis.
 

banane623

Membre junior
18 Novembre 2020
19
0
39
Bloc de code:
-bash-3.2# diskutil list internal
/dev/disk0 (internal):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                         251.0 GB   disk0
   1:             Apple_APFS_ISC ⁨⁩                        524.3 MB   disk0s1
   2:                 Apple_APFS ⁨Container disk3⁩         245.1 GB   disk0s2
   3:        Apple_APFS_Recovery ⁨⁩                        5.4 GB     disk0s3

/dev/disk3 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +245.1 GB   disk3
                                 Physical Store disk0s2
   1:                APFS Volume ⁨BaNaNE HD⁩               15.3 GB    disk3s1
   2:                APFS Volume ⁨Preboot⁩                 487.4 MB   disk3s2
   3:                APFS Volume ⁨Recovery⁩                1.1 GB     disk3s3
   4:                APFS Volume ⁨Data⁩                    100.0 GB   disk3s5
   5:                APFS Volume ⁨VM⁩                      1.1 GB     disk3s6

-bash-3.2#
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
84 979
25 557
Forêt de Fontainebleau
Bien posté. Je vois une distribution à 5 volumes dans le Conteneur > dont le volume-Système : BaNaNE HD & le volume-Données : Data.

- effectue à présent une vérification : dans la fenêtre des 4 Utilitaires macOS > lance l'Utilitaire de disque. Les volumes BaNaNE HD & Data sont-il libellés en noir (= montés) ou en grisé (= non montés car verrouillés par FileVault) ?​
 

banane623

Membre junior
18 Novembre 2020
19
0
39
Le banane hd est noir, le data est grisé

Par contre j’ai réussi à faire un truc : sur la page de démarrage quand j’ai que la session invité j’ai appuyé sur contrôle, option, commande, et j’ai eu deux cases —- nom et mot de passe.
J’ai rentré le nom de ma session perso et mon mot de passe et j’ai bien accès de nouveau à mon compte.

Mais quand je redémarre l’ordi j’ai toujours pas mon icône de session perso.

Bon, après ma manip je suis retourné dans l’utilitaire de disque et le data n’est plus grisé
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
84 979
25 557
Forêt de Fontainebleau
Alors > le volume Data monté et donc adressable > voici la commande à passer dans le terminal :
Bloc de code:
rm /Volumes/Data/private/var/db/.AppleSetupDone
  • je te conseille de la passer en "copier-coller à rebours" : tu la copies ici avec Safari > tu la colles dans le terminal > tu l'exécutes
  • la commande supprime un fichier de finalisation vide .AppleSetupDone dans le volume-Données > qui assure au Système au démarrage qu'un compte d'utiilsateur a bien été créé in fine et que l'écran d'ouverture de session peut se trouver affiché en fin de chargement de l'OS. La suppression de ce fichier simule pour le Système un état d'installation non finalisée de l'OS > ce qui induit le réaffichage des écrans de paramétrage permettant in fine la création d'un compte d'utilisateur admin neuf. Commande muette (retour direct de -bash-3.2#) si elle passe

Si tel a été le cas > redémarre (Menu  > Disque de démarrage > BaNaNE HD > Redémarrer). Est-ce qu'à la fin du chargement de l'OS --> au lieu de l'écran d'ouverture de session > tu obtiens un écran de paramétrage du Mac (choix du Pays) comme à la fin d'une 1ère installation ?

Note : si le service LoginWindow d'affichage de l'écran d'ouverture de session --> n'affiche pas ton icône d'utilisateur > on peut conjecturer un dysfonctionnement du Service d'Annuaire (gestionnaire des Utilisateurs et des groupes) qui sert de référence au LoginWindow. En créant un nouvel utilisateur admin auxiliaire => on devrait pouvoir depuis sa session restaurer la validité de ton identité d'utilisateur.
 

banane623

Membre junior
18 Novembre 2020
19
0
39
Oui avec ta manip j’ai eu la page avec sélection de langue et dans le truc d’un 1er démarrage

Quand j’ouvre ma session et que je vais dans l’utilitaire de disque j’ai ça :

C4FF82D0-E8B6-4C9E-8FE0-2977E98A57F0.jpeg
 
Dernière édition par un modérateur:

banane623

Membre junior
18 Novembre 2020
19
0
39
Oui, j'ai tout renseigné, cela m'a crée un nouveau compte session. Maintenant j'ai ma session d'origine, la nouvelle session qui vient de se créer et l'invité :
Capture d’écran 2021-05-06 à 10.39.18.png
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
84 979
25 557
Forêt de Fontainebleau
D'accord.

- est-ce que loic est ton identité d'utiilsateur principale (dont tu n'arrives pas à ouvrir la session) ? Et Loïc xxxx ta nouvelle identité d'utilisateur admin auxiliaire ?​
 

banane623

Membre junior
18 Novembre 2020
19
0
39
Non, c'est l'inverse : celle du haut avec ma photo c'est ma vraie session
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
84 979
25 557
Forêt de Fontainebleau
Et donc tu arrives à ouvrir la session originale Loïc xxxx (actuellement ouverte manifestement) > après avoir ouvert la session loic auxiliaire --> en basculant sur une autre ouverture de session ?
 

banane623

Membre junior
18 Novembre 2020
19
0
39
oui , et j'avais réussi a l'ouvrir aussi depuis la page de démarrage en appuyant sur control , option , command + entré.

mais quand je redémarre le Mac j'ai de nouveau que la session invité ( avec aucun mot de passe qui fonctionne ) qui s'affiche
 

banane623

Membre junior
18 Novembre 2020
19
0
39
Quand je démarre le Mac je n’ai que ça :
B234A987-1574-4D9A-880B-DEC6FCF81899.jpeg

quand j’appuie sur Contrôle, Option, Commande + Entrée j’ai accès à ça :

B620859A-3F84-4A5A-839F-8409B64E4542.jpeg

et à partir de ça en rentrant mon nom de session et mot de passe, mon Mac démarre normalement
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
84 979
25 557
Forêt de Fontainebleau
Tu veux dire que même le nouvel utilisateur admin auxiliaire Loic n'est pas affiché à l'écran d'ouverture de session ?

- une fois dans ta session > va à : Menu  > Utilisateurs et groupes. Déverrouille le cadenas. Options --> dans l'espace de droite : est-ce que tu as la préférence : Ouverture de session par --> Nom et mot de passe cochée ?​
 

banane623

Membre junior
18 Novembre 2020
19
0
39
Capture d’écran 2021-05-06 à 11.27.10.png

Je pense que tout est bien configuré. J'ai essayé avec nom et mot de passe, c'est pareil.
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
84 979
25 557
Forêt de Fontainebleau
Fais l'essai de cocher l'option : nom et mot de passe et redémarre une fois -->

- à l'écran d'ouverture de session > as-tu 2 cases de saisie vides de nom et mot de passe ? => qui te permettent d'ouvrir la session correspondant à ta saisie ?​