Soucis Terminal

chrisjea

Membre junior
31 Mars 2010
31
0
Bonjour, je suis nouveau sur ce forum.

J'ai un petit soucis sur mon iMac 24" au niveau du terminal, ça fait quelques jours qu'en début de ligne au lieu de me mettre le nom de mon ordinateur comme d'habitude, il me met "iPhone" alors qu'en temps normal il devrait me mettre "imac-de-chris".
Je ne sais pas d'où pourrait venir ce problème étant donné que je n'ai jamais utilisé le terminal pour mon iphone et que qui plus est que celui ci n'est pas branché.

J'ai appelé Apple pour qu'il me donne un coup de main, mais j'ai dû écourter la discussion car il fallait payer (eh oui, les mac ne sont pas assez chers comme çà, il faut toujours plus d'argent).
Bizarrement pendant la conversation, j'ai voulu jeté un coup d'oeil rapide sur le terminal qui m'a finalement mis "imac-de-chris"... sauf que... après l'avoir fermé et ré ouvert, il recommence à me mettre "iPhone".

Alors je me tourne vers vous pour savoir si jamais quelqu'un aurait une solution à me faire part.

Je vous remercie.
 

tsss

Membre d’élite
Club MacG
1 Mai 2007
2 272
112
De passage ....
… et si tu tapes la commande hostname dans ton terminal tu obtiens aussi iMac-de-Cris ?

(juste par hazard : tu ne serais pas connecté en ssh sur ton iphone ? :) )
 

DarKOrange

Modulo
18 Novembre 2004
4 292
349
Paris
Bonjour, un règle chez MacG, comme sur les autres forums, poster dans le bon forum. Ici comme marqué plus haut on traite les problèmes matériels spécifiques à l'iMac intel...

iMac Intel Conseils et aide technique pour iMac avec processeur Intel (Core Duo et Core 2 Duo).

Le terminal c'est OS X, allez zou.
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 944
3 181
Dans le Terminal tape la commande suivante :
Bloc de code:
echo $PS1
et donne-nous le résultat.
 

chrisjea

Membre junior
31 Mars 2010
31
0
merci bien, c'est gentil, par contre il y a un problème... l'anglais n'est pas trop mon fort et c'est vraiment un vocabulaire compliqué...
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 944
3 181
Je suis distrait : dans un des posts précédents, il est indiqué que hostname renvoie la même valeur (enfin, au domaine près).
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 944
3 181
Disons que, quelque part dans la machine, est stocké ce nom.
Par exemple, la commande
Bloc de code:
scutil --get LocalHostName
doit te retourner "iPhone".

Tu peux toujours essayer de le changer en faisant quelque chose comme
Bloc de code:
sudo scutil —set LocalHostName Toto
pour changer ce nom en "Toto".
Très honnêtement, je ne sais pas quelle autre incidence peut avoir cette modification ;)
 

chrisjea

Membre junior
31 Mars 2010
31
0
Ca ne marche pas, je veux dire que quand je tape la commande, il me met bien le bon nom et non pas iphone.

Je me suis rendu compte en cherchant qu'il y avait marqué iPhone en NETBIOS dans les paramètres réseaux, mais après rectification, ça ne change toujours rien...
 

boninmi

Membre d’élite
Club MacG
4 Avril 2008
4 579
2 318
Ardèche
Et dans

Terminal -> Préférences -> Démarrage -> Ouvrir les shells avec

est-ce que "shell de session par défaut (/usr/bin/login)" est coché ?

Si dans Terminal tu vas dans:

Shell ->Nouvelle fenêtre -> Basic

l'erreur subsiste ?

Si tu essaies une commande du style exit ou logout, quel effet ?
 

chrisjea

Membre junior
31 Mars 2010
31
0
Voilà, j'ai essayé un peu tout:
Premièrement, quand j'ouvre mes paramètres il y a bien la bonne ligne dans l'option shell
Deuxièmement, quand j'ouvre une nouvelle fenêtre, c'est la même chose
Troisièmement quand je mets "exit" ou "logout" ça m'affiche çà (image jointe)

Pour information, je n'ai aucune autre session sur cet ordinateur, il n'y a qu'une seule personne (en admin) et c'est moi.

Une dernière chose, pour bompi: quand je mets ta commande, il me renvoit le bon nom, cad iMac-Chris.
 

chrisjea

Membre junior
31 Mars 2010
31
0
Qu'entends tu par: Réactualisé tes sauvegardes ? Il risque d'y avoir un problème après l'opération tu crois ?
Y a t il un risque de conflit avec mon d'utilisateur "Chris" en changeant par cette commande ?