system profiler sature le processeur

pgui

Membre junior
5 Janvier 2005
45
0
53
pierre.guicquero.free.fr
Bonjour,

je rencontre un problème depuis quelques temps avec le system_profiler :
Celui-ci, lorsqu'il est sollicité (je ne suis pas sûr que cela fonctionne comme ça) se charge en plusieurs fois et sature complètement le processeur bloquant quasiment complètement l'ordinateur.
Cela s'est produit il y a quelques temps et recommence quand je lance une application (bitcasa en l'occurrence)

Est-ce un bug système ou application ?

Comment le résoudre ?

Je suis sous SN 10.6.8


Merci pour vos réponses.

Ci jointes les copies d'écran du moniteur d'activité
Capture1.jpg


et de istat menu
Capture2.jpg

ici le LOAD AVERAGE peux grimper bien au delà encore... !
 

pgui

Membre junior
5 Janvier 2005
45
0
53
pierre.guicquero.free.fr
Bonjour,

Si le problème se déclenche quand tu lances Bitcasa, préviens les développeurs de l'application, qu'ils fournissent un correctif ;-)

Je croyais que mon problème était résolu en n'utilisant pas bitcasa, mais le voilà revenu de plus belle ce matin.
Cette fois c'est en lançant iTune ou iPhoto ou les deux me semble-t'il !

Ca bloque complètement l'ordi et impossible de faire quoi que ce soit !

HELP please

merci pour vos réponses
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 944
3 181
Vraiment étonnant, ce qui t'arrive. Est-ce que tu pourrais essayer de voir les processus sous forme hiérarchique, histoire de voir quel processus engendre autant de processus fils ?

Eventuellement, tu pourrais essayer sur une autre session pour voir si c'est un problème dans la configuration de ta session.

Enfin, il y a peut-être des messages d'erreur à glaner (à l'aide de l'application Console).
 

pgui

Membre junior
5 Janvier 2005
45
0
53
pierre.guicquero.free.fr
Vraiment étonnant, ce qui t'arrive. Est-ce que tu pourrais essayer de voir les processus sous forme hiérarchique, histoire de voir quel processus engendre autant de processus fils ?

Eventuellement, tu pourrais essayer sur une autre session pour voir si c'est un problème dans la configuration de ta session.

Enfin, il y a peut-être des messages d'erreur à glaner (à l'aide de l'application Console).

Pour l'instant c'est iTune qui déclenche l'orage processeur.
Tout marche bien tant que je ne l'ouvre pas.
Avec la session root, tout est parfait, zéro pb

voici les messages d'erreur que j'ai pu copier au moment du plantage
19/12/13 15:00:00 system_profiler[1103] Error -50 (ffffffce) occurred reading DPCD register data in System Profiler.
19/12/13 15:00:00 com.apple.SystemUIServer.agent[866] 2013-12-19 15:00:00.948 system_profiler[1103:903] Error -50 (ffffffce) occurred reading DPCD register data in System Profiler.
19/12/13 15:00:00 system_profiler[1103] Error -50 (ffffffce) occurred reading DPCD register data in System Profiler.
19/12/13 15:00:00 com.apple.SystemUIServer.agent[866] 2013-12-19 15:00:00.951 system_profiler[1103:903] Error -50 (ffffffce) occurred reading DPCD register data in System Profiler.
19/12/13 15:00:00 com.apple.SystemUIServer.agent[866] 2013-12-19 15:00:00.952 system_profiler[1103:903] Error -50 (ffffffce) occurred reading HDCP register data in System Profiler.
19/12/13 15:00:00 system_profiler[1103] Error -50 (ffffffce) occurred reading HDCP register data in System Profiler.
19/12/13 15:00:20 [0x0-0x97097].com.apple.iTunes[1090] Returning 0x0. Advertising wake service for libraryIdentifier "30A90EA534E2F2F4".



Est-ce que ça te parle ??


Merci encore pour ton aide
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 944
3 181
Hors-sujet : par ailleurs, attention à la session root !
 

pgui

Membre junior
5 Janvier 2005
45
0
53
pierre.guicquero.free.fr
Hors-sujet : par ailleurs, attention à la session root !

Salut.
Qu'est-ce qui est hors sujet ?

La session root était la seule que j'avais sous la main et je l'ai manié avec prudence je pense (juste un essai de itunes)

Merci pour ton aide

---------- Nouveau message ajouté à 18h03 ---------- Le message précédent a été envoyé à 17h57 ----------

Ben les logs que tu as postés parlent de ça : DPCD register Data ; HDCP register Data.

Le pourquoi du comment, c'est à toi de voir.

Je viens de faire un essai en débranchant mon 2nd écran et le pb persiste. Ca ne vient pas de là.

J'ai vu ça aussi comme log aux heures de bloquage :
19/12/13 17:59:32 kernel disk1s2: I/O error.
19/12/13 17:59:32 kernel
19/12/13 17:59:32 kernel
19/12/13 17:59:32 kernel hfs_clonefile: cluster_read failed - 5
19/12/13 18:00:33 virusbarrierb[107] Blocking file access after 60 seconds timeout Google Chrome -> /Volumes/Macintosh HD/Users/pierreguicquero/Library/Caches/Google/Chrome/Default/Cache/data_0
19/12/13 18:00:33 virusbarrierb[107] Blocking file access after 60 seconds timeout Google Chrome -> /Volumes/Macintosh HD/Users/pierreguicquero/Library/Application Support/Google/Chrome/Default/Current Tabs
19/12/13 18:00:33 virusbarrierb[107] Blocking file access after 60 seconds timeout Google Chrome -> /Volumes/Macintosh HD/Users/pierreguicquero/Library/Caches/Google/Chrome/Default/Cache/data_1
19/12/13 18:00:33 virusbarrierb[107] Blocking file access after 60 seconds timeout Google Chrome -> /Volumes/Macintosh HD/Users/pierreguicquero/Library/Application Support/Google/Chrome/Default/Cookies-journal
19/12/13 18:00:33 virusbarrierb[107] Blocking file access after 60 seconds timeout Google Chrome -> /Volumes/Macintosh HD/Users/pierreguicquero/Library/Application Support/Google/Chrome/Default/Sync Data/SyncData.sqlite3
19/12/13 18:00:47 kernel disk1s2: I/O error.
19/12/13 18:00:47 com.apple.backupd[1558] Error: (-36) SrcErr:YES Copying /Volumes/Macintosh HD/Users/pierreguicquero/Music/iTunes/iTunes Music Library.xml to (null)
19/12/13 18:00:47 kernel
19/12/13 18:00:47 kernel


le " kernel disk1s2: I/O error." c'est une erreur d'accès disque ?
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 944
3 181
Salut.
Qu'est-ce qui est hors sujet ?

La session root était la seule que j'avais sous la main et je l'ai manié avec prudence je pense (juste un essai de itunes)

Merci pour ton aide.

<...>
Ce qui est hors sujet, c'est ma remarque faite, en passant, sur la session root qui est (à mon humble avis) une erreur, dans la mesure où elle est très généralement inutile et dangereuse.

À part ça, oui, il y a une erreur d'accès disque sur la partition disk1s2.Pour savoir à quoi elle correspond, tu peux exécuter
Bloc de code:
diskutil list
dans le Terminal ou regarder dans l'utilitaire de disque.
 

pgui

Membre junior
5 Janvier 2005
45
0
53
pierre.guicquero.free.fr
Merci pour vos réponses.

Après une bonne journée à essayer comprendre ce qui se passe, voici ce que j'ai fait, où j'en suis et les questions que je me pose encore :
Avant d'aller plus loin, je vous précise ma configuration un peu particulière :
J'ai donc un mbp (2009) sous OSX 10.6.8 auquel j'ai ajouté un SSD 128Go l'an dernier sur lequel je fais tourner le système et les applications. Mon dossier utilisateur étant sur mon DD d'origine. Pour le lier au système sur l'autre disque, j'ai appliqué le tuto macg : Pas-à-pas : déplacer le dossier Utilisateur de Mac OS X sur un autre disque.
Je n'ai jamais eu de pb depuis un an et je ne pense pas que ça vienne subitement de là.

J'ai donc vérifié et réparé les autorisations, vérifié et réparé les disques
J'ai ensuite lancé la vérification avec TechTool Pro du volume DD (disk1s2) puisque c'est là que ça coince. TTP m'indique 10 blocs défectueux sans donnés dessus.
"10 mauvais blocs.
NA 272177916
NA 272177938
NA 272177935
NA 272177954
NA 272177946
NA 272177919
NA 272177911
NA 272177957
NA 272177951"
NA 272177900
(j'ai une sauvegarde time machine)
Est-ce grave ou est-ce que le système peu isoler ces bloc (SMART ??)

pendant un gel voici ce que m'indique la console :
20/12/13 08:59:05 kernel disk1s2: I/O error.
20/12/13 08:59:05 kernel
20/12/13 08:59:05 kernel
20/12/13 08:59:05 kernel hfs_clonefile: cluster_read failed - 5

Comme mon plantage démarre avec iTunes, j'ai essayé de charger une sauvegarde (justement) de ma librairie iTunes (iTunes Library.itl) mais ça a tenu 5mn.

Quand le plantage (figeage) arrive, le moniteur d'activité m'indique plein de system_profiler (environ 140 opérations - j'ai une centaine d'opérations en moyenne en temps normal, 245 sur ma capture d'écran) qui saturent le CPU (cf plus haut).

Les questions que je me pose sont :
Sont-ce les blocs défectueux qui cause ces gels (alors que TTP m'indique qu'il n'y a rien dessus) ?
Pourquoi ai-je ces system_profiler (information système, non?) en profusion ?

Est-ce le bug du systeme_profiler qui empêche l'accès disque en saturant le CPU ou est-ce un pb physique disque qui empêche le systeme_profiler de fonctionner correctement et de tourner en rond comme il fait ?

Voilà ou j'en suis.

Je pense qu'il faudra neanmoins que je change mon DD rapidement.
A ce sujet, comme j'ai mon système et mes données perso sur 2 disques, est-ce que la sauvegarde me remettra les fichiers perso à la bonne place (je n'ai jamais fait de restauration depuis une sauvegarde Time Machine) ?


Merci encore pour vos éclairements.
 

pgui

Membre junior
5 Janvier 2005
45
0
53
pierre.guicquero.free.fr
Dernières nouvelles :

Le problème se déclenchait vraiment avec les fichiers iTunes Library.itl et .xml
Dès que je cliquais sur le fichier, dès que je le regardais même, ça gelait.
J'ai donc supprimé et reconstruit le fichier .itl à partir du .xml que j'avais au préalablement déplacé sur le bureau comme le préconise apple
Je n'ai plus de freez. Ouf ! et iTunes remarche parfaitement à nouveau.

Je suis conscient que c'est une rustine en attendant de changer le DD que je viens de commander.

Je vérifie bien que Time Machine fait bien les sauvegardes et attends avec appréhension le changement de DD.

Je vous tiendrai au courant de la suite (pour ceux que ça intéresse)

Merci pour vos lumières