XPress > PDF "non exportable"

TYPO 48

Membre junior
11 Juin 2007
97
4
Liège
Bonjour,
Le titre de mon sujet n'est peut-être pas clair. Je n'en ai pas trouvé d'autre. Si le modérateur trouve mieux, qu'il le change.
Voici mon problème.
Je travaille sous Mac OS 10.4.11 avec QuarkXPress 8.1 et je génère des documents PDF que j'envoie à des correspondants.
Ceux-ci se plaignent de ce que le texte des PDF n'est pas exportable (copier-coller) ou, en tout cas, que le texte qu'ils exportent n'est pas correct, au niveau des accents notamment.
Quand je produits un PDF compressé (Fichier>Imprimer>Imprimante>PDF>Compresser le document PDF), le texte exporté du PDF est complètement illisible. Soit. Mais quand je crée un PDF "normal" (Fichier>Imprimer>Imprimante>PDF>Enregistrer en format PDF), le texte exporté du PDF est lisible mais les caractères accentués sont remplacés par des points et, à chaque fin de ligne, un retour à la ligne est généré.
Il y a bien la commande XPress Fichier>Enregistrer qui fonctionne mais elle n'est utilisable que pour le bloc activé. Or, le nombre élevé de blocs dans le document rend cette façon de faire fort fastidieuse.
Qui pourra me dire comment faire parvenir facilement le texte du document XPress de manière correcte et utilisable par quelqu'un qui ne possède pas l'application ?
J'aimerais joindre les documents mais les "Règles de messages" affichées m'indiquent que ce n'est pas autorisé ! Peut-on modifier ces règles ?
Merci à ceux qui répondront.
 

CMYK

Membre d’élite
Club MacG
25 Novembre 2004
1 554
39
Ici, pourquoi ?
Salut ! D'abord faire la mise à jour vers XPress 8.5. Ensuite, produire ton PDF par exemple en choisissant Fichier > Exporter > Mise en page en PDF, et en choisissant les bons réglages (Options > Polices, Tout sélectionner). Note que je suis en v9, je ne sais plus s'il y a eu des changements entre la 8 et la 9 à ce niveau-là.
Reviens si tu as d'autres questions.
 

TYPO 48

Membre junior
11 Juin 2007
97
4
Liège
Merci CMYK pour ta réponse rapide et efficace.

Pour ce qui est de la mise à jour, c'est un peu compliqué.
Je travaille sur un matériel qui date de 2005, hérité d'une entreprise qui a cessé son activité et dans laquelle j'ai travaillé.
Les mises à jour, quand elles sont financièrement envisageables, se heurtent souvent à des problèmes sérieux.
Le système 10.4.11 n'est souvent plus compatible avec les nouvelles versions des applications.
D'autre part, je me suis renseigné pour mettre le système à jour.
Mon fournisseur me répond que ma machine (G5) ne le supporterais pas...
Comme je l'utilise à des fins personnelles (ou bénévoles), la dépense n'est pas envisageable.
Il faut donc me débrouiller avec ce que j'ai.

Quant à la méthode que tu conseilles, je l'ai essayée.
Les réglages sont assez nombreux, compliqués et parfois difficilement compréhensibles pour moi.
MAIS ÇA MARCHE !
Du moins, les accents apparaissent-ils (dans mon système en tout cas). Reste à voir sous le(s) système(s) de mes correspondants.
Il me reste le problème des retours à la ligne.
Je vais piocher la fonction d'aide pour voir si je peux trouver les bons réglages.

En tout cas, encore merci !
 

claude72

Membre d’élite
Club MacG
13 Février 2005
3 657
277
60
Pour ce qui est de la mise à jour, c'est un peu compliqué.
Non, c'est au contraire très simple : tu vas sur le site de Quark, tu télécharges la mise à jour 8.5 et tu la lances, c'est tout.

Ce que tu dis sur les mises à jour compliquées à cause de ceci ou de cela n'est valable que pour des mises à jour MAJEURES (upgrade en english), donc les changements de version, comme par exemple passer de 8.x à 9)...

... mais la mise à jour de 8.x à 8.5 est une mise à jour MINEURE (update en english) qui apporte quelques petites améliorations techniques mais qui est surtout faite pour corriger des bugs tout en restant dans la même version (la version 8) du logiciel. Elle ne demande ni changement de système, ni changement d'ordinateur et en plus elle est gratuite.

Donc, commence par faire la mise à jour en 8.5.



Le système 10.4.11 n'est souvent plus compatible avec les nouvelles versions des applications.
XPress 8.5 n'est pas une nouvelle version par rapport à la 8.1, donc il fonctionne sans problème sous 10.4.



D'autre part, je me suis renseigné pour mettre le système à jour.
Mon fournisseur me répond que ma machine (G5) ne le supporterais pas...
Ton fournisseur est soit un incompétent, soit un voleur : le G5 supporte jusqu'à Mac OS 10.5, c'est à dire Léopard en langage félin. Mais en fait le 10.5 n'apporte pas grand-chose par rapport au 10.4. (j'ai essayé le 10.5, et je suis revenu au 10.4)
 
Dernière édition:

TYPO 48

Membre junior
11 Juin 2007
97
4
Liège
Bonjour Claude72,

J'ai été un peu surmené et j'ai négligé mes courriels (29 non lus sans compter les pourriels !). C'est pourquoi j'ai tardé à répondre.
Comme je l'ai dit, j'ai hérité le matériel et les logiciels d'une firme en liquidation depuis plusieurs années. Je ne possède pas les licences des programmes, je ne peux même pas dire s'ils sont inscrits. Est-il possible de faire des mises-à-jour dans ces conditions ? J'ai ouvert la page suivante : Quark mais je ne sais comment procéder.

En avril 2012, j'avais contacté le fournisseur de la machine et je lui avais posé la question suivante :
De plus en plus d'applications ou de services en lignes réclament une version plus récente de mon système. Est-ce possible sur ma machine et cela nécessite-t-il une intervention de votre part ? Quel en serait le prix ? Pour information, voici le système actuellement en fonctionnement et le processeur installé : Mac OS X 10.4.11 - Processeur 2 x 2 GHz PowerPC G5 - Mémoire 1.5 Go DDR2 SDRAM

Et il m'avait répondu :
Pour ce qui est de votre G5, il est matériellement limité à Mac OS 10.5.8 (Leopard) et certains autres éléments pourraient être ennuyeux pour l'accès à certains sites comme Adobe Flash Player qui n'existe qu'en version 10.xx alors que la plupart des sites sont déjà passés à la version 11.xx. En fait la plupart des logiciels pour Apple ne sont plus développés que pour les machines à processeur Intel...

Pour en revenir au sujet, le problème qui subsiste est donc celui de la création d'un retour à la ligne (alinéa) intempestif à chaque fin de ligne du document PDF. Est-ce que la mise à jour réglerait ce problème ?
 

claude72

Membre d’élite
Club MacG
13 Février 2005
3 657
277
60
Je ne possède pas les licences des programmes, je ne peux même pas dire s'ils sont inscrits.
Venant d'une société, il y a de fortes probabilités que le logiciel soit enregistré !!!
En revanche le transfert de licence n'a pas été fait, donc ton logiciel est toujours enregistré chez Quark au nom de la société et non pas au tien.



Est-il possible de faire des mises-à-jour dans ces conditions ?
Oui.



J'ai ouvert la page suivante : Quark mais je ne sais comment procéder.
Là, tu exagères un peu ! ça marche comme tout site internet de support de logiciel : tu cliques sur "Assistance", puis sur "Télécharger"...

... ensuite tu sélectionnes le logiciel à mettre à jour (QuarkXPress), ton OS, et "Updaters", et tu cliques sur "Rechercher"...

... puis tu défiles la (longue) page des mises à jour jusqu'à trouver "QuarkXPress 8.5.1" et tu télécharges le fichier...

... et pour finir tu lances l'installation de la mise à jour.



En avril 2012, j'avais contacté le fournisseur de la machine et je lui avais posé la question suivante :
De plus en plus d'applications ou de services en lignes réclament une version plus récente de mon système. Est-ce possible sur ma machine et cela nécessite-t-il une intervention de votre part ? Quel en serait le prix ? Pour information, voici le système actuellement en fonctionnement et le processeur installé : Mac OS X 10.4.11 - Processeur 2 x 2 GHz PowerPC G5 - Mémoire 1.5 Go DDR2 SDRAM

Et il m'avait répondu :
Pour ce qui est de votre G5, il est matériellement limité à Mac OS 10.5.8 (Leopard) et certains autres éléments pourraient être ennuyeux pour l'accès à certains sites comme Adobe Flash Player qui n'existe qu'en version 10.xx alors que la plupart des sites sont déjà passés à la version 11.xx. En fait la plupart des logiciels pour Apple ne sont plus développés que pour les machines à processeur Intel...
Pour l'OS, il a raison, 10.5.8 maximum sur le G5... pour FlashPlayer aussi, dans l'absolu...

... mais il y a des gens qui refusent l'obsolescence programmée et qui savent faire vivre des Mac anciens, il suffit de chercher : je surfe sur internet avec un G4 (donc un Mac plus ancien que le tien) sous 10.4.11 (donc le même OS que toi) sans trop de problèmes, et je regarde aussi des vidéos, même parfois avec Flash :

D'abord j'utilise le navigateur TenFourFox : c'est une base de FireFox, mais recompilée pour Mac à processeur PPC sous OS 10.4 et 10.5... donc il suit les évolution de FireFox et a (quasiment) les mêmes possibilités, et notament la compatibilité html5 ce qui permet de se passer de Flash sur YouTube et autres sites utilisant l'html5. (sur YouTube il faut aller je-ne-sais-plus-où activer une option qui permet d'avoir de préférence les vidéos en html5)
Bon, faut quand-même pas rêver, il ne faut pas compter regarder du streaming...
L'inconvénient majeur de 104fox, c'est qu'il n'accepte pas les plug-ins, pour la bonne et simple raison que la plupart (comme FlashPlayer) ne sont pas compatibles PPC et/ou ne sont plus mis à jour pour PPC et contiennent des failles de sécurité qui peuvent être dangereuses...
Attention, il y a 4 versions : il faut bien télécharger celle qui correspond au bon processeur ! Et à la base il est en anglais... mais il y a les ressources de langues, dont le français, sont tout en bas de la page.
Tu peux aussi lui ajouter AdBlock+ !

Ensuite, un bidouilleur (de génie) a réussi à modifier un plug-in FlashPlayer 10 pour lui donner la signature d'un 11... donc quand le site regarde la signature il voit que c'est "11" et donc il accepte la connexion sans afficher le traditionnel panneau demandant d'upgrader FlashMachin... Bon, évidemment, parfois ça plante, mais en général ça fonctionne bien...
TenFourFox ne l'accepte pas, mais une fois qu'il est installé dans le système il est utilisable par Safari, et après il suffit de jongler avec les 2 navigateurs en fonction des contenus.

Tu peux aussi télécharger le .zip directement ici... ensuite tu dé-zippes, et tu lis bien le mode d'emploi pour l'installation !!!


Et pour finir, j'ai installé le 10.5 sur mon G4, mais je ne l'ai pas du tout aimé... en plus j'ai aussi 1,5 Go de RAM et c'est (peut-être) un peu juste... alors je suis revenu sous 10.4.



Pour en revenir au sujet, le problème qui subsiste est donc celui de la création d'un retour à la ligne (alinéa) intempestif à chaque fin de ligne du document PDF. Est-ce que la mise à jour réglerait ce problème ?
Aucune idée ! mais XPress 8.1 a apporté une modification majeure dans la gestion des PDF, et donc il y a des bugs qui sont apparus...
De toutes façons, il faut toujours faire les mises à jour techniques : même si ça ne règle pas le problème actuel, ça en règlera d'autres dont tu ne soupçonnes même pas l'existence !
 
Dernière édition: