Accès à Sites impossible

Kcinn4y

Nouveau membre
23 Septembre 2011
3
0
Bonjour,

J'ai suivi le tutoriel suivant afin d'installer PHP, MySQL, PHPMyAdmin et Apache opérationnels sur mon MacBook Pro avec Mac OS X Lion :

http://www.pheelit.fr/HighTech/Developpement/Installation-Apache-PHP-Mysql-sur-Mac-OS-X-Lion

Mais il y a un problème, je ne peux pas accéder à mon localhost j'ai l'erreur suivante :

"Forbidden
You don't have permission to access /~[User]/ on this server"

Si quelqu'un pouvait m'aider je lui en serait reconnaissant...

Cordialement.
 

Kcinn4y

Nouveau membre
23 Septembre 2011
3
0
Très bonne question ^^ j'utilise 192.168.0.10/~username mais je viens de voir dans les réglages de mon partage web que cette adresse pointe dans le dossier Sites alors que l'adresse 192.168.0.10 pointe dans Bibliothèque/WebServer/Documents/ ou là j'ai bien un "it works!"

Je pense qu'il faudrait faire pointer 192.168.0.10 dans Sites au lieu de Bibliothèque/WebServer/Documents/ mais je ne suis pas sûr de savoir comment faire...

---------- Nouveau message ajouté à 14h33 ---------- Le message précédent a été envoyé à 13h46 ----------

Bon ben en fait c'est bon j'ai réussi :) j'ai remplacé tous les /Library/WebServer/Documents que j'ai trouvé par /Users/Kcinn4y/Sites dans /etc/apache2/httpd.conf /etc/apache2/original/httpd.conf

Merci bien en tout cas...
 

ntx

Vénérable sage
Club MacG
15 Octobre 2004
12 057
371
92
A noter que les URL à utiliser sont données dans le panneau "Partage" des "Préférences système" quand tu actives le partage web.

Après dans ton cas, tu sembles te trouver derrière un routeur, d'où quelques réglages en plus à faire pour que le routeur fasse suivre vers le bon site les demandes entrantes.

Par contre modifier le fichier http.conf dans original n'est pas une bonne idée, car le jour où tu voudras remettre ta conf Apache d'aplomb, tu auras perdu l'original.
Et ta solution n'est qu'une rustine car tu n'as pas à modifier ce fichier, en tout cas pour faire ce que tu veux faire. Par contre tu peux modifier le fichier <ton utilisateur>.conf qui se trouve dans /etc/apache2/users, ou le créer s'il n'existe pas :siffle:

A y mettre par exemple :
Bloc de code:
<Directory "/Users/Kcinn4y/Sites">
    Options Indexes MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>
 
Dernière édition:

Kcinn4y

Nouveau membre
23 Septembre 2011
3
0
Ah d'accord merci beaucoup pour l'info :up:

---------- Nouveau message ajouté à 15h58 ---------- Le message précédent a été envoyé à 15h55 ----------

Sinon maintenant j'ai un problème au moment du
/usr/bin/phpize
"Cannot find config.m4."

Une idée?