Adapter : problème avec des sources en AVI

ccciolll

Vétéran
Club MacG
Bonjour,

ayant découvert adapter pour exporter aisément mes vidéos en libx264, ce qui permet une belle économie d'espace, dans la foulée je voulais aussi y faire passer mes vieilles vidéos d'APN en .avi

Mais je n'y parviens pas.
Quand je dépose des .AVI dans adapter, il les affiche bien.
Si je mets encoder = mpeg4 il met un logo ERROR rouge sur la vidéo, mais si je mets encoder = libx264 il ne met bien le truc en vert, il me fait la prévisualisation du résultat, mais quand je lance la conversion, les fichiers obtenus ont bien un poids en correspondance avec la durée, mais l'image est blanche et pas de son.

Je remarque, par ailleurs, que si je passe d'abord ces fichiers AVI par MPSC pour les exporter en mp4, et ensuite je les repasse dans adapter, il les prend en charge, mais ça fait 2 encodages, perte de temps, perte de qualité, c'est un peu con.

Il y a un bug qqpart sur mon poste ou adapter ne convertit pas le AVI ?

Pour info, voici les détails d'un de mes fichiers AVI pris au hasard
Bloc de code:
Flux : 2008.08.01 — TL plage cap.avi
Chemin : ~/Movies/Decoupe et encodage/_2b encodés originaux a jeter plus tard copie/2008.08.01 — TL plage cap.avi

Durée : 0:00:14
Taille des données : 4.69 Mo
Débit : 2.80 Mbps

Pistes vidéo :
Animation JPEG OpenDML, 320 × 240, 30 fps, 2.45 Mbps

Pistes audio :
Petit boutien à 16 bits mono, 22.05 kHz, 353 kbps

Fichiers du flux :
2008.08.01 — TL plage cap.avi (4.69 MB)
 

JLB21

Vétéran
Club MacG
22 Novembre 2007
5 479
491
Bonjour ccciolli :coucou:

Décidément, on te vois souvent sur le forum vidéo par les temps qui courent…

Je te répondrai simplement :

- j'ignore pourquoi Adapter ne prend pas ce type de vidéo. Mais si tu regarde sur le net, cela n'a rien d'étonnant et tu as de la chance que MPEG Streamclip les ouvre.
Alors ne sois pas, une fois de plus, plus royaliste que le roi !

- pourquoi 2 encodages alors que MPEG Streamclip t'offre la solution une fois pour toutes… ?

En effet, si MPEG Streamclip ouvre tes fichiers avec la vidéo encodée en 'Animation jpeg OpenDML', il te suffit depuis MPEG Streamclip de faire :
Fichier/Exporter en MPEG-4. Une fenêtre s'ouvre/menu déroulant Compression->choisir H.264/Taille de l'image : sélectionner Autre, rentrer la définition souhaitée (la même que choisie dans Adapter)/Limiter le débit : rentrer le même débit en kbps que celui que tu choisis dans Adapter/Menu déroulant Son : choisir AAC et limiter le débit au même niveau que dans Adapter/et enfin…
Créer mp4.


Et tu vas obtenir exactement le même fichier que celui que tu aurais obtenu avec Adapter…

Et si tu veux effectuer des traitements par lots, une fois MPEG Streamclip ouvert, tape cmd-B pour afficher une fenêtre où tu pourras glisser les vidéos à traiter.

Alors, par avance, je sais que tu va compliquer les choses avec des considérations qui te sont habituelles, mais tant pis si tu n'as toujours pas compris l'encodage vidéo.
Et notamment, tu vas rétorquer : 'mais ce n'est pas du x.264…'

Alors OK, télécharge le codec x.264 ici (et pas ailleurs car c'est le site d'origine). Installe le sur ta machine. Il te faudra alors je pense re-démarrer.
Et oh, miracle, dans MPEG Streamclip, lorsque tu iras dans le menu déroulant Compression (voir plus haut), tu auras un choix supplémentaire, en plus du codec H.264, le x.264, le même qu'utilisé par Adapter.
Si donc tu choisis les mêmes débits vidéo et audio que dans Adapter, tu obtiendras rigoureusement le même fichier en sortie de MPEG Streamclip que s'il avait été produit par Adapter.

Mais avec un seul encodage au lieu de deux… C'est bien ce que tu cherches ?

Magique, non ?:rolleyes:
 

ccciolll

Vétéran
Club MacG
Bonjour ccciolli :coucou:

Décidément, on te vois souvent sur le forum vidéo par les temps qui courent…

Oui, ça a commencé avec cette histoire de capture VHS Elgato (je dois d'ailleurs encore faire qqes tests et ajouter de nouveaux éléments dans la discussion précédentes) et du coup je me suis aperçu que le h264 était un format plutôt efficace en terme de compression donc j'ai attaqué la transition de certains de mes vieilles vidéo d'APN.


- j'ignore pourquoi Adapter ne prend pas ce type de vidéo. Mais si tu regarde sur le net, cela n'a rien d'étonnant et tu as de la chance que MPEG Streamclip les ouvre.
Alors ne sois pas, une fois de plus, plus royaliste que le roi !

Quand j'ai fait une recherche sur le net, justement, je n'ai rien trouvé là-dessus (sur le fait qu'adapter n'arrive pas à les lire) mais je n'ai peut-être pas mis les bons termes techniques.
Et je ne comprends pas ce que tu entends par « Alors ne sois pas, une fois de plus, plus royaliste que le roi ! »

- pourquoi 2 encodages alors que MPEG Streamclip t'offre la solution une fois pour toutes… ?

En effet, si MPEG Streamclip ouvre tes fichiers avec la vidéo encodée en 'Animation jpeg OpenDML', il te suffit depuis MPEG Streamclip de faire :
Fichier/Exporter en MPEG-4. Une fenêtre s'ouvre/menu déroulant Compression->choisir H.264/Taille de l'image : sélectionner Autre, rentrer la définition souhaitée (la même que choisie dans Adapter)/Limiter le débit : rentrer le même débit en kbps que celui que tu choisis dans Adapter/Menu déroulant Son : choisir AAC et limiter le débit au même niveau que dans Adapter/et enfin…
Créer mp4.


Et tu vas obtenir exactement le même fichier que celui que tu aurais obtenu avec Adapter…


C'est possible, c'est juste que je suis désormais plus familier avec les réglages d'Adapter (l'interface est tout de même plus simple, tu ne trouves pas ?).
J'indiquais d'ailleurs moi-même que ce serait un peu absurde de procéder comme ça.
MAIS.
Une différence notable entre MPSC et adapter c'est que dans MPSC, je peux faire les réglages d'export, balancer tous les fichiers, et le laisser bosser tout seul.
Dans MPSC, je vais devoir les exporter tous un par un (sauf si tu me dis qu'il existe encore un truc caché dans MPSC qui en est capable).

Et si tu veux effectuer des traitements par lots, une fois MPEG Streamclip ouvert, tape cmd-B pour afficher une fenêtre où tu pourras glisser les vidéos à traiter.


Ah ben voilà ce qui arrive quand on répond à un message sans l'avoir lu en entier d'abord.
Ça c'est une bonne nouvelle !

Alors, par avance, je sais que tu va compliquer les choses avec des considérations qui te sont habituelles, mais tant pis si tu n'as toujours pas compris l'encodage vidéo.


Dès les premiers mots de ta réponse j'ai craint que tu ne places quelques mots désagréables pour bien montrer ta supériorité absolue, mais je m'étais abstenu d'écouter ces craintes, me disant que peut-être c'était juste moi qui ne comprenais pas tes réponses ou ta façon de dire les choses…

Et notamment, tu vas rétorquer : 'mais ce n'est pas du x.264…'


Non, même pas.
Dans MPSC, export MPEG-4, on a le choix du codec H.264
Et comme dans mon esprit simpliste libx264 et H.264 c'était pareil (d'ailleurs quand j'exporte en libx264 dans adapter, que j'ouvre ledit export dans MPSC et fais pomme-I, il annonce du H.264 et pas du libx264, ce qui corrobore cette confusion dans mon esprit).
Mais maintenant que tu y as insinué le doute… Hin hin hin… Je vais effectivement pinailler là-dessus.


Alors OK, télécharge le codec x.264 ici (et pas ailleurs car c'est le site d'origine). Installe le sur ta machine. Il te faudra alors je pense re-démarrer.
Et oh, miracle, dans MPEG Streamclip, lorsque tu iras dans le menu déroulant Compression (voir plus haut), tu auras un choix supplémentaire, en plus du codec H.264, le x.264, le même qu'utilisé par Adapter.


Donc il existe vraiment une différence entre H.264 et libx264 ?
Mais alors pourquoi donc MPSC annonce H.264 quand je lui fais ouvrir un export d'adapter en libx264.

Tu ne vas pas me dire que ça ne prête pas à confusion.

Mais la différence entre libx264 et H.264 est elle vraiment importante ?

Il y en a au moins une : les exports (*)264 d'adapter ont bien fonctionné chez moi, pas ceux de MPSC (tu te souviens, c'était le début de nos échanges et de notre incompréhension mutuelle).

Peut-être (je pose une hypothèse au hasard) que cette nuance entre libx264 et h.264 expliquerait que les exports de MPSC se comportaient bizarrement sur mon lecteur BD et pas celles d'adapter. À tester…


Si donc tu choisis les mêmes débits vidéo et audio que dans Adapter, tu obtiendras rigoureusement le même fichier en sortie de MPEG Streamclip que s'il avait été produit par Adapter.

Mais avec un seul encodage au lieu de deux… C'est bien ce que tu cherches ?


Pour l'instant, vu comme ça, oui.
Je pense qu'il faudra tout de même le tester pour en être sûr, un grain de sable pourrait bien venir égayer tout ça.


Magique, non ?:rolleyes:

C'est pas parce que je suis une quiche en encodage vidéo que je crois à la magie, n'exagérons rien. Mais « satisfaisant » oui, aucun doute.






Mais, allez, puisque tu es venu me provoquer en disant « tu vas encore pinailler blablabla », j'ai un nouveau sujet de turlupinage.

La fois dernière, tu m'es rentré dans le lard en me traitant subtilement d'abruti fini car je j'utilisais le terme « MP4 » au lieu de « MPEG-4 », et s'en est suivi une docte leçon expliquant que le MP4 est un conteneur et MPEG-4 est un codec vidéo. Depuis, OK, pas contrariant, j'ai pris ton parti et je considère MP4 comme un conteneur et MPEG-4 comme un codec vidéo (car même si tu en doutes, je fais la différence entre conteneur et codec vidéo, et je sais aussi entendre (enfin lire) ce que tu me dis).
Mais en me faisant retourner dans MPSC pour vérifier la présence de H.264 (que je confondais avec libx264, je l'avoue sans problème), tu m'as aussi fait constater que, dans MPSC, ils n'indiquent pas « Exporter en MP4 » mais bien « Exporter en MPEG-4 ».
Et ce menu « exporter en MPEG-4 », qui crée des fichiers conteneurs MP4, propose bien d'utiliser le codec vidéo H.264 qui n'est donc pas le MPEG-4.
Du coup, je me dis, soit ils ont déconné dans MPSC et tu devrais aller pinailler sur le terme mal utilisé (attention, je ne dis pas que pinailler c'est mal, je serais mal placé pour ça) dans leur menu déroulant. Soit MP4 est bien la contraction textuelle de MPEG-4 et dans ce cas je trouve que c'était un peu gonflé de ta part de me faire croire le contraire tout en me prenant de haut.
 

ccciolll

Vétéran
Club MacG
Tout ceci étant dit, il n'en demeure pas moins troublant de voir que Adapter sait prévisualiser mes fichiers AVI (je peux voir avant et après conversion dans la fenêtre du bas comme avec d'autres vidéos) mais se plante au moment de le faire en vrai.
 

JLB21

Vétéran
Club MacG
22 Novembre 2007
5 479
491
Bonjour ccciolli :)

Je me doutais bien que j'allais encore avoir une tartine à lire…:rolleyes: Je commence à te connaître…

Mais comme je vois que tu as tout compris (malgré les doutes que tu émets encore par ci par là), je vais juste te répondre à propos de ton 'nouveau sujet de turlupinage', et je vais te faire plaisir : si l'on regarde le définition du MPEG-4 part 14 dans Wikipedia, on peut admettre une confusion entre MPEG-4 et mp4…
Mais ce sont des différences subtiles, car le 'MPEG-4 Part 14' est un container qui peut supporter des codecs MPEG-4.

Alors, tu as raison, et j'ai raison, et MPEG Streamclip a raison, sauf que ce dernier ne propose pas le codec MPEG-4 pour exporter en… container MPEG-4/mp4…
Alors que Adapter propose plus prosaïquement d'exporter en mp4 (container) et propose les seuls codecs 'mpeg-4' et 'libx.264' (en fait, les plus utilisés)…

Pourtant, MPEG Streamclip permet d'encoder aussi avec le codec MPEG-4, mais il faut faire 'Exporter en d'autres formats' et choisir dans le menu déroulant MPEG-4…
Je pense quand même à ce niveau, à un défaut de conception.

Un logiciel comme iFFmpeg, plus complet que Adapter, propose en container mp4 : H/x.265, H/x.264, MPEG, MPEG-2, MPEG-4.

Et la philosophie est encore différente dans Compressor !

Alors, je te l'accorde, c'est un peu une jungle et ce n'est pas facile à comprendre pour une personne possédant, comme toi, un esprit on ne peut pas plus cartésien…:banghead:

Mais je sens que désormais, tu es capable de nager dans toutes ces considérations comme un poisson dans l'eau, tu n'as plus besoin de bouées aux bras et à la taille…:coucou:
 

ccciolll

Vétéran
Club MacG
Oh ben je vais quand-même les garder encore un peu les bouées. Je ne suis pas très aventurier…

Parce que (désolé hein) il y a encore un truc qui me gratte un peu.
Nyxouf a donc indiqué la différence entre h.264 et x264. En gros H.264 est un langage et x264 est le logiciel qui encode des vidéos dans ce langage.
Mais pourtant, avant ça, tu m'avais indiqué qu'il existait, pour MPSC, la possibilité d'installer un truc pour encoder en x264 plutôt qu'en h264 (enfin, c'est peut-être pas les termes exacts que tu emploies, mais tu expliquais bien qu'il existait 2 possibilités dans MPSC/exporter en mpeg4 ; assez similaire certes, mais suffisamment différentes pour qu'on puisse les distinguer : le h264 déjà présent, et le x264 qu'on peut ajouter en suivant le lien que tu as donné). Encore de la confusion dans la confusion… Bon, je pourrais passer outre sauf que…

Sauf que, après test, j'ai bien tenté d'exporter depuis mpsc avec le réglage MPEG-4 > H264, en limitant le débit et réglages audio « comme dans adapter » mais la vidéo qui en résulte s'affiche mal sur mon lecteur BD (étroitisé, comme ce que j'avais déjà constaté avec mes premiers tests, finalement). Du coup je me demande si je tenterai pas d'installer le x264 pour MPSC dont tu parlais pour voir si ça change qqchose.

Et donc pour mes fameux AVI qui ne passent pas dans adapter mais passent dans MPSC, soit je trouve un moyen pour que l'export MPSC s'affiche bien sur mon lecteur BD (probablement donc en modifiant cet export car les réglages sur le lecteur BD sont un peu pauvres), soit je fais cette aberration (mais je ne vois pas d'autre piste) : premier encodage vers MP4 « qualité maxi » dans MPSC et deuxième encodage dans adapter qui me fait des fichiers qui passent bien sur mon lecteur.

Si qqe expert passant par ici arrive à me dire où est le loup juste en lisant ce rapport de videospec, on gagnera peut-être 2.000 caractères de diatribes supplémentaires…
Voici les analyses de 2 fichiers Elgato après que je les ais rabotés et exportés.
L'un exporté via MPSC-mpeg4-h264 l'autre via adpater-mp4-libx264 (leur noms sont assez éloquents).



Les différences que je trouve (hormis nom, date, durée et poids, évidemment)
- le démarrage rapide pour le h264/MPSC
- La fréquence d'image (bizarre car je ne l'ai jamais modifiée volontairement (en tout cas dans adapter elle est en « source »)) mais je doute que ça puisse influencer l'anamorphose.
- le profil d'encodage (baseline pour MPSC h264, high pour Adapter x264)
- param suppl : - CABAC pour x264/adapter - 2 contre 4 - GOP pour h264/mpsc - rapport bits un peu différent
et plus bas dans la compatibilité, bcp plus de formats en oui pour le h264/mpsc

pour moi, c'est tout de même un peu du chinois.
 

ccciolll

Vétéran
Club MacG
Je précise tout de même un truc : même si ça n'est pas complètement faux, je ne suis pas seulement un maniaque obsédé de précision qui va éplucher le moindre petit détails de ses fichiers. En fait, si l'export h264 de MPSC s'était affiché directement comme il faut sur mon lecteur BD, je ne serai jamais allé plus loin, je n'aurais pas découvert Adapter, je ne chercherai pas à trouver la subtile nuance entre h264 et x264 (s'il y en a une autre que celle expliqué par Nyxouf et qui indiquerait que comparer x264 à h264 c'est comme comparer un ver du chou à la constitution Bolivarienne). Breffle, je consommerai de la vidéo comme n'importe qui, le cul dans mon canapé. Seulement ça déconne, ça s'affiche tout anamorphosé, et moi j'aime pas ça. Donc je cherche comment faire pour avoir l'image comme je l'aime. Et je cherche longtemps, c'est vrai.
 

JLB21

Vétéran
Club MacG
22 Novembre 2007
5 479
491
Je précise tout de même un truc : même si ça n'est pas complètement faux, je ne suis pas seulement un maniaque obsédé de précision qui va éplucher le moindre petit détails de ses fichiers. En fait, si l'export h264 de MPSC s'était affiché directement comme il faut sur mon lecteur BD, je ne serai jamais allé plus loin, je n'aurais pas découvert Adapter, je ne chercherai pas à trouver la subtile nuance entre h264 et x264 (s'il y en a une autre que celle expliqué par Nyxouf et qui indiquerait que comparer x264 à h264 c'est comme comparer un ver du chou à la constitution Bolivarienne). Breffle, je consommerai de la vidéo comme n'importe qui, le cul dans mon canapé. Seulement ça déconne, ça s'affiche tout anamorphosé, et moi j'aime pas ça. Donc je cherche comment faire pour avoir l'image comme je l'aime. Et je cherche longtemps, c'est vrai.
Pourrais-tu me remettre au téléchargement un clip issu de Elgato, et qui sort étroit après traitement dans de MPEG Streamclip (pas une image fixe comme tu as fait les dernières fois).
Il doit bien y avoir moyen, depuis MPEG Streamclip de rétablir le bon format des pixels à l'export ?
 

ccciolll

Vétéran
Club MacG
Voici les fichiers. Attention c'est hyper lourd, pas loin de 60 mo !

J'ai mis 3 fichiers. L'original mpeg4 d'Elgato, l'export h264 de MPSC, l'export H264 d'adapter.
Seul celui de MPSC s'affiche étroitisé sur mon lecteur BD. Les 2 autres c'est OK.
à noter aussi que, bien qu'étant tous les deux au même débit de 512, celui de MPSC est bcp plus flou au final, alors que celui d'adapter est proche de l'original. Étonnant, non ?
https://www.transfernow.net/1073g6i9fp5x?lng=fr
Il y a un poltergheist dans ce mac…
 

JLB21

Vétéran
Club MacG
22 Novembre 2007
5 479
491
Salut ccciolll,
Bizarre de trouver hyper lourd quelques fichiers de 60 Mo… Moi je transfère des Go et ce n'est pas un problème.
je regarde cela demain matin.
A+
 

ccciolll

Vétéran
Club MacG
Bizarre de trouver hyper lourd quelques fichiers de 60 Mo…

Je suis un vieux grincheux, avec des connexion au web poussives, et en 1998 on m'avait appris, lors d'un stage html, que 100Ko pour une page web c'est un bon poids, depuis j'en suis resté là.

je regarde cela demain matin.

Pour compléter tout ça, voici aussi un tableau xls fait à partir des infos tirées de videoSpec.
Car j'ai constaté que des fichiers issus d'exports h264 de adapter pouvaient eux aussi avoir ce même problème d'affichage sur mon lecteur BD. (j'étais parti bêtement sur l'idée que j'en avais testé qqes uns, ça marchait pour eux donc ça marcherait pour tous les suivants…)


https://www.transfernow.net/63el4446udca?lng=fr
Ligne grise, l'original de Elgato (qui passe bien dans mon lecteur BD mais un peu lourd à mon goût)
Lignes vertes, ceux qui sont passés en H264 par adapter et passent bien dans mon lecteur BD (comme je le souhaite)
Lignes oranges, 2 fichiers qui sont passés en H264 par adapter MAIS ne passent pas bien dans mon lecteur BD (à mon étonnement)
Lignes rouges, 2 fichiers qui sont passés en H264 par MPSC et ne passent pas bien dans mon lecteur BD (comme je m'y attendais).

J'ai surligné en jaune les endroits où je trouve des subtilités qui peuvent être des pistes.

Le fait que les 2 adapter qui posent problème ont subi des interventions supplémentaires dans d'autres logiciels (mais il faudrait que j'approfondisse encore avec d'autres tests car j'ai l'impression que c'est encore plus compliqué que ça n'en a l'air).

dans « Four CC », j'ai H264 sur tous ceux qui déconnent, mais j'ai H528 (soit H264*2, bizarre) sur ceux qui marchent bien.

Dans « Profil d'encodage » j'ai Baseline sur les MPSC au lieu de High sur les adapter (à ce sujet, pas surligné en jaune mais qui me turlupine, dans les high de adapter, j'ai tout et n'importe quoi, dans le désordre, du High@L2.2 au @L3.1 en passant par le @3.0 sans que cela ne semble avoir de cause ni de conséquence bien nette et avec un modus opérandi d'export H264 à priori similaire).

Dans les dimensions de la vidéo, les 2 adapter qui déconnent ont des formats inhabituels.
L'une car j'ai fait une rotation
L'autre car je l'ai passée dans iMovie pour recaler le son (et allez savoir pourquoi, iMovie a jugé bon de changer la taille en pixels de mon fichier Elgato)

Dans param. supplémentaires, j'ai Cabac NON et images de reference 2 dans les MPSC (au lieu de Oui et 4 dans les adapter) et GOP M=1 sur les mpsc, aussi.

Enfin qqes compatibilités en OUi dans MPSC contre non dans adapter.

Je crois que c'est tout…
Quelle pagaille !
 

Nyx0uf

Zetsubou Sensei
Club MacG
1 Janvier 1970
805
55
The net is vast and infinite.
whine.fr
Pour la source du problème tu peux éliminer :
- Les profiles (baseline/main/high), c'est choisi automatiquement par le codec quand l'utilisateur ne le spécifie pas, mais ça ne changera pas le format de l'image.
- Les frames de références, pareil que les profiles.
- CABAC, ca n'aura pas d'incidence sur le format de l'image, après c'est probablement mieux quand c'est activé
- l'audio on s'en fou.

Sinon H258, heu non, c'est un bug du soft à mon avis, cf http://www.fourcc.org/codecs.php
 

ccciolll

Vétéran
Club MacG
Sinon H258, heu non, c'est un bug du soft à mon avis, cf http://www.fourcc.org/codecs.php

Non, j'ai vérifié les sources en .txt, c'est un bug qui s'est produit qd j'ai manipulé les données dans xls. C'est bien h264 à l'origine, ça a dû se multiplier par deux à un moment… Excel aime bien ajouter sa patte un peu partout !
Faut dire que le format dans lequel elles sont fournies par videospec demande énormément de retouches…
 

JLB21

Vétéran
Club MacG
22 Novembre 2007
5 479
491
Ben dis donc, quel travail !!!!

Si en plus Excel y met du sien en multipliant par deux les H.264, la situation devient trop complexe pour moi…:meh:

J'ai regardé ce que tu m'as mis au téléchargement, inspection avec VideoSpec, MediaInfo, iMediaHUD, j'ai bien remarqué quelques unes de tes observations, mais je n'ai rien vu susceptible d'expliquer ton problème d'anamorphose.

En plus, chez moi sous El Capitan, MPEG Streamclip 1.9.3b8 n'ouvre pas tes fichiers en sortie d'ElGato, il n'aime pas le 'MPEG-4 Visual' (format donné par MediaInfo et par iMediaHUD) !

Je t'ai mis 2 fichiers au téléchargement ici : https://drive.google.com/folderview?id=0B58mzBdlohf_M0ZlMUxiLUZaYUE&usp=sharing
- Elgato turbo-400 : encodage avec Turbo.264HD d'Elgato, vidéo à 400 kbps, audio à 80 kbps,
- iFFmpeg-400 : encodage avec iFFmpeg, vidéo à 400 kbps, audio à 96 kbps (impossible de rentrer un bit rate manuel en audio).

Peux-tu vérifier comment sont-ils lus par ton lecteur BD ?
Ce sont tous deux des logiciels payants.
 

ccciolll

Vétéran
Club MacG
Je testerai ça quand j'aurais le lecteur sous la main.
Mais je me demande si ce n'est pas le lecteur BD qui est simplement capricieux (bon, malgré tout, il doit y avoir qqchose qui l'empêche de bien afficher l'image de temps en temps) car, comme on le voit dans mes derniers tests, même des fichiers issus d'export d'adapter mais de sources différentes que du Elgato mpeg-4 posent problème.
 

ccciolll

Vétéran
Club MacG
Salut,

Avant toute chose, j'ai fait d'autres tests qui éclairent encore un peu mieux les choses : j'ai testé la lecture sur mon lecteur BD de mes fichiers « source » AVANT export en H264 (généralement du mpeg4, mais aussi qqes variations m4v ou avi).
Conclusion : les fichiers qui s'affichent mal une fois exportés en H264 via adapter s'affichaient DÉJÀ mal avant cet export.
Donc l'export en H264 via adapter n'est pas du tout en cause (je le supposais, maintenant j'en suis sûr).

Ensuite,
J'ai testé les fichiers savamment exportés par JLB21. Les deux passent bien. (EDIT : je rappelle que la version SOURCE de ce fichier, ainsi que celle exporté en H264 via adapter passait bien également).
Ce qui semblerait dire que, à partir d'un fichier source qui s'affiche bien sur mon lecteur BD, seuls les export H264 via MPSC posent problème sur mon lecteur BD (puisque tous les autres exports vers du h264, à partir d'une source OK, via adapter, turbo264 ou iffmpeg, passent bien, seuls ceux exportés via MPSC passent mal).

J'ai donc 2 problèmes avec ce lecteur BD.

- il ne prend pas bien les export H264 issus de MPSC. (ça, pas trop de souci, il suffit que j'utilise adapter ou autre)
- il ne prend pas bien non plus certains fichiers (qui s'affichent pourtant bien sur le mac) et là j'ignore pourquoi EXACTEMENT. C'est donc là que je vais devoir encore approfondir pour identifier ce qui pose problème, c'est peut-être plusieurs causes différentes, d'ailleurs.

Je vais aussi tenter des exports H264 avec d'autres version MPSC sur d'autres postes avec d'autres OSX, peut-être que ça marchera mieux, mais pas sûr que ça résolve le second problème qui est celui qui m'embête le plus actuellement.
 

houdini

Membre d’élite
Club MacG
24 Novembre 2005
1 883
50
Lyon
Non, j'ai vérifié les sources en .txt, c'est un bug qui s'est produit qd j'ai manipulé les données dans xls. C'est bien h264 à l'origine, ça a dû se multiplier par deux à un moment… Excel aime bien ajouter sa patte un peu partout !
Faut dire que le format dans lequel elles sont fournies par videospec demande énormément de retouches…
Bonjour,
On peut choisir dans les préférences de VideoSpec en mode analyse multiple le format csv importable facilement dans Excel.
houdini :merci:
 
  • J’aime
Réactions: ccciolll

ccciolll

Vétéran
Club MacG
Bonjour,
On peut choisir dans les préférences de VideoSpec en mode analyse multiple le format csv importable facilement dans Excel.
houdini :merci:

Ah nom de dieu le temps que j'aurai gagné si j'avais su ça plus tôt !
C'est parfait !