Application d'état

Jab

Membre junior
8 Décembre 2001
11
0
Suivant ton conseil, je viens de virer une préférence schockwave (c'est la seule qui a apparemment un rapport avec flash) et pour plus de sureté, j'ai viré l'application Flashplayer.
Maintenant IE pédale dans la semoule pour ouvrir les zip, à la recherche, je suppose, de son Flashplayer... Mais il n'ouvre pas Stuffit.
Tu penses que je dois virer TOUTES les préférences IE? Explorer, Explorer control, et tout le bazard? Il me semble difficile de localiser la préférence "types de fichiers"...
 

roro

Membre d’élite
Club MacG
22 Décembre 2000
3 606
31
43
Lille
dans IE, menu édition--> préférences--> onglet "type de fichiers", détermine l'appli qui doit ouvrir les .zip, en l'occurence "stuffit expander". Ca prendra effet pour les nouveaux fichiers .zip téléchargés avec IE.

[08 décembre 2001 : message édité par roro]
 

Jab

Membre junior
8 Décembre 2001
11
0
Salut Roro!

Le problème est que dans "types de fichiers", c'est bien "Stuffit" qui est affecté aux fichiers zip...
Maintenant, je crois avoir tout fait: j'ai viré toutes les préférences IE, et je l'ai même réinstallé... le problème persiste. Ça n'est pas très grave en soi, mais il se trouve qu'en ce moment, je dois télécharger de nombreux petits fichiers zipés, et ça m'oblige à aller chercher Stuffit à chaque fois, et puis... ben c'est pas normal, quoi!
 

MarcMame

Vétéran
Club MacG
25 Janvier 2001
7 011
266
<BLOCKQUOTE><font size="1" face="Verdana, Geneva">quote:</font><HR>Posté à l'origine par Jab:
Le problème est que dans "types de fichiers", c'est bien "Stuffit" qui est affecté aux fichiers zip...<HR></BLOCKQUOTE>
Oui, mais cela ne suffit pas...
Double-clic sur l'association et verifie que dans la section Gestion : "how to handle" tu as bien "post-traitement avec l'application.
 

Jab

Membre junior
8 Décembre 2001
11
0
Oui, c'est bien "post-traitement qui est sélectionné".
par contre, je viens de remarquer un truc pour la première fois: l'icône de Stuffit dans les préférences "types de fichiers" est grisée. J'ai essayé de la resélectionner en faisant "remplacer", mais IE rale , disant que la case "type de fichier doit comporter au moins 4 caractères. Or, il y en a 3: "ZIP" . Le problème viendrait-il de là? (je n'ai pourtant pas souvenir que cette icône était grisée la dernière fois que j'ai mis le nez dedans)
 

MarcMame

Vétéran
Club MacG
25 Janvier 2001
7 011
266
<BLOCKQUOTE><font size="1" face="Verdana, Geneva">quote:</font><HR>Posté à l'origine par Jab:
par contre, je viens de remarquer un truc pour la première fois: l'icône de Stuffit dans les préférences "types de fichiers" est grisée.<HR></BLOCKQUOTE>
Si elle est grisée, c'est qu'il croit que l'application n'est pas présente sur le disque. Plutot que de faire "remplacer" essaye de faire "parcourir" et reselectionne Stuffit.
 

Jab

Membre junior
8 Décembre 2001
11
0
C'est IE 5.O1.
Quand je suis dans la fenêtre des préférences "réglage des types de fichier", j'ai le choix entre "ajouter", "remplacer", et "supprimer". Je choisis la ligne "Stuffit Expander.... .zip", je double-clique dessus, je parcours pour choisir stuffit, et là, invariablement, il me dit qu'il faut 4 caractères dans la case "type de fichiers", et j'ignore lesquels...
Attends! ça marche: "StuffIt n'est plus grisé (j'ai rentré 4 "x"...)..........

......... mais c'est toujours Flash player qui esaye d'ouvrir les fichiers zip.

Laisse tomber, je vais essayer le bain d'acide.
Je te remercie de ton aide, en tous cas!
 

Jab

Membre junior
8 Décembre 2001
11
0
Bonjour, tout le monde!
j'ai, depuis quelque temps, un problème de téléchargement (Internet Explorer):
A la fin du téléchargement des fichiers "sit", l'application qui s'ouvre est "stuffit". Jusque là, rien d'anormal.
Mais si je télécharge un fichier compressé "zip", ce n'est plus stuffit qui s'ouvre (comme ça l'était il y a quelque temps) mais une autre application, en l'occurence "Flash player", qui, bien évidemment, ne peut pas faire grand chose d'un fichier "zip".
J'avais, il y a quelque temps, changé les préférences d'IE de manière à ce que les fichiers swf soient lus sur le web par Flash player et non par IE .J'ai, depuis, annulé cette préférence, mais c'est à partir de ce moment que le problème est apparu.
j'ai beau gratter, je n'arrive pas à régler ce problème.
Est-ce quelqu'un a une idée? Merci d'avance.
 

Bernard53

Membre d’élite
Club MacG
19 Mai 2000
1 313
34
66
Roissiat - 01370 COURMANGOUX
Pour les 4 caractères à rentrer ce sont ZIP et le dernier caractère est une espace.

Quand vous aurez fini dans IE allez ouvrir StuffIt Expander et dans le menu File - Preferences - choisissez la dernière option Internet et vous cliquez sur le bouton Use StuffIt Expander for all available types et vous validez par OK.
Ensuite vous allez dans le tableau de bord Internet, menu Édition - Mode utilisateur... choisissez Avancé et cliquez sur OK. Ensuite sélectionnez l'onglet Options avancées et la rubrique Associations et cherchez l'extension .zip et vérifiez qu'elle est bien associée à StuffIt Expander sinon refaites le réglage.
Ensuite tableau de bord Échange de fichiers - onglet Échange PC/Macintosh et de même vérifiez ou réglez pour l'extension .zip.
Vous quittez tout et redémarrez en reconstruisant le bureau, si après ça ne marche pas il faut aller brûler des cierges !

Salutations.

[09 décembre 2001 : message édité par Bernard53]
 

archeos

Membre d’élite
Club MacG
16 Janvier 2001
1 840
1
Alpes de Haute Provence
Supprime les prefs des applis concernés, d'abord Flashplayer, responsable à mon avis et plus léger à reconfigurer. Essaie ensuite avec celles d'IE
 

Jab

Membre junior
8 Décembre 2001
11
0
Je viens de suivre à la lettre vos instructions.
Rien à faire... Ce mac est hanté par FlashPlayer.
je vous remercie d'avoir pris le temps de me répondre à une heure aussi tardive.
Demain, j'essayerai les cierges. Et si ça ne marche pas, ce sera l'acide. (j'exagère... en dehors de ça, tout marche bien)
merci encore et bonne soirée.
 

Bernard53

Membre d’élite
Club MacG
19 Mai 2000
1 313
34
66
Roissiat - 01370 COURMANGOUX
Attention quand même avec l'acide, au fait lequel ? Un mélange chlorhydrique et nitrique pour dissoudre aussi l'or ? Faites gaffe aussi aux vapeurs.

Bref, et si vous désinstalliez Flash player, revérifiez les réglages sus-mentionnés et reconstruisiez le bureau ; que va faire IE maintenant en présence d'un fichier.zip ?
Parce que les fantômes je n'y crois pas, pas plus qu'aux cierges d'ailleurs ! M'enfin à cette époque de l'année on en voit un peu de partout.

Si par chance ou miracle ça marchait sans Flash player, allez-y doucement dans sa réinstallation.

Salutations.
 

Jab

Membre junior
8 Décembre 2001
11
0
Bonjour,
Le lecteur FlashPlayer est une petite application de 500k, qui apparemment ne crée même pas de préférences (ou alors, la préférence Schockwave?).
Je l'ai virée purement et simplement, puis j'ai reconstruit le bureau, et vérifié que toutes les préférences "type ou échange de fichiers" étaient bien braquées sur Stuffit en ce qui concerne les fichiers zip, comme hier soir...
Rien à faire. A chaque décompactage après téléchargement, IE cherche sans fin (il cherche Flashplayer, je suppose), et ne trouve pas stuffit.
Le fichier zip reste un "document Internet Explorer", jusqu'à ce que je le décompresse manuellement avec stuffit.
 

Bernard53

Membre d’élite
Club MacG
19 Mai 2000
1 313
34
66
Roissiat - 01370 COURMANGOUX
Décidemment c'est la poisse ! Au fait vous n'avez qu'une version de StuffIt Expander ?

Essayez autre chose : vous allez dans les préférences IE et vous supprimez le type de fichier .zip et fermez IE. Rouvrez IE - Préférences, là il ne devrait plus rien y avoir pour l'extension zip (à la limite faites un essai pour voir ce que dit IE) et on va la redéfinir ainsi :

Représentation
Description : PC ZIP Archive (c'est ce qu'il y a dans mon cas, mais ça n'a pas d'importance ce n'est qu'informatif)
Extension : .zip
Type MIME : application/zip

Type de fichiers
Application : cliquez sur le bouton Parcourir... et allez chercher StuffIt Expander
Type de fichiers : choisissez ZIP en déroulant le menu avec les deux flèches - Créateur de fichier : SITx doit s'installer automatiquement
Codage : cochez Données binaires et cochez également Pour l'entrant et Pour le sortant

Destination du Téléchargement
Là vous choisissez votre dossier préféré

Gestion
How to handle : (pas fini de traduire IE
) choisissez Post-traitement avec l'application
Application : cliquez sur le bouton Parcourir... et allez de nouveau chercher StuffIt Expander

Validez le tout par le bouton OK.

Si ça ne marche toujours pas, il ne vous reste plus qu'à choisir Enregistrer dans un fichier à la rubrique Gestion. Ainsi vous êtes condamné à décompresser ces fichiers à la main à postériori. Mais je ne vois pas d'autres solutions actuellement

Salutations.
 

Jab

Membre junior
8 Décembre 2001
11
0
Et bien voilà. je viens de faire tout ce que vous m'avez conseillé... et le problème demeure. J'imagine qu'il doit exister une préférence quelconque, cachée quelque part, qui doit "court-circuiter" StuffIt, ou un truc tout bête qui me donnera envie de me coller des baffes quand je le découvrirai. (Si c'est le cas, je le signalerai, ça peut toujours servir)
C'est extrêmement agaçant de ne pas comprendre, mais bon... A la prochain M.A.J., je ferai une ré-installation complète.
Merci de vous être donné autant de mal!

(j'ai bien une seule version de Stuffit - 6.01)
 

Bilbo

Vétéran
Club MacG
17 Octobre 2001
7 084
725
Strasbourg
<BLOCKQUOTE><font size="1" face="Verdana, Geneva">quote:</font><HR>Posté à l'origine par Jab:
A la prochain M.A.J., je ferai une ré-installation complète.<HR></BLOCKQUOTE>

Ce n'est pas la peine d'aller à de telles extrémités.


1. Redémarre sans les extensions (touche majuscule enfoncée).
2. Jette le fichier Dossier Système -&gt; Préférences -&gt; Internet Preferences
3. Redémarre en maintenant les touches pomme et alt pour reconstruire le bureau.

Ainsi, tu perds toutes tes prefs Internet et les associations de fichiers, c'est l'inconvénient. Tu pars d'une base saine, c'est l'avantage.

A+
 

Bernard53

Membre d’élite
Club MacG
19 Mai 2000
1 313
34
66
Roissiat - 01370 COURMANGOUX
C'est malheureusement aussi mon avis, suivez le conseil de Bilbo, jetez le fichier Internet Preferences et il se refera de toute pièce. D'ailleurs ce fichier ne doit pas être facile à bidouiller, pour ceux qui l'ont un peu ausculté le resource fork et data fork sont de même taille ! On peut lire les ressources avec ResEdit et la totalité avec HexEdit. On y trouve même les mots de passe de courrier.

Salutations.
 

Jab

Membre junior
8 Décembre 2001
11
0
Il est vrai que je n'avais jamais essayé de jeter cette préférence-là. J'avais jeté celles d'IE. Je vais le faire.
Merci!
 

MarcMame

Vétéran
Club MacG
25 Janvier 2001
7 011
266
Il reste aussi la possibilité d'utiliser plutot un shareware comme Zipit
Il ne fait que ça, mais il le fait bien !