Augmentation trop 'rapide' de la memoire inactive

flotow

AppIeSpirit™
Club MacG
23 Mars 2004
12 572
2 348
Bonsoir,
voila, je suis en 10.4.9, j'ai tout a jour, sauf QT et iTunes (et la .10 :p)
j'ai remarqué depuis deux jours que j'ai une memoire inactive qui augmente, meme juste apres l'ouverture de la session!
Au final, je ne sais pas quelle application a pu me faire un truc pareil!
Ca donne qu'au bout de meme pas une heure, sur juste le finder (et rien d'autre qui tourne, pas d'apps), et bien, j'ai au moins 500Mo de ram inactive!! (alors que rien n'a ete ouvert :siffle: )
Une idée? :rose:
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 907
3 150
Si elle est inactive, c'est qu'elle est disponible ;)
Mais bon, effectivement, elle a été utilisée auparavant ! Cela peut être un service ou une application en tâche de fond qui fait des choses ...

Ouvre dès l'entame le moniteur d'activité pour surveiller.

Sinon on peut aussi activer un petit contrôle qui donne toutes les tâches exécutées sur la machine mais il faut encore en analyser le résultat par la suite.
 

flotow

AppIeSpirit™
Club MacG
23 Mars 2004
12 572
2 348
Je sais bien que inactif, c'est disponible :nailbiting:, mais le vrai soucis, c'est qwu'elle grimpe sans raison... et qu'apres, ca tourne au swap '(et ca, c'est mal :eek:) et surtout, c'est non justifié ;)
Ca augmente des le demarrage de la machine, et il n'y a rien de specifique d'ouvert :eek:
C'est quoi ton petit control :) ca m'interesse :D

P.S: j'ai reussi a stopper ca en vidant les caches :nailbiting: (onyx, et j'ai vidé caches Kernel et caches Apps)
 

lappartien

Membre d’élite
Club MacG
29 Novembre 2004
1 570
25
65
j'aimerais bien répondre à tuscpaskit , c'est çà non? mais comme Bompi est déjà sur le coup et que mon humour risque effectivement de ne pas passer cette fois...
Je me contente de vs souhaiter une bonne soirée, tout au moins à la blonde qu'est en photo.:D
 

flotow

AppIeSpirit™
Club MacG
23 Mars 2004
12 572
2 348
j'aimerais bien répondre à tuscpaskit , c'est çà non? mais comme Bompi est déjà sur le coup et que mon humour risque effectivement de ne pas passer cette fois...
Je me contente de vs souhaiter une bonne soirée, tout au moins à la blonde qu'est en photo.:D
Elle est pas blonde :eek:
c'est sur que repondre pour ne riend dire…

J'ai l'impression que c'est Application Enhancer qui fout le bazar. PLus de prebindign, mais bazar quand meme ;)
 

divoli

Vénérable sage
Club MacG
13 Août 2005
15 862
1 420
Bah la question serait de savoir ce que tu as fait ces derniers jours. Tu n'aurais pas installé une de ces applications qui tournent en tache de fond, et qui ont la fâcheuse tendance à se mettre en ouverture au démarrage ? Tu n'as rien de spécial dans la barre de menu ?
Pas de widgets nouvellement installés ou de màj récentes ?
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 907
3 150
Comme je le disais précédemment, on peut mettre en place une (mini-)surveillance des tâches lancées sur le système, tout utilisateur confondu. Les journaux ne sont pas trop volumineux (mais mieux vaut que les tâches de maintenance soient correctement exécutées).
Je ne connais pour l'instant qu'un moyen pour cela : le Terminal (sueur froide dans l'assistance).
Bloc de code:
[SIZE=-1]sudo accton /var/account/acct
fera l'affaire.
Pour arrêter :
Bloc de code:
sudo accton
Pour voir les dernières commandes passées :
Bloc de code:
lastcomm
Pour voir des statistiques (c'est un peu aride :D) :
Bloc de code:
sa
En désespoir de cause, cela peut permettre de voir ce qui se passe sur ton Mac.
[/SIZE]
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 907
3 150
Bon, ok :
Bloc de code:
sudo mkdir -p /var/account
sudo touch /var/account/acct
sudo accton /var/account/acct
Voili.
 
  • J’aime
Réactions: supermoquette

flotow

AppIeSpirit™
Club MacG
23 Mars 2004
12 572
2 348
Bah la question serait de savoir ce que tu as fait ces derniers jours. Tu n'aurais pas installé une de ces applications qui tournent en tache de fond, et qui ont la fâcheuse tendance à se mettre en ouverture au démarrage ? Tu n'as rien de spécial dans la barre de menu ?
Pas de widgets nouvellement installés ou de màj récentes ?
Alors, j'ai juste installé LCC (Logitech Control Center)
Il installe "Application Enhancer.framework"
Dans les versions precedentes, ca buggai, et il fallait l'enlever. Dans les nouvelles versions, il faut le laisse (ca bug plus...) sinon, ca le fait bugger :D

accton: /var/account/acct: No such file or directory

:siffle:
Pareil ici :D
Alors Bompi :siffle: :nailbiting:

Ce qui est quand meme etrange, c'est qu'apres un nettoyage du cache kernel/app, ca ne revient plus (je sais, j'ai guetté toute la nuit pour le savoir :D)
 

flotow

AppIeSpirit™
Club MacG
23 Mars 2004
12 572
2 348
Comme indiqué dans le post juste au dessus (mais peut-être n'as-tu pas pu encore le lire, vu l'heure de ton post), c'est toi-même qui doit créer le dossier /var/account et qui y ajoute le fichier acct , afin que accton puisse l'utiliser.
Oui, je sais, j'ai vu apres ;)
Pour le le mkdir, j'y ai pensé, mais j'ai laissé Bompi parler (ca serai con de faire une connerie :D)
et sinon, comment on interprette les stats :nailbiting:
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 907
3 150
bonne question ... :D

En fait, je ne sais pas encore car pour l'instant je ne l'ai utilisé que pour avoir une idée de quelle binaire était actif à tel ou tel moment. La commande lastcomm te donne ça vite fait et évite d'utiliser top.
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
21 765
3 720
Là-haut
J'ai eu ce problème il y a quelques mois.

Le responsable été effectivement la version d'Application Enhancers (la 2.0.2) fournie avec le LCC 2.1.4.

Pour y remédier, j'ai installé Application Enhancers 2.0.3 puis le Logitech Control Center qui se garde ainsi d'installer quoique ce soit.

Depuis plus de problème.

A noter que APE 2.0.2 a une faille de sécurité importante découverte par le MOAB.

C'moon.
 

flotow

AppIeSpirit™
Club MacG
23 Mars 2004
12 572
2 348
J'ai installé le ControlCenter 2.2.2, mais je ne sais pas quelle version du Application Enhancer ca installe :eek:

Une idée d'un autre soft pour controler les fonctions avancées de la souris?
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
21 765
3 720
Là-haut
Il installe la dernière version de APE la 2.0.3 (j'ai vérifié cela l'autre jour). Toutefois, le LCC 2.2.2 ne fonctionne pas chez moi pour le Cordless S530 Mac. Il ne trouve ni le clavier ni la souris. D'ailleurs, sur le site Logitech, il préconisent toujours le 2.1.4 pour cet ensemble clavier-souris.

Je ne peux donc te dire s'il a un effet indésirable au démarrage.

Avec le APE 2.0.3 et le LCC 2.1.4, il y a toujours un peu de mémoire bleue, mais plus de swap.

Pour la bleue, si tu fais une simple vérification des autorisations, ça en passera une bonne part en vert.

Pour moi, c'était surtout le swap qui était gênant et l'update prebinding qui me faisait des démarrages de plus d'une minute.
 

flotow

AppIeSpirit™
Club MacG
23 Mars 2004
12 572
2 348
Je sais pour l'update prebinding, j'ai eu le probleme.
le swap arrive des que la memoire est remplie... et j'aimerai bien essayer de ne pas la remplir juste a cause de ce driver a la con :eek:
Il faut aussi savoir que la toute derniere version marche pas bien quand tu vires Application Enhancer (ca m'embete de l'avoir celui la :/)

Alors, un driver alternatif pour controler ma souris? (MX400)
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 907
3 150
Il y a aussi USBOverDrive, que j'utilise pour différentes souris sans problème.
 

flotow

AppIeSpirit™
Club MacG
23 Mars 2004
12 572
2 348
Ca commence a me prendre la tete cette histoire de fuite de memoire :mad:
j'ai viré LCC et AppEnhancer, et j'ai toujours une (faible) perte maintenant
En meme temps, je surveille, mais je fait super gaffe a la memoire en ce moment, ca doit etre ca.
@Bompi, une appli qui a ete lancée, qui a ete fermée, et qui a ete supprimée, le tout sur la meme session. Quand elle est lancée, elle monte en ram, apres, elle libere la ram (quand on quitte) mais en laisse une partie quand meme. Le fait de la supprimer du systeme ne force pas le systeme a 'demonter' la ram d'une application qui n'existe plus :nailbiting:
Merci :love:
Ni SteerMouse, ni USBOverDrive fonctionne pour ma souris :(