Bug avec ports FireWire

Titbulle

Membre junior
22 Octobre 2005
17
1
www.titbulle.fr
Bonjour,

Je suis sur OS X 10.4.2. J'aimerais pouvoir brancher des périphériques sur les ports Firewire, mais j'ai chaque fois une énorme bug quand j'essaie de connecter quelque chose dessus.

L'écran se grise et une fenêtre noire apparaît me disant en plusieurs langues "votre ordinateur doit être redémarré" et la fenêtre m'indique d'appuyer plusieurs secondes sur le bouton de démarrage pour éteindre l'ordi.

Ce message apparaît chaque fois que je tente de connecter un périphérique (quel qu'il soit) sur l'un ou l'autre des ports Firewire.

J'ai eu aussi, une première fois, sur le fond gris en superposition de mon bureau, des lignes de code en blanc commençant ainsi :

System failure : cpu=0 ; code=00D16670 (unknown failure code)
Latest crash info for cpu 0 :
Exception state (sv=0x1AD0F000)
PC= pleins de chiffres que je ne retranscris pas ici et tout un tas d'infos du même type...

Mes questions : quelqu'un a-t-il déjà rencontré ce problème ? Que faire ? Suis-je obligée de réinstaller tout mon système ?

Merci d'avance !
 

Inor

Membre d’élite
Club MacG
Titbulle a dit:
Bonjour,

Je suis sur OS X 10.4.2. J'aimerais pouvoir brancher des périphériques sur les ports Firewire, mais j'ai chaque fois une énorme bug quand j'essaie de connecter quelque chose dessus.

L'écran se grise et une fenêtre noire apparaît me disant en plusieurs langues "votre ordinateur doit être redémarré" et la fenêtre m'indique d'appuyer plusieurs secondes sur le bouton de démarrage pour éteindre l'ordi.

Ce message apparaît chaque fois que je tente de connecter un périphérique (quel qu'il soit) sur l'un ou l'autre des ports Firewire.

J'ai eu aussi, une première fois, sur le fond gris en superposition de mon bureau, des lignes de code en blanc commençant ainsi :

System failure : cpu=0 ; code=00D16670 (unknown failure code)
Latest crash info for cpu 0 :
Exception state (sv=0x1AD0F000)
PC= pleins de chiffres que je ne retranscris pas ici et tout un tas d'infos du même type...

Mes questions : quelqu'un a-t-il déjà rencontré ce problème ? Que faire ? Suis-je obligée de réinstaller tout mon système ?

Merci d'avance !

Bonjour et bienvenue. :)

Connecter un périphérique sur un port FireWire déclanche, sur ton Mac, un Kernel Panic.

Il doit y avoir compatibilité matérielle entre le port FireWire et le périphérique que tu branche.
Ce périphérique, déjà, ne peut être quelconque mais FireWire ( pas USB ).
Il doit être branché sur le port FireWire :hein: ( désolé de soulever la question :( : )
Les prises sont différentes et ne permettent pas la confusion.Donc il ne devrait pas s'agir de cela ?!!
Le périphérique nécessite-t-il une alimentation électrique indépendante ?
Le cable FireWire est peut-être à changer ? ( ça arrive, aussi :( )
----
Il doit y avoir aussi compatibilité logicielle.
Il faut utiliser le Pilote à jour du périphérique.
----
Je ne sais si tout cela fera avancer le smilblic....
D'autres avis seraient les bienvenus. ;)
 

Titbulle

Membre junior
22 Octobre 2005
17
1
www.titbulle.fr
Merci, Inor, d'avoir pris le temps de me répondre. Mais j'ai déjà bien fait attention à tout ce que tu indiques. J'ai tenté les manips indiquées ci-dessous sans résultat, pour l'instant (pour info, mon Mac est un POWER PC G4 800 MHz)

CÂBLES ET PÉRIPHÉRIQUES. J'ai vérifié que le problème ne venait ni des câbles, ni des périphériques, en utilisant des câbles et périphériques Firewire différents. La "kernel panic" se déclenche systématiquement au branchement du périphérique, quel qu'il soit, ordinateur allumé comme ordinateur éteint suivi d'un démarrage.

PORTS FIREWIRE. J'ai ensuite suivi une procédure indiquée par le Support Apple au cas où les ports Firewire seraient inopérationnels à cause d'une surtension ou de l'électricité statique : déconnecter tous les ports sauf le USB pour souris+clavier, débrancher l'alimentation de l'ordi, laisser passer une dizaine de minutes, rebrancher, redémarrer. Sans résultat.

TEST MATÉRIEL. Pour m'assurer que le problème n'était pas matériel et interne à l'ordi, j'ai rebooté sur le CD Apple Hardware Test. Les résultats sont OK. Je l'ai fait deux fois pour vérifier la détection de périphérique. Quand l'iPod n'est pas connecté, le résultat est périphérique Firewire "absent", quand il est connecté, l'ordi indique bien "présent". C'est déjà ça. (Pour précision, aucun pb logiciel ni système avec l'iPod quand il est connecté en USB.) Le bug proviendrait donc du système, comme je m'en doutais...

AUTORISATIONS. J'ai bien évidemment réparé les autorisations via l'utilitaire disque. Ça ne change rien.

NVRAM. J'ai ensuite rebooté en mode Open Firmware (pomme+alt+o+f) pour réinitialiser la mémoire non volatile (Non Volatil RAM) sur la carte mère (reset-nvram, reset-all). Ça n'a rien changé.

FICHIERS, RÉPERTOIRES ET CACHES CORROMPUS. J'ai alors tenté le grand nettoyage via l'utilitaire Applejack (éventuels fichiers corrompus, caches, etc.). En vain là aussi...


Là, je n'ai plus d'idée. A part réinstaller tout le sytème, bien sûr, ce qui ne m'enchante guère (d'autant que je ne peux même pas sauvegarder mes données sur un autre DD en connexion Firewire, à cause de la kernel panic, et qu'il me faudra passer par une connexion USB, beaucoup plus lente...)

Bref, je suis preneuse de tous les conseils et suggestions des âmes compatissantes qui liront ce post. Merci d'avance ! ;)
 

Inor

Membre d’élite
Club MacG
Titbulle a dit:
Merci, Inor, d'avoir pris le temps de me répondre. Mais j'ai déjà bien fait attention à tout ce que tu indiques. J'ai tenté les manips indiquées ci-dessous sans résultat, pour l'instant (pour info, mon Mac est un POWER PC G4 800 MHz)

CÂBLES ET PÉRIPHÉRIQUES. J'ai vérifié que le problème ne venait ni des câbles, ni des périphériques, en utilisant des câbles et périphériques Firewire différents. La "kernel panic" se déclenche systématiquement au branchement du périphérique, quel qu'il soit, ordinateur allumé comme ordinateur éteint suivi d'un démarrage.

PORTS FIREWIRE. J'ai ensuite suivi une procédure indiquée par le Support Apple au cas où les ports Firewire seraient inopérationnels à cause d'une surtension ou de l'électricité statique : déconnecter tous les ports sauf le USB pour souris+clavier, débrancher l'alimentation de l'ordi, laisser passer une dizaine de minutes, rebrancher, redémarrer. Sans résultat.

TEST MATÉRIEL. Pour m'assurer que le problème n'était pas matériel et interne à l'ordi, j'ai rebooté sur le CD Apple Hardware Test. Les résultats sont OK. Je l'ai fait deux fois pour vérifier la détection de périphérique. Quand l'iPod n'est pas connecté, le résultat est périphérique Firewire "absent", quand il est connecté, l'ordi indique bien "présent". C'est déjà ça. (Pour précision, aucun pb logiciel ni système avec l'iPod quand il est connecté en USB.) Le bug proviendrait donc du système, comme je m'en doutais...

AUTORISATIONS. J'ai bien évidemment réparé les autorisations via l'utilitaire disque. Ça ne change rien.

NVRAM. J'ai ensuite rebooté en mode Open Firmware (pomme+alt+o+f) pour réinitialiser la mémoire non volatile (Non Volatil RAM) sur la carte mère (reset-nvram, reset-all). Ça n'a rien changé.

FICHIERS, RÉPERTOIRES ET CACHES CORROMPUS. J'ai alors tenté le grand nettoyage via l'utilitaire Applejack (éventuels fichiers corrompus, caches, etc.). En vain là aussi...


Là, je n'ai plus d'idée. A part réinstaller tout le sytème, bien sûr, ce qui ne m'enchante guère (d'autant que je ne peux même pas sauvegarder mes données sur un autre DD en connexion Firewire, à cause de la kernel panic, et qu'il me faudra passer par une connexion USB, beaucoup plus lente...)

Bref, je suis preneuse de tous les conseils et suggestions des âmes compatissantes qui liront ce post. Merci d'avance ! ;)

Bonjour.

Il paraît bien difficile de faire mieux pour résoudre ce Pb.:siffle:
Tu auras, peut-être, de bonnes suggestions, à la sortie de week-end ? :)

Ton Power PC G4 est-il toujours sous garantie ? Ce qui se passe est anormal.

Un Kernel Panic ne peut se produire que si Mac OX X plante à bas niveau.
Peut-être as-tu saturé les bus du disque ? Mais pourquoi ?
Le Kernel panique se déclanche-t-il:
-- quand tu branche le cable firewire non relié au périphérique ?
-- quand tu relie le périphérique éteind ? :confused:
 

Titbulle

Membre junior
22 Octobre 2005
17
1
www.titbulle.fr
Bonjour Inor,

La Kernel Panic se déclenche à la connexion du périphérique, pas du cable Firewire seul.

Je crois que c'est foutu pour les ports FireWire et en plus je me suis créé toute seule un énorme problème (ça en fait deux maintenant, aargh).

Je m'explique :

Ce week-end, à force de trop bidouiller pour cette histoire de Kernel Panic, j'ai fait une mauvaise manip et mis à la poubelle des éléments de mon DD, appartenant au dossier système (Tiger 10.4.2) que je n'aurais jamais du mettre là (genre la bibliothèque) pensant ne pas vider la poubelle, mais les remettre à leur place après démarrage.

NOUVEAU PROBLEME. Hélas, au démarrage, l'ordi me propose les trois noms d'utilisateurs enregistrés dans mes comptes, à choisir avec mot de passe. Et là, impossible de reconnaître le mot de passe. Il me suggère bien l'indice au bout d'un certain nombre de tentatives, mais refuse d'aller plus loin, quel que soit le mot de passe (pourtant correct) ou l'utilisateur essayé. Je reste donc bloquée là, rien à faire.

REINSTALLATION SYSTEME SUR AUTRE PARTITION. En désespoir de cause, comme mon DD est divisé en trois partitions, j'ai rebooté sur le CD d'installation, et réinstallé mon vieux système 10.2 sur une partition qui ne contenait que des documents. J'ai redémarré sur ce système, où j'ai fait qq mises à jour (système, iTunes et iPod notamment), si bien que je suis en 10.2.8 sur cette partition, et tenté de voir si je ne pouvais pas rétablir les choses dans celle de mon précédent DD. Mais il y a des fichiers invisibles, je ne maîtrise pas trop tout ça, et je n'ai pas le droit d'accéder au .trashes où doivent encore être les éléments dont j'ai besoin. Mais bref, ça c'est un autre problème (pour lequel je suis preneuse de solutions aussi : comment zapper l'identification pour mot de passe et utilisateurs au démarrages, par exemple, pour accéder à mon DD Tiger devenu inaccessible ?)

NOUVEAU TEST FIREWIRE SUR SYSTEME REINSTALLE. J'en ai profité pour tenter, sous le nouveau DD fraîchement réinstallé, donc normalement tout beau tout propre, de connecter le port FireWire à mon iPod de nouveau : et là, rebelote, Kernel Panic. Donc je crois que, contrairement à ce que je pensais, c'est bien un pb matériel et interne à l'ordinateur... Hélas.

AU SECOURS... Donc, sous le nouveau DD en 10.2.8 je vais pouvoir récupérer et sauver un certain nombre d'éléments de mon DD Tiger, c'est déjà ça, mais j'aimerais bien mieux, vu le nombre d'appli et de réglages perso, pouvoir rebooter et accéder à ce DD sans être coincée par l'identification utilisateurs (PS : j'ai déjà tenté les manips pour réinitialiser les mots de passe via un boot sur le CD d'installation, où il y a cette possibilité dans le menu, en vain).

Je crois que je vais devoir créer un nouveau fil de discussion pour ce problème, distinct de mon problème de Kernel Panic. En attendant, si quelqu'un peut m'aider... :(
 

Inor

Membre d’élite
Club MacG
En attendant d'autres avis...

Peux-tu récupérer Applications et Réglages de ta partition 10.4 dans la 10.2.8 ?
Dans ce cas, tu pourrais alors :
effacer et réinstaller le Tigre sur ton ancienne partition bogguée, et, en te servant de l'Utilitaire
Assistant de Migration, copier et récupérer ce qui t'intéresse de la partition 10.2.8.

Sinon,
Archiver Installer le Tigre sur son ancienne partition.Un nouveau système sera installé.
Les composantes Apple préservées, mais elles-seules.
Les réglages utilisateurs et réseau aussi, si tu les réclame dans les Options.
Il faudra réinstaller les logiciels non-Apple. :(
 

cedricX

Membre junior
24 Juillet 2004
24
1
41
Pour ton problème de mot de passe: peut-être que le clavier est configuré en mode qwerty vu qu'il manque des fichiers système?
 

Titbulle

Membre junior
22 Octobre 2005
17
1
www.titbulle.fr
Mille mercis Inor, pour ces conseils, je vais voir ce que je peux faire, il faut d'abord que je récupère les CD Tiger, qui n'étaient point les miens... :siffle:

Lumineux ton idée pour le mot de passe CedriX, il y a effectivement des "a" dans le mien !!!! Je m'en vais essayer ça dès que je suis rentrée chez moi. Je vous tiens au courant.

Encore merci à tous les deux !!! :up:
 

Titbulle

Membre junior
22 Octobre 2005
17
1
www.titbulle.fr
Hip hip hourra !!! Le clavier était bien qwerty !!!! Ça y est, je viens de rentrer à nouveau sur mon DD Tiger, de remettre les petits dossiers à la bonne place, de ranger un peu le bordel, de redémarrer, et j'ai tout qui est revenu proprement. OUF !

Des millions de mercis :) :up:


Bon. J'ai récupéré mon système, mais je n'ai toujours pas la solution à la fameuse Kernel Panic lors d'un branchement de périphérique sur Firewire... :(