bug Safari a la fermeture de fenetres

abdefo

Nouveau membre
28 Janvier 2005
6
0
33
bonjour

depuis que j'ai installé mac os 10.4.3 (avant j'avais la 10.3), safari (2.0.2 depuis la mise a jour) quitte inopinément chaque fois que je ferme une fenetre de navigation, ce qui est passablmement agaçant (meme carrément chiant) :mad:
quelqu'un a une idée de comment arranger ca?

mirci ^^
 

ReggySan

Membre junior
17 Août 2005
76
4
44
Je crois savoir, tu dois avoir des anciens trucs dans la mémoire cash qui date de l'ancienne version et au moment du backup de ta navigation il comprend pas, donc onyx et nettoyage du cache.
 

Paski.pne

Membre d’élite
Club MacG
7 Novembre 2005
4 468
769
on the Lost Highway
perso.wanadoo.fr
Salut,

Tu peux effacer le cache de Safari en allant à la Bibliothèque de ton compte, dossier Caches. Dedans tu trouveras un dossier appelé tout bêtement Safari et tu mets ce qu'il contient à la poubelle.

Pour les préférences, toujours dans ta Bibliothèque, tu as un dossier Préférences. Tu y trouveras un fichier appelé "com.apple.Safari.plist". C'est lui que tu dois jeter.

Pourvu que ça marche :up:
 

ReggySan

Membre junior
17 Août 2005
76
4
44
je parlais du cache général pas de celui de safari, c'est pour cela qu'il faut avoir recours à Onyx, sinon pour atteindre les préférences il faut aller dans application/safari/preferences ...
 

abdefo

Nouveau membre
28 Janvier 2005
6
0
33
j'ai viré les prefs, vidé le cache de safari manuellement et vidé les caches avec onyX, rien n'y fait... :(
et dans application/safari y'a pas de dossier préférence...en tout cas je le vois pas

pour réinstaller safari, je commence par virer juste l'application safari?
 

Paski.pne

Membre d’élite
Club MacG
7 Novembre 2005
4 468
769
on the Lost Highway
perso.wanadoo.fr
Essaye peut-être déjà de réparer les autorisations en démarrant sur le DVD d'installation de Tiger, puis en choisissant Utilitaire de disque, sélectionne ton disque, puis SOS, réparer les autorisations. Parfois cela règle tout seul certains petits soucis.
 

Paski.pne

Membre d’élite
Club MacG
7 Novembre 2005
4 468
769
on the Lost Highway
perso.wanadoo.fr
abdefo a dit:
pour réinstaller safari, je commence par virer juste l'application safari?

Normalement, oui. Si je ne me trompes pas, tu devrais trouver Safari dans le DVD d'installation de Tiger, dossier Système/Installation/Packages. Dedans se trouve le fichier "Safari.pkg". Tu double-cliques dessus.

Je te parles de tout cela sans l'avoir jamais fait moi-même. Mais j'ai double-cliqué sur le fichier pour tester et cela lance l'installation de Safari, donc cela à l'air tout bon. :)
 

Paski.pne

Membre d’élite
Club MacG
7 Novembre 2005
4 468
769
on the Lost Highway
perso.wanadoo.fr
As-tu tenté de réparer les autorisations ?
Ce n'est pas une solution miracle, mais qui sait ?
Au-delà de ça, moi, je ne te serais plus d'aucune utilité. :rose:
Essaye de voir si tu n'as pas installé une application particulière qui pourrait entrer en conflit avec Safari.
 

abdefo

Nouveau membre
28 Janvier 2005
6
0
33
réparer les autorisation n'a rien changé non plus
et pour savoir si c'est une application qui rentre en conflit...je sais juste que ca a commencé a faire ca dès que j'ai installé mac os 10.4 ...
y'a-t-il quelu'un qui puisse encore quelque chose pour moi? :(
 

abdefo

Nouveau membre
28 Janvier 2005
6
0
33
me revoila (ca faisait longtemps) avec toujours le meme problème

pour ce qui est du rapport de bug, il est suuuuper long, et je comprend rien a rien de ce qu'il raconte! :confused:

je desespère...:(
 

teo

Vénérable sage
Club MacG
14 Novembre 2000
10 524
3 096
Paris XXe
www.last.fm
salut
Pas de solutions miracles, juste pour ajouter que ça arrive aussi sous Panther, j'ai le même problème.

Je suis sous Panther, et je surfe avec Firefox 1.07 et Safari 1.2
Je suis à jour de toutes mes MàJ (10.39 sur un Ti400/512).

Je ne peux plus surfer sans devoir relancer l'un ou l'autre des navigateurs.
Sous Safari, la fermeture (par erreur ou volontairement) provoque un blocage pendant 3 ou 4 secondes et un crash de Safari juste après.
[Sous Firefox, les liens des sites internet fonctionnent pendant une dizaine de minutes puis deviennent inactifs (sur Macgé par exemple, les liens sur les fils, les boutons Répondre etc.) Le seul moyen est de faire un Force-Quit sur Firefox car quitter ne suffit pas, l'appli reste ouverte après avoir demandé à quitter.]
J'ai réparé les autorisations, booté sur mon update de DiskWarrior, réparé ce qu'il fallait, passé un bon coup d'onyx, jeté les préfs. Rien.

C'est un bon moyen pour que je passe moins de temps sur les forums mais particulièrement exaspérant à la longue.

Je me disais qu'il n'y avait plus qu'à passer à Tiger, mais ça me gave de lire que ce problème persiste alors que ça marche plutot bien depuis décembre où j'ai investi dans Panther. Une clean install ? sous Panther ou Tiger ?

D'autres idées ? Ca serait super cool parce que là...