Debug php

wyllyjon

Membre enregistré
10 Juillet 2012
4
0
Bonjour à tous !

J'espère trouver la solution ici car je suis un peu en train de désespérer !
Je suis sur linux au boulot, et j'avais réussi à installer le debugger pour le php (il me semble que j'avais utilisé xdebug), mais chez moi, sur mon mac, pas moyen ! J'avoue que je suis en train d'haïr de plus en plus les mac pour le développement...

Bref, je suis sur Eclipse avec PDT, et je veux débugger mon appli. J'ai suivi des tutos pour installer XDebug, j'ai essayé d'installer ZendServer CE, mais rien ne fonctionne. Le serveur Zend ne se lance pas, et avec xdebug, je lance mon appli en mode debug, qui m'ouvre une fenêtre, mais mes points d'arrêt sur Eclipse ne sont pas pris en compte.

J'ai également testé macGDBP qui ne se connecte pas !!!!

Bref, j'ai vraiment les nerfs à vif :p

Quelqu'un aurait-il la connaissance suprême du mac pour réussir à débloquer mon problème de m.... ??

Merci beaucoup à mon futur sauveur (ou ma...)
 

sixfeetunder

Membre confirmé
10 Juillet 2012
15
1
Bonsoir,

Je ne connais pas bien Eclipse, je ne l'utilise pas. En revanche, j'utilise Netbeans. Celui-ci a un bon débogueur et fonctionne très bien sous OSX.
De même pour Zend Server CE, quelle est exactement ton problème ? Car je n'ai eu aucun soucis pour l'installer.
En espérant pouvoir t'aider :)
 

wyllyjon

Membre enregistré
10 Juillet 2012
4
0
En fait, je pense que XDebug était bien installé puisque j'avais les logs sur ma page web lors d'erreurs. C'est le lien avec apache qui ne fonctionne pas apparemment.

Mais bon, j'ai un plus gros soucis maintenant, peut-être que vous pourrez m'aider.
Plus moyen de faire fonctionner mon appli. Ou plus exactement, pendant quelques jours, mon appli pointait je ne sais où, et peu importe le virtualhost que j'appelais, ça tapait toujours sur la même appli, celle qui semblait être la première par ordre alphabétique dans mon DocumentRoot...

J'ai testé plusieurs choses, installer MAMP, installer des GUI apache pour essayer de contrôler tout ça (dont itools), et hier, comme par magie, ça a refonctionné, mais je ne sais pas comment.

Et ce matin, rebelote...

Je suis complètement perdu avec l'installation apache sous mac, j'ai l'impression qu'il y a des fichiers de configuration partout, des exécutables (apachectl) partout, et je n'arrive pas à savoir quels sont les fichiers appelés et ceux qui configurent réellement l'instance d'apache lancée...

Pourriez-vous m'aider ?

Pour info, lorsque je fais "sudo apachectl start", ça à l'air d'appeler /usr/sbin/apachectl, mais j'aimerais bien savoir quel est le fichier de conf lié utilisé car j'en ai à plusieurs endroits (/private/etc/apache2/httpd.conf, /usr/local/zend/apache2/conf/httpd.conf), sachant que mon fichier sous /private/etc/apache2/httpd.conf à l'air d'avoir été modifié par je sais pas qui, qui m'a rajouté des path commençant par "/Library/WebServer/" partout...

Une idée pour nettoyer tout ça ?

Merci beaucoup !!!!

PS : je vais mettre ça dans un nouveau post, car ça me semble plus adapté
 

Ali Ibn Bachir, Le Gros

Membre confirmé
3 Février 2011
56
2
Ça va pas répondre directement à ta question mais j'ai pas mal galéré pour installer un environnement de dév sous Mac OS X.

Ce que j'ai fini par faire c'est me monter un serveur Ubuntu dans une Virtualbox. J'utilise Netbeans sur le, Mac, mais le serveur est dans la box. En plus, comme les environnements de prod sont en général sous Linux, ça permet d'avoir un environnement de dév proche de l'environnement en prod.
 

tatouille

Membre expert
1 Juin 2004
5 174
493
Stanford CA
Ça va pas répondre directement à ta question mais j'ai pas mal galéré pour installer un environnement de dév sous Mac OS X.

Ce que j'ai fini par faire c'est me monter un serveur Ubuntu dans une Virtualbox. J'utilise Netbeans sur le, Mac, mais le serveur est dans la box. En plus, comme les environnements de prod sont en général sous Linux, ça permet d'avoir un environnement de dév proche de l'environnement en prod.

houa t'as donc ete fini au pipi, car finir au japon pour seulement acheter une simple baguette de pain dans le 14eme, t'incarnes un peu le clown de service de l'humanité.
 

wyllyjon

Membre enregistré
10 Juillet 2012
4
0
"Merci" tatouille pour cette réponse fort peu productive, et merci beaucoup Ali pour cette proposition de solution. J'aimerais quand même essayer de nettoyer cet Apache pour pouvoir le faire fonctionner correctement, et ne pas avoir à lancer une virtualbox à chaque fois que je veux développer.
Dans le pire des cas, je fais un dual boot sur ce mac de merde et je développe sur Windows ou Linux.
Mais bon, si quelqu'un a une solution, je suis évidemment preneur :-D
 

sixfeetunder

Membre confirmé
10 Juillet 2012
15
1
Je n'ai pas tout bien compris :)

Mes fichiers de configurations MAMP sont dans le dossier Applications, puis dans MAMP/conf/apache/ j'ai mon fichier httpd.conf

Si tu veux refaire une installation propre, il existe des outils pour nettoyer les fichiers qui seraient restés lors de la "désinstallation" : AppCleaner par exemple.