Excel fonction SI

omni

Membre d’élite
17 Mars 2007
1 192
39
Bonjour à Tous,
Travaillant avec Excel je recherche la fonction qui me permettrait d'insérer une astérisque dans une cellule à la condition que certaines cellules suivantes (de la même colonne) ne soit pas vide.
Je sais le faire avec la fonction SI dans l'hypothèse ou je ne "regarde" qu'une seule cellule après celle où je souhaite une astérisque, par contre si je veux que la condition prenne en compte plusieurs cellules suivantes = je n'y arrive pas …

En vous remerciant,
 

zeltron54

Membre d’élite
29 Mars 2008
2 065
327
Lorraine
Bonjour,

Soit tu imbriques des "SI" , suivant le nombres de cellules à tester.
Soit tu utilises la fonction SI.CONDITIONS

Autre possibilité, si les cellules à tester se suivent alors utiliser SI(NBVAL(plage cellule=0;"vide";"pas vide"
 
Dernière édition:

omni

Membre d’élite
17 Mars 2007
1 192
39
Merci Zeltron,
La fonction SI NBVAL etc => fonctionne bien.
Par contre la fonction SI.CONDITIONS n’existe pas dans ma version d’EXCEL ?
 

zeltron54

Membre d’élite
29 Mars 2008
2 065
327
Lorraine
La fonction SI.CONDITIONS à du apparaître avec la version 2016 ou 2019 , je ne sais plus.

Par contre ce n'est qu'une version plus simple (plus lisible) de la fonction SI avec des SI imbriqués.
Si la condition1 est faux alors test de la condition2 etc...
Si(Condition1;valeur si vrai;SI(condition2;valeur si vrai; valeur si faux))
 

Aliboron

Chercheur de son
Modérateur
Club MacG
1 Janvier 2008
14 004
968
Toulouse.cong
faq.office.macintosh.free.fr
Petite ruse : dans la cellule voulue, mettons A1, tu rentres la formule suivante pour tester la plage A2:A5 :
=SI(SOMMEPROD(-(A2:A5<>""))=0;"Valeur si vides";"*")

La fonction SI.CONDITIONS est arrivée dans la version 2019 d'Excel. Elle n'est pas disponible pour les versions précédentes (les versions < 16.17)...
 
Dernière édition:

omni

Membre d’élite
17 Mars 2007
1 192
39
Merci à vous deux.