Ce forum est en partie financé par l’affichage de publicités. Merci de désactiver votre bloqueur de publicités pour nous permettre de continuer à fournir ce service.
  1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.
  2. Découvrez macOS High Sierra avec notre nouveau livre Le guide de macOS High Sierra.
    Rejeter la notice

Excel ne respecte pas format nombres

Discussion dans 'Bureautique et productivité' créé par Damien Amast, 12 Janvier 2018.

Modérateurs: Aliboron
  1. Damien Amast

    Damien Amast Nouveau membre

    Inscrit:
    12 Janvier 2018
    Messages:
    3
    J'aime reçus:
    0
    Bonjour,

    depuis plusieurs années, j'utilise mon macbook pro en configuration "US" pour le format des nombres, c'est-à-dire , pour séparation des milliers et . pour décimale.

    J'ai fait de la sorte en modifiant les préférences régionales dans les préférences systèmes. J'utilise régulièrement des fichiers CSV à importer dans un software et cette configuration me permet de faire tout cela rapidement.

    Depuis deux jours, catastrophe, Excel ne respecte plus ses préférences là et choisi comme format des nombres un espace comme séparateur de milliers et une virgule comme décimale. Dans les préférences régionales, aucun changement, toujours configuration US, et j'ai bien entendu déjà essayé une bonne dizaine (vingtaine?) de fois de changer, en quittant Excel, en redémarrant, rien à faire.

    L'intégralité de mes fichiers Excel affichent ce nouveau format.

    Excel ne respecte pas le format des nombres tels qu'ils devraient être selon les préférences régionales.

    La chose qui me vient en tête et qui pourrait avoir déclenché mes soucis: un client codeur/programmateur m'a envoyé un lien qui génère et me fait télécharger automatiquement un CSV depuis l'un de ses programmes. Est-ce que cette manipulation aurait pu modifier certains de mes paramètres de manière permanente dans Excel ou alors créer une "règle" qui force mon Excel à changer le format des nombres ?

    Merci pour votre aide, c'est un point capital pour moi!
     
  2. Aliboron

    Aliboron Chercheur de son
    Modérateur Club MacG

    Inscrit:
    1 Janvier 2008
    Messages:
    12 221
    J'aime reçus:
    529
    De quelle version d'Excel est-il question ? En quel niveau de mise à jour ? Sur quelle version de Mac OS X ?

    La première chose à faire serait un test dans une session avec un nouveau compte utilisateur Mac OS X, créé pour l'occasion ou le compte "Invité", par exemple, pour voir si les choses se passent différemment dans un contexte "propre". Le comportement observé n'est évidemment pas le comportement normal. Personnellement, je n'arrive pas à le reproduire, en tout cas.

    Difficile à dire sans savoir précisément ce qui a été fait. Si c'est une macro, on ne peut pas exclure qu'elle se déclenche à l'ouverture d'Excel pour toucher au paramétrage. Mais pour en dire plus, il faudrait voir cela de plus près... Si tu ouvres Excel en tenant la touche "Majuscule" enfoncée, est-ce que les choses se passent différemment ?
     
    Damien Amast aime ça.
  3. Damien Amast

    Damien Amast Nouveau membre

    Inscrit:
    12 Janvier 2018
    Messages:
    3
    J'aime reçus:
    0
    Bonjour Aliboron merci beaucoup pour la réponse. Je suis sous MacOS High Sera version 10.13.2. Ma version d'Excel est 2011 version 14.7.7.

    J'ai fait le test avec un utilisateur "invité" et dans ce cas là les nombres sont tels que j'aimerai ! le problème serait donc lié à mon compte utilisateur ?

    Quand j'ouvre Excel en maintenant la touche majuscule enfoncée, le problème reste le même.
     
  4. Aliboron

    Aliboron Chercheur de son
    Modérateur Club MacG

    Inscrit:
    1 Janvier 2008
    Messages:
    12 221
    J'aime reçus:
    529
    Oui, de toute évidence il y a quelque chose dans ton compte utilisateur qui est à l'origine du problème rencontré. Dommage qu'on n'ait pas plus de précisions sur la fameuse manip via un lien qui intervient sur les CSV. Mais dans un premier temps, tu peux toujours t'attaquer aux fichiers de préférences d'Excel (voire d'Office). Avec un peu de chance...
     
    Damien Amast aime ça.
  5. Damien Amast

    Damien Amast Nouveau membre

    Inscrit:
    12 Janvier 2018
    Messages:
    3
    J'aime reçus:
    0
    OK merci. Dans les préférences de Microsoft Office j'ai déjà cherché mais rien ne m'a aidé jusqu'à maintenant. J'essaierai de contacter la personne qui m'a fourni le lien sur le fichier CSV. Il y a aussi des préférences d'Office accessible quelque part ?
     
  6. Aliboron

    Aliboron Chercheur de son
    Modérateur Club MacG

    Inscrit:
    1 Janvier 2008
    Messages:
    12 221
    J'aime reçus:
    529
    Je ne suggère pas de chercher dans les préférences d'Excel, mais de supprimer les fichiers de préférences d'Excel. Tu les trouveras dans ~/Bibliothèque/Preferences (et dans le sous-dossier Microsoft). Suppressions à faire suivre d'un redémarrage du Mac, en général, pour qu'elles soient prises en compte.

    Rappelons que, par défaut, le dossier ~/Bibliothèque (la Bibliothèque du compte utilisateur - à ne pas confondre avec celle qui est à la racine du disque dur ou celle qui est dans /Système) est masqué. On y accède par le menu "Aller" du Finder en tenant la touche "Option" enfoncée.
    On peut aussi demander à ce que ce dossier ne soit plus masqué dans les "Options de présentation" du dossier "Départ" du compte utilisateur (celui avec l'icône de petite maison).
     
    Damien Amast aime ça.
Modérateurs: Aliboron

Partager cette page

Chargement...

iOccasion - Achetez un produit Apple d'occasion

refurb Apple