10.14 Mojave Fichiers cachés sur carte sd

jcfaggia

Membre émérite
2 Juillet 2006
626
24
AJACCIO
Bonsoir,

Je copie des fichiers musicaux sur carte SD pour les lire sur ma radio auto Bose, sur Audi.
Certaines fois, les cartes lues sur la voiture, j’ai mes playlists qui sont doublées en totalité avec tous les titres précédés avec un point et un tiret bas, titres que le lecteur est obligé de parcourir avant d’arriver aux vrais fichiers qui contiennent ma musique.
Malgré un grand nombre de manips , je ne suis pas arrivé à savoir pourquoi certaines fois ces fichiers "fantômes " ne sont pas vus par le lecteur, et certaines fois oui.
Peut-être faudrait-il pouvoir les faire apparaître sur l’ordi pour les supprimer ? Là, je cale.
Qqu’ sait?
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
76 822
23 594
Forêt de Fontainebleau
:coucou: Jean-Claude

Bonne Année d'abord !

Je te propose d'abord une petite lecture. Va à ce fil d'archive :☞ Fichiers en double sur SD card et clé USB☜ (clique le lien rouge) > et intéresse-toi spécialement au message #16 (pour la partie technique : la commande dot_clean est ton amie) > et au message #25 (pour la partie théorique : rédaction facétieuse de la mi-Août).

- il sera très facile d'appliquer cette commande au volume de la carte SD. Signale-toi de nouveau pour effectuer cette manœuvre.​
 
  • J’aime
Réactions: litobar71

jcfaggia

Membre émérite
2 Juillet 2006
626
24
AJACCIO
:coucou: Jean-Claude

Bonne Année d'abord !

Je te propose d'abord une petite lecture. Va à ce fil d'archive :☞ Fichiers en double sur SD card et clé USB☜ (clique le lien rouge) > et intéresse-toi spécialement au message #16 (pour la partie technique : la commande dot_clean est ton amie) > et au message #25 (pour la partie théorique : rédaction facétieuse de la mi-Août).

- il sera très facile d'appliquer cette commande au volume de la carte SD. Signale-toi de nouveau pour effectuer cette manœuvre.​

Merci Macomaniac, et bonne année également. J’étais presque sûr de ton intervention tant les cas désespérés sont ta spécialité. Malgré mes recherches je ne suis pas tombé sur ce post. D’où mon appel pour ce pb qui me fait ...depuis longtemps, d’autant plus que ce n’est pas systématique, certaines playlists passent normalement.
Dès que j’ai un instant libre je tente les manips et te tiens au courant.
Merci encore
JCF
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
76 822
23 594
Forêt de Fontainebleau
Ta carte SD attachée au Mac > et son volume affiché monté sur le Bureau > tu lances le Terminal > tu commences par saisir :
Bloc de code:
dot_clean -v

  • et tu sautes un espace libre après -v. Puis tu fais un glisser-déposer au pointeur de l'icône du volume de la carte affiché sur le Bureau => dans la fenêtre du Terminal > ce qui inscrit automatiquement l'adresse et le nom du volume. Tu obtiendras donc une commande du type :
Bloc de code:
dot_clean -v /Volumes/[nom_carte_SD]

  • tu exécutes avec la touche "Entrée". Ce qui : a) devrait t'afficher la liste des fichiers qui ont été "aplatis" (option -v = verbose) > b) supprimera pour l'environnement Windows l'affichage des fichiers doublons ._

=> si tu ajoutes ensuite de nouveaux fichiers dans le volume de la carte > pour éviter de nouveaux affichages de doublons --> hop ! tu récidives le procédé de la commande dot_clean ici décrit.
 

lamainfroide

Porc Sain
Club MacG
3 Avril 2009
1 935
785
Sous le Soleil
Me voici de passage sur le sujet, dans l'unique but de louer le légendaire maco.
En effet, me voici depuis 2 semaines confrontés à ces fichiers doubles invisibles à l'oeil nu d'un mac.
J'ai fait l'acquisition d'un cadre photo destiné à diffuser des vidéos personnelles contenues sur une sd.
Agacé par les incessantes annonces du cadre m'annonçant "format non lisible" sur pléthore de vidéos, j'ai pu constater la présence de ces "._" doublons (via l'explorateur du cadre).
L'affichage des fichiers invisibles via le mac, en vue de suppressions en série, n'ayant rien donné, j'étais prêt à jeter l'éponge (me disant au passage que j'avais l'intention inavoué de jeter aussi le cadre récalcitrant).
Joie dominicale, je tombe sur ce fil par hasard.
Et poubelle les satanés doublons.
Merci.

PS : il me reste encore quelques fichiers non lisibles mais je suppute que le phénomène est tout autre. Un codec vidéo non supporté ou une bêtise de ce genre. Problème que je règlerais plus tard en réencodant différemment les dites vidéos.
 
  • J’aime
Réactions: macomaniac

jcfaggia

Membre émérite
2 Juillet 2006
626
24
AJACCIO
Ta carte SD attachée au Mac > et son volume affiché monté sur le Bureau > tu lances le Terminal > tu commences par saisir :
Bloc de code:
dot_clean -v

  • et tu sautes un espace libre après -v. Puis tu fais un glisser-déposer au pointeur de l'icône du volume de la carte affiché sur le Bureau => dans la fenêtre du Terminal > ce qui inscrit automatiquement l'adresse et le nom du volume. Tu obtiendras donc une commande du type :
Bloc de code:
dot_clean -v /Volumes/[nom_carte_SD]

  • tu exécutes avec la touche "Entrée". Ce qui : a) devrait t'afficher la liste des fichiers qui ont été "aplatis" (option -v = verbose) > b) supprimera pour l'environnement Windows l'affichage des fichiers doublons ._

=> si tu ajoutes ensuite de nouveaux fichiers dans le volume de la carte > pour éviter de nouveaux affichages de doublons --> hop ! tu récidives le procédé de la commande dot_clean ici décrit.

J’allais te demander quelques précisions pour ne pas faire de bêtises. Tu as devancé l’appel.
Je pense faire ça demain.
Bonne journée.
JCF
 

jcfaggia

Membre émérite
2 Juillet 2006
626
24
AJACCIO
Bonjour Maco,
Comme toujours, la formule magique a marché ! La procédure est très simple et redoutablement efficace ! En plus ça m’a l’air de vraiment faire le ménage dans les cartes SD et clés USB utilisées sur autoradio en réglant certains problèmes de visibilité de fichiers . Ex : sur une clé où j’ai mis 100 fichiers musique, les 100 fantômes étaient présents, et seulement 3 vrais. Le dot clean a réglé ça en 30 secondes.
Au moins dans ce domaine, l’année a bien commencé.
Re-mille mercis.
À la prochaine
Cordialement
JCF
 
  • J’aime
Réactions: macomaniac