Help! Mon iTune ne marche plus... :(

evilpet

Nouveau membre
3 Juillet 2007
7
0
Paris
vik.l.free.fr
Je viens de faire la mise à jour pour iTune version 7.3...
Mais maintenant je ne peux plus utiliser iTune, car cela demande mac OS 10.4.7 (le mien est 10.4)
J'ai un vieux PowerBook G4 et je ne peux pas mettre OS 10.4.7.

Je voulais revenir à l'ancienne version (iTune7.1), mais la case à crocher pour l'installer est grise... comment faire? Help...:(
 

Paski.pne

Membre d’élite
Club MacG
7 Novembre 2005
4 468
769
on the Lost Highway
perso.wanadoo.fr
Tu peux parfaitement passer de 10.4.0 à 10.4.7 (et même plutôt 10.4.10) sur ton PowerBook. C'est normalement une mise jour proposée depuis le module de mise à jour (menu Pomme). J'ai 10.4.10 d'installé sur mon PowerBook Pismo, alors sur un G4, c'est largement possible.

Sinon, pour installer une ancienne version d'iTunes (ou simplement réinstaller iTunes) il faut avoir écarté les packages (fichiers avec pour extension .pkg) concernant iTunes du dossier DisqueDur/Bibliothèque/Receipts. Car sans cela, le système considère que l'Application est toujours installée.
 

evilpet

Nouveau membre
3 Juillet 2007
7
0
Paris
vik.l.free.fr
Paski.pne, Merici beaucoup!!!

J'ai écarté les packages (fichiers avec pour extension .pkg) concernant iTunes et l'installation de l'ancienne version a marché!

A propos de passer de 10.4.0 à 10.4.7, le module de mise à jour (menu Pomme) me propose rien... je ne sais pas pourquoi.

En tous cas, je suis ravie de retrouver mon iTune! Merci encore... :up:
 

Paski.pne

Membre d’élite
Club MacG
7 Novembre 2005
4 468
769
on the Lost Highway
perso.wanadoo.fr
De rien ;)

Sinon, tu peux parfaitement télécharger la mise à jour 10.4.10 depuis le site d'Apple :

- Mise à jour 10.4.10 pour Mac à puces PPC (version Combo)

Je ne saisi pas par contre pourquoi tu n'as pas cette mise à jour de proposée. Tu peux nous dire quelle est la version système d'indiquée dans la fenêtre d'info quand tu vas au Menu Pomme/À propos de ce Mac ?

De plus, tu n'aurais pas par hasard fait le "ménage" dans le dossier que je t'ai indiqué précédemment DisqueDur/Bibliothèque/Receipts ? Si c'est le cas, il ne faut pas, en tout cas pas sans savoir ce que l'on fait.
 

karabe

Membre confirmé
6 Mai 2005
169
8
Bonjour,

Paski.pne> Tu conseillerai d'effacer tous les .pkg contenu dans le dossier Receipts ou bien cela risque-t-il de créer des problèmes ? D'ailleur il sert à quoi exactement ce dossier ?
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
22 554
4 943
Là-haut
Vas-y efface... :siffle:

Eh non ! Triple windows, ne touche pas à ça !!!

Ce sont des éléments essentiels au système.

Cela sert entre autre à la réparation des autorisations, à la mise à jour des logiciels du système et de toute application installée via le programme d'installation.

Ne jamais enlever quelque chose de là-dedans sans savoir très exactement ce que l'on fait et pourquoi.
 

Paski.pne

Membre d’élite
Club MacG
7 Novembre 2005
4 468
769
on the Lost Highway
perso.wanadoo.fr
Bonjour,

Paski.pne> Tu conseillerai d'effacer tous les .pkg contenu dans le dossier Receipts ou bien cela risque-t-il de créer des problèmes ? D'ailleur il sert à quoi exactement ce dossier ?
Salut,

Il ne faut surtout pas effacer le contenu de ce dossier. On peut en écarter (effacer) certains éléments lorsque la nécessité s'en fait sentir, comme dans le cas présent où le système ne voulait pas réinstaller iTunes.

Les .pkg contenus dans ce dossier sont des traces laissées par les installations, essentiellement celles des applis Apple ou encore celles de logiciels qui emploient le logiciel d'installation du système pour s'installer (celles qui s'installent par simple glissé/déposé n'auront pas de fichier .pkg).

Ces .pkg servent au système pour deux choses :
- Tout d'abord, dans le cadre des applis Apple et du système, ils servent au système à savoir qu'elles sont les logiciels et les versions de ces logiciels. Le module de mise à jour des applications du Système (menu Pomme/Mise à jour de logiciels) lit ce dossier Receipts et les packages qu'il contient pour savoir qu'elles sont les applis installées et donc en comparant avec la base de données d'Apple, il sait qu'elles sont les mises à jour nécessaires pour le présent Mac.
- Ensuite, ces .pkg contiennent des infos concernant la gestions des droits (autorisations d'accès) des différents logiciels installés. C'est à ces fichiers que se réfère l'Utilitaire de disques quand on lui demande de vérifier et réparer les autorisations, ils sait ainsi quels sont les droits normalement appliqués aux différentes Applications et corrige donc les erreurs en fonction.

J'espère avoir été clair ;)

EDIT : Grillé par le Marcheur Lunatique... Heu... Je voulais dire Lunaire, bien sûr :siffle: :D ;)
 

evilpet

Nouveau membre
3 Juillet 2007
7
0
Paris
vik.l.free.fr
J'ai ce powerbook depuis 4 ans. Je pense qu'il est trop "vieux" pour le tigre.
A l'installation du tigre, j'ai eu un pb... mais finalement ça a marché.

Voici la version système d'indiquée:

Mac OS X
Version 10.4
Processor 1.25GHz PowerPC G4
Memory 512 MB DDR SDRAM


T'inquiètes, je n'ai pas fait le "ménage" dans le dossier "Bibliothèque/Receipts".
J'ai just écarté, et après, je les ai remis dedans... :siffle:
 

Paski.pne

Membre d’élite
Club MacG
7 Novembre 2005
4 468
769
on the Lost Highway
perso.wanadoo.fr
J'ai ce powerbook depuis 4 ans. Je pense qu'il est trop "vieux" pour le tigre.
A l'installation du tigre, j'ai eu un pb... mais finalement ça a marché.

Voici la version système d'indiquée:

Mac OS X
Version 10.4
Processor 1.25GHz PowerPC G4
Memory 512 MB DDR SDRAM


T'inquiètes, je n'ai pas fait le "ménage" dans le dossier "Bibliothèque/Receipts".
J'ai just écarté, et après, je les ai remis dedans... :siffle:

Les specs sont bonnes pour Tiger. La Ram est le minimum utile.
Tout à fait, et comme je l'ai dit précédemment, j'ai Tiger (toutes les mises à jour de faites) d'installé sur une machine plus ancienne, moins puissante et avec moins de RAM, alors dans ton cas, il ne devrait pas y avoir de problèmes.

C'est souvent un Placebo, mais je me demande si une petite réparation des autorisations ne serait pas utile ? Cela se passe dans Applications/Utilitaires/Utilitaires de disques, sélectionner la partition système, puis cliquer sur l'onglet SOS et cliquer sur Réparer les autorisations. Regarde ensuite si ton module de mise à jour te propose enfin la mise à jour du système.
 

evilpet

Nouveau membre
3 Juillet 2007
7
0
Paris
vik.l.free.fr
Tout à fait, et comme je l'ai dit précédemment, j'ai Tiger (toutes les mises à jour de faites) d'installé sur une machine plus ancienne, moins puissante et avec moins de RAM, alors dans ton cas, il ne devrait pas y avoir de problèmes.

C'est souvent un Placebo, mais je me demande si une petite réparation des autorisations ne serait pas utile ? Cela se passe dans Applications/Utilitaires/Utilitaires de disques, sélectionner la partition système, puis cliquer sur l'onglet SOS et cliquer sur Réparer les autorisations. Regarde ensuite si ton module de mise à jour te propose enfin la mise à jour du système.

Je viens d'essayer le "Mac OS 10.4.10 PPC Update Combo", on me dit "This volume does not meet the requirements for this update".... :nailbiting:

Je vais suivre ton conseil et essayer de réparer les autorisations... on verra... :rose:
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
22 554
4 943
Là-haut
Je viens d'essayer le "Mac OS 10.4.10 PPC Update Combo", on me dit "This volume does not meet the requirements for this update".... :nailbiting:

Je vais suivre ton conseil et essayer de réparer les autorisations... on verra... :rose:

What ? :mouais:

T'es sûr d'être en 10.4 ?
 

Paski.pne

Membre d’élite
Club MacG
7 Novembre 2005
4 468
769
on the Lost Highway
perso.wanadoo.fr
Je viens d'essayer le "Mac OS 10.4.10 PPC Update Combo", on me dit "This volume does not meet the requirements for this update".... :nailbiting:
Étrange... :mouais: Vu que ton système est bien 10.4 au vu de ce que tu dis, ça ne devrait pas poser de problème.
Je ne comprends pas. En tout cas, pas pour l'instant. J'aurais peut-être une idée lumineuse plus tard :rateau:

Tu peux (toujours dans Utilitaire de disques) essayer de Vérifier le disque (pas Réparer, cela ne fonctionnera pas). Cette fonction se trouve à côté de celle de Vérification des autorisations. Le disque a peut-être un problème.
Je vais suivre ton conseil et essayer de réparer les autorisations... on verra... :rose:
Pas sûr que cela résolve ton problème, mais ça ne peut pas faire de mal ;)

EDIT : Le petit Moonwalker est demandé à l'accueil. :eek:
Y'a un monsieur qui l'attend pour lui faire copier cent fois :
"Je ne dois pas griller mes petits camarades"
:D :D
 

evilpet

Nouveau membre
3 Juillet 2007
7
0
Paris
vik.l.free.fr
J'ai fait la réparation des autorisations...
Mon MAC est très capricieux...
Le mise à jour "Mac OS 10.4.10" ne marche toujours pas...
mais ce n'est pas très grave...

En tous cas, merci à tous ceux qui m'ont aidées!!! :)
 

Paski.pne

Membre d’élite
Club MacG
7 Novembre 2005
4 468
769
on the Lost Highway
perso.wanadoo.fr
J'ai fait la réparation des autorisations...
Mon MAC est très capricieux...
Le mise à jour "Mac OS 10.4.10" ne marche toujours pas...
mais ce n'est pas très grave...

En tous cas, merci à tous ceux qui m'ont aidées!!! :)
Grave, je ne sais pas, mais il serait peut-être mieux de ne pas laisser les choses en l'état. D'autant plus que les mises à jours servent à corriger des problèmes (même si elles apportent souvent leur propre lot de bugs :D).
Attention : pour vérifier le disque via l'utilitaire de disque de ./Applications/Utilitaire, il faut être en 10.4.3 minimum. Sinon il faut avoir recourt au DVD d'installation n°1.
Ah tiens ! Je ne me rappelais pas de ça. Tu te rappelles du pourquoi ? Cette fonction n'existait pas avant ?
Je ne dois pas griller mes petits camarades. (le reste en copier/coller) :D
Fainéant ! :eek:
:D
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
22 554
4 943
Là-haut
Ah tiens ! Je ne me rappelais pas de ça. Tu te rappelles du pourquoi ? Cette fonction n'existait pas avant ?
Ben non, j'ai commencé en 10.4.4. :D

Je sais que c'est en relation avec la journalisation. Il m'est d'avis qu'ils n'avaient pas fini de travailler chez Apple lorsqu'ils ont lâché le tigre. Du coup, je ne suis pas pressé de passer à Leopard avant quelques mois et mises à jour. :siffle: