10.12 Sierra Inskape et Xquartz

Maurice21

Membre confirmé
2 Janvier 2011
25
1
Bonjour et bonne année,

Sous Sierra, je ne parviens pas à faire fonctionner Inskape. Au lancement, Inskape essaie de charger xquartz, mais ce dernier s'ouvre et se referme immédiatement, puis s'ouvre à nouveau et se referme, en boucle, indéfiniment. Je suis obligé de redémarrer pour arrêter cette boucle. Quelqu'un a-t'il une idée ? J'ai supprimé puis réinstallé réinstaller xquartz, mais j'ai toujours ce même phénomène.

moribo
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
23 141
5 881
Là-haut

Maurice21

Membre confirmé
2 Janvier 2011
25
1
Hum…

Je suis allé faire un tour sur la page de Xquartz et je ne vois nulle part une référence à Sierra. Pas bon signe. :meh:
https://www.xquartz.org/releases/index.html
Puis, je suis allé chez Inkscape et là je vois qu’on parle de Mac OS X 10.7 Lion. o_O
https://inkscape.org/fr/release/0.92.2/mac-os-x/

Si tu veux un conseil, laisse tomber X11 et passe par Homebrew.
Merci,

J'essaie d'installer Homebrew mais je suis bloqué dans le terminal qui me demande un code développer Xcode, que je n'ai pas.
Voilà ce que le terminal me dit :

-allowProvisioningUpdates Allow xcodebuild to communicate with the Apple Developer website. For automatically signed targets, xcodebuild will create and update profiles, app IDs, and certificates. For manually signed targets, xcodebuild will download missing or updated provisioning profiles. Requires a developer account to have been added in Xcode's Accounts preference pane.
-allowProvisioningDeviceRegistration Allow xcodebuild to register your destination device on the developer portal if necessary. This flag only takes effect if -allowProvisioningUpdates is also passed.
pc2:~ mauricebour$

Et c'est en anglais, ce qui n'est pas mon fort !
Comment faire ? (J'ai bien xcode installé)
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
23 141
5 881
Là-haut
Étrange.

Je n’ai jamais eu de problème de ce genre avec l’installation de Homebrew.

J’ouvre le Terminal et je tapes :
Bloc de code:
/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

Extrait de: Nicolas Furno. « Tout savoir sur : Le terminal. » iBooks. https://itunes.apple.com/fr/book/tout-savoir-sur-le-terminal/id1211185824?mt=11

Mais comme signalé dans l’excellent livre ci-dessus, il faut aussi installer les outils Xcode en ligne de commande. Normalement, la procédure s’enclenche automatiquement.

Néanmoins, pour installer les outils en ligne de commande Xcode, il suffit de taper ceci dans le Terminal :
Bloc de code:
xcode-select --install

Il n’est même pas besoin d’avoir installé Xcode.
 

Maurice21

Membre confirmé
2 Janvier 2011
25
1
Étrange.

Je n’ai jamais eu de problème de ce genre avec l’installation de Homebrew.

J’ouvre le Terminal et je tapes :
Bloc de code:
/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

Extrait de: Nicolas Furno. « Tout savoir sur : Le terminal. » iBooks. https://itunes.apple.com/fr/book/tout-savoir-sur-le-terminal/id1211185824?mt=11

Mais comme signalé dans l’excellent livre ci-dessus, il faut aussi installer les outils Xcode en ligne de commande. Normalement, la procédure s’enclenche automatiquement.

Néanmoins, pour installer les outils en ligne de commande Xcode, il suffit de taper ceci dans le Terminal :
Bloc de code:
xcode-select --install

Il n’est même pas besoin d’avoir installé Xcode.
Encore merci pour tes conseils Moonwalker.
Enfin, Homebrew est installé, mais maintenant je bute sur une demande de permission pour installer inkscape. Je ne sais pas ce qu'il faut faire pour donner cette permission. Je ne trouve pas de Homebrew dans les logs. Je joins la copie du terminal :

pc2:~ mauricebour$ xcode-select --install
xcode-select: error: command line tools are already installed, use "Software Update" to install updates
pc2:~ mauricebour$ /usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
==> This script will install:
/usr/local/bin/brew
/usr/local/share/doc/homebrew
/usr/local/share/man/man1/brew.1
/usr/local/share/zsh/site-functions/_brew
/usr/local/etc/bash_completion.d/brew
/usr/local/Homebrew

Press RETURN to continue or any other key to abort
==> /usr/bin/sudo /bin/mkdir -p /Library/Caches/Homebrew
Password:
==> /usr/bin/sudo /bin/chmod g+rwx /Library/Caches/Homebrew
==> /usr/bin/sudo /usr/sbin/chown mauricebour /Library/Caches/Homebrew
==> Downloading and installing Homebrew...
HEAD is now at 09bfb2a8f Merge pull request #3633 from MikeMcQuaid/lines_cop_version
==> Cleaning up /Library/Caches/Homebrew...
==> Migrating /Library/Caches/Homebrew to /Users/mauricebour/Library/Caches/Home
==> Deleting /Library/Caches/Homebrew...
Already up-to-date.
==> Installation successful!

==> Homebrew has enabled anonymous aggregate user behaviour analytics.
Read the analytics documentation (and how to opt-out) here:
https://docs.brew.sh/Analytics.html

==> Next steps:
- Run `brew help` to get started
- Further documentation:
https://docs.brew.sh
pc2:~ mauricebour$
pc2:~ mauricebour$ brew install caskformula/caskformula/inkscape
==> Installing inkscape from caskformula/caskformula
Error: Permission denied @ dir_s_mkdir - /Users/mauricebour/Library/Logs/Homebrew
pc2:~ mauricebour$
 

Maurice21

Membre confirmé
2 Janvier 2011
25
1
Bien. Tu as installé Homebrew.

Le problème de permission…

Encore.

À la limite va trafiquer les droits du répertoire qui te pose problème.
?????
Trafiquer les droits ... Je ne sais pas faire ! Je suis réellement incompétent en la matière et j'ai du mal à entrer dans les arcanes du système... Et ça ne s'arrange pas avec l'âge (je suis en approche des 78 ans). Tant pis. Je pense que je vais abandonner Inkscape et chercher un autre logiciel plus simple à installer.
Merci quand même pour ton aide qui m'a fait progresser.
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
23 141
5 881
Là-haut
Je viens d’installer XQuartz et Inkscape sur High Sierra.

Ça marche.

Alors, j’ai téléchargé ce Xquartz :
https://www.xquartz.org

Et téléchargé Inkscape :
https://inkscape.org/fr/release/0.92.2/mac-os-x/


1. J’ai installé Xquartz.

2. J’ai redémarré mon iMac.

3. J’ai installé Inkscape

4. J’ai ouvert Xquartz puis Inkscape

Comme il n’est pas reconnu par Gatekeeper, j’ai contourné la protection via le menu contextuel « Ouvrir ».
 
Dernière édition:

Maurice21

Membre confirmé
2 Janvier 2011
25
1
Je viens d’installer XQuartz et Inkscape sur High Sierra.

Ça marche.

Alors, j’ai téléchargé ce Xquartz :
https://www.xquartz.org

Et téléchargé Inkscape :
https://inkscape.org/fr/release/0.92.2/mac-os-x/


1. J’ai installé Xquartz.

2. J’ai redémarré mon iMac.

3. J’ai installé Inkscape

4. J’ai ouvert Xquartz puis Inkscape

Comme il n’est pas reconnu par Gatekeeper, j’ai contourné la protection via le menu contextuel « Ouvrir ».
Bonjour,

J'ai suivi la démarche que tu m'indiques, mais toujours en vain. xquartz refuse de s'ouvrir, même à partir du menu contextuel "Ouvrir".
Merci encore pour ton aide.
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
23 141
5 881
Là-haut
« Ouvrir » concernait Inkscape. Je n’ai eu aucun problème avec Xquartz.

Il faut absolument redémarrer le Mac après l’installation de Xquartz afin qu’il soit pris en compte.

Il n’y a pas de raison que cela ne fonctionne pas chez toi.

Mais avant de recommencer, tu vas nettoyer les préférences de Xquartz et les différents répertoires où il a écrit.

Suis-moi bien :
/Library c’est Macintosh HD/Bibliothèque
~/Library c’est Users/maurice.../Bibliothèque le répertoire bibliothèque invisible.

1. Faire apparaître la bibliothèque invisible
– tu affiche une fenêtre Finder
– barre de menu > Présentation > Afficher les options de présentation ou cmd j
– dans la petite fenêtre qui apparaît tu coches Afficher le dossier Bibliothèque
– maintenant tu as un répertoire Bibliothèque à côté des répertoires Images, Documents, Musiques, etc.

2. Enlever les scories de Xquartz (c’est-à-dire mettre tout cela à la corbeille)

~/Library/Caches/org.macosforge.xquartz.X11
~/Library/Preferences/org.macosforge.xquartz.X11.plist
~/Library/Saved Application State/org.macosforge.xquartz.X11.savedState (il est possible que celui-ci ne soit pas présent)

/Library/LaunchAgents/org.macosforge.xquartz.startx.plist
/Library/LaunchDaemons/org.macosforge.xquartz.privileged_startx.plist

/Applications/Utilities/Xquartz.app

/opt


Barre de menu du Finder > Aller > Aller au dossier...

taper /private et trouver les deux fichiers suivants :
/private/var/db/receipts/org.macosforge.xquartz.pkg.bom
/private/var/db/receipts/org.macosforge.xquartz.pkg.plist

Voilà, Xquartz est à la corbeille. Redémarrer le Mac.


3. Réinstaller Xquartz.

Ne pas lancer Xquartz mais redémarrer le Mac.
Ouvrir Xquartz.


4. Installer Inkscape.

Ouvrir Inkscape (besoin de contourner Gatekeeper par le menu « Ouvrir »)
Attendre quelques instants jusqu’à ce que la fenêtre Inkscape s’affiche.

nota bene : redémarrer après l’installation de Xquartz. Ouvrir Xquartz avant d’ouvrir Inkscape pour la première fois.
 

Maurice21

Membre confirmé
2 Janvier 2011
25
1
« Ouvrir » concernait Inkscape. Je n’ai eu aucun problème avec Xquartz.

Il faut absolument redémarrer le Mac après l’installation de Xquartz afin qu’il soit pris en compte.

Il n’y a pas de raison que cela ne fonctionne pas chez toi.

Mais avant de recommencer, tu vas nettoyer les préférences de Xquartz et les différents répertoires où il a écrit.

Suis-moi bien :
/Library c’est Macintosh HD/Bibliothèque
~/Library c’est Users/maurice.../Bibliothèque le répertoire bibliothèque invisible.

1. Faire apparaître la bibliothèque invisible
– tu affiche une fenêtre Finder
– barre de menu > Présentation > Afficher les options de présentation ou cmd j
– dans la petite fenêtre qui apparaît tu coches Afficher le dossier Bibliothèque
– maintenant tu as un répertoire Bibliothèque à côté des répertoires Images, Documents, Musiques, etc.

2. Enlever les scories de Xquartz (c’est-à-dire mettre tout cela à la corbeille)

~/Library/Caches/org.macosforge.xquartz.X11
~/Library/Preferences/org.macosforge.xquartz.X11.plist
~/Library/Saved Application State/org.macosforge.xquartz.X11.savedState (il est possible que celui-ci ne soit pas présent)

/Library/LaunchAgents/org.macosforge.xquartz.startx.plist
/Library/LaunchDaemons/org.macosforge.xquartz.privileged_startx.plist

/Applications/Utilities/Xquartz.app

/opt


Barre de menu du Finder > Aller > Aller au dossier...

taper /private et trouver les deux fichiers suivants :
/private/var/db/receipts/org.macosforge.xquartz.pkg.bom
/private/var/db/receipts/org.macosforge.xquartz.pkg.plist

Voilà, Xquartz est à la corbeille. Redémarrer le Mac.


3. Réinstaller Xquartz.

Ne pas lancer Xquartz mais redémarrer le Mac.
Ouvrir Xquartz.


4. Installer Inkscape.

Ouvrir Inkscape (besoin de contourner Gatekeeper par le menu « Ouvrir »)
Attendre quelques instants jusqu’à ce que la fenêtre Inkscape s’affiche.

nota bene : redémarrer après l’installation de Xquartz. Ouvrir Xquartz avant d’ouvrir Inkscape pour la première fois.
Bonsoir,
J'ai essayé, mais je bute toujours sur le même problème. xquartz s'installe mais impossible de le lancer (il tourne en boucle, son icône apparait et disparait, puis ça recommence...). J'ai pourtant suivi scrupuleusement tes instructions.
Lors de la désinstallation, j'ai bien trouvé tous les fichiers que tu indiques, sauf les trois premiers, malgré une recherche dans Spotlight. (Je suppose que ces fichiers n'existent qu'après une ouverture réussie de xquartz).
Demain, je vais essayer d'installer Hight Sierra. J'hésitais jusque là car avec lui, je vais perdre Final Cut Express que j'utilisais de temps en temps.
Je t'informerai de la suite.
Merci, bonne soirée.
 

Maurice21

Membre confirmé
2 Janvier 2011
25
1
Bonsoir,
J'ai essayé, mais je bute toujours sur le même problème. xquartz s'installe mais impossible de le lancer (il tourne en boucle, son icône apparait et disparait, puis ça recommence...). J'ai pourtant suivi scrupuleusement tes instructions.
Lors de la désinstallation, j'ai bien trouvé tous les fichiers que tu indiques, sauf les trois premiers, malgré une recherche dans Spotlight. (Je suppose que ces fichiers n'existent qu'après une ouverture réussie de xquartz).
Demain, je vais essayer d'installer Hight Sierra. J'hésitais jusque là car avec lui, je vais perdre Final Cut Express que j'utilisais de temps en temps.
Je t'informerai de la suite.
Merci, bonne soirée.
Toujours rien !
J'ai désinstallé xquartz comme prévu, installé High Sierra, téléchargé xquartz, installé xquartz, redémarré le Mac. Rien à faire, xquartz refuse de s'ouvrir. J'ai tenté d'installer Inskcape pour voir, mais c'est la même chose. Rien ne peut s'ouvrir. Si je lance Inkscape, xquartz tente en vain de s'ouvrir et je suis obligé de redémarrer pour l'arrêter (Je ne peux même pas le forcer à quitter par le menu pomme car il n'apparait que furtivement et reste impossible à cliquer).
J'abandonne.
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 993
3 182
En cherchant un peu, j'ai pu lire (ici) que la version 2.7.8 de XQuartz semblait mieux fonctionner que la 2.7.11

Tu n'aurais pas un petit message d'erreur quelque part, qui permettrait de savoir ce qui ne lui convient pas, à XQuartz ?
Ouvre l'utilitaire Console (que tu trouveras dans /Applications/Utilitaires). Dedans se trouvent concentrés les messages des applications et du système, dont l'affichage est rafraîchi régulièrement (presque en temps réel).
Avec un peu de chance tu auras des informations sur ces problèmes de lancement.

Si jamais XQuartz résiste, il est toujours possible de le remplacer par un autre portage de X11 sur Mac, comme XOrg dans MacPorts (mais c'est une solution un peu lourde, de dernier recours...)
 

Maurice21

Membre confirmé
2 Janvier 2011
25
1
À mon avis il y a un problème avec le système de Maurice21, car j’ai essayé X11 sur deux machines différentes avec deux systèmes différents sans aucune difficulté.
Bonsoir,

Merci pour vos retours. J'ai ouvert la console et lancé xquartz. J'ai ensuite fait trois copies d'écran, un peu au hasard, car cela défile très rapidement et on ne sait pas où pointer. Ci-joint les trois copies. Peut-être trouverez-vous quelques informations utiles. Apparemment, il y a quelques erreurs signalées, mais je suis bien incapables de les interpréter.
 

Fichiers joints

  • Capture d’écran 2018-01-11 à 17.56.39.png
    Capture d’écran 2018-01-11 à 17.56.39.png
    315,8 KB · Affichages: 91
  • Capture d’écran 2018-01-11 à 17.56.49.png
    Capture d’écran 2018-01-11 à 17.56.49.png
    345,5 KB · Affichages: 71
  • Capture d’écran 2018-01-11 à 17.57.07.png
    Capture d’écran 2018-01-11 à 17.57.07.png
    777 KB · Affichages: 103

Maurice21

Membre confirmé
2 Janvier 2011
25
1
Bonsoir,

Merci pour vos retours. J'ai ouvert la console et lancé xquartz. J'ai ensuite fait trois copies d'écran, un peu au hasard, car cela défile très rapidement et on ne sait pas où pointer. Ci-joint les trois copies. Peut-être trouverez-vous quelques informations utiles. Apparemment, il y a quelques erreurs signalées, mais je suis bien incapables de les interpréter.
Capture d’écran 2018-01-11 à 17.56.39.png Capture d’écran 2018-01-11 à 17.56.49.png Capture d’écran 2018-01-11 à 17.57.07.png
 
Dernière édition par un modérateur:

Maurice21

Membre confirmé
2 Janvier 2011
25
1
Beaucoup de choses qui ne disent rien de bon mais difficile de faire le lien avec Xquartz.

Regarde dans la colonne de gauche (à afficher) à ~/Libary/Logs

Il doit y avoir un dossier consacré à X11.
Bonjour,

J'ai mis le temps, mais tout à fait par hasard, je me suis aperçu que le dossier Logs n'avait pas les autorisations "Lecture et "écriture" dans Partage et permissions. J'ai réinstallé Xquartz et maintenant tout fonctionne. Inskape s'ouvre sans problème.
Merci à tous.
Maurice
 
  • J’aime
Réactions: Moonwalker