Installation de serveurs web sur mon Mac

M

Membre supprimé 1129907

Invité
Finalement, c'est bon ? Tant mieux.
Pour le timezone, je crois que je n'avais pas utilisé cette commande lors de la mise à jour. Donc elle ne doit pas être nécessaire
 

Marc ou Net

Membre émérite
20 Avril 2008
640
39
45
Rennes
Mon pauvre @ecatomb je sens que tu vas avoir encore un gros problème avec moi. J'ai été obligé de redémarrer mon Mac, et MySQL fonctionne toujours, mais, à présent, PHPMyAdmin m'affiche ceci : #2006 - MySQL server has gone away
Qu'est-ce qui ne fonctionne pas bien avec mon Mac. :banghead:
 

touba

toubato ketchup
Club MacG
10 Avril 2001
2 740
524
47
Dakar
cocoriweb.community
je ressors le pop-corn...

Que renvoie le navigateur si tu navigues vers un fichier contenant ceci ? (avec les bons paramètres SQL of course sur la première ligne...)
PHP:
<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* check if server is alive */
if (mysqli_ping($link)) {
    printf ("Our connection is ok!\n");
} else {
    printf ("Error: %s\n", mysqli_error($link));
}

/* close connection */
mysqli_close($link);
?>

Voir également le réglage timeout trop bas ou max_allowed_packets trop faible
 

Marc ou Net

Membre émérite
20 Avril 2008
640
39
45
Rennes
je ressors le pop-corn...
Mais mais mais, il semble s'amuser le petit ******* :hilarious:
PHP:
<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* check if server is alive */
if (mysqli_ping($link)) {
    printf ("Our connection is ok!\n");
} else {
    printf ("Error: %s\n", mysqli_error($link));
}

/* close connection */
mysqli_close($link);
?>
Voici ce que le navigateur me répond (Chrome en se moment) :
Bloc de code:
Connect failed: The server requested authentication method unknown to the client
Je ne sais pas où vous en êtes, mais si ça peut servir :

Pour être franc, Apache, facile (très facile), MySQL un peu plus complexe (faut aller dans les archives de MySQL pour trouver une build compatible avec 10.13, et un ou deux bugs de configuration), PHPMyAdmin n'arrive pas à être vraiment installé. Une fois, il faut tout réinstaller après un redémarrage, une autre fois, il y a un réglage qui fait tout foirer… bref, l'horreur.
Sinon, je connais ce lien, c'était ma page de référence avant mes ennuis avec PHPMyAdmin.

Quand à toi @ecatomb, je te mp mardi soir ou mercredi soir (histoire de te laisser un peu souffler), c'est promis.
 

Marc ou Net

Membre émérite
20 Avril 2008
640
39
45
Rennes
Coucou à tous !

J'ai un problème avec ma configuration. De temps en temps, j'ai l'erreur "Errno: 2002 Error: Operation not permitted". Mais, sans que j'arrive à l'expliquer, j'ai à nouveau accès à ma base de données.
De plus, quand je lance phpMyAdmin (après plusieurs heures d'inactivité), ce dernier me répond que ma base MySQL est partie !. Il lui faut 3 à 5 rafraichissements pour qu'il retrouve ses esprits.
De plus, voici les messages d'erreurs qu'il affiche tout le temps :
  • Le fichier de configuration nécessite maintenant une phrase de passe secrète (blowfish_secret).
  • $cfg['TempDir'] (/Users/marcbleriot/Sites/PHPMyAdmin/tmp/) n'est pas accessible. phpMyAdmin est incapable de mettre en cache les modèles et de ce fait sera lent.
Comment résoudre mes soucis ?