Installation open office et x11

Pooki

Membre émérite
6 Juillet 2007
768
20
39
Lille
Bonsoir,

J'essaye d'installer Open Office sur mon mac. Lors de l'installation il me dit que je dois installer x 11. Du coup j'installe x11 mais lors de l'installation il me dit que je ne peux ps l'installer car une version plus récente existe déjà sur mon ordinateur. Je suis sur Mac OS X 10.4.10

Merci pour votre aide

PS: je suis débutant sur mac, essayer de ne pas trop me parler une autre langue ;)
 

Pooki

Membre émérite
6 Juillet 2007
768
20
39
Lille
Vraiment désolé Moonwalker....:siffle: Je ne dois pas trop saisir comment marche la section recherche car g tapé x11, rien n'est sorti.....alors encore 1000 excuses !!! Par contre ca ne répond pas trop à mon problème car j'ai fait comme ce tuto et au moment ou il me demande de choisir ou l'installer il me dit que ça n'est pa possible puisqu'une version plus récente existe déjà sur mon ordinateur alors qu'Open Office ne le touve pas...Donc u final je ne peux toujours pas l'istaller.
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
22 572
4 954
Là-haut
Vraiment désolé Moonwalker....:siffle: Je ne dois pas trop saisir comment marche la section recherche car g tapé x11, rien n'est sorti.....alors encore 1000 excuses !!!
;)

C'moon.

Edit : ok ! Pas de panique, c'est courant comme problème après une installation de la mauvaise version.

Va dans Macintosh HD/Bibliothèque/Receipts et enlève le X11.pkg (ou X11User.pkg) que tu y trouveras (à la corbeille).
Va aussi vérifier que tu n'aurais pas un X11 dans Macintosh HD/Applications/Utilitaires (si oui à la corbeille).
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
22 572
4 954
Là-haut
tu vas me prendre pour un gros boulet mais il y a aucun x11 a ces endroits la :s :rose:
Non je ne te prends pas pour un boulet. X11 pose ce genre de problèmes lorsqu'on ne l'a pas installé convenablement.

Mais tu vas me décrire précisément ce que tu as fait la première fois qu'il t'a dit que tu ne pouvais pas installer X11. Ce premier X11, où es-tu allé le chercher ?

Tu as redémarrer le Mac avant de re-tenter l'installation ?
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
22 572
4 954
Là-haut
Voici un truc à essayer mais il faut bien suivre scrupuleusement chaque étape (nota : je ne peux le reproduire puisque X11 est convenablement installé chez moi) :


1. Télécharger OnyX et l'installer.

2. Dans OnyX choisir Paramêtres>Finder et cocher la case "Afficher les fichiers et dossiers cachés".

[les fichiers cachés du système apparaissent sur le bureau. Attention, n'y touche pas sauf si je te le dis.]

3. Dans la fenêtre de ton dossier Départ (la petite maison), là où il y a les dossiers "Séquences, Musique, Documents, etc..." tu devrais voir un dossier ".Xauthority".

4. Mettre ce dossier .Xauthority à la corbeille et la vider.

5. Aller dans Macintosh HD/usr et si tu trouves quelque chose comme X11R6 tu le places à la corbeille et tu la vides.

6. Retourner sur la fenêtre d'OnyX et décocher la case "Afficher les fichiers et dossiers cachés" puis quitter OnyX.

7. Dans la barre de menu>Pomme>Redémarrer puis au retour sur le bureau, insérer le DVD d'installation n°1 et recommencer la procédure d'installation.

Pffff ! :p
 

Pooki

Membre émérite
6 Juillet 2007
768
20
39
Lille
Alors, pour commencer je l'ai télécharger ici . Ensuite j'ai ouvert l'image puis fais glisser x11 dans mes applications. J'ai double cliqué dessus, l'installation s'est lancée et là il me dit que je ne peux pas l'installer sur Macintosh HD car une version plus récente est déjà installée. Là, c'était le début de ces problèmes!!
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
22 572
4 954
Là-haut
Alors, pour commencer je l'ai télécharger ici . Ensuite j'ai ouvert l'image puis fais glisser x11 dans mes applications. J'ai double cliqué dessus, l'installation s'est lancée et là il me dit que je ne peux pas l'installer sur Macintosh HD car une version plus récente est déjà installée. Là, c'était le début de ces problèmes!!

Ok !

Là c'est normal puisqu'il s'agit de la version 1.0 uniquement prévue pour 10.3 alias Panther.

Je vais reproduire la manoeuvre sur mon disque externe et te tiens au courant.

A+.
 

Pooki

Membre émérite
6 Juillet 2007
768
20
39
Lille
Sinon, utiliser la dernière version 2.3 (qui est en béta), et qui ne nécessite pas X11.

D'habitude, j'évite de conseiller les versions en béta, mais celle-ci est déjà largement "utilisable", sans risque de bugs majeurs...
J'ai lu ça dans un autre sujet. Ne serait ce pas plus simple dans mon cas?
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
22 572
4 954
Là-haut
Bon ! Résultat des courses :

tentative installation mauvais X11 :

image1ls1.png


tentative du bon (celui du DVD d'installation n°1 par Optional Installs) :

image2qt3.png


Et résultat :

image3jr8.png


Conclusion : il y a quelque chose que tu fais mal... mais quoi ?
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
22 572
4 954
Là-haut
Je n'ai pas encore testé la dernière version. Mais c'est sûrement loin d'être stable pour une utilisation courante.

J'aimerais bien comprendre où ça coince pour toi...

Sinon tu as NeoOffice, il ne nécessite pas X11 est bien que ce basant sur une version ancienne d'OpenOffice.org (la 2.1) il est d'une stabilité éprouvée.

Cela ne réglera pas le problème X11 mais tu auras au moins une suite bureautique qui fonctionne, même si un peu plus lente que OpenOffice.org.
 

Pooki

Membre émérite
6 Juillet 2007
768
20
39
Lille
Ok je vais essayer NeoOffice mais une dernière question et après c'est fini, promis;)
A quoi sert x11 au juste pour un mac?
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
22 572
4 954
Là-haut
Yo !!!!!!! J'ai compris où tu coinces.

Le paquet de l'image disque du mauvais X11 est toujours dans ./Application ?

Lorsque tu as un paquet d'installation contenu dans une image disque, tu ne le dépose pas dans "Application", tu double-clique simplement dessus.

Là, il s'agissait en plus d'une mauvaise version.

X11 est une sorte de support pour afficher les applications de type Unix. Il sert principalement pour OpenOffice.org et Gimp (l'équivalent libre de Photoshop), mais aussi pour d'autres applications Unix qui peuvent ainsi fonctionner sous Mac OS X sans passer par Aqua, l'interface native du système.

Si tu n'as pas d'énormes besoin prend NéoOffice en attendant que OpenOffice.org Aqua soit plus fonctionnel.
 

divoli

Vénérable sage
Club MacG
13 Août 2005
15 862
1 420
La dernière fois que je l'ai testée tu pouvais pas imprimer donc je te conseille d'attendre encore un peu...

La plus récente (20070630) le permet.

Mais ça ne règle pas ce problème avec X11, qui peut être utilisé pour faire fonctionner d'autres logiciels venant du monde Linux...