10.11 El Capitan Installation os X impossible

thomasp14

Nouveau membre
10 Juillet 2017
7
0
30
Bonjour,

Je me permet de venir poser ma question sur le forum que je découvre. J'ai un iMac aluminium qui était sous El capitan. Il ne démarrait plus : barre de chargement avec la pomme puis il se coupait.
J'ai essayé de booter sur la partition "Recovery', j'ai refait la parition (en GUID) mais lors du redémarrage la procédure d'installation se bloque et m'indique que Mac os x ne peut être installé.

En relançant la partition recovery, j'ai pu lancer l'utilitaire de disque :
Sur le disk physique : SOS ok. Sur la partition des erreurs.
Je viens de faire un dsck -fyn "The volums OS X Base Systel appears to be OK". J'ai testé avec un clé usb El capitan d'un ami, impossible de l'installer. Idem avec un CD OS X Lion.

Je ne vois plus quoi faire pour avancer ... Sans autre mac ni de sauvegarde time machine.

Avez-vous des pistes pour localiser le problème et le corriger.

Merci à vous
 
D

Deleted member 1099514

Invité
Salut

Quel modèle d'iMac? Quelle année?
Quand tu démarres en mode Recovery, tu ouvres le terminal (Menu/Utilitaires/Terminal) puis tu tapes la commande :
diskutil list
tu fais ensuite un copier des résultats, tu quittes le terminal et dans le menu à 4 choix, tu sélectionnes "Obtenir de l'aide". C'est un "safari" qui va te permettre de venir coller les résultats sur le forum entre balises Code :


Ensuite tu quittes Safari et tu repasses sur le terminal pour donner les retours de la commande :
diskutil cs list
 

thomasp14

Nouveau membre
10 Juillet 2017
7
0
30
Merci pour ta réponse. Il s'agît du premier iMac aluminium. Je l'ai acheté d'occasion, donc je ne sais pas quelle année, mais c'est la version de 2009 "visuellemen".
Voici le report du diskutil list.

Bloc de code:
#:    TYPE NAME    SIZE    IDENTIFIER
0:    GUID_partition_scheme    +6.8 GB    disk1
1:    EFI EFI     209.7 MB    disk1s1
2:    Apple_HFS OS X Base System     6.5 GB     disk1s2
/dev/disk2 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    GUID_partition_scheme    +2.1 GB    disk2
1:    Apple_HFS OS X Base System     2.0 GB    disk2s1
/dev/disk3 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +5.2 MB    disk3
/dev/disk4 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +524.3 KB    disk4
/dev/disk5 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +524.3 KB    disk5
/dev/disk6 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +524.3 KB    disk6
/dev/disk7 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +524.3 KB    disk7
/dev/disk8 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +524.3 KB    disk8
/dev/disk9 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +6.3 MB    disk9
/dev/disk10 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +2.1 MB    disk10
/dev/disk11 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +1.0 MB    disk11
/dev/disk12 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +524.3 KB    disk12
/dev/disk13 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +524.3 KB    disk13
/dev/disk14 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +1.0 MB    disk14
/dev/disk15 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +6.3 MB    disk15
Et la seconde :
Bloc de code:
[-bash-3.2# diskutil cs list
No CoreStorage logical volume groups found
 
D

Deleted member 1099514

Invité
Oups, pas de disque présent?
Lors du démarrage, as-tu vu un globe tourner?
Sinon que te renvoie dans le terminal :
system_profiler SPHardwareDataType
 
D

Deleted member 1099514

Invité
Tu es sûr que la liste :
diskutil list
est complète ?
Il manque pas le début?
 

thomasp14

Nouveau membre
10 Juillet 2017
7
0
30
Non, je n'ai vu aucun globe tourner ...
Voici le retour du system_profiler :
Bloc de code:
[-bash-3.2# system_profiler SPhardwareDataType
2017-07-10 06:07:29.747 system_profilerr[477:20880] Error loading /System/Library/SystemProfiler/SPDisplayReporter.spreporter: Error Domain=NSCocoaErrorDomain Code=3587 "dlopen_preflight(/System/Library/SystemProfiler/SPDisplayReporter.spreporter/Contents/MacOS/SPDisplaysReporter): Library not loaded: /System/Library/PrivateFrameworks/AmbiantDisplay.framework/Versions/A/AmbiantDisplay
Referenced from: /System/Library/SystemProfiler/SPDisplaysReporter/spreporter/Content/MacOS/SPDisplaysReporter
Reason: image not found" UserInfo={NSLocalizedFailureReason=The bundle is damaged or missiong necessary resources., NSlocalizedRecoverySuggestion=Try reinstalling the bundle., NSFilePath=/System/Library/SystemProfiler/SPDisplayReporter.spreporter/Contents/MacOS/SPDisplaysReporter, NSDebugDescription=dlopen_prelight(/System/Library/SystemProfiler/SPDisplaysReporter.spreporter/Contents/MacOS/SPDisplaysReport): Library not loaded: /System/Library/PrivateFrameworks/AmbientDisplay.framework/Versions/A/AmbientDisplay
Referenced from:/System/Library/SystemProfiler/SPDisplaysReporter/spreporter/Content/MacOS/SPDisplaysReporter
Reason: image not found, NSBundlePath=/System/Library/SystemProfiler/SPDisplaysReporter.spreporter, NSLocalizedDescription=The Bundle "SPDisplaysReporter" couldn't be loaded because it is damaged or missing necessary resources.}
2017-07-10 06:06:31.993 system_profiler[476.20870] Error loading /System/Library/SystemProfiler/SPDisplayReporter.spreporter: Error Domain=NSCocoaErrorDomain Code=3587 Referenced from: /System/Library/SystemProfiler/SPDisplaysReporter/spreporter/Content/MacOS/SPDisplaysReporter
Referenced from: /System/Library/SystemProfiler/SPDisplaysReporter/spreporter/Content/MacOS/SPDisplaysReporter
Reason: image not found" UserInfo={NSLocalizedFailureReason=The bundle is damaged or missiong necessary resources., NSlocalizedRecoverySuggestion=Try reinstalling the bundle., NSFilePath=/System/Library/SystemProfiler/SPDisplayReporter.spreporter/Contents/MacOS/SPDisplaysReporter, NSDebugDescription=dlopen_prelight(/System/Library/SystemProfiler/SPDisplaysReporter.spreporter/Contents/MacOS/SPDisplaysReport): Library not loaded: /System/Library/PrivateFrameworks/AmbientDisplay.framework/Versions/A/AmbientDisplay
Referenced from:/System/Library/SystemProfiler/SPDisplaysReporter/spreporter/Content/MacOS/SPDisplaysReporter
Reason: image not found, NSBundlePath=/System/Library/SystemProfiler/SPDisplaysReporter.spreporter, NSLocalizedDescription=The Bundle "SPDisplaysReporter" couldn't be loaded because it is damaged or missing necessary resources.}
Hardware:

Hardware Overview:

Model Name: iMac
Model Identifier: iMac7,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2 GHz
Number of Procesors: 1
Total Number of Cores: 2
L2 Cache: 4 MB
Memory: 2 GB
Bus Speed: 800 MHz
Boot ROM Version: IM71.007A.B03
SMC Version (system): 1.20f4
Serial Number (system): W8739CH2X85
Hardware UUID: 00000000-0000-1000-8000-001B63A3CB3A

Et je reposte le diskutil list car en effet j'ai mangé le début de la requête :
Bloc de code:
[-bash-3.2# diskutil list
/div/disk0 (internal,physical):
#:    TYPE NAME    SIZE    IDENTIFIER   
0:    GUID_partition_scheme    *250.1 GB    disk0
1:    EFI EFI         209.7 MB    disk0s1
2:    Apple_HFS Mac HD    249.2 GB    disk0s2
1:    Apple_Boot Recovery HD    650.0 MB    disk0s3
/dev/disk1 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    GUID_partition_scheme    +6.8 GB    disk1
1:    EFI EFI     209.7 MB    disk1s1
2:    Apple_HFS OS X Base System     6.5 GB     disk1s2
/dev/disk2 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    GUID_partition_scheme    +2.1 GB    disk2
1:    Apple_HFS OS X Base System     2.0 GB    disk2s1
/dev/disk3 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +5.2 MB    disk3
/dev/disk4 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +524.3 KB    disk4
/dev/disk5 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +524.3 KB    disk5
/dev/disk6 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +524.3 KB    disk6
/dev/disk7 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +524.3 KB    disk7
/dev/disk8 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +524.3 KB    disk8
/dev/disk9 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +6.3 MB    disk9
/dev/disk10 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +2.1 MB    disk10
/dev/disk11 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +1.0 MB    disk11
/dev/disk12 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +524.3 KB    disk12
/dev/disk13 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +524.3 KB    disk13
/dev/disk14 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +1.0 MB    disk14
/dev/disk15 (disk image):
#:    TYPE NAME    SIZE    IDENTIFIER
0:    untitled    +6.3 MB    disk15
 
D

Deleted member 1099514

Invité
Donc c'est un 20" mi-2007

On va tenter de reformater la partition système :
tu vas taper :
diskutil erasevolume jhfs+ "Mac HD" disk0s2
 
Dernière édition par un modérateur:

thomasp14

Nouveau membre
10 Juillet 2017
7
0
30
Il me dit impossible de "démonter" le volume. Je n'arrive plus à booter sur la partition recovery, je bloque sur "Installer OS X". Cela doit jouer dans le fait de ne pas pouvoir unmount le volume.
 
D

Deleted member 1099514

Invité
Tu as les DVD d'origine?
Tente un arrêt électrique puis de démarrer en appuyant sur la touche ALT.
Tu as réussi à formater la partition système?
 

thomasp14

Nouveau membre
10 Juillet 2017
7
0
30
Après avoir booter sur mon CD "OS X Lion", j'accède au terminal et la commande me donne :

Bloc de code:
bash-3.2# diskutil erasevolume jhfs+ "Mac HD" disk0s2
Started erase on disk0s2 Mac HD
Unmounting disk
Error: -69879: Couldn't open disk
 
D

Deleted member 1099514

Invité
J'ai bien peur que ton disque ai pris un coup de chaud.
Tu vas tenter :
diskutil repairdisk disk0
puis
diskutil repairVolume disk0s2
 

thomasp14

Nouveau membre
10 Juillet 2017
7
0
30
Unable to find disk for disk0 ... Et quand je fais diskutil list, mon disk0 n'apparait plus depuis que j'ai fait le erasevolume
 

thomasp14

Nouveau membre
10 Juillet 2017
7
0
30
Je viens de retrouver le disk0.

Voici ce que j'obtiens.
Repairdisk : Unable to repair this whole disk: A writable disk is required (-69772)
Repairvolume : Error strating file system repair for disk0s2: Unrecognized file system (-69846)
 
D

Deleted member 1099514

Invité
J'ai bien peur que ton disque soit HS.

Tu peux quand même tenter la commande du désespoir :
Effacer tout le disque :
diskutil erasedisk jhfs+ "Mac HD" disk0

Si ko, je te conseille, si tu veux continuer à utiliser ta machine, d'investir dans 4 ou 6 go de mémoire (c'est le maxi) et d'acheter un disque SSHD bon compromis pour ce type de machine : https://www.amazon.fr/Seagate-ST1000DX001-Disque-interne-1000/dp/B00ELAVIQ0
Après il faut ouvrir le Mac, mais je pense que ces modèles sont plus faciles à ouvrir que les + récents : https://fr.ifixit.com/Guide/Installation+d'un+SSD+dans+les+iMac+Intel+20-Inch+EMC+2133+et+2210/1008