iTunes ne se lance plus

Joffrey7

Nouveau membre
26 Novembre 2009
7
0
Bonsoir à tous,

Je rencontre actuellement un sacré problème puisque iTunes ne démarre plus.

Je suis sur Snow Leopard. Hier, j'ai fait un nettoyage avec l'application Monolingual pour enlever les architectures powerPC. J'ai l'impression que toutes mes applications fonctionnent sauf iTunes.

Je suis allé dans l'utilitaire de disque pour faire une réparation des permissions, j'ai passé un coup d'Onyx, j'ai aussi désinstallé et réinstallé proprement iTunes, mais rien n'y fait, quand je le lance, l'icone apparait, il "saute", le bouton blanc apparait et tout de suite après l'icône disparait.

J'ai aussi réinstallé Rosetta via le DVD de Snow Leopard mais cela n'a rien changé.

A votre avis, je suis condamné à faire une réinstallation système ?

J'ai fait il y a 3 jours une sauvegarde avec Time machine, est-ce que je peux pas m'en servir pour réparer tout cela ?

D'avance, merci.
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
21 893
3 872
Là-haut
Monolingual est un logiciel malfaisant.

Si tu as retiré les éléments PPC, Rosetta ne te sert plus à rien.

Time Machine => Prendre ton DVD de Snow Leopard et faire une réintégration depuis ta dernière sauvegarde viables.
 

Joffrey7

Nouveau membre
26 Novembre 2009
7
0
Alors je n'y connais quasiment rien au monde mac :p

J'insère mon DVD de SL et j'installe sur l'installation existante ?

Ou je dois faire ça au boot de la machine ?

J'aimerais faire une réinstallation la plus propre possible, est-ce que en installant SL, cela va en quelque sorte "formater" ma partition ?

J'ai également une partition Bootcamp, est-ce que je peux faire tout cela sans y toucher ?

Encore merci.

Edit : Alors j'ai vu la méthode pour faire une installation propre (redémarrage, utilitaire de disque etc...). Je me pose par contre plusieurs questions :

- Si je refais une sauvegarde time machine maintenant, est-ce que je risque d'enregistrer les modifications de l'architecture ou celles-ci vont être réinstallées avec le système ?
- Est-ce qu'une fois l'installation faite, je peux utiliser ma sauvegarde time machine manuellement sans passer par l'utilitaire ? (ce qui me permettra de piocher ce que je veux garder)
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
21 893
3 872
Là-haut
Ben quand on n'y connait pas grand chose, on n'utilise pas des machins comme Monolingual. :D

Tu ne réinstalles pas.

Après le choix de langue, tu vas dans la barre de menu>Utilitaires>Restauration du système depuis la sauvegarde

Tu branches ton disque de sauvegarde Time Machine et tu choisis une sauvegarde que tu sais viable (avant ton passage à Monolingual).


Maintenant, si tu veux faire une réinstallation complète, tu vas dans Utilitaires>Utilitaires de disque et tu effaces le volume Mac OS X de ton Mac. Ensuite tu reviens à la procédure d'installation.
 

Joffrey7

Nouveau membre
26 Novembre 2009
7
0
Merci pour tout, non je n'utiliserai plus jamais Monolingual, c'est promis :D

Je vais faire une réinstallation complète je pense, j'ai édité mon message précédent car j'avais une autre question : "Est-ce qu'une fois l'installation faite, je peux utiliser ma sauvegarde time machine manuellement sans passer par l'utilitaire de migration ? (ce qui me permettra de piocher ce que je veux garder)"
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
21 893
3 872
Là-haut
Merci pour tout, non je n'utiliserai plus jamais Monolingual, c'est promis :D

Je vais faire une réinstallation complète je pense, j'ai édité mon message précédent car j'avais une autre question : "Est-ce qu'une fois l'installation faite, je peux utiliser ma sauvegarde time machine manuellement sans passer par l'utilitaire de migration ? (ce qui me permettra de piocher ce que je veux garder)"
Oui, si tu passes par le Finder.

Attention aux droits, ça peut bloquer dans certains cas.
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 126
625
À côté (de ma plaque)
Quand on restaure son système à partir d'une sauvegarde TM, TM fait habituellement une sauvegarde complète de la partition OS X à la première connexion (et pas une sauvegarde différentielle).

Il est important de le savoir car il est conseillé d'inactiver TM à la première connexion, le temps que Spotlight fasse sa réindexation,
et parce qu'ensuite, on peut Restaurer ce qu'on veut dans ses sauvegardes en passant par l'espace intergalactique de TM.
 

Joffrey7

Nouveau membre
26 Novembre 2009
7
0
Oui j'avais fait attention à désactiver TM à la première connexion !

J'ai donc fait une clean install, tout s'est bien passé, j'ai remis ensuite manuellement toutes mes applications et tout ce que contenait le dossier bibliothèque.

Par contre, chose assez étrange, je me suis amusé à chronométrer le temps de démarrage : Juste après avoir installé SL, il était d'environ 20 secondes, et après remis toutes mes applications et mes documents (et pourtant, j'en ai pas beaucoup), il est passé à 40 secondes.

C'est vrai qu'on s'en fou un peu, mais c'est quand même étrange ! :D

Merci à tous.