Kernel panic au démarrage standard - En "safe boot" OK

A

Anonyme

Invité
Salut,
Je vous écris après avoir enfin réussi à démarrer mon iMac G5 PPC en démarrage sans extensions, appelé aussi le mode "Safe Boot" (touche MAJ enfoncée au boot) car je ne peux plus démarrer en mode standard (ni même booter en standard depuis mon DD externe) : symptôme = Kernel panic systématique au démarrage.
Ca a commencé après les événements suivants :
1) En configuration habituelle, je suis connecté à Internet via Airport + borne Airport Express sur un réseau fermé (masqué pour le voisinage), c'est à dire que je saisis le nom et la clé de protection du réseau à l'ouverture de session.
2) Quand j'ai voulu saisir mon nom de réseau et la clé, j'ai reçu un message disant que le réseau ne supportait pas ce type de chiffrement (dans mon cas, du WPA2 personnel). Je suis sûr à 200% de mon mot de passe et j'ai refait plusieurs tentatives mais toujours la même punition.
3) J'ai fini par un redémarrage de ma session et c'est là que que les ennuis du démarrage standard ont commencé avec apparition systématique du Kernel panic au démarrage.
4) Le seul mode de démarrage que j'ai réussi est le démarrage sans les extensions et ça m'a permis de contrôler quelques petites choses :
  • J'ai réparé les autorisations => OK
  • J'ai vérifié mon HD interne et mon DD externe avec utilitaire de disque => OK
  • La carte Airport n'est pas reconnue (ni dans Informations Système ni dans Préférences Système, partie Réseau) mais c'est normal puisque je suis en "safe boot".
5) Entre 2 démarrages (sans extensions), j'ai réussi (?) un démarrage standard qui m'a permis de retrouver momentanément la carte Airport MAIS elle s'obstine à ne pas voir ma borne AE ni les réseaux sans fil du voisinage (que je vois toujours d'habitude).
6) J'en ai aussi profité pour contrôler, dans les Prefs Système Réseau, ma configuration réseau pour Airport et les paramètres de mon réseau sans fil enregistré dans la liste des réseaux préférés et là encore, bizarre, j'ai découvert que ma clé de protection WPA2 personnel n'avait plus la même valeur que mon mot de passe habituel. A la place, j'avais une valeur qui ressemble étrangement à une adresse mac de carte ou de borne Airport avec des chiffres en plus (??).
7) Après avoir supprimé cette entrée de ma liste des réseaux préférés, j'ai retenté une connexion à mon réseau sans fil mais, toujours le même refus sur le type de chiffrement qui ne serait pas supporté et disparition de la carte Airport dans les Infos Système et les Préfs Réseau.
8) Depuis (j'en suis au 3ème jour), Kernel Panic au démarrage systématique.
9) J'ai lancé, depuis mon CD d'installation, un Apple Test Hardware et tous les contrôles (y compris celui de la carte Airport) ont été réussis.

J'aurais donc tendance à dire qu'il ne s'agit pas d'un pb. matériel mais plutôt logiciel et, par rapport à la chronologie des événements, que ça se passe au niveau de la carte Airport.
Malgré tout je ne suis sûr de rien et surtout très embarassé car je ne sais pas du tout par quel bout prendre le problème. On me suggère de réinstaller OS X mais, avant d'en arriver là, je me dis qu'il y a peut-être quelque chose à faire de plus spécifique et de moins radical.

Si quelqu'un(e) a une idée ou un bon conseil, bienvenu :)
@+
 

Modern__Thing

HRM the Queen of Kekeland
Club MacG
pour info, l'Apple Hardware test n'est pas la bible, quand il detecte un probleme il est bel et bien la mais quand il ne le detecte pas, ca ne veut rien dire...

Ce que tu peux toujours faire pour bien isoler ton probleme c'est tenter PRAM + NVRAM, et ensuite si tjrs pareil, reinstaller completement le systeme, si toujours meme probleme apres avec la carte AirPort, c'est bel et bien hardware...
 
A

Anonyme

Invité
pour info, l'Apple Hardware test n'est pas la bible, quand il detecte un probleme il est bel et bien la mais quand il ne le detecte pas, ca ne veut rien dire...

Ce que tu peux toujours faire pour bien isoler ton probleme c'est tenter PRAM + NVRAM, et ensuite si tjrs pareil, reinstaller completement le systeme, si toujours meme probleme apres avec la carte AirPort, c'est bel et bien hardware...

Merci pour ta réponse.
Effectivement mon Apple center m'a fait la même remarque sur le AHT.
Je ne connais pas PRAM et NVRAM. Qu'est-ce que c'est censé faire ?
Je m'apprête à réinstaller OS X à partir de mon CD d'install (avec l'option "archiver et installer" ou quelque chose comme ça) afin de valider, comme tu le dis, s'il s'agit d'un problème logiciel ou matériel.
Un grand merci pour ton éclairage :)
 

Camille LaPomette

Membre junior
23 Janvier 2007
26
2
Le problème de mon mac est qu'il ne fonctionne qu'en SAFE MODE, sinonmon écran gèle à la fenêtre d'ouverture ou peu de temps après...

Le Forum fournit dans "À lire impérativement avant de poster", plusieurs lien d'aide et de conseils par rapport aux résolutions de problèmes, aux applications, à l'entretien, etc.
Voici le lien:

http://forums.macg.co/vbulletin/showthread.php?t=129383

Et j'ai trouvé plusieurs conseils dans "sauver mon mac pas à pas", ça m'a beaucoup aidé à comprendre le problème de mon ordi, alors si ça peut t'aider.
Voici le lien:

http://forums.macg.co/vbulletin/showpost.php?p=643322

Bonn' Chan'
oukidouki chiaouw!!
 
A

Anonyme

Invité
Le problème de mon mac est qu'il ne fonctionne qu'en SAFE MODE, sinonmon écran gèle à la fenêtre d'ouverture ou peu de temps après...

Le Forum fournit dans "À lire impérativement avant de poster", plusieurs lien d'aide et de conseils par rapport aux résolutions de problèmes, aux applications, à l'entretien, etc.
Voici le lien:

http://forums.macg.co/vbulletin/showthread.php?t=129383

Et j'ai trouvé plusieurs conseils dans "sauver mon mac pas à pas", ça m'a beaucoup aidé à comprendre le problème de mon ordi, alors si ça peut t'aider.
Voici le lien:

http://forums.macg.co/vbulletin/showpost.php?p=643322

Bonn' Chan'
oukidouki chiaouw!!

Merci pour cette mine de bonnes infos. J'en connaissais un certain nombre mais très loin encore d'en avoir fait le tour.
Il y a quelques temps, j'ai procédé à une clean install depuis les CD d'install (OS 10.4) sur mon DD externe. A l'arrivée, au reboot automatique qui se lance à la fin de l'install du CD n° 1, le Kernel Panic se reproduit :( . Ma conclusion : ce n'est pas un problème système mais un problème matériel et, étant donné que ça persiste après avoir débranché tous les périphériques (sauf clavier et souris), j'ai tendance à croire que ça se situe au niveau du HD interne, ou de la carte Airport ou, pourquoi pas, de la carte mère elle-même (?).
Mon Apple center pense à peu près la même chose et ils m'attendent avec ma machine pour un diagnostic plus précis. J'y vais prochainement...avec mon Apple Care dans la poche ;) car le mode "safe boot", bien que très pratique en situation de dépannage, limite énormément la machine.
Merci encore pour ta contribution :)
 

Camille LaPomette

Membre junior
23 Janvier 2007
26
2
Merci pour cette mine de bonnes infos. J'en connaissais un certain nombre mais très loin encore d'en avoir fait le tour.
Il y a quelques temps, j'ai procédé à une clean install depuis les CD d'install (OS 10.4) sur mon DD externe. A l'arrivée, au reboot automatique qui se lance à la fin de l'install du CD n° 1, le Kernel Panic se reproduit :( . Ma conclusion : ce n'est pas un problème système mais un problème matériel et, étant donné que ça persiste après avoir débranché tous les périphériques (sauf clavier et souris), j'ai tendance à croire que ça se situe au niveau du HD interne, ou de la carte Airport ou, pourquoi pas, de la carte mère elle-même (?).
Mon Apple center pense à peu près la même chose et ils m'attendent avec ma machine pour un diagnostic plus précis. J'y vais prochainement...avec mon Apple Care dans la poche ;) car le mode "safe boot", bien que très pratique en situation de dépannage, limite énormément la machine.
Merci encore pour ta contribution :)

C'est un plaisir..Je n'ai pas pu utiliser ma MAChine depuis le mois de septembre ..et maintenant que je suis en safe mode, je ppeux au moins fouiller un peu partout sur internet et dans mon mac pour trouver le problème...J'en suis fort heureuse, meme si, comme tu dis, on ne peut pas écouter de la musique, regarder des vidéos, utiliser les ports usb et certaines applics..mais bon! j'peux lire des BD!!! :up:

j'espère que le apple center te coutera pas trop cher!
 
A

Anonyme

Invité
Y'a t'il du nouveau de ton côté??
Oui, effectivement. Le problème a été réglé par mon Apple Center en février. Il y avait 2 causes : 1) Carte Airport extrême sortie de son logement 2) Un connecteur (?) défaillant sur la carte mère à cause d'une vis microscopique sortie elle aussi de son pas. Donc, rien de "système" mais que du "hardware"
Tout a été remis en place ou changé à neuf...heureusement sous garantie AppleCare.
Et depuis, la vie est plus belle :)
 

Camille LaPomette

Membre junior
23 Janvier 2007
26
2
Oui, effectivement. Le problème a été réglé par mon Apple Center en février. Il y avait 2 causes : 1) Carte Airport extrême sortie de son logement 2) Un connecteur (?) défaillant sur la carte mère à cause d'une vis microscopique sortie elle aussi de son pas. Donc, rien de "système" mais que du "hardware"
Tout a été remis en place ou changé à neuf...heureusement sous garantie AppleCare.
Et depuis, la vie est plus belle :)

Oh! c'est super encourageant! Yai!! chuis contente pour toi! espèront que ce soit la même chose pour moi hihi!
 
A

Anonyme

Invité
Oh! c'est super encourageant! Yai!! chuis contente pour toi! espèront que ce soit la même chose pour moi hihi!

Salut,
As-tu toujours les problèmes que tu décrivais il y a quelques mois ?
Es-tu toujours en mode "safe boot" ?
Est-ce que tu as pris contact avec un centre Apple agréé ? Quand on pense avoir fait le tour de la question et que le problème n'est toujours pas réglé, le mieux est de passer par les "professionnels" ;)
A+