Mac Pro Le Mac Pro ne fonctionne plus...

Nevcam

Membre confirmé
12 Novembre 2016
141
8
32
Bonjour,

Ce matin, comme tous les jours sans changements particuliers la veille, j'ai démarré mon Mac Pro début 2009 sous Mojave 10.14.6 pour travailler. Sauf qu'aucun affichage n'est apparu à l'écran : écran noir. J'ai donc :

- Changer le câble reliant la tour à l'écran.
- Changer de moniteur
- Rebranché la carte graphique
- Changé la carte graphique
-->> Rien a changé : écran noir. Pourtant le Mac Pro est toujours bien allumé (je ne sais pas si la session est ouverte ou non).

J'ai donc tout remis à l'origine et j'ai démarré en mode récupération. Là, enfin, tout fonctionne bien. Je vois le mode récupération sur l'écran. Je réinstalle donc Mojave pensant à un problème système. Tout se passe normalement jusqu'à ce qu'il redémarre une fois l'installation fini -->> écran noir, plus d'affichage.
Je suis donc retourné en mode récupération et j'ai décidé d'utiliser l'utilitaire de disque afin de procéder à un S.O.S, détecter une erreur sur le disque et la réparer. Mais il m'affiche ça :

IMG_4738 copie.jpg


Je ne comprends pas pourquoi...
Je décide donc de formater le disque SSD et de réinstaller Mojave en partant de 0. Mais au cours de l'installation il m'a mit ça après :

IMG_4737 copie.jpg


Voilà ces 2 messages dépassent mes compétences, je ne vois pas ce que ça signifie (le disque SSD est endommagé ? Mal branché ? Il faut le remplacer ?). Tout est bloqué quoi que je fasse, je ne peux donc plus utiliser l'ordinateur.

Merci d'avance si vous avez une idée de ce qu'il se passe dans cette machine ;)
 

Lil Montréal

Membre confirmé
14 Juin 2019
457
213
67
Hello,

Bon en attendant d'y voir plus clair, et pour pouvoir redémarrer, n'as-tu pas un disque sur une des 4 baies SATA sur lequel tu puisses réinstaller un système car je suppose que tu n'as de clone bootable.

Amitiés
 
  • J’aime
Réactions: Nevcam

sifoto

Membre confirmé
2 Février 2019
315
464
sifoto.wixsite.com
Sur mon Mac Pro 2006 j'ai eu à un moment un problème d'écran noir, c'était la ram qui déconnait, après un bon nettoyage c'est reparti et depuis plus de soucis, du coup dommage de ne pas avoir testé avant de formater d'autant qu'il me semble qu'il faut une bidouille pour installer Mojave sur le Mac Pro début 2009. Peut-être devrais-tu essayer d'installer El Capitan qui lui est compatible à l'origine pour voir si ça fonctionne.
 
  • J’aime
Réactions: Accrok et Nevcam

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
79 036
24 174
Forêt de Fontainebleau
Bonjour Nevcam (& Sifoto & Sly)

Pour ce qui est du 1er message (le volume Macintosh HD n'a pas pu être démonté) -->

- il n'y a pas d'interprétation unilatérale. Le volume n'est manifestement pas démarré > mais il peut se faire qu'un service de l'OS de secours démarré --> utilise un répertoire du volume et hop ! le volume échoue à être démonté.​

Pour ce qui est du 2è message ("Impossible de créer un volume de prédémarrage pour l'installation de l'apfs") -->

- il s'agit d'un cas de figure qui a été popularisé par l'OS High Sierra. Le sens est le suivant : un volume de démarrage apfs (comme Macintosh HD) est membre d'un Conteneur en compagnie de 3 autres volumes auxiliaires (Preboot de prédémarrage > Recovery de secours > VM d'archivage de la RAM). Ces volumes ne sont bien évidemment pas montrés par l'Utilitaire de disque > ce qui fait croire à l'utilisateur à l'unicité du volume Macintosh HD. Et donc que reformater Macintosh HD suffit pour préparer une réinstallation.​

- or reformater Macintosh HD ne supprime pas les 3 volumes auxiliaires du Conteneur apfs, dont le volume de prédémarrage Preboot. Ce qui s'avère bloquant pour le programme d'installation > lequel commence par créer les 2 volumes auxiliaires Preboot & Recovery en préambule de la réinstallation. Ce blocage ridicule (lequel a tout d'un bogue de programmation) > qui a pesamment handicapé les utilisateurs de High Sierra => récidive ici à la réinstallation de Mojave : voilà qui m'étonne > car je me figurais ce bogue corrigé (en n'en entendant plus parler).​

=> en résumé : il faut supprimer l'apfs entier avant réinstallation.

----------

@ Nevcam

Voici comment tu vas pouvoir fournir ici les informations de base (tuto) -->

- aucune option de la fenêtre des 4 Utilitaires macOS lancée (comme l'option : "Réinstaller macOS" ou l'Utilitaire de disque) => va à la barre de menus supérieure de l'écran > menu : Utilitaires > sous-menu : Terminal.​

Dans la fenêtre ouverte > saisis la commande informative (ce qui est inscrit sous Bloc de code) :
Bloc de code:
diskutil list internal
et ↩︎ (presse la touche "Entrée" du clavier pour exécuter la commande)

  • tu vas voir s'afficher la configuration du disque interne seule

Voici comment tu vas pouvoir poster ici ce tableau sans avoir besoin de prendre de photo -->

  • tu sélectionnes le tableau > ⌘C pour le copier dans le presse-papier > ⌘Q pour quitter le «Terminal» > option  : "Obtenir de l'aide en ligne" (dans la fenêtre des 4 Utilitaires) > ce qui lance un navigateur «Safari»
  • page Apple par défaut > un clic sur l'adresse de haut de page pour l'éditer > saisis  : macgénération (tout court  : c'est une barre de recherche Google) et valide > tu atteins le site MacGé > Forums > te connectes > ce fil
  • utilise le menu ...▾ (à droite de la bobine souriante) dans la barre de menus au-dessus du champ de saisie d'un message > sous-menu : </> Bloc de code => tu fais ton coller dans la fenêtre de code et Continuer.

=> ces informations montreront la configuration logique de ton disque.

Note 1 : si tu ne peux pas poster via le Safari de la session de secours (ça arrive) --> poste une photo du tableau (à partir du commencement = le disque /dev/disk0 ou disque physique interne) - tu as un bouton : "Joindre un fichier" en bas de cette page.

Note 2 : dans la session de secours > les applications se lancent en mode "alternatif" et pas parallèle. Il faut quitter le Terminal pour lancer Safari. Vice-versa > quitter Safari pour récupérer l'écran général de la session de secours et pouvoir relancer le Terminal. Aucun redémarrage n'est requis.
 

Nevcam

Membre confirmé
12 Novembre 2016
141
8
32
Merci beaucoup pour votre aide et votre réactivité !!

@sifoto J'ai bien effectué la manip pour avoir Mojave sur ce Mac Pro en amont, pas de soucis à ce niveau-là. Cependant effectivement je tiens à signaler qu'un slot de RAM est défaillant suite à un choc dû au transport. Mais tout fonctionnait bien malgré ça pendant 2 ans jusqu'ici. J'ai dépoussiéré à plusieurs reprises l'intérieur de la tour.

@macomaniac J'aurais tellement aimé faire cette manip pour avancer et en savoir plus sur le disque dur mais toujours sans aucunes raisons aujourd'hui je n'arrive même plus à accéder au mode récupération. Je maintiens ⌘R au démarrage comme avant en attendant jusqu'à 10min mais rien ne se produit, écran noir. J'ai essayé 4 fois de suite.

Y-a-t-il autre chose à tenter selon vous ? Sinon lundi je contacte un réparateur sur place et je l'emmène pour diagnostic...
A 1ère vue il me semble qu'en changeant le Macintosh SSD, le problème devrait se résoudre sinon non ?
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
47 725
8 549
Nancy___
- or reformater Macintosh HD ne supprime pas les 3 volumes auxiliaires du Conteneur apfs, dont le volume de prédémarrage Preboot. Ce qui s'avère bloquant pour le programme d'installation > lequel commence par créer les 2 volumes auxiliaires Preboot & Recovery en préambule de la réinstallation. Ce blocage ridicule (lequel a tout d'un bogue de programmation) > qui a pesamment handicapé les utilisateurs de High Sierra => récidive ici à la réinstallation de Mojave : voilà qui m'étonne > car je me figurais ce bogue corrigé (en n'en entendant plus parler).

=> en résumé : il faut supprimer l'apfs entier avant réinstallation
Du coup, si l'on a déjà installé Catalina et que l'on veut reformater son disque, est-on obligé de passer par le Terminal ? On ne peut rien faire en passant par l'Utilitaire de disques ?
(c'est ce que je crois comprendre quand tu écris que reformater Macintosh HD ne suffit pas)
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
79 036
24 174
Forêt de Fontainebleau
@ Sly

Le démarrage de secours de Mojave aussi bien que de Catalina est spécial -->

- au lieu de faire démarrer sur l'OS de secours contenu dans le volume Recovery du Conteneur apfs (ce qui interdirait ipso facto de faire table rase de l'apfs entier avec son Conteneur depuis un démarrage sur un de ses volumes apfs) --> il s'effectue un clonage en RAM de l'image-disque contenant l'OS de secours > suivi d'un démarrage sur l'OS de secours cloné en RAM. De manière analogue à ce qui se passe quand on démarre par internet > où une image-disque contenant un OS de secours se trouve téléchargée en RAM.​

- conséquence : il est donc possible après démarrage de secours via ⌘R --> sur un clone d'OS de secours en RAM => de supprimer l'apfs interne avant réinstallation. Ce que permet une commande du terminal (que je privilégie parce qu'il est possible dans une conversation d'entre-aide => de savoir exactement quelle action va faire l'intéressé et d'enregistrer explicitement ses résultats). Mais il est possible aussi dans l'Utilitaire de disque d'effectuer la même chose ...​

- ... à condition de démasquer au préalable dedit Conteneur apfs. Car il est masqué par défaut > seul le volume de démarrage se trouvant affiché. Il faut donc dans l'angle supérieur gauche du panneau --> presser le pastille : "Présentation" et sélectionner l'option : "Afficher tous les appareils" => pour que le Conteneur soit affiché et puisse être sélectionné pour se trouver effacé. Avec l'option de format apfs => on recrée un nouvel apfs avec son Conteneur et un volume unique réinstallable. Avec l'option jhfs+ => on supprime le Conteneur avec reformatage d'un volume standard réinstallable (mais pas par Catalina qui requiert un volume apfs).​

En résumé : ce genre d'embrouilles graphiques me font privilégier la clarté explicite du terminal.
 
  • J’aime
Réactions: Sly54 et Nevcam

sifoto

Membre confirmé
2 Février 2019
315
464
sifoto.wixsite.com
En résumé : ce genre d'embrouilles graphiques me font privilégier la clarté explicite du terminal.

Malheureusement, il n'a plus d'affichage écran pour pouvoir avoir accès au terminal et suivre tes instructions. Pour moi, il y a des "chances" qu'il y ait un problème avec la ram, peut être faudrait-il enlever la moitié des barrettes installées et essayer ensuite plusieurs combinaison afin de trouver celle qui pourrait-être défectueuse et causer la panne, qu'en penses-tu @macomaniac ?
 
Dernière édition:
  • J’aime
Réactions: Nevcam

Nevcam

Membre confirmé
12 Novembre 2016
141
8
32
@Sly54 J'ai essayé avec ces différentes touches enfoncées et j'ai également essayé avec la touche "Alt" enfoncée afin d'essayer de changer de disque de démarrage mais toujours aucun résultat.

Effectivement le Mac Pro, abîmé pendant le transport, a un slot de RAM qui ne fonctionne plus. A l'époque lorsque j'avais laissé la barrette de RAM dans le slot dysfonctionnel j'ai eu 2 ou 3 fois écran noir au démarrage en effet. Une fois enlevée plus de soucis à ce niveau-là.
Malgré tout, suite à la proposition de @sifoto j'ai essayé d'enlever toutes les barrettes de RAM adjacentes au slot dysfonctionnant puis de ne laisser qu'une seule barrette de 4Go, j'ai réessayé les combinaisons de démarrage avec ces 2 options mais toujours aucun affichage à l'écran.

Je pense qu'il faudrait que je puisse démarrer le système à partir d'un autre disque (avec El Capitan dessus dans le doute comme ça pas de problème de compatibilité). Je garde cette impression que le SSD est corrompu. Mais n'ayant aucun affichage je vois pas comment faire plus...
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
47 725
8 549
Nancy___
@ Sly

- ... à condition de démasquer au préalable dedit Conteneur apfs. Car il est masqué par défaut > seul le volume de démarrage se trouvant affiché. Il faut donc dans l'angle supérieur gauche du panneau --> presser le pastille : "Présentation" et sélectionner l'option : "Afficher tous les appareils" => pour que le Conteneur soit affiché et puisse être sélectionné pour se trouver effacé. Avec l'option de format apfs => on recrée un nouvel apfs avec son Conteneur et un volume unique réinstallable. Avec l'option jhfs+ => on supprime le Conteneur avec reformatage d'un volume standard réinstallable (mais pas par Catalina qui requiert un volume apfs).
ach so, maintenant je comprends mieux, merci !
Pas cool de la part d'Apple de masquer à ce point les choses.
 

Nevcam

Membre confirmé
12 Novembre 2016
141
8
32
Bonjour,

Un petit point sur l'évolution du problème. Ne pouvant plus rien faire j'ai donc finalement dû déposer le Mac Pro chez un réparateur. Celui-ci a pu le rebooter en passant par une installation sur un disque externe et en ayant changé auparavant toutes les barrettes de RAM (avant de remettre celles d'origine). Le problème viendrait donc effectivement de la RAM défaillante suite au choc subit pendant le transport 2 ans auparavant.

Suite à ça plusieurs interrogations me viennent :

1. Je me souviens qu'il est arrivé 2 ou 3 fois que le Mac Pro ne m'affiche rien au démarrage non plus lorsque que j'avais laissé la barrette de RAM dans le slot défaillant. J'avais fini par enlever la barrette et ça avait ensuite très bien fonctionné jusqu'à aujourd'hui. J'avais également constaté que le Mac Pro ne voulait rien m'afficher non plus suite à une suspension d'activité, obligé de redémarrer la machine. Tout ça sera donc dû à la RAM défaillante ? Ça s'explique ?

2. Deux jours avant que le Mac Pro ne veuille plus rien m'afficher j'avais programmé un démarrage automatique quotidien (qui a très bien fonctionner le lendemain). Si on prend en compte tout ça, pensez-vous que ce serait ça qui soit définitivement mal passé le surlendemain et qui a fait que l'ordinateur finisse par ne plus rien afficher du tout ? Si c'est lié du coup j'éviterai cette programmation la prochaine fois si l'ordinateur reste stable sans ça.

3. A terme le mieux serait de changer la baie RAM+processeur non ?

Merci encore d'avance pour votre aide :)
 

Y_E_S

Membre confirmé
20 Juillet 2008
279
27
Paris
1) C'est fort possible mais impossible à déterminer. Au moins tu as identifié une cause très probable aux dysfonctionnements...
2) Rien à voir, c'est certain, et heureusement car avec de tels bugs il y a longtemps qu'une telle fonction n'existerait plus.
On retourne à la cause probable du 1...
3) Pourquoi s'il y a juste la ram à changer? (Et encore probablement pas toutes tes barrettes...) Je n'ai pas vu ton quel est ton proc, mais au pire un upgrade de proc et voilà. C'est bien moins cher qu'un changement complet de carte fille.
 
  • J’aime
Réactions: Nevcam

Nevcam

Membre confirmé
12 Novembre 2016
141
8
32
1) C'est fort possible mais impossible à déterminer. Au moins tu as identifié une cause très probable aux dysfonctionnements...
2) Rien à voir, c'est certain, et heureusement car avec de tels bugs il y a longtemps qu'une telle fonction n'existerait plus.
On retourne à la cause probable du 1...
3) Pourquoi s'il y a juste la ram à changer? (Et encore probablement pas toutes tes barrettes...) Je n'ai pas vu ton quel est ton proc, mais au pire un upgrade de proc et voilà. C'est bien moins cher qu'un changement complet de carte fille.

Merci de ta réponse :)

D’accord, en fait ce que je voulais dire c’est que comme la RAM est défaillante sur ce Mac Pro et qu’elle a dû avoir un lien avec l’écran noir au démarrage et en retour de suspension d’activité, le démarrage automatique pourrait en être affecté aussi sauf que je n’ai jamais pu retrouver d’affichage ensuite là. Je ne parlais pas d’un simple bug sur cette fonctionnalité.
En fait que le problème mentionné en 1 se déclenche à cause de ce que je parle dans le 2.

Ça me semblait plus simple à réparer moi-même puisqu’il y a des baies d’occasion sur le net et il suffirait juste de l’insérer dans la tour. Plutôt que de changer des composants, opérations plus coûteuses et délicates nécessitant du matériel et un professionnel.

Je ne comprends pas pourquoi un upgrade de processeur résoudrait le problème du coup ? Puisqu’il semblerait que cela vienne de la RAM.
 

Y_E_S

Membre confirmé
20 Juillet 2008
279
27
Paris
Merci de ta réponse :)

D’accord, en fait ce que je voulais dire c’est que comme la RAM est défaillante sur ce Mac Pro et qu’elle a dû avoir un lien avec l’écran noir au démarrage et en retour de suspension d’activité, le démarrage automatique pourrait en être affecté aussi sauf que je n’ai jamais pu retrouver d’affichage ensuite là. Je ne parlais pas d’un simple bug sur cette fonctionnalité.
En fait que le problème mentionné en 1 se déclenche à cause de ce que je parle dans le 2.

Ça me semblait plus simple à réparer moi-même puisqu’il y a des baies d’occasion sur le net et il suffirait juste de l’insérer dans la tour. Plutôt que de changer des composants, opérations plus coûteuses et délicates nécessitant du matériel et un professionnel.

Je ne comprends pas pourquoi un upgrade de processeur résoudrait le problème du coup ? Puisqu’il semblerait que cela vienne de la RAM.



Je parlais d'un upgrade proc car je ne comprends pas pourquoi tu envisages de changer la carte fille de ton mac juste à cause d'un problème de ram...
Si ce sont les barrettes de ram qui posent problème, pourquoi changer la baie complète alors que tout est fonctionnel?

Si je parlais d'un upgrade proc c'était au cas où tu souhaites faire évoluer ta machine, un upgrade de proc coûtant bien moins cher qu'une baie complète ;)

Commence par identifier la barrette défectueuse, et remplace là et tout va refonctionner normalement à priori...
 

Nevcam

Membre confirmé
12 Novembre 2016
141
8
32
Je parlais d'un upgrade proc car je ne comprends pas pourquoi tu envisages de changer la carte fille de ton mac juste à cause d'un problème de ram...
Si ce sont les barrettes de ram qui posent problème, pourquoi changer la baie complète alors que tout est fonctionnel?

Si je parlais d'un upgrade proc c'était au cas où tu souhaites faire évoluer ta machine, un upgrade de proc coûtant bien moins cher qu'une baie complète ;)

Commence par identifier la barrette défectueuse, et remplace là et tout va refonctionner normalement à priori...

D'accord je vois ! Car comme je disais il me semblait plus simple de juste retirer la baie et de la remplacer. Car je ne pense pas que les barrettes soient le soucis mais plutôt le slot/les composants qui sont défaillants (le slot ne détecte pas d'autres barrettes non plus). Et là je vois pas comment le changer tout seul sans l'aide d'un pro.
Au niveau du processeur j'ai 2x3,06 GHz 6-Core Intel Xeon, l'upgrade n'était pas prévu au programme mais merci du conseil :)
 

Nevcam

Membre confirmé
12 Novembre 2016
141
8
32
J'ai donc récupéré le Mac Pro qui s'allume maintenant. Mais un autre problème survient, forcément. Il ne veut pas m'autoriser à installer Catalina maintenant et je comprends pas du tout pourquoi... :

Capture d’écran 2020-01-09 à 14.19.01.png


J'ai donc trouvé l'installateur ailleurs qu'en passant par le Mac App Store mais les disques sont grisés :

Capture d’écran 2020-01-10 à 10.42.22.png


Je n'ai pas d'avantage d'explications de la part du système, c'est assez étrange.

Je ne sais pas si je fais bien de poster ça ici du coup où si ça fait l'objet d'un nouveau sujet ? A moi tout seul je vais alimenter les forums MacG pour l'année là à ce rythme hahaa :D