Leopard : Disparition d'applications !

Chamyky

Membre d’élite
Club MacG
11 Mars 2005
1 274
39
28
ehv.monespace.net
Damned ! J'ai installé Leoapard Mercredi, et là, aujourd'hui, toutes les applications Apple du dossier Application on disparues. Envolées ! Je ne peux plu lancer Safari, etc. Impossible d'utiliser Spotlight qui ne fonctionne plus depuis hier/avant-hier pour les retrouver...



Dans le dossier application reste (j'installe généralement mes applis dans un second dossier, sauf si je ne peux pas) des applis comme Fusion, ... et il y a encore les prefs Système ! En revanche
le dossier Utilitaires aussi est vide.
Je remarque également l'absence de Snapz X Pro... je me demande combien d'applications ont réellement sauté.

Précision, j'ai macFuse, et au démarrage il me fait un bref message, "Operating System Too Old". Je suis parti pour le désinstaller, pour ça j'ai copier Terminal.app d'un autre ordi sous Leopard.

Si quelqu'un a une quelqu'un idée supplémentaire...

Edit: Après désinstallation de MacFuse et redémarrage, Spotlight se met à indexer. Après désinstallation de NTFS-3G et redémarrage, ma partition Windows apparaît désormais sur le Bureau.
Je vais maintenant essayer de lancer Safari pris d'un autre ordi.

Edit2 : En tous cas, Aperçu marche. Safari est long à copier... je remarque que sur le CD, il n'y a pas toutes les applications (il manque PhotoBooth). Quelqu'un saurait-il où les récupérer ?

Edit3 : Spotlight et Safari fonctionnent… je pense qu'il ne me reste plus qu'à transférer toutes les applications.
À mon avis, mon problème venait de MacFuse/NTF-3G…
 

marcelpahud

Membre confirmé
4 Décembre 2007
359
75
Sur le planché des vaches...
Je viens d'avoir un problème semblable... mais seules quelques applications ont disparu comme toute ma suite Adobe ou le carnet d'adresse par exemple... trop bizarre... j'installais une nightly build de Camino en la glissant simplement dans applications et là, tout d'un coup, il a fait des trucs bizarres et je me suis rendu comptes que l'OS avait supprimé plusieurs applications... je soupçonne Caminoknight d'en être le responsable... bizarre... bon heureusement aucune donnée de perdue...

Et comme l'a dit Chamyky, toutes les applications ne se trouvent pas forcément sur le disque... qqn aurait le carnet d'adresse quelque part ??

Edit: je l'ai trouvé dans les "optionals" sur le disque du gros chat ;)
pfiou... ai eu peur, mais ça va mieux :)
 

marcelpahud

Membre confirmé
4 Décembre 2007
359
75
Sur le planché des vaches...
Bon, finalement plus de problèmes que dit précédemment...

La plupart des applications Apple refusent de ce lancer pour la raison suivante (copie du rapport lors de l'exécution de mail) :

Process: Mail [466]
Path: /Applications/Mail.app/Contents/MacOS/Mail
Identifier: com.apple.mail
Version: ??? (???)
Build Info: Mail-9190000~3
Code Type: X86 (Native)
Parent Process: launchd [107]

Date/Time: 2008-02-20 18:09:15.394 +0100
OS Version: Mac OS X 10.5.2 (9C31)
Report Version: 6

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0

Dyld Error Message:
Library not loaded: /System/Library/PrivateFrameworks/GraphicsAppSupport.framework/Versions/A/Frameworks/ImageKit.framework/Versions/A/ImageKit
Referenced from: /System/Library/PrivateFrameworks/iLifeMediaBrowser.framework/Versions/A/iLifeMediaBrowser
Reason: image not found

J'ai l'impression que ces lignes à la fin sont importantes dans la mesure où le dossier "PrivateFrameworks" n'existe nulle part sur mon macbook...
 

marcelpahud

Membre confirmé
4 Décembre 2007
359
75
Sur le planché des vaches...
Morale : toujours bien faire ses mises à jour :D !

Tellement ;)

Autre remarque à ce propos, en réinstallant, la suite Adobe, j'ai remarqué qu'en fait le programme d'installation reconnaissait les applications comme encore installées alors qu'elles étaient plus du tout dans le dossier Applications... Naturellement toutes mes préférences ont été conservées...

Moi y'en a pas comprendre grand chose... mais bon ce soir mon macbook a la même tronche qu'à midi, c'est l'essentiel ;)
 

Chamyky

Membre d’élite
Club MacG
11 Mars 2005
1 274
39
28
ehv.monespace.net
Tellement ;)

Autre remarque à ce propos, en réinstallant, la suite Adobe, j'ai remarqué qu'en fait le programme d'installation reconnaissait les applications comme encore installées alors qu'elles étaient plus du tout dans le dossier Applications... Naturellement toutes mes préférences ont été conservées...

Moi y'en a pas comprendre grand chose... mais bon ce soir mon macbook a la même tronche qu'à midi, c'est l'essentiel ;)

Quand un programme d'installation installe une application, il met un paquet dans le dossier "Receipts" de la bibliothèque. Si il trouve ce .pkg présent au moment de l'installation, il croit l'application encore installée.
 

schwipps

Membre junior
20 Septembre 2009
26
2
Même problème Marcel : toute ma suite Adobe a fait pshit, sans prévenir, plus quelques autres apps, dont Garage Band. Cool ! Il a 1 mois, le Mac, ça marche du feu de Dieu !!

J'ai réinstallé tout ce qui me manquait, plus de peur que de mal, mais c'est le genre de trucs qui a le don de m'énerver. J'aurais fait quoi si c'était mes données ?! Je crois que je vais sincèrement me pencher sur Time Machine :nailbiting: