macOS Big Sur Macintosh HD introuvable sur l'utilitaire de disque

hugs13

Membre confirmé
30 Août 2021
79
1
22
Je vais réessayer mais il me semble avoir tout mis et je n'ai rien modifié sur mon DDE.

Le voilà, sûrement une mauvaise manip de ma part :
Bloc de code:
diskutil list

/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *121.3 GB   disk0
   1:                        EFI ⁨EFI⁩                     314.6 MB   disk0s1
   2:                 Apple_APFS ⁨Container disk2⁩         121.0 GB   disk0s2

/dev/disk1 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        +1.8 GB     disk1
   1:                 Apple_APFS ⁨Container disk3⁩         1.8 GB     disk1s1

/dev/disk2 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +121.0 GB   disk2
                                 Physical Store disk0s2
   1:                APFS Volume ⁨Macintosh HD - Données⁩  86.7 GB    disk2s1
   2:                APFS Volume ⁨Macintosh HD⁩            15.3 GB    disk2s2
   3:                APFS Volume ⁨Preboot⁩                 283.6 MB   disk2s3
   4:                APFS Volume ⁨Recovery⁩                626.2 MB   disk2s4
   5:                APFS Volume ⁨VM⁩                      1.1 GB     disk2s5

/dev/disk3 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +1.8 GB     disk3
                                 Physical Store disk1s1
   1:                APFS Volume ⁨macOS Base System⁩       1.6 GB     disk3s1
   2:                APFS Volume ⁨Preboot⁩                 77.8 MB    disk3s2

/dev/disk4 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk4
   1:                        EFI ⁨EFI⁩                     209.7 MB   disk4s1
   2:                  Apple_HFS ⁨Elements⁩                850.0 GB   disk4s2
                    (free space)                         134.2 MB   -
   3:                 Apple_APFS ⁨Container disk5⁩         149.7 GB   disk4s3

/dev/disk5 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +149.7 GB   disk5
                                 Physical Store disk4s3
   1:                APFS Volume ⁨TEST - Données⁩          83.0 GB    disk5s1
   2:                APFS Volume ⁨Preboot⁩                 283.6 MB   disk5s2
   3:                APFS Volume ⁨Recovery⁩                626.2 MB   disk5s3
   4:                APFS Volume ⁨VM⁩                      1.1 MB     disk5s4
   5:                APFS Volume ⁨TEST⁩                    15.3 GB    disk5s5
 
Dernière édition par un modérateur:

hugs13

Membre confirmé
30 Août 2021
79
1
22
Je n’arrive plus à venir sur la page avec mon Ma. Jj’ai une page blanche avec « Error composing block page » mais TEST a bien été monté avec succès.
 
Dernière édition par un modérateur:

hugs13

Membre confirmé
30 Août 2021
79
1
22
Oui, oui, pas de problème, le souci est juste sur le forum macg : je n’ai pas accès aux dernières pages du post. Mais ce n’est pas très grave je posterai des photos au lieu des balises de code.
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 791
26 372
Forêt de Fontainebleau
D'accord pour les photos.

- passe la commande :​
Bloc de code:
bless --mount /Vol*/TEST --setBoot
  • la commande admet a priori qu'un chemin de démarrage valide existe déjà pour le volume-Système TEST --> et réécrit en NVRAM la valeur de la variable efi-boot-device pour lui faire pointer le volume TEST comme appareil de démarrage automatique de l'EFI

Commande muette (retour direct de -bash-3.2#) si elle passe. Est-ce que ça a été le cas ?
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 791
26 372
Forêt de Fontainebleau
Bon. On vérifie si l'effet souhaité a été produit en NVRAM. Repasse la commande :
Bloc de code:
nvram efi-boot-device
  • qui affiche la valeur de la variable efi-boot-device en NVRAM

Tu vas rencontrer un problème dû à l'affichage linéaire de ce chemin qui ne va pas se laisser capturer en entier sur une photo. Déroule lentement l'affichage et à un moment donné tu vas tomber sur un segment qui était auparavant :
Bloc de code:
<string>disk2s2</string>
  • et qui serait maintenant (espérons-le) :
Bloc de code:
<string>disk5s5</string>
  • il te suffit de m'indiquer (sans photo) quel est l'actuel index d'appareil (le diskxsx) associé comme valeur à la variable efi-boot-device.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 791
26 372
Forêt de Fontainebleau
Magnifique ! disk5s2 désigne le volume de prédémarrage Preboot du Conteneur disk5 de la distribution Big Sur du TEST externe. Volume Preboot qui a le privilège de receler le chemin de démarrage de l'OS. La valeur de la variable efi-boot-device en NVRAM a donc été éditée --> de sorte que l'EFI du Mac devrait automatiquement démarrer l'OS Big Sur du DDE externe.

- quitte le terminal. Va à : Menu  > Redémarrer. Tu n'auras qu'à dire si tu as pu réouvrir ta session d'utilisateur de TEST.​
 

hugs13

Membre confirmé
30 Août 2021
79
1
22
Alors, première chose, quand j’ai ouvert ma session j’ai eu ce message :

9007576F-EC68-40E1-B0BD-66F39E061CC0.png

Je ne sais pas si ca nous aide mais je préférais le notifier.
En ce qui concerne Macintosh HD - Donées je ne l’ai pas directement sur mon bureau, si c’est ça le propos, mais je l’ai bien dans mon utilitaire de disque et il semble monté :

image.png
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 791
26 372
Forêt de Fontainebleau
Bon. Je te propose d'entrer dans Macintosh HD - Données > Utilisateurs > ton dossier de compte.

- regarde si tu peux récupérer des données à la main (dans les sous-dossiers Bureau etc.) --> qui te feraient défaut dans ta session de TEST déjà un peu ancienne - même si elle correspond à la source depuis laquelle la distribution interne de Macintosh HD a été clonée.​

Je fais une pause. Je reviendrai vers les 21 H.
 

hugs13

Membre confirmé
30 Août 2021
79
1
22
Si j’ai bien compris, tu veux que je vérifie si j’ai accès aux fichiers présents dans "Macintosh HD - Données" ? Si c’est ça, oui, j’ai accès notamment aux fichiers téléchargés depuis le clonage c’est à dire ces 10 derniers jours.

Bonne pause !
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 791
26 372
Forêt de Fontainebleau
Je voulais dire : tu n'as qu'à importer (par glisser-déposer) les fichiers nouveaux de ton compte dans Macintosh HD - Données => dans ton compte de TEST. Pour effectuer une mise-à-jour.

- car je pense qu'il va falloir reformater le disque interne.​