Mamp veut me télécharger application/x-httpd-php ?

mrsoyer

Membre junior
7 Mars 2008
16
0
Bonjour à tous

J'ai un énorme problème incompréhensible qui viens de m'arriver aujourd'hui.

J'utilise le logiciel mamp afin de pouvoir dévelloper mes programme en php avant de les mètre en ligne.

Depuis aujourd'hui lorsque je le lance que la page localhost:8888 ce lance il me demande de telecharger un fichier de type application/x-httpd-php

Et sa me fait la même chose si je rentre l'adresse exacte d'un site héberger en local.

Je pense que sa dois venir d'une mauvaise manip car sa me la jamai fait auparavant.

Mai qoi ???? je ne sais vraiment pas ce qui à pus cosser ce désagrement.

Je fait donc un appel a l'aide.


A L'AIDE!!!!!! ;)
 

p4bl0

Membre d’élite
Club MacG
12 Juillet 2004
4 772
425
31
$PWD
p4bl0.net
Bonjour à tous

J'ai un énorme problème incompréhensible qui viens de m'arriver aujourd'hui.

J'utilise le logiciel mamp afin de pouvoir dévelloper mes programme en php avant de les mètre en ligne.

Depuis aujourd'hui lorsque je le lance que la page localhost:8888 ce lance il me demande de telecharger un fichier de type application/x-httpd-php

Et sa me fait la même chose si je rentre l'adresse exacte d'un site héberger en local.

Je pense que sa dois venir d'une mauvaise manip car sa me la jamai fait auparavant.

Mai qoi ???? je ne sais vraiment pas ce qui à pus cosser ce désagrement.

Je fait donc un appel a l'aide.


A L'AIDE!!!!!! ;)
ça ressemble à une mauvaise config de Apache.

Dans ton httpd.conf est ce qu'il y a une ligne du genre :
"AddType application/x-httpd-php .php .php3 .phtml" ?
Et le module PHP chargé
"LoadModule php5_module modules/libphp5.so" ?
 

mrsoyer

Membre junior
7 Mars 2008
16
0
Et bien c'est ce qui parai vrement bizar ces ligne y sont dans mon httpd.conf.

Jai essayé de supprimer MAMP et de le réinstaller, le probléme est le même...:mouais:

j'ai beau arrêter redémarrer les serveur toujours le même problème.
Je vais tenté distaller xamp on verra bien, mais cela membete vraiment ...

Cela ne pourai t'il pas venir du serveur apache intégrer à os x qui est en route et remplacerai celui de mamp.????

Je dit peu etre de grosse bétise........:nailbiting::(
 

mrsoyer

Membre junior
7 Mars 2008
16
0
je n'arrive toujour pas a me dépatouiller de ce probléme...

J'ai beau chercher tout suprimer réinstaller....... si jamais qulqu'un a idée ...

.... pour vous dire le problème j'ai du ressortir un vieux pc et y installer mysql afin de pouvoir continuer à bosser... triste quand même....
 

lunamia

Nouveau membre
27 Février 2009
3
0
Salut MrSoyer
J'ai le même problème que toi.. Du jour au lendemain, Mamp ne lit plus le php et veut me télécharger ces fichiers systématiquement.
As-tu trouvé une solution depuis ? La je suis au point mort..
Merci pour ta réponse.
 

mrsoyer

Membre junior
7 Mars 2008
16
0
Non je n'ai toujours pas trouvé la solution, et sa m'embête vraiment. Ayant windows sur mon mac grasse à parralel, j'utilise donc wamp sur windows:mad::mad::mad:.
 

lunamia

Nouveau membre
27 Février 2009
3
0
J'ai trouvé ce qui causait le pb chez moi :
Depuis filezilla, j'ai vu que mon htdocs comportait des fichiers cachés et notamment un .htaccess mal rangé... J'ai tout retiré et hop ça fonctionne à nouveau !
En espérant que ça puisse t'aider !