• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

Mémoire virtuelle

-anonyme-

Légende
26 Février 2001
66 286
2 667
Je travaille sur un PowerBook G4 Titanium (256 Mo RAM). Quand la mémoire virtuelle est activée, le Mac avance par "hoquets". Toutes les 30-60 secondes environ, le Mac s'arrête, émet un petit gazouilli, se fige pendant 1-2 secondes et repart. En fait on dirait qu'il accède au disque dur qui fait ce petit bruit le temps de se réveiller et de livrer les infos à la mémoire.

Le problème est que le Mac est totalement bloqué pendant ces 1-2 secondes. Donc la musique s'arrête (impossible d'écouter un CD-Rom sur iTunes dans ces conditions), la frappe calvier aussi, etc. C'est donc très pénible car on a l'impression d'avancer par petits bonds.

Si la mémoire virtuelle est désactivée, c'est OK mais Mac OS 9.1 seul fait... 86 Mo! Le disque dur est pourtant fraîchement défragmenté avec SystemWorks.

Y a-t-il moyen de régler ceci afin que le Mac soit fluide même avec la VM activée?
 

Gwenhiver

Membre d’élite
Club MacG
8 Décembre 2000
3 351
2
Visiter le site
La mémoire virtuelle utilise intensivement le disque dur.
Vérifie dans le tableau de bord Economies d'Energie que tu n'as pas modifié les réglages pour que ton disque dur se mette en veille toute les minutes d'inactivité par exemple (taper du texte dans un traitement de texte n'implique pas une activité du disque dur, donc il se met en veille). Mets-le en veille par exemple après cinq minutes d'inactivité, et ce seulement sur batterie. Sur secteur, pas besoin de le mettre en veille.

------------------
Gwenhiver — Truly addicted to MacG
 

MarcMame

Vétéran
Club MacG
25 Janvier 2001
7 011
266
<BLOCKQUOTE><font size="1" face="Verdana, Geneva">quote:</font><HR>Posté à l'origine par rossi:
Mac OS 9.1 seul fait... 86 Mo!<HR></BLOCKQUOTE>
WOW ! Je n'ose même pas imaginer les centaines d'extensions et TdB que ton Mac doit se goinfrer au demarrage...
Tu installes tout ce qui te tombe sous la main ou quoi ?

 

-anonyme-

Légende
26 Février 2001
66 286
2 667
Question bète mais 256MO, c'est quand même pas mal. Ca te suffit pas pour bosser?
Et 9.1 à 86MO.... C'est du délire... Comme dit l'autre, tu as combien de log d'installés?...
 

touba

Membre d’élite
Club MacG
10 Avril 2001
2 705
401
46
Dakar
il a surement OS X à faire tourner aussi...

------------------
el Mac'istador !!!
 

-anonyme-

Légende
26 Février 2001
66 286
2 667
FAUX !
moi aussi, j'ai un systeme qui affiche 67 MO avec la mémoire virtuelle désactivée, bien que relativement dépouillé.

la mémoire virtuelle aussi etait mega pénible pour moi, redemarrant le disque tt le temps, ralentissant nb d'applis. J'ai 192 Mo.
 

MarcMame

Vétéran
Club MacG
25 Janvier 2001
7 011
266
<BLOCKQUOTE><font size="1" face="Verdana, Geneva">quote:</font><HR>Posté à l'origine par blueblood:
FAUX !
moi aussi, j'ai un systeme qui affiche 67 MO avec la mémoire virtuelle désactivée, bien que relativement dépouillé.
<HR></BLOCKQUOTE>
C'est déjà bcp...
commence par ramener le cache disque à 4096Ko ou moins, tu va récuperer un peu de Ram...
 

ficelle

Vénérable sage
Club MacG
21 Avril 2000
10 744
815
9-3
c'est beaucoup mais tout à fait normal ! des qu'on lance des applications qui utilisent quicktime ou open gl, le systeme peut occuper pres de 100 MO. mais si on active la memoire virtuelle en la reglant au minimum (mapping), le ti doit rester tres veloce... donc, comme le suggerait gwen, il faut jeter un coup d'œil au tdb "economies d'energie".
a+