Mac Pro Mise à jour firmware Mac Pro 4.1 flashé 5.1

IRONHIDE49

Membre d’élite
23 Février 2020
2 231
326
Nantes
D'accord, c'est donc un 2009.
Je me suis trompé, je voulais dire 2010/2012.

J'avais lu que ça fonctionne dans ce sens là, mais que il y avait les ventilos qui s'emballent pour rien.
 

yst

Membre junior
29 Octobre 2020
21
9
39
Plan d'Aups Sainte Baume
Pour l'instant (je touche du bois mais bon, vu que ça fait un moment que je l'ai... ) pas de soucis de ventilo qui s'emballe, pourvu que ça dure :)
Dommage d'ailleurs qu'il n'y ait pas un site référençant les logic board CPU par rapport aux numéros de série (ou alors je ne connais pas) histoire d'avoir quelques infos.
 

IRONHIDE49

Membre d’élite
23 Février 2020
2 231
326
Nantes
De toute façon, si tu aurai eu des problèmes, ça aurai été dès le début, maintenant, je doute que ça arrive.
 

teiki arii

Membre junior
4 Novembre 2020
26
10
54
Bon Matin à Toutes et à Tous :coucou: ,

Aucun driver n'est nécessaire pour un NVMe en PCIe avec la 144.0.0.0.0 qui autorise également le boot sur le SSD.
Seule chose, un SSD sur une carte en PCIe est considéré comme externe et le temps de boot est plus long sur un MP 5.1 car il cherche d'abord un OS sur les volumes internes (lecteur DVD, les 4 x SATA 2) et si en plus la RAM est importante (128 Go ou plus), cela peut être très long car il vérifie d'abord l'intégrité de toutes les RAM :yawn: .
@Lil Montréal
J'ai trouvé le moyen de faire reconnaître les SSD sur PCIe comme SSD "internes". Le problème n'est pas seulement esthétique. Des lecteurs mal identifiés peuvent entraîner des problèmes pour Boot Camp Assistant et le programme d'installation de macOS.

Le kext s'appelle "Innie" qui est un plugin Lilu. Lilu est un kext open source qui fournit une plate-forme unifiée pour appliquer divers correctifs. Pour la dernière version d'Innie, mieux vaut la dernière version de Lilu ici: Télécharger la dernière version de Lilu (celle du jour 1.4.9.) en cliquant sur Lilu-1.4.9-RELEASE.zip à l'adresse: https://github.com/acidanthera/Lilu/releases
La dernière version d'Innie est la 1.2.1: Innie-1.2.1-RELEASE.zip disponible ici: https://github.com/cdf/Innie/releases

Pour installer Innie, veuillez suivre les étapes suivantes:

0) Désactivez SIP.
Pour savoir si SIP est déjà désactivé, il faut ouvrir le Terminal et taper csrutil status et ENTER. Si la réponse est System Integrity Protection status: disabled, vous passez à l''étape suivante. Sinon ("System Integrity Protection status: enabled."), il faut désactiver SIP comme suit:
- Redémarrez votre MacPro en "mode recovery": redémarrez votre Mac sur la partition de restauration, en maintenant les touches ⌘ et R au démarrage. Maintenez les dites-touches une bonne trentaine de secondes après le bip de démarrage et être patient! Une fois le mode Recovery chargé, ouvrez une fenêtre de Terminal depuis le menu Utilitaires de la barre des menus, en haut de l'écran. Tapez la commande suivante dans la fenêtre de Terminal : csrutil disable; reboot. Pressez l'une des touches Retour ou Entrée, le système redémarre: System Integrity Protection a été désactivée (System Integrity Protection status: disabled). Vous pouvez le vérifier en entrant dans le terminal csrutil status.
1) Téléchargez Lilu. Le fichier (décompressé) s'appellera Lilu.kext.
2) Contrôle-cliquez sur Lilu.kext et sélectionnez Afficher le contenu du paquet. Vous verrez le dossier Contenu. Ouvrez-le.
3) Dans Contenu, créez un nouveau dossier appelé Plugins. C'est là qu'il faudra y placer Innie.
4) Copiez Innie.kext dans le dossier Plugins.
5) Copiez maintenant Lilu.kext dans / Bibliothèque / Extensions à la racine de votre SSD NVMe. Vous devrez autoriser cela en entrant votre mot de passe.
6) Terminal ouvert. Entrez les commandes suivantes:

sudo chmod -R 755 /Library/Extensions/Lilu.kext
sudo chown -R root:wheel /Library/Extensions/Lilu.kext
sudo touch /Library/Extensions
sudo kextcache -update-volume /


Attendez que la dernière commande soit terminée. Ne vous préoccupez pas du message de retour.
7) Redémarrez.
Si tout se passe bien, tous vos SSD (mSATA et NVMe) sur carte PCIe et même le SSD sur baie optique seront désormais considérés comme internes.

Voilà, j'espère que ça peut aider. Vous trouverez le post original ici:
https://forums.macrumors.com/thread...external.2136229/?post=26433989#post-26433989 sur une idée originale de cdf.
 
Dernière édition:
  • J’aime
Réactions: yst et IRONHIDE49

IRONHIDE49

Membre d’élite
23 Février 2020
2 231
326
Nantes
Très très intéressant, et c'est vraiment une bonne idée.
Par contre, il y a un problème, désactiver le SIP, là, tu va vers la mauvaise direction, c'est vraiment très risqué, même en réactivant après, ce que tu n'a pas énoncé au passage, et qui me parais nécessaire.



Mais très bonne initiative, merci à toi.
 
  • J’aime
Réactions: teiki arii

teiki arii

Membre junior
4 Novembre 2020
26
10
54
Très très intéressant, et c'est vraiment une bonne idée.
Par contre, il y a un problème, désactiver le SIP, là, tu va vers la mauvaise direction, c'est vraiment très risqué, même en réactivant après, ce que tu n'a pas énoncé au passage, et qui me parais nécessaire.
Rien ne t'empêche de le réactiver: redémarre macOS une nouvelle fois en mode Recovery, à l'aide du raccourci ⌘ R (maintenir les deux touches enfoncées au moins trente secondes après le bip de démarrage et être patient!), puis tu ouvres une fenêtre de Terminal comme précédemment et tu tapes : csrutil enable; reboot dans Terminal. Ça redémarre tout seul et le tour est joué...
 
Dernière édition:

teiki arii

Membre junior
4 Novembre 2020
26
10
54
NB: à chaque nouvelle itération de Mojave (ou de High Sierra), les kext (Lilu et Innie) de cdf n'étant pas signés, il faudra refaire la manipulation...:bigtears:
Le problème est lié à tous les Kexts non signés (en particulier HDMIaudio par exemple)...
 
Dernière édition:

Lil Montréal

Membre confirmé
14 Juin 2019
462
214
67
Bon Matin @teiki arii :coucou: ,

Merci pour l'info.
Je connais bien les plugins Lilu (dernière release 1.2.1).
Je les ai utilisé aux débuts de Mojave 10.14.0 ... 10.14.6 car cela résolvait les problèmes d'imprimantes, d'AirPlay, de Bluetooth et d'Audio ;) .
Les GPU ne passaient pas le son avec les premières release de Mojave et donc pas de son :sorry: sur les écrans sans Lilu.

Je connais GitHub grâce à MacRumors.

Mais comme tu le précises très bien, il faut faire la manip à chaque MàJ et nous avons encore sept cMP 5.1 ... sans compter toutes les autres machines (iMac, Mac mini, MBP divers, etc ...) et comme pour les cMP 5.1, la 10.14.6 a résolu les PB de BlueTooth, d'Airplay, etc..., je n'ai plus continué à utiliser les kexts externes.

Je n'ai jamais rencontré de PB d'install Mac OS.
Nous utilisons Parallels Desktop qui permet de switcher sans latence entre Mac OS et Windows et cela depuis de nombreuses années pour certaines imprimantes spéciales (Tyco et Brady) sur manchons.
Le meilleur des deux mondes en instantané.

Amitiés
 

IRONHIDE49

Membre d’élite
23 Février 2020
2 231
326
Nantes
Rien ne t'empêche de le réactiver: redémarre macOS une nouvelle fois en mode Recovery, à l'aide du raccourci ⌘ R (maintenir les deux touches enfoncées au moins trente secondes après le bip de démarrage et être patient!), puis tu ouvres une fenêtre de Terminal comme précédemment et tu tapes : csrutil enable; reboot dans Terminal. Ça redémarre tout seul et le tour est joué...
Ce que je veux dire, c'est que même si tu le réactive après, ton Mac a quand même fonctionné sans SIP, ce qui peut mener à des gros soucis de sécurité ou des bugs.
Pour moi, c'est ce qui pose problème.
 
  • J’aime
Réactions: teiki arii

yst

Membre junior
29 Octobre 2020
21
9
39
Plan d'Aups Sainte Baume
Coucou tout le monde,

j'espère que tout le monde va bien.
Pour la suite et fin (pour le moment) de l'histoire, j'ai fait un essai de fonctionnement avant de commander du matériel.
Au boulot j'avais cette carte :
ICY Dock ToughArmor MB840M2P-B
que j'ai récupéré pour faire mon test. A côté je me suis commandé un Samsung SSD EVO 970 M.2 NVMe 1To.
Bon, et bien je dois dire que ça dépote sévère par rapport aux SSD sata que j'avais initialement ! Je suis à 1500 MB/s en lecture comme en écriture, c'est plutôt confortable !!
Et cette carte n'est finalement pas si mal que ça je trouve. Seul inconvénient, on ne peut y installer qu'une seule carte M.2.
Voilà voilà,

Bonne journée
A très vite :)
 

teiki arii

Membre junior
4 Novembre 2020
26
10
54
Coucou tout le monde,

j'espère que tout le monde va bien.
Pour la suite et fin (pour le moment) de l'histoire, j'ai fait un essai de fonctionnement avant de commander du matériel.
Au boulot j'avais cette carte :
ICY Dock ToughArmor MB840M2P-B
que j'ai récupéré pour faire mon test. A côté je me suis commandé un Samsung SSD EVO 970 M.2 NVMe 1To.
Bon, et bien je dois dire que ça dépote sévère par rapport aux SSD sata que j'avais initialement ! Je suis à 1500 MB/s en lecture comme en écriture, c'est plutôt confortable !!
Et cette carte n'est finalement pas si mal que ça je trouve. Seul inconvénient, on ne peut y installer qu'une seule carte M.2.
Voilà voilà,

Bonne journée
A très vite :)
Bravo pour ton acquisition!
La limite classique en lecture/écriture semble limitée à 1.5GB/s sur carte PCIe 3.0.
La seule exception concerne la HighPoint SSD7101A-1 NVMe RAID controller.:eek:

 
  • J’aime
Réactions: yst

yst

Membre junior
29 Octobre 2020
21
9
39
Plan d'Aups Sainte Baume
Merci @teiki arii :) Je voulais faire des essais avant d'investir dans un quelconque adapatateur M.2 / PCI-E.
Effectivement, à partir du moment ou tu passes en raid, les débits sont tout autre, mais le tarif de la carte aussi est tout autre :eek:
Je crois que je vais partir pour l'instant sur cette carte, ça sera déjà pas mal !
Seule déception, mais qui n'a rien à voir avec le M.2 ou la version de la ROM, c'est que la RX 5700 XT que j'ai mange... un poil plus que 2 slots, donc je perds un port PCI-E :mad: Je n'avais pas fait attention aux dimensions avant de l'acheter :banghead:
 
Dernière édition:

Lil Montréal

Membre confirmé
14 Juin 2019
462
214
67
Bravo pour ton acquisition!
La limite classique en lecture/écriture semble limitée à 1.5GB/s sur carte PCIe 3.0.
La seule exception concerne la HighPoint SSD7101A-1 NVMe RAID controller.:eek:

Bon Matin à Toutes et à Tous :coucou: ,

En fait la limite est celle des PCIe 2.0 des cMP 5.1 qui ne sont pas en 3.0.

Pour accéder au PCIe 3.0 sur cMP 5.1, il faut une carte switch comme les I/O Crest qui permettent des vitesses de liaison de 8.0 GT/s et donc des vitesses théoriques de 3 000 MB/s en Read/Write mais plutôt ~ 2 600 MB/s en W et 2 800 MB/s en R.

La HighPoint 7101A double ces vitesses à 6 000 MB/s en R/W théorique mais plutôt ~ 5 000 MB/s en pratique.

Il en existe d'autres en I/O Crest (HQC) qui permettent le switch 3.0 avec 4 x SSD et des vitesses pratiques de 5 000 MB/s sur cMP5.1 mais presque 9 500 MB/s sur cMP 7.1 :eek: .

Amitiés
 
  • J’aime
Réactions: yst et IRONHIDE49

IRONHIDE49

Membre d’élite
23 Février 2020
2 231
326
Nantes
Hello Lil Montréal,

J'avais une question pour toi:
J'ai pas tout compris, ont peut mettre du pcie3. 0 sur nos Mac pro ? Mais comment ? Parce que les ports sont bridé en V2.
 

Lil Montréal

Membre confirmé
14 Juin 2019
462
214
67
Hello :coucou: ,

En fait, il faut connaître la technologie PCIe.

Il existe actuellement 5 versions de PCIe avec les vitesses suivantes par ligne ou par largeur de câble :
  • PCIe 1.0 ( 2,5GT/s)
  • PCIe 2.0 ( 5GT/s)
  • PCIe 3.0 ( 8GT/s)
  • PCIe 4.0 (16GT/s)
  • PCIe 5.0 (32GT/s)

Il existe 4 largeur de lignes. Une ligne étant le canal d’émission, plus le canal de réception.
x1 - x4 - x8 et x16

Le cMP 5.1 (2012) a deux ports (Slots 1 & 2) en PCIe en x16, et deux ports (Slots 3 & 4) en x4

Attention, seul le 2012 est en full lane x16 (sur 1&2) et x4 (sur 3&4). Pas le 2009 et pas certains 2010.

Donc avec une largeur de câble de x16 et et donc une vitesse de 5GT/s par ligne = 80 GT/s pour le port complet, une carte switch (avec le chip dédié ASM2824) permet une vitesse de 8GT/s par ligne x 4 comme le PCIe 3.0, mais uniquement sur les slots 1 ou 2 avec deux NVMe (970 EVO par exemple) pour l'I/OCrest ou quatre NVMe pour la 7101A qui peut en plus être utilisée en RAID 0 :eek: et là, tu accroches ta ceinture ton harnais :hilarious: :hilarious: :hilarious: .

Amitiés
 
Dernière édition:
  • J’aime
Réactions: yst et IRONHIDE49

IRONHIDE49

Membre d’élite
23 Février 2020
2 231
326
Nantes
Hello,

Merci pour ta précision Lil Montréal, j'y vois plus clair.

Mais je ne comprends pas, le MP2012 peut avoir le double X16 mais pas certains 2010? C'est pourtant les mêmes cartes mères, mêmes cartes fille, mêmes identifiants.....

Mais merci pour ces détails.

Autres truc que je comprends pas, ma carte sata est en X2, c'est normal, et physiquement, c'est du X4.
 

Lil Montréal

Membre confirmé
14 Juin 2019
462
214
67
Hello :coucou: ,

Mais je ne comprends pas, le MP2012 peut avoir le double X16 mais pas certains 2010? C'est pourtant les mêmes cartes mères, mêmes cartes fille, mêmes identifiants.....
Non, les slots 1 & 2 sont en x 16, mais la vitesse du 1 est de 5 GT/s et pour certains 2010 et les 2009 le slot 2 est en 2,5 GT/s.

Autres truc que je comprends pas, ma carte sata est en X2, c'est normal, et physiquement, c'est du X4.
Non, ta SATA est en SATA2 et la ligne PCIe est en x4, ce qui n'a rien à voir.
En PCIe, la largeur de ligne x2 n'existe pas.

Amitiés
 
  • J’aime
Réactions: yst et IRONHIDE49

teiki arii

Membre junior
4 Novembre 2020
26
10
54
Waow! Superbe réponse.
Merci @Lil Montréal.
Oui qu'en est-il des cMP 2009?

PS: ben moi c'est du 5GT/s pour le slot 2 ... o_O
 

IRONHIDE49

Membre d’élite
23 Février 2020
2 231
326
Nantes
Hello :coucou: ,


Non, les slots 1 & 2 sont en x 16, mais la vitesse du 1 est de 5 GT/s et pour certains 2010 et les 2009 le slot 2 est en 2,5 GT/s.


Non, ta SATA est en SATA2 et la ligne PCIe est en x4, ce qui n'a rien à voir.
En PCIe, la largeur de ligne x2 n'existe pas.

Amitiés
OK, merci pour ces précisions.

Je te post une photo pour que tu voie, elle est bien en X2 dans les infos système.

Merci à toi.