PHP sur leopard : bibliothèques GB et mcrypt

NAC NAC

Membre junior
21 Mars 2006
54
0
Salut,
J'ai un iMac Intel Core 2 Duo Mac OS X 10.5.5 avec PHP Version 5.2.6
C'est la galère pour installer les bibliothèques GB et mcrypt
J'ai suivi http://www.lozix.com/2008/03/30/installer-gd/ à la lettre mais il n'y a pas de répertoire /usr/share/libtool sur mon mac. Pourquoi ?

Alors, dés le départ je suis bloqué !

Quelqu'un peut m'aider sur ce coup là ?

Est il possible d'enlever PHP Version 5.2.6 pour réinstaller PHP Version 5 ?


Merci beaucoup

@+
 
A

Anonyme

Invité
Le répertoire /usr/share/ existe mais est invisible, le sous-répertoire libtool doit se créer au moment de la copie. ;)
 

NAC NAC

Membre junior
21 Mars 2006
54
0
Sqlut loup gloupm
quand je tape
cp /usr/share/libtool/config.sub .
dans le terminal
j‘ai
No such file or directory


ps . j‘ai ;on clavier en qwerty sous root comment on le met en azerty

Merci
 
A

Anonyme

Invité
Pourquoi tu es en root? :confused: C'est dangereux et ça ne sert à rien… Essaye de créer le dossier avant de faire la copie, mais bon je ne suis pas très doué dans tout ce qui est terminal… ;)
 

NAC NAC

Membre junior
21 Mars 2006
54
0
Alors la commande :
cp /usr/share/libtool/config.sub .
Copie config.sub sur le répertoire courant ( . )

Mais ni le répertoire libtool ni le fichier config.sub existe sur mon mac !

Quelqu'un peut m'aider ?

Ou est t-il plus simple d'installer php 5 au lieu de php 5.2.6 ?

Merci
@+
 

iMatthieu

Membre confirmé
31 Août 2004
383
24
37
CH - Neuchâtel
www.imatt.ch
Que le package entropy nous manque à tous :love:

J'avais aussi besoin d'installer GD et j'ai voulu suivre le tuto de lozix, mais apparemment il passe pas mal de détails et les commandes ne sont que pour les processeurs 32bits (donc pas les core 2 duo).

Voilà un article que je viens de suivre et qui a parfaitement fonctionné (en anglais) : http://www.kenior.com/macintosh/adding-gd-library-for-mac-os-x-leopard

Quelques remarques qui pourront t'aider :
- si tu as un Core 2 Duo choisi la commande 64bits quand tu as le choix.
- perso j'ai la version php 5.2.6 et non 5.2.4, sans doute suite à une mise à jour d'apple, pour vérifier dans le terminal $ php -v.
- les instructions make install doivent (chez moi) être faites en root (sudo make install).

Pour mcrypt aucun idée par contre je n'ai jamais utilisé cette lib, mais ça doit être le même principe avec quelques différences dans le ./configure.

Bon courage