Ce forum est en partie financé par l’affichage de publicités. Merci de désactiver votre bloqueur de publicités pour nous permettre de continuer à fournir ce service.

Problème avec iWeb

Discussion dans 'Développement web' créé par raphh-ol, 29 Novembre 2008.

Modérateurs: Nephou
  1. raphh-ol

    raphh-ol Membre junior

    Inscrit:
    20 Février 2008
    Messages:
    72
    J'aime reçus:
    1
    Bonjour.

    J'ai fait un site avec iWeb. Une fois tout publié en UTF8, je me suis retrouvé avec un problème : Il y a des caractères bizarres de partout. Je crois que ça s'appelle "unicodes"... J'ai donc cherché tout les moyens de changer ce problème, et un jour par hasard, j'ai mis les textes en liens, et, miracle ! Les caractères spéciaux ont disparus ! ((( Je pense que c'est du au fait que comme je l'ai mis en lien, ça n'a plus été du texte, mais une image png du texte, et que ainsi il n'y a plus eu d'unicodes... )))

    Mais en fouillant bien dans mon site, je me suis aperçu que certains unicodes étaient restés, mais pas la où je peux les modifier. C'est en fait dans la Gallerie photo "préfabriquée" que certains unicodes snot restés. ((( Comme par exemple sur "Précédent" dans la gallerie. Je vous donne une copie écran. )))

    Comment faire pour enlever ces caractères bizarres qui pourrissent mon site ?
    J'ai déjà visité des sites créé avec iWeb qui ne rencontraient pas ce problème là.
    Qu'ai-je fait qui fait que, moi, je rencontre ce problème ?


    Merci beaucoup,

    Raphh-ol
     
  2. pierre-auvergne

    pierre-auvergne Membre d’élite
    Club MacG

    Inscrit:
    27 Mai 2008
    Messages:
    2 133
    J'aime reçus:
    317
    Je crois que le principal provient du navigateur. Si tu utilises safari, vide le cache.
     
  3. raphh-ol

    raphh-ol Membre junior

    Inscrit:
    20 Février 2008
    Messages:
    72
    J'aime reçus:
    1
    J'ai utilisé firefox et safari sur 3 macs et le résultat reste le même !
    J'ai vidé les cashs, les caractères sont toujours là...

    N'y a-t-il pas autre chose a faire ?


    Merci..

    raphh-ol
     
  4. koeklin

    koeklin Membre d’élite
    Club MacG

    Inscrit:
    17 Août 2007
    Messages:
    2 366
    J'aime reçus:
    249
    vider le cache du navigateur ne servira à rien, comme le soupçonne Zepatente il faudra changer d'hebergeur pour ton site. Ça arrive parfois même avec des hébergeurs français ( je me rappelle d'une discution de ce genre sur le forum d'avosmac)
     
  5. pierre-auvergne

    pierre-auvergne Membre d’élite
    Club MacG

    Inscrit:
    27 Mai 2008
    Messages:
    2 133
    J'aime reçus:
    317
    parfois si, puisque l'utilisateur a changé l'encodage lors d'un transfert ou d'une synchronisation, et le changement n'a pas été répercuté.
     
  6. koeklin

    koeklin Membre d’élite
    Club MacG

    Inscrit:
    17 Août 2007
    Messages:
    2 366
    J'aime reçus:
    249
    une des solutions un peu zarbi pour un affichage correct est de transformer les textes qui posent problème en images de textes (on ne pourra sans doute pas le faire pour tous, mais bon...), je crois que Zepatente a expliqué quelque part sur son site mais j'ai la flemme de chercher parce que MÔssieur Zepatente n'a pas fait de page d'index unique à son site (oui, je remets ça sur le tapis :D et il préfère nous laisser chercher ses tutos sur 3 pages différentes)
     
  7. pierre-auvergne

    pierre-auvergne Membre d’élite
    Club MacG

    Inscrit:
    27 Mai 2008
    Messages:
    2 133
    J'aime reçus:
    317
    c'est donc pour ça que certains site faits par iweb ne marchent pas avec pomme +.
     
  8. zepatente

    zepatente Membre d’élite
    Club MacG

    Inscrit:
    12 Octobre 2007
    Messages:
    1 132
    J'aime reçus:
    56
    Çà fait longtemps que t'es pas venu :D

    pour le lien http://www.iwebeginner.com/iwebeginner/Didactiels.html dans les didacticiels vidéos ;)
     
  9. koeklin

    koeklin Membre d’élite
    Club MacG

    Inscrit:
    17 Août 2007
    Messages:
    2 366
    J'aime reçus:
    249
    Euh l'autre... on me la fait à moi!
    Une vraie page d'index réunirait le contenu des pages didacticiels, astuces et codes
    [​IMG]
    Au boulot!

    :D
     
  10. zepatente

    zepatente Membre d’élite
    Club MacG

    Inscrit:
    12 Octobre 2007
    Messages:
    1 132
    J'aime reçus:
    56
    koeklin aime ça.
  11. koeklin

    koeklin Membre d’élite
    Club MacG

    Inscrit:
    17 Août 2007
    Messages:
    2 366
    J'aime reçus:
    249
    Ouais!!!!!!! :up:
    oui mais avec un gros bouton en haut de la page c'est mieux au lieu d'un petit lien caché au bas de l'écran! (emmerdeur je suis, emmerdeur je resterai , demande à Mireille!)
    Au moins là, j'ai un lien potable à donner aux débutants et j'ai pas à fouiller le site comme avant :rateau:
    je vais d'ailleurs mettre ce lien que celui de ta page de lien et d'iWeb sur debutersurmac.com
     
Modérateurs: Nephou
Chargement...

iOccasion - Achetez un produit Apple d'occasion

refurb Apple