MacBook Pro Problème batterie et language

alexmaz

Membre junior
21 Août 2017
16
0
28
Bonjour;
j'aurais besoin de votre aide pour 2 problèmes..

Le 1er, c'est un problème de batterie, depuis environ bien 1an, la barre d'état de mon mac book pro 13inch milieu 2012 et acheté en Octobre 2013 indique "vérifiez la batterie".. J'ai laissé couler car pas mal débordé dans mon boulot depuis 1an..
Mon rapport service indique:
" Charge Information:
Charge Remaining (mAh): 4179
Fully Charged: Yes
Charging: No
Full Charge Capacity (mAh): 4179
Health Information:
Cycle Count: 860
Condition: Service Battery
Battery Installed: Yes
Amperage (mA): 0
Voltage (mV): 12473 "
Que me conseillez-vous de faire?

Le 2ème, c'est un problème de langue.. ma barre d'état, les menus du system préférences, tout est en anglais.. Je vais dans réglages et quand je veux ajouter langue française, le "French" disparait aussitôt, impossible de remettre en français..
Merci pour votre aide :)!
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
85 376
25 762
Forêt de Fontainebleau
Bonjour alexmaz

Concernant ta 2è question (problème de langue) --> va à : Applications > Utilitaires > lance le «Terminal».

Dans la fenêtre qui s'est ouverte > saisis la commande simplement informative (en copier-coller) :
Bloc de code:
defaults read -g AppleLanguages
et ↩︎ presse la touche "Entrée" du clavier pour exécuter la commande)

  • cette commande retourne les préférences générales de langue pour ta session

=> tu n'as qu'à poster ce résultat ici en copier-coller.
 

alexmaz

Membre junior
21 Août 2017
16
0
28
Voilà
Last login: Mon Aug 28 18:24:46 on console

macbook-pro-de-mazuy:~ Alexis$ defaults read -g AppleLanguages

(

"en-FR"

)

macbook-pro-de-mazuy:~ Alexis$
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
85 376
25 762
Forêt de Fontainebleau
Alors c'est le Français qui est bien la langue par défaut pour ta session. Tu as bien les menus du Finder en Français ?

Est-ce que les menus en Anglais ne seraient pas spécifiques à des applications ? - si oui > lesquelles ? --> Préférences Système ? Safari ?
 

daffyb

-Duck Warrior-
Modérateur
Club MacG
18 Octobre 2001
13 871
1 720
Angoulême
pour ce qui est du problème de langue, faire une réinstalle de l'OS me parait une bonne option.
On dirait qu'il y a eu une "optimisation" de l'espace occupé en virant des langues.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
85 376
25 762
Forêt de Fontainebleau
Comme la préférence de langue pour la session est bien le Français (et pas l'Anglais) > re-démarre un coup pour forcer sa prise en compte.

=> est-ce que les menus du Finder sont revenus en Français ?
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
85 376
25 762
Forêt de Fontainebleau
Pardon : j'avais mal lu le retour de la commande que je t'avais donnée. "en-FR" = Anglais (en comme english). Il faut donc susbstituer cette préférence (je vais y arriver).

Passe la commande :
Bloc de code:
defaults write -g AppleLanguages '("fr-FR")'

  • qui inscrit "fr-FR" = Français (fr = french) comme valeur de la clé AppleLanguages du fichier : ~/Library/ Preferences/.GlobalPreferences.plist

=> tu n'as qu'à re-démarrer un coup et ça devrait le faire pour le Finder.
 

alexmaz

Membre junior
21 Août 2017
16
0
28
Merci pour votre aide encore.. la plupart semble s'etre remis en français à première vue.. SAUF safari et préférences system..
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
85 376
25 762
Forêt de Fontainebleau
Alors pour ces 2 applications spécifiques > tu n'as qu'à passer les 2 commandes (l'une après l'autre) :
Bloc de code:
defaults write com.apple.Safari AppleLanguages '(fr)'
defaults write com.apple.systempreferences AppleLanguages '(fr)'


  • la 1ère incrit la valeur fr (french) pour la clé AppleLanguages du fichier de préférences de «Safari» (de ta bibliothèque de compte)

  • la 2è > la même valeur pour la même clé dans le fichier de préférences des «Préférences Système» (toujours de ta bibliothèque personnelle)

=> Re-démarre encore une fois et teste.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
85 376
25 762
Forêt de Fontainebleau
Même les menus du Finder ?

Passe (l'une après l'autre) les 2 commandes simplements informatives :
Bloc de code:
defaults read -g AppleLanguages
defaults read com.apple.systempreferences AppleLanguages

  • la 1ère retourne la préférences de langue des menus pour le «Finder»
  • la 2è > la préférence de langue des menus pour les «Préférences Système»

=> affiche ici ces 2 résultats > que je voie de visu de quoi il retourne.
 

alexmaz

Membre junior
21 Août 2017
16
0
28
Last login: Thu Aug 31 07:53:58 on ttys000

macbook-pro-de-mazuy:~ Alexis$ defaults read com.apple.systempreferences AppleLanguages

(

en

)

macbook-pro-de-mazuy:~ Alexis$ defaults read -g AppleLanguages

(

"en-FR"

)

macbook-pro-de-mazuy:~ Alexis$
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
85 376
25 762
Forêt de Fontainebleau
C'est encore en Anglais !

Alors passe les 2 commandes :
Bloc de code:
defaults write -g AppleLanguages '(fr)'
defaults write com.apple.systempreferences AppleLanguages '(fr)'

  • qui remettent une préférence pour fr = french (Français) dans le fichier de préférences des 2 logiciels.

Ne re-démarre pas encore > mais passe ensuite les 2 commandes (informatives) que tu as déjà passées :
Bloc de code:
defaults read -g AppleLanguages
defaults read com.apple.systempreferences AppleLanguages

  • afin de vérifier que les 2 valeurs fr (= french) se sont bien inscrites dans les fichiers

=> et poste encore ici les 2 retours.