Problème de droit

Stemba

Membre enregistré
6 Octobre 2011
7
0
Bonjour,

je souhaite créer un fichier .emacs dans mon $HOME pour régler le problème de la touche alt avec emacs 23.

voici ce que je doit ajouter dans .emacs pour régler le problème:
(setq mac-option-modifier 'super )
(setq mac-command-modifier 'meta )
(define-key global-map [home] 'beginning-of-line)
(define-key global-map [end] 'end-of-line)

sudo -u root touch .emacs
Password:
touch: .emacs: Operation not permitted
(avec TextWrangler ou nano même erreur !)

Voici les droits de mon $HOME : drwxr-xr-x+ 56 Nicolas staff 1904 10 jul 16:24 Nicolas

Le problème est que je ne peux pas créer de fichier à cette endroit, même en tant que root :mouais:

Merci d'avance pour votre aide.
 

Stemba

Membre enregistré
6 Octobre 2011
7
0
Comme la commande que tu cite ne marche pas, il me sort la même erreur, j'ai essayé en root.

Enfin je ne comprend vraiment pas j'ai tous les droits !

La je peux uniquement lire ou modifié un fichier ...
 

edd72

Membre expert
Club MacG
14 Avril 2010
9 850
283
Pourtant, toi (en tant qu'utilisateur Nicolas), tu peux créer un fichier à cet endroit de la manière la plus simple:

touch .emacs

rwx : toi -> lecture, écriture, traverse
r-x : ton groupe (staff) -> lecture, traverse
r-x : les autres -> lecture, traverse

Peux-tu indiquer précisément l'erreur qui t'est retournée? (capture?)
 

Stemba

Membre enregistré
6 Octobre 2011
7
0
[19:28:43 Nicolas:/Users]$ touch .emacs
touch: .emacs: Permission denied

Enfin peu importe ce que je crée, du moment que j'ai les droits, il n'y a pas de raison que cela ne marche pas.

Je me demande si le problème n'est pas lié à mon back up Time machine que j'ai fait il y a peu de temps à cause d'un problème avec Firevault.
 

Stemba

Membre enregistré
6 Octobre 2011
7
0
oups pas fait attention :)

[19:42:50 Nicolas:~]$ ls -lai ~/.emacs
ls: /Users/Nicolas/.emacs: No such file or directory

[19:43:02 Nicolas:~]$ touch ~/.emacs
touch: /Users/Nicolas/.emacs: Operation not permitted
 

edd72

Membre expert
Club MacG
14 Avril 2010
9 850
283
Ouais, donc tu as un problème :)

Il faudrait que tu réinitialises les permissions au niveau de ton dossier utilisateur, pour se faire (l'Utilitaire de Disque ne fait pas ça mais que les permissions système):
- démarrage sur le DVD de SL
- réinitialiser mot de passe (oui, c'est là mais on ne va pas changer le psswd)
- choisir ton disque et ton utilisateur
- réinitialiser avec le bouton en bas à droite
HT1274_Leopard.png
 

Stemba

Membre enregistré
6 Octobre 2011
7
0
Cela ne marche toujours pas :(

c'est vraiment bizare je n'ai juste pas les droit sur ce dossier la mais aucun problème sur le reste de l'arborescence !
 
Dernière édition:

Stemba

Membre enregistré
6 Octobre 2011
7
0
Problème résolut, pour ceux qui serai dans ce cas, faite GetInfo du répertoire et vérifié si l'option locked est coché.

Si c'est le cas, décoché la (cette option n'est pas visible avec la commande ls -l !).

Je pense que mon Back up Time machine a activé cette option.

Merci tout de même edd72 :)