Problème d'installation

Karateka

Membre junior
11 Août 2010
36
1
28
désolé je n'avais pas vérifié une partie des noms de fichiers. voilà la version corrigé, à lancer dans une nouvelle fenêtre du terminal.
cd ./Downloads/stockfish-8-mac/Mac/ et entrée.
chmod +x stockfish-8-64 et entrée.
./stockfish-8-64 et entrée.

Mon Dieu ! Ca ne se terminera jamais je crois... J'ai ça :

-bash: ./stockfish-8-64: No such file or directory
 
  • Snif
Réactions: meeshoot

meeshoot

Membre junior
14 Juin 2008
15
2
il y a un simple problème de chemin je pense... au moment du désarchivage il y a peut etre différence avec chez moi.
en fait il faudrait que tu vérifie les dossiers de la première commande, cela pourrait ressembler à ça :
cd ./Downloads/stockfish-8-mac/stockfish-8-mac/Mac/ et entrée.
est-ce que cette première commande se lance sans rien retourner ?
--
si rien est retourner alors seulement tu peux passer à la suite :
chmod +x stockfish-8-64 et entrée.
./stockfish-8-64 et entrée.
 

Karateka

Membre junior
11 Août 2010
36
1
28
il y a un simple problème de chemin je pense... au moment du désarchivage il y a peut etre différence avec chez moi.
en fait il faudrait que tu vérifie les dossiers de la première commande, cela pourrait ressembler à ça :
cd ./Downloads/[B]stockfish-8-mac[/B]/stockfish-8-mac/Mac/ et entrée.
est-ce que cette première commande se lance sans rien retourner ?
--
si rien est retourner alors seulement tu peux passer à la suite :
chmod +x stockfish-8-64 et entrée.
./stockfish-8-64 et entrée.

Je crois que le problème c'est ce que j'ai mis en gras. Le dossier dans Téléchargement s'appelle "Stockfish 8" et non pas "stockfish-8-mac" comme pour le Stockfish 11. Je ne sais pas si c'est ça le souci...
 

meeshoot

Membre junior
14 Juin 2008
15
2
Effectivement cela vient bien d'un souci de différence entre nos logiciels pour désarchiver, il faut alors que tu remplace par
cd ./Downloads/Stockfish \8/Mac/
J'ai un doute sur le \ donc si cela ne marche pas il te suffit de taper cd ./Downloads/Sto et d'appuyer plusieurs fois sur la touche tabulation pour que le terminal te complète le chemin.
 

Karateka

Membre junior
11 Août 2010
36
1
28
Effectivement cela vient bien d'un souci de différence entre nos logiciels pour désarchiver, il faut alors que tu remplace par
cd ./Downloads/Stockfish \8/Mac/
J'ai un doute sur le \ donc si cela ne marche pas il te suffit de taper cd ./Downloads/Sto et d'appuyer plusieurs fois sur la touche tabulation pour que le terminal te complète le chemin.

J'ai donc fait comme tu m'as dit, avec tabulation et tout... Le résultat c'est :

Stockfish 8 64 by T. Romstad, M. Costalba, J. Kiiski, G. Linscott

Rien de plus... =/
 

meeshoot

Membre junior
14 Juin 2008
15
2
ok, quelque chose m'échappe. On peut essayer Komodo si tu veux ?
le principe est le même, il y a un fichier a rendre exécutable puis à lancer.
http://komodochess.com/pub/komodo-9.zip si tu le n'a pas déjà.

Bloc de code:
cd ./Downloads/komo... TAB ..../komodo-9_9dd577/OSX[/ICODE] (tu vas avoir plusieurs sous dossier le but étant d'arriver au dossier OSX
Bloc de code:
chmod -x komodo-9.02-64-osx
Bloc de code:
./komodo-9.02-64-osx

je croise les doigts et me déconnecte pour ce soir.
j'espère ne pas t'avoir fait veiller sans résultat :(

ps: c'est vraiment des applications informaticiens ;)
 
Dernière édition par un modérateur:

Karateka

Membre junior
11 Août 2010
36
1
28
ok, quelque chose m'échappe. On peut essayer Komodo si tu veux ?
le principe est le même, il y a un fichier a rendre exécutable puis à lancer.
http://komodochess.com/pub/komodo-9.zip si tu le n'a pas déjà.

cd ./Downloads/komo... TAB ..../komodo-9_9dd577/OSX (tu vas avoir plusieurs sous dossier le but étant d'arriver au dossier OSX
chmod -x komodo-9.02-64-osx
./komodo-9.02-64-osx

je croise les doigts et me déconnecte pour ce soir.
j'espère ne pas t'avoir fait veiller sans résultat :(

ps: c'est vraiment des applications informaticiens ;)

J'ai essayé Komodo, mais c'est pareil. Voilà le résultat après avoir bien méticuleusement fait le nécessaire :

-bash: ./komodo-9.02-64-osx: Permission denied


Enfin bref. Ca ne fait rien. Merci à toi d'avoir été si patient avec moi. Je sais que j'ai abusé de ta gentillesse.
Si on trouve une solution demain ou un autre jour, tant mieux, sinon merci pour tout.

Bonne nuit !
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
35 797
4 341
Je me tourne vers vous parce que j'ai un gros souci d'installation d'applications sur mon ordinateur (OS X 10.11.5 El Capitan). J'ai regardé toutes les vidéos possible, je ne trouve pas de solution.
Officiellement ce petit jeu est compatible macOS Catalina...

Capture-001.jpg

...aucun souci sous macOS Mojave...

Capture-000.jpg

...alors si des membres peuvent confirmer ou pas un problème sous macOS Catalina, c'est le moment.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
35 797
4 341
Merci pour ta réponse. Si je comprends bien, pour jouer à Stockfish 11, je dois impérativement faire une mise à jour du logiciel ?
Non, tu mentionnes ceci...
Je me tourne vers vous parce que j'ai un gros souci d'installation d'applications sur mon ordinateur (OS X 10.11.5 El Capitan). J'ai regardé toutes les vidéos possible, je ne trouve pas de solution.
...et moi je mentionne via la copie écran que l'éditeur annonce que son logiciel est compatible à partir de la version macOS High Sierra 10.13 et ultérieure, donc compatible macOS Catalina 10.15. Pour ma part, je n'ai eu aucun problème d'installation depuis App Store sous macOS Mojave.

Par curiosité, télécharges ce fichier...
Bloc de code:
https://mega.nz/#!lApVVKrC!e7k_mJ-mmrgy1xdKbQw8fggr-0d5_z2a-aMz_EpSI9E
...après décompression et un double-clic dessus, il se passe quoi ?
 
  • J’aime
Réactions: meeshoot

Karateka

Membre junior
11 Août 2010
36
1
28
Par curiosité, télécharges ce fichier...
Bloc de code:
https://mega.nz/#!lApVVKrC!e7k_mJ-mmrgy1xdKbQw8fggr-0d5_z2a-aMz_EpSI9E
...après décompression et un double-clic dessus, il se passe quoi ?

J'ai fait ça. L'application apparait mais il y a un panneau sens interdit blanc dessus. Et au double-clic, il y a ce message dans une fenêtre :

"Vous avez OS X 10.11.5. L’application requiert OS X 10.13 ou ultérieur."
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
35 797
4 341
"Vous avez OS X 10.11.5. L’application requiert OS X 10.13 ou ultérieur."
Il faudrait qu'un membre sous macOS Catalina teste aussi le fichier que j'ai mis en ligne, car là je ne comprends pas !
 
  • J’aime
Réactions: meeshoot et Karateka