MacBook Pro Problème hibernation/mise en veille après changement SSD

angelet78

Membre junior
12 Février 2021
32
1
38
ok donc je dois avoir un firmware 430.0.0.0 si je comprends bien..mais impossible de l'avoir sans le ssd original?..j'ai une sauvegarde de l'original sur un hdd externe..
 

ericse

Membre d’élite
Club MacG
30 Avril 2019
4 088
665
ok donc je dois avoir un firmware 430.0.0.0 si je comprends bien..
Oui ;)

mais impossible de l'avoir sans le ssd original?..
Ca on ne sait pas exactement, la mise à niveau du firmware est délicate et ne se fait que si toutes les conditions sont requises, mais Apple ne communique pas la liste de ces conditions.

Soit tu veux essayer différentes choses dans l'espoir que ça finisse par mettre à jour le firmware, soit tu laisse tomber et tu désactives le mode veille pour éviter le reboot (comme je proposais message #238)

j'ai une sauvegarde de l'original sur un hdd externe..
Pas utile pour ce problème.
 

angelet78

Membre junior
12 Février 2021
32
1
38
Oui ;)


Ca on ne sait pas exactement, la mise à niveau du firmware est délicate et ne se fait que si toutes les conditions sont requises, mais Apple ne communique pas la liste de ces conditions.

Soit tu veux essayer différentes choses dans l'espoir que ça finisse par mettre à jour le firmware, soit tu laisse tomber et tu désactives le mode veille pour éviter le reboot (comme je proposais message #238)


Pas utile pour ce problème.
j'ai effacé la mémoire persistante de Big Sur bootant sur usb externe lorsque j'étais sous majove, cela a bien était utile pour supprimer toute les partitions innutiles et plus de message disque lors du démarrage.
Mais mon problème de sortie de veille persistant, j'ai décidé de reinstaller Big Sur bien propre comme vous me l'aviez conseillé en effaçant le ssd depuis la racine mais mon efi ou firmware n'a pas changé , et maintenant j'ai plus de problème lorsque je sort du mode veille.. pas encore vu la mise en someille profond lors de la fermeture de l'ecran..mais je veux revenir sur Majove car je n'arrive pas à utiliser big sur correctement..
 

Fichiers joints

  • Capture d’écran 2021-02-28 à 19.45.53.png
    Capture d’écran 2021-02-28 à 19.45.53.png
    242,2 KB · Affichages: 13

JCM94

Nouveau membre
28 Mars 2021
5
0
46
bonjour j'ai un Mac Book Pro 2012 High Sierra. Récemment, un atelier MAC a mis une nouvelle batterie et changé le disque dur défectueux par un SSD. Depuis, j'ai un écran gris foncé à la sortie hibernation (sur batterie); Je suis obligé de forcer un rédémarrage. J'ai changé le mode hibernate après lecture sur quelques forums à 0 au lieu de 3 mais je ne suis pas si sûr que ce soit la solution..

voici le pmset-g :

standbydelay 4200
standby 0
halfdim 1
sms 1
hibernatefile /var/vm/sleepimage
disksleep 10
sleep 10
autopoweroffdelay 14400
hibernatemode 0
autopoweroff 1
ttyskeepawake 1
displaysleep 3
acwake 0
lidwake 1

merci pour vos conseils !
 

JCM94

Nouveau membre
28 Mars 2021
5
0
46
Bonjour,
Il y a plusieurs modèles 2012, il faudrait donner l’intitulé exact tel qu’il apparaît dans la fenêtre A propos de ce Mac, ou faire une copie d’écran.
ok voici un détail :

Nom du modèle : MacBook Pro
Identifiant du modèle : MacBookPro9,2
Nom du processeur : Intel Core i5
Vitesse du processeur : 2,5 GHz
Nombre de processeurs : 1
Nombre total de cœurs : 2
Cache de niveau 2 (par cœur) : 256 Ko
Cache de niveau 3 : 3 Mo
Mémoire : 4 Go
Version de la ROM de démarrage : 233.0.0.0.0
Version SMC (système) : 2.2f44
 

JCM94

Nouveau membre
28 Mars 2021
5
0
46
trouvez vous que désactiver l'hibernation est une bonne chose pour un ancien mac book pro à qui on a installé un SSD ? ou il y a d'autres solutions ? j'ai lu aussi qu'il fallait décocher l'option "suspendre l'activité des disques durs" dans l'économiseur car ça pouvait créer des conflits sachant que c'est un SSD installé ...
 

ericse

Membre d’élite
Club MacG
30 Avril 2019
4 088
665
Identifiant du modèle : MacBookPro9,2
Ce modèle n'a habituellement aucun problème d'hibernation, donc les solutions que tu peux trouver sur internet ont beaucoup de chances de s'appliquer à un autre modèle. Mais il a fréquemment un problème de nappe SATA, qu'il faut remplacer lorsque l'on met un SSD. Ca ne se manifeste d'habitude pas lors de la sortie de veille, mais c'est possible, il faudrait demander à la boutique s'il l'ont remplacée en mettant le SSD.

Ensuite bien sur tu pourrais probablement désactiver la veille, mais ce n'est pas résoudre le problème, c'est le contourner en se passant de la fonction.
 

JCM94

Nouveau membre
28 Mars 2021
5
0
46
Ce modèle n'a habituellement aucun problème d'hibernation, donc les solutions que tu peux trouver sur internet ont beaucoup de chances de s'appliquer à un autre modèle. Mais il a fréquemment un problème de nappe SATA, qu'il faut remplacer lorsque l'on met un SSD. Ca ne se manifeste d'habitude pas lors de la sortie de veille, mais c'est possible, il faudrait demander à la boutique s'il l'ont remplacée en mettant le SSD.

Ensuite bien sur tu pourrais probablement désactiver la veille, mais ce n'est pas résoudre le problème, c'est le contourner en se passant de la fonction.
merci pour la réponse. Mais la nappe SATA a été changée aussi donc pas de souci de ce coté là...
 

ericse

Membre d’élite
Club MacG
30 Avril 2019
4 088
665
merci pour la réponse. Mais la nappe SATA a été changée aussi donc pas de souci de ce coté là...
Alors ça peut être le SSD (mais c'est très peu probable), ou la RAM, et sinon la carte mère...
Si tu as constaté ce problème peu de temps après l'intervention en atelier, il vaudrait mieux leur demander de regarder et de réparer le problème.
 

Shav

Membre junior
3 Décembre 2014
12
2
Bonjour à tous,
Je relance mon sujet car j'ai essayé beaucoup de choses mais rien n'y fait malheureusement...

Rappel:
Depuis le changement de batterie + SSD + RAM de mon MacBook Pro 13" mi-2012, celui-ci s'éteints de manière un peu aléatoire lorsqu'il est en veille.
Parfois c'est après 30 minutes, parfois après quelques heures. A noter aussi que quand je le passe en veille (fermeture du capot) sur batterie et qu'il finit par s'éteindre anormalement, rebrancher l'alimentation fait qu'il se rallume ! Mais il s'éteints aussi lorsqu'il est en veille sur secteur... Bref je n'y comprends pas grand chose.
J'ai essayé les différents reset de SNC / PRAM, etc. rien n'y fait.

Une bonne âme pour m'éclairer stp ? Merci !
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
49 815
9 235
Nancy___
Une bonne âme pour m'éclairer stp ? Merci !
Tu pourrais sortir le SSD, le mettre dans un boitier externe, démarrer sur ton SSD devenu externe et voir si le problème se reproduit à l'identique.
Si la réponse est non --> change la nappe.
 

Shav

Membre junior
3 Décembre 2014
12
2
Tu pourrais sortir le SSD, le mettre dans un boitier externe, démarrer sur ton SSD devenu externe et voir si le problème se reproduit à l'identique.
Si la réponse est non --> change la nappe.
Merci je vais essayer. Je n'ai rien a faire au niveau logiciel ? Je sors le SSD, le rends externe et je peux rallumer le Mac sans autre intervention ?
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
49 815
9 235
Nancy___
Merci je vais essayer. Je n'ai rien a faire au niveau logiciel ? Je sors le SSD, le rends externe et je peux rallumer le Mac sans autre intervention ?
Tu le rallumes en gardant la touche alt enfoncée, pour pouvoir sélectionner ton disque de démarrage.
 

Shav

Membre junior
3 Décembre 2014
12
2
Tu as réussi à trouver une nappe entre hier et aujourd'hui ? Quelle efficacité :up:
Oui j'ai un MacWay près de chez moi ;)

Par contre j'ai parlé trop vite cette nuit je l'ai laissé en veille sur batterie et il s'est éteint (Il était à 100% lorsque j'ai débranché l'alimentation et 92% lorsque je l'ai rallumé. Je ne comprends vraiment rien c'est désespérant.
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
49 815
9 235
Nancy___
Par contre j'ai parlé trop vite cette nuit je l'ai laissé en veille sur batterie et il s'est éteint (Il était à 100% lorsque j'ai débranché l'alimentation et 92% lorsque je l'ai rallumé. Je ne comprends vraiment rien c'est désespérant.
Pour être sûr d'éliminer un problème de nappe, laisse ton disque branché en externe et travaille comme ça plusieurs jours.
Si les extinctions se produisent quand même, tu auras donc exclus un problème de nappe.

Que reste-t-il alors comme possibilité :
  • problème aléatoire de batterie ?
  • faux contacts ?
  • problème avec le connecteur d'alimentation (carte de raccordement) ?