MacBook Pro Problème hibernation/mise en veille après changement SSD

ericse

Membre d’élite
Club MacG
30 Avril 2019
2 571
325
Bonjour,
Je rajoute mon cas : MBPr 2013 avec un SSD NVMe Transcend, qui rencontre les mêmes problèmes de plantage à la sortie de veille profonde. L'utilitaire Transcend permet de corriger le problème, mais en étudiant ce qu'il fait, j'ai trouvé qu'il change juste 2 valeurs, les autres restant à leur valeurs par défaut :
Bloc de code:
 standby              0
 autopoweroff         0
 

lasperule

Membre confirmé
21 Janvier 2016
127
6
63
Si besoin en est.
Je vais juste signaler pour info que dans mon cas je n'ai pas eu de problèmes de plantage. Certainement dû au fait de ne pas avoir changé le ssd par un Transcend NVMe (avec adaptateur) mais par un Transcend JetDrive 850 (idem à l'origine).
Donc je n'ai pas eu à installer l'utilitaire (si qui a peut être évité ce problème supplémentaire)
 

foflarage

Membre confirmé
8 Août 2011
106
11
Si besoin en est.
Je vais juste signaler pour info que dans mon cas je n'ai pas eu de problèmes de plantage. Certainement dû au fait de ne pas avoir changé le ssd par un Transcend NVMe (avec adaptateur) mais par un Transcend JetDrive 850 (idem à l'origine).
Donc je n'ai pas eu à installer l'utilitaire (si qui a peut être évité ce problème supplémentaire)

Du coup ça semble confirmer ce que je soupçonne à savoir que c'est le fait que le SSD (format NVME non standard Apple) ne soit pas directement connecté à la CM mais via un adaptateur qui provoque ces problèmes d'hybernation/kernel panic...

Les manips des fabricants d'adaptateur vont aussi dans ce sens pour contourner le problème.

Lors d'un diagnostic de mon MBP, j'avais l'erreur VDH0002 qui semble indiquer une erreur liée à un périférique USB, du coup j'aurais tendance à penser que l'adaptateur "empêche" le mac de considérer le SSD comme un vrai DD dans les process d'hybernation...

Bon j'arrête les suppositions là... :)

Je vais tester un autre adaptateur et j'aviserai ensuite
 
Dernière édition:

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
35 223
4 154
Bon j'arrête les suppositions là... :)
Non, car je pense que tu es dans le vrai, mais difficile à prouver. Je crois en effet que c'est la qualité de l'adaptateur qui fait la différence, c'est à dire la reconnaissance totale de la barrette SSD. Mais quelle marque est la meilleure ?
 

ericse

Membre d’élite
Club MacG
30 Avril 2019
2 571
325
Du coup ça semble confirmer ce que je soupçonne à savoir que c'est le fait que le SSD (format NVME non standard Apple) ne soit pas directement connecté à la CM mais via un adaptateur qui provoque ces problèmes d'hybernation/kernel panic...
Non, car je pense que tu es dans le vrai, mais difficile à prouver. Je crois en effet que c'est la qualité de l'adaptateur qui fait la différence, c'est à dire la reconnaissance totale de la barrette SSD. Mais quelle marque est la meilleure ?

J'ai un NVMe sans adaptateur, et j'ai quand même le problème ;)

Je pense juste (comme ça a été déjà dit) que les Macbook Pro 2013-2014 ne sont pas 100% compatibles abec les SSD NVMe, avec ou sans adaptateur (qui n'est qu'un connecteur passif de toute façon). On gagne beaucoup en vitesse avec le NVMe, mais il y a une perte partielle de compatibilité, c'est un choix à faire...
 

ericse

Membre d’élite
Club MacG
30 Avril 2019
2 571
325
Si besoin en est.
Je vais juste signaler pour info que dans mon cas je n'ai pas eu de problèmes de plantage. Certainement dû au fait de ne pas avoir changé le ssd par un Transcend NVMe (avec adaptateur) mais par un Transcend JetDrive 850 (idem à l'origine).
Donc je n'ai pas eu à installer l'utilitaire (si qui a peut être évité ce problème supplémentaire)
Bonjour,
Ca dépend de ton modèle de Macbook : j'ai un JetDrive 850 sur un MBPr 2013 et j'ai le problème de reboot.
Par contre Transcend vend aussi la série JetDrive 820 qui est identique au SSD d'origine (non MVNe)
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
35 223
4 154
J'ai un NVMe sans adaptateur, et j'ai quand même le problème ;)
Ca me fait penser au fait qu'Apple faisait modifier le firmware de tous les disques durs à plateaux pour que ce soit OS X, macOS, qui gère la température et la vitesse du ventilateur. J'ai le sentiment que c'est la même chose avec les barrettes SSD non certifiées Apple ? On va me dire, on parle d'hibernation pas de température ni de vitesse, mais va savoir puisque ce type de problème devient, disons, récurrent avec pas mal de membres ?
 

lasperule

Membre confirmé
21 Janvier 2016
127
6
63
J'ai un NVMe sans adaptateur, et j'ai quand même le problème ;)
1 - Comment fais-tu pour brancher ce type de ssd sans adaptateur ?
2 - Quelle marque, modèle ce ssd ?
 

foflarage

Membre confirmé
8 Août 2011
106
11
1 - Comment fais-tu pour brancher ce type de ssd sans adaptateur ?
2 - Quelle marque, modèle ce ssd ?

La marque Transcend propose des SSD au format propriétaire Apple, ce sont les Jetdrive 850/820....


Il me semble qu’OWC propose le même genre de produits
 

lasperule

Membre confirmé
21 Janvier 2016
127
6
63
La marque Transcend propose des SSD au format propriétaire Apple, ce sont les Jetdrive 850/820....
C'est avec celui là que j'ai fait le remplacement sur mon MBP 13" Retina Early 2015.

Après le remplacement de ce ssd Transcend JetDrive 850 je n'ai pas installé leur utilitaire.

J'ouvre une parenthèse
Malgré ce qu'en dit Transcend, pour moi au vue de ses performances ce n'est pas vraiment un NVMe :
Par rapport a un vrai NVMe Samsung 970 Evo :
Je ferme la parenthèse.
 

ericse

Membre d’élite
Club MacG
30 Avril 2019
2 571
325
Résultat de cette nuit (MBPr 2013 avec standby 0 autopoweroff 0) :
Bloc de code:
2020-09-17 00:07:02 +0200 Sleep                   Entering Sleep state due to 'Clamshell Sleep': Using Batt (Charge:100%) 35974 secs
2020-09-17 10:06:36 +0200 Wake                    Wake from Deep Idle [CDNVA] : due to EC.LidOpen/Lid Open Using BATT (Charge:97%)
Donc pas de reboot, démarrage instantané, 3% de perte de batterie pour 10h.

Question : y a-t-il un meilleur choix de SSD pour un MBPr 2013 ? Un SSD Sata va être plus lent, un AHCI plus cher...
 

foflarage

Membre confirmé
8 Août 2011
106
11
Hello,

Bon un peu de news... j'ai reçu et testé un nouvel adaptateur (Qnine) et malheureusement résultat identique...

J'ai remis du coup le SSD d'origine et là miracle Apple plus de pb.... :mad:

Bref ça confirme ce que je pense, à savoir que les adaptateurs empêchent le MBP de considérer le SSD comme un SSD natif mais plus comme un DD externe bootable...

Reste à savoir comment sont considérés les SSD format Apple de Transcend ou OWC... a priori c'est a l'air un peu aléatoire...

Du coup, je renvois tout ce que j'ai acheté et je vais surement tester un Transcend JetDrive 850..
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
35 223
4 154
Je sentais bien que ce message serait intéressant. ;)
 

foflarage

Membre confirmé
8 Août 2011
106
11
Montage en cours, je vous tiens au courant dans quelques minutes...

Bon montage et clean install de Catalina done, pour l'instant ça se présente bien...

Pas de reboot en sortie de veille...

Je me laisse quand même quelques jours pour voir ce que ça donne et je le laisse sur batterie toute la nuit