10.12 Sierra Probleme kernel panic

flavienmaggs

Nouveau membre
10 Septembre 2017
5
0
34
bonjour les amis ! depuis ce matin jai un gros soucis avec mon macbook pro 2013 ! je l'utilisé normalement jusqu'a ce qui ne reponde plus , je l'ai eteint manuelement et depuis il ne se rallume plus .. du moins il se rallume mais avant la fin de la barre de chargement jai un message d'erreur panic cpu 2 caller ! jai essayer de le re demarrer en mode sans echec mais impossible de le demarrer en mode sans echec .. je suis desesperé :-/ ! si quelqu'un qs deja eu ce probleme une aide me serais tres utile merci
 

Fichiers joints

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
71 573
21 469
Forêt de Fontainebleau
Salut Flavien

Tu as bien l'affichage d'un kernel_panic (plantage du noyau). La raison en est la suivante : le processus INIT se choppe un SIGKILL en cours d'exécution.

Petite explication : le kernel une fois activé exécute une séquence dite "intra_kernel" : celle de l'injection des extensions (qui chez toi fonctionne sans problème) > puis inaugure uns séquence dite "extra_kernel" consistant en l'initialisation de l'OS proprement dit.

C'est le processus launchd (launch_daemon : service d'initialisation) qui est en charge de cette opération et à ce titre est le processus parent, ou premier des processus extra_kernel. Comme il a en en charge l'initialisation de l'OS > il est désigné aussi par le sobriquet INIT (INITIALIZATION).

C'est donc le processus launchd qui reçoit un SIGKILL qui signifie une signal d'extinction. Suite à quoi > il est coupé net, et lorsque le processus launchd coupe > le kernel plante automatiquement dans la foulée --> d'où kernel_panic.

Pourquoi un SIGKILL est-il adressé au processus launchd ? - je lis dans ta capture :
Bloc de code:
unexpected SIGKILL of init with reason -- namespace 9 code 0x1 description none
  • signal d'extinction inattendu adressé à launchd > avec pour raison -- suivi d'une indication dont je ne décode pas le sens.

----------

Je te conseille de démarrer ton Mac les 2 touches ⌘R tenues pressées ensemble jusqu'à l'affichage d'une  = démarrage sur le système de secours Recovery OS du disque.

  • Au cas où tu aurais activé le chiffrement «FileVault» > lance l'«Utilitaire de Disque» > sélectionne le nom de ton volume (Macintosh HD par défaut) qui serait alors grisé, car verrouillé par le chiffrement et donc non monté > va au menu Fichier > sous-menu Déverrouiller > renseigne ton mot-de-passe de session admin dans le panneau qui le demande --> le volume Macintosh HD doit être affiché en noir plein = remonté. Si tu n'as pas activé «FileVault» > saute cette étape.

  • Active l'option : Ré-installer macOS > à destination du volume monté de ton OS (une identification te sera demandée pour te connecter à l'AppStore). Un installateur de macOS (dans les 5 Go) sera téléchargé dans le volume de l'OS > puis le seul Logicel-Système restauré > sans que ton compte (avec ses données et réglages) ne soit touché > non plus que les applications tierces ajoutées.

=> si tout se passe bien et que l'extinction forcée de launchd ne soit due qu'à une erreur dans les fichiers du Système > tu devrais pouvoir ré-ouvrir ta session après restauration de l'OS.
 
  • J’aime
Réactions: flavienmaggs

Yuls

Membre d’élite
1 Juin 2003
1 034
165
41
Lyon
Dernière édition:
  • J’aime
Réactions: flavienmaggs

flavienmaggs

Nouveau membre
10 Septembre 2017
5
0
34
bonjour les amis , merci pour vos reponse , en conclusion , je n'avais aucun acces a mon disque dur par quelque soit le moyen , meme mon utilitaire de disque ne le trouvé pas , je ne sais pas exactement pourquoi ce disque dur ne marche plus...je l'ai donc changé par un samsung evo ssd ! cela marche niquel ! merci de votre aide, néanmoins j'essaye de récupérer les données sur mon ancien disque dur grace a un cable sata , mon mac ne le detecte pas quand je le branche , mais quand je le debranche jai le message d'erreur comme quoi je l'ai debranché sans l'ejecter , c'est vraiment bizarre il a l'air de bien tournee, je pense qu'un programe a l'interieur l'as fait completement tilté ! , et du coup les fichier racine os ne doivent pas charger ... bizarre , peut etre avais vous une autre expliquation ? cheers
 

flavienmaggs

Nouveau membre
10 Septembre 2017
5
0
34
merci pour ton aide , alors la raison au probleme , il y est ecrit : of init with reason -- namespace 9 code 0x1 description none...
 

Yuls

Membre d’élite
1 Juin 2003
1 034
165
41
Lyon
Ne le prends pas mal, ça devient difficile de te suivre et de comprendre tes actions avec un texte tapé au kilomètre, avec en moins la syntaxe et l'orthographe (j'ai même failli pas y répondre), donc ça serait sympa pour ceux qui te lisent, de faire un petit effort de relecture et de correction avant de poster. ;)

Pour en revenir à ton disque dur monté en externe avec câble SATA (lequel ? marque ?), peut-être qu'il est monté sur le bureau (ou dans le Finder) sans que tu t'en aperçoives, d'où le message comme quoi t'as éjecté le disque "à la sauvage" quand tu l'as débranché.
Vigilance de ne pas faire ça souvent, sous peine que ton disque externe rende définitivement l'âme :(
Je suppose que tu voulais récupérer des trucs dessus ? Des fichiers importants ?

As-tu tenté une réparation via Utilitaire de disque ?

D'où vient le message d'erreur "of init with reason -- namespace 9 code 0x1", suite à quelle action sur quoi ?

Pour le SSD fraîchement installé as-tu activé le TRIM ?
 

flavienmaggs

Nouveau membre
10 Septembre 2017
5
0
34
Ne le prends pas mal, ça devient difficile de te suivre et de comprendre tes actions avec un texte tapé au kilomètre, avec en moins la syntaxe et l'orthographe (j'ai même failli pas y répondre), donc ça serait sympa pour ceux qui te lisent, de faire un petit effort de relecture et de correction avant de poster. ;)

Pour en revenir à ton disque dur monté en externe avec câble SATA (lequel ? marque ?), peut-être qu'il est monté sur le bureau (ou dans le Finder) sans que tu t'en aperçoives, d'où le message comme quoi t'as éjecté le disque "à la sauvage" quand tu l'as débranché.
Vigilance de ne pas faire ça souvent, sous peine que ton disque externe rende définitivement l'âme :(
Je suppose que tu voulais récupérer des trucs dessus ? Des fichiers importants ?

As-tu tenté une réparation via Utilitaire de disque ?

D'où vient le message d'erreur "of init with reason -- namespace 9 code 0x1", suite à quelle action sur quoi ?

Pour le SSD fraîchement installé as-tu activé le TRIM ?
Je ne le prends pas mal du tout , je suis désolé je vie a l'etranger et je suis conscient d'en avoir perdu un peut mon orthographe , je m'en excuse !

je vais essayé de re expliquer mon probleme clairement .

si tu as lu le debut de ce post , tu auras compris que jai eu un probleme avec mon disque dur interne de mon mac book , celui ci n'etait plus reconnue je ne sais pas pourquoi , je l'utilisé normalement sur photoshop et le mac c'est bloqué , je l'ai rallumé et jai eu le message d'erreur que jai publier en photo au debut de ce post , le code etait un panic cpu .
pour répondre a Macomaniac qui ne voyais pas la suite de mon message d'erreur , il y est ecrit : sigkill of init with reason -- namespace 9 code 0x1 description none !

j'ai donc acheter un nouveau disque dur ainsi qu'un cable sata usb pour essayé de récuperer les donné de mon disque dur hs , jai changé ce disque dur par mon nouveau , celas fonctionne a merveille , et jai ensuite connecté mon ancien disque dur sur mon macbook grace au cable sata usb ,le disque dur a l'air de bien tourner , mais mon mac ne le detecte pas , du moins il n'apparait pas sur mon bureau ni dans le finder , néanmoins quand je le déconnecte , le macbook me donne le message d'erreur comme quoi je l'ai deconnecté sans l'éjecté , celas veut dire qu'il le détecte mais je ne le vois nullepart , si j'ouvre mon utilitaire de disque , il ne se passe rien du tout , la fenetre de l'utilitaire s'ouvre , mais reste en chargement de disque et ca peut charger comme ca pendant des heures sans detecter mon disque dur ... jai essayer autre chose , au demarrage du mac en pressant alt , il apparait bien mes 2 disques dur , le nouveau que jai changé puis l'ancien que jai mis en usb data , je clique dessus pour demarrer avec celui ci , mais comme par avant celas ne m'ai impossible le message d'erreur panic cpu est toujours la , jaimerais recuperer des choses importante sur ce disque ..
 

flavienmaggs

Nouveau membre
10 Septembre 2017
5
0
34
Essaie avec ce type de logiciels à installer sur ton SSD :

Pour tenter de réparer le dd : Diskwarrior ou bien Techtool pro

Pour tenter de récupérer les données : Datarescue ou bien Photorec ou encore Stellar Phoenix® Mac Data Recovery
merci pour ta réponse , J'ai fait un rebuild avec Diskwarrior , mais le rebuilding stop a la step 5 of 10 , celui ci me dit que la vitesse du disque est réduite , disfonctionement : 10 !
je pense que mon disque est bien mort , le principale c'est que mon macbook re fonctionne , je vous remercie a tous pour votre aide
 

Fichiers joints