Problème publication de site avec iweb et cyberduck

LeProf

j'aime pas les mômes !!
Club MacG
30 Novembre 2004
1 654
206
"On dirait le SUD..."
Bonjour,

donc je vous expose mon problème:

J'ai fait un site avec iweb, que je publie sur mon disque dur.
Puis avec cyberduck, j'uploade le site vers mon hébergeur (orange).
Tout se passe bien, j'ai vérifié plusieurs fois que tous les fichiers étaient présents, etc... mais lorsque je vais sur internet et que je navigue sur le site, un grand nombre de mes pages ne sont pas disponibles, et j'ai un message d'erreurs du serveurs d'hébergement:"Erreur 404: Fichier non trouvé. La page demandée a été retirée, modifiée déplacée ou renommée."

Je n'arrête pas de le republier puis de faire des uploads du site, etc ... mais rien n'y fait ??!!

Quelqu'un aurait-il une solution ?
 

LeProf

j'aime pas les mômes !!
Club MacG
30 Novembre 2004
1 654
206
"On dirait le SUD..."
Je viens de constater que toutes les pages qui donnent lieu à l'erreur 404, sont des pages dont le nom comporte un accent.
Par exemple: "Découvrir Peyriac de Mer" ou "La nature en vélo", etc....

Je ne me vois pas pourtant, nommer ces pages dans iweb sans mettre les accents ???!!! une solution ?
 

LeProf

j'aime pas les mômes !!
Club MacG
30 Novembre 2004
1 654
206
"On dirait le SUD..."
je me suis rendu compte un peu tard qu'il y avait des sujets concernants ces problèmes d'accents.

Quand tu dis de tout supprimer, dois-je supprimer les dossiers qu'il y avait en natif quand j'y ai accédé pour la première fois ? (j'ai un dossier Data, erreurs, ... mis par l'hébergeur)
 

LeProf

j'aime pas les mômes !!
Club MacG
30 Novembre 2004
1 654
206
"On dirait le SUD..."
Bon j'ai pris le parti de supprimer les accents et cela fonctionne !!!

Voilà le site www.peyriacdemer.org

J'ai maintenant juste un soucis de mise en forme: dans iweb il n'apparaît pas mais sur safari oui.
Je m'explique:les bandeaux vert et orange empiètent sur le menu de navigation iweb.
 

pierre-auvergne

Membre d’élite
Club MacG
Bon j'ai pris le parti de supprimer les accents et cela fonctionne !!!

Voilà le site www.peyriacdemer.org

J'ai maintenant juste un soucis de mise en forme: dans iweb il n'apparaît pas mais sur safari oui.
Je m'explique:les bandeaux vert et orange empiètent sur le menu de navigation iweb.

Ce n'est pas mortel; il faut faire attention pour s'en rendre compte. Pour les bandeaux, regarde en local, et joue avec les boutons "en dessous" "au dessus".

A+
 

LeProf

j'aime pas les mômes !!
Club MacG
30 Novembre 2004
1 654
206
"On dirait le SUD..."
Ce n'est pas mortel; il faut faire attention pour s'en rendre compte. Pour les bandeaux, regarde en local, et joue avec les boutons "en dessous" "au dessus".

A+

Oui je sais, mais je suis un perfectionniste .... ca peut être une qualité, mais aussi un défaut :D
... et comme c'est mon premier site et destiné à la mairie de mon village, je veux que ce soit parfait ;)


en tous les cas, j'y travaille.

Sinon, globalement, qu'en penses-tu ?
 

magicPDF

abracadabrantesque
Modérateur
Club MacG
5 Décembre 2007
7 629
739
43.93 N / 4.84 E
abracadabraPDF.net
Par principe : pas de caractères non-ascii ni d'espace dans les noms de fichiers sur le web.

Il reste encore un lien foireux : <http://www.peyriacdemer.org/Site/La_nature_en_vélo.html>

Sinon le site est beau mais un peu long à charger (comme toujours avec iWeb).

:up:
 

Chamalo

Membre junior
12 Octobre 2007
19
0
38
Pour le probleme des accents. Même en faisant attention, iWeb en rajoute (par exemple le dossier Entrées).
Pour ne plus avoir de probleme (et en attendant qu'apple corrige tout ca), tu peux passer ton client FTP en mode UTF8 (je ne sais plus exactement ou c'est dans cyberduck, mais l option existe).
Ou alors utiliser ton programme en anglais.

J'ai fait comme ca, et je nai plus de prob.
Et c'est quand meme mieu d'avoir des Titre écrit en bon francais avec des accents :)
(oui car iweb prends le titre des pages pour composer le nom du fichier de la page).
 

magicPDF

abracadabrantesque
Modérateur
Club MacG
5 Décembre 2007
7 629
739
43.93 N / 4.84 E
abracadabraPDF.net
J'avais eu le même problème avec Fetch : tous les caractères accentués étaient transformés...

J'avais résolu le problème en utilisant l'excellent et gratuit OneButton FTP, localisé en VF qui plus est (et aussi en n'utilisant plus iWeb mais c'est une autre histoire).

Il n'est plus supporté et n'évoluera plus mais en attendant une future version incompatible de MAC OS X, il fonctionne très bien avec X.4 et X.5

http://abracadabrapdf.net/articles.php?lng=fr&pg=152

http://onebutton.org/

:up: