Activation trackpad

mrb2

Membre junior
12 Février 2007
39
0
32
Bonjour tout le monde,

Mon ancien Macbook est décédé dernièrement et j'ai installé mon tout nouveau macbook aujourd'hui. Seulement lorsque je branche ma souris bluethoot, le trackpad se désactive, j'aimerais bien que ce ne soit pas le cas. Mais je trouve aucune option sous souris, ...

Merci d'avance
 

surfman06

Membre d’élite
Club MacG
22 Février 2007
1 003
43
On dirait le sud.
Il ne reste plus que l'onglet bluetooth dans préférences systèmes et de rechercher ce qui pose problème dans les options de cet onglet, j'ai été voir mais je ne vois pas ce qui peut poser l'arrêt du trackpad, à moins qu'on puisse forcer le système à utiliser le périphérique bluetooth au lieu du périphérique par défaut.
 

surfman06

Membre d’élite
Club MacG
22 Février 2007
1 003
43
On dirait le sud.
Perso, j'ai le nouveau MacBook Alu avec souris Apple bluetooth et clavier bluetooth, mon trackpad fonctionne très bien.
Essaie de désinstaller t'as souris dans la liste des appareils reconnus dans bluetooth et refais une détection de ta souris, peut être que tout rentrera dans l'ordre.
 

Mister-Photos

Membre junior
11 Mai 2008
17
0

Frodon

Membre d’élite
Club MacG
29 Juin 2002
2 838
363
40
France (Nantes)
Ce problème est connu, il vient que dans ton ancien portable tu avais l'option "Ignorer le trackpad lorsque la souris est connecté".
Or je supposes que tu as récupéré tes données de ton ancien MacBook, et donc ton nouveau MacBook a hérité de ce paramètre.

Un moyen de t'assurer que cela vient de là, est de créer un autre compte utilisateur et de voir si ca le fait aussi en te connectant sur ce nouveau compte.
Normalement cela ne doit alors pas le faire, ce qui confirmerait que c'est les fichiers de ta migration depuis les données de ton ancien MacBook qui posent problème.

Et comme tu l'as constaté, l'option précédemment citée n'est plus disponible dans le nouveau panneau de préférences "Trackpad".
Le fichier incriminé est l'un des fichiers .plist de Utilisateurs/<ton nom d'utilosateur>/Bibliotheque/Preferences et très certainement le fichier cacher .GlobalPreferences.plist

Tu peux supprimer ce dernier en ouvrant un Terminal (Qui est dans Applications/Utilitaires) et en tapant:

rm ~/Library/Preferences/.GlobalPreferences.plist

(tu peux copier la ligne ci-dessus directement si tu préfères).

Ensuite tu dermes ta session actuelle (menu pomme -> Fermer la session) et tu te reconnecte. Ca devrait alors avoir disparu... Cependant il se pourrait alors que certaines de tes préférences soient revenus à la valeur par défaut. Il te faudra alors remettre les options que tu désires.