Automator : Conversion video impossible.

kooky

Membre confirmé
24 Juin 2010
130
7
Bonjour à tous,

Après un long silence sur le forum, me voici de retour. Malgré toutes les réticences que j'ai pu exprimer ici au sujet de Lion, piqué par la curiosité et l'attrait de certaines fonctions dont notamment la présence de voix françaises j'ai franchi le pas :) J'ai attendu d'avoir un peu de recul pour m'exprimer sur le sujet avant de poster mes impressions et remarques.

En attendant ce petit récapitulatif, je suis confronté à un problème avec automator et la conversion vidéo que j'ai choisi d'évoquer ici plutôt que dans la rubrique vidéo car j'ai l'intuition qu'il s'agit d'un problème de permissions/droits lié à Lion.

Le contexte : Lion 10.7.1, quicktime avec perian et automator.

Sous Snow Leopard, j'avais pour habitude de convertir des vidéos en H264/ADPCM issues de mon caméscope Toshiba en séquences Quicktime pour les monter dans iMovie par le biais d'un processus automator. A présent, quand je lance l'opération, la conversion s'arrête avec l'erreur suivante :

"CMA warning : Color tag is missing from the source video. Assuming rec 601 ..." suivi de "avconvert completed with error : -12906".

De même, toute conversion de films utilisant des codecs pris en charge par perian se plante dans automator avec un message disant en gros que la source n'est pas trouvée et qu'il est impossible le de créer le fichier !

C'est ce dernier message qui me fait penser à un problème lié à Lion. Mais après recherche, je n'ai rien trouvé sur ce code d'erreur.

J'ai d'abord pensé qu'il s'agissait d'un problème lié à périan ou quicktime. Or si je fais cette conversion manuellement dans quicktime cela fonctionne. De même si j'enregistre les actions dans automator.

C'est la fonction "Encoder le contenu multimédia" qui plante pour des raisons que j'ai du mal à cerner.

J'utilise les mêmes paramètres de conversion dans tous les cas : 480p.

Ce code d'erreur -12906 me fait penser à un problème de droits/permissions mais rien trouvé sur le net :(

Merci de votre aide par avance,
Kooky
 

kooky

Membre confirmé
24 Juin 2010
130
7
Salut et merci de ta réponse.

Honte sur moi, je n'avais même pas remarqué la présence de cette option que je viens de tester : j'ai exactement la même erreur : -12906

Au moins ce n'est pas automator qui est en cause mais bien la fonction elle-même :(

J'ai tenté une réparation des permissions sans aucun succès.

Peut-etre qu'elle passe directement par quicktime et zappe perian ???

Une idée ?
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 134
627
À côté (de ma plaque)
Tu as essayé de convertir un fichier compatible (.mov, MPEG-4, ou H.264) ?

(histoire de savoir si l'erreur est une erreur de fonction ou de fonctionnement = une fonction impossible ou une conversion corrompue)
 

kooky

Membre confirmé
24 Juin 2010
130
7
Re :)

J'ai essayé avec une video quicktime "pure" : une session d'enregistrement d'écran ...

Pas de soucis la conversion a fonctionné.

Ça me conforte dans l'idée que cette fonction zappe perian.

En fait, dans le cas qui m’intéresse c'est le codage audio qui pose soucis : mon caméscope produit du son en adpcm non pris en charge. La vidéo ne pose pas de soucis c'est du H264.

J'ai besoin d'une solution qui idéalement ne ré-encode que la piste audio avec un traitement par lot : Soit un script, un process automator ou une petite appli gratuite ou pas chere :)

Handbrake scanne un dossier mais il faut mettre manuellement en file d'attente chaque fichier :(

Je n'ai pas encore fouillé du côté d'actions supplémentaires à ajouter a automator. Si tu as une idée ou des sources à me proposer ?