10.13 High Sierra blocage barre de chargement au démarrage de mon mac

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
88 019
26 935
Forêt de Fontainebleau
Bonjour Guillaume

Quand tu cites ainsi la commande que tu as tentée :
J'ai tenté la commande rm /Vomumes/"Macintosh HD"/var/db/caches/opendirectory/*, mais ça ne semble pas fonctionner

  • le "Vomumes" au lieu de "Volumes" dans la commande est un lapsus calami de ta part à la retranscription ici ? - tu avais bien saisi : Volumes dans la commande ?

Par ailleurs > l'OS actuellement installé est-il High Sierra ? -->

- des loupés de programmation du Service d'Annuaire (qui gère les utilisateurs et les groupes) dans cet OS --> induisent des plantades variées liées à ce service. Une des plus retorses consiste dans une corruption du cache mbr_cache du Service d'Annuaire. Car le Service d'Annuaire (Open Directory) fonctionne à partir de & par l'intermédiaire d'un cache des bases de données des utilisateurs et des groupes - et pas par accès direct aux informations "on_disk" (càd. par prise en charge directe des fichiers de ces mêmes bases de données). Il s'ensuit que la corruption du cache --> ne donne pas lieu à un rattrapage par adressage direct aux informations du disque => mais induit un plantage. Celui du service d'ouverture de session LoginWindow qui prend en charge ce cache.​

- étant donné le contexte de fonctionnement "indirect" (par cache interposé) que je viens de brosser > une suppression du cache mbr_cache force le Service d'Annuaire à se référer aux informations primitives des bases de données du disque. Cette suppression permet souvent le déblocage du démarrage et de l'ouverture de session.​

En résumé : si tu avais bien passé la commande correcte et qu'au redémarrage il n'y ait pas eu déblocage d'ouverture de session => alors il faut passer au "plan B".
 

GuillaumeHer

Membre confirmé
22 Septembre 2018
59
2
42
J'ai repassé la commande pour être sur et ça ne passe pas: "No such file or directory" Quel est le plan B du coup?
Bloc de code:
-bash-3.2# rm /Volumes/"Macintosh HD"/var/db/caches/opendirectory/*
rm: /Volumes/Macintosh HD/var/db/caches/opendirectory/*: No such file or directory
-bash-3.2#
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
88 019
26 935
Forêt de Fontainebleau
Il y a un bogue de la commande rm dans la session de secours -->

- la commande commence par supprimer le fichier > puis lance une sous-commande de listage qui > ne trouvant plus l'objet qui vient d'être supprimé > retourne logiquement un : "no such file or directory". Sauf que ce constat a posteriori --> apparaît faussement comme un échec a priori à trouver l'objet et laisse penser que la commande a échoué.​

Donc redémarre quand même une fois sur ton volume habituel > afin de vérifier si l'ouverture de session n'aurait pas été débloquée. Tu n'as qu'à dire ici ce qui s'est passé. Si tu es toujours bloqué > le plan B consiste dans l'opération des « 4 r » -->

- recopie de Macintosh HD dans le volume d'un DDE USB (via une commande du Terminal) > reformatage > réinstallation > récupération des données du clone à la fin via l'Assistant de migration. Longuet mais efficace.​
 
D

Deleted member 18124

Invité
J’avais aussi ce problème ce matin à l’allumage de mon iMac.

J’ai seulement fait les opérations de vérification de disque à partir du terminal et c’est réglé.

Merci macomaniac pour les infos. :up:
 
Dernière édition par un modérateur:

Vinc3D

Membre enregistré
23 Avril 2019
2
0
Bonjour à tous,

Je me permets de poster ici car mon iMac subi une panne similaire au lancement depuis quelques jours.
Comme je commence à avoir utilisé la plupart des pistes de dépannage que j'ai pu trouver içi et là sur des sites spécialisés et dans l'aide officielle Apple, je me suis décidé à venir poster ici dans l'espoir d'obtenir une aide précieuse ainsi que des pistes de dépannages supplémentaires.

Voici les principaux symptômes :
- le système démarre jusqu'à l'affichage de l'écran avec le logo Apple et la barre de chargement
- la barre de chargement progresse de façon relativement rapide jusqu'environ les trois-quarts du chargement (il ne me semble pas en tout cas que la progression soit nettement plus lente qu'auparavant)
- passé cette étape, l'écran disparait puis s'affiche un écran gris / blanc qui semble figé
- parfois, et passé quelques minutes sur cet écran, le système reboot par lui-même

Voici quelques pistes de dépannages que j'ai tenté d'appliquer (probablement pas de manière judicieuse d'ailleurs) :
- plusieurs tentatives de démarrage en mode "Recovery" via ⌘R => non concluant, l'écran des utilitaires MacOS ne s'affichant même pas !
- reset du SMC et de la PRAM => sans effet non plus
- démarrage sur internet afin de télécharger le "kit de secours" via ⌘⌥R => après choix de mon wifi et saisie du mot de passe correspondant, j'accède bien à un écran de téléchargement avec une barre de progression. Après un redémarrage avec ⌥, je sélectionne le disque de récupération MacOS 10.13 ainsi que le réseau wifi. J’accède à l'écran de démarrage avec le logo Apple et la barre de chargement, toutefois, j'arrive à nouveau à un écran blanc / gris figé passé cet étape.
- démarrage en mode Verbose => ce mode de démarrage fonctionne bien, toutefois je suis incapable de déchiffrer les lignes affichées et je finis par arriver au même écran blanc figé que précédemment, sans pouvoir noter les informations contenues dans les dernières lignes du terminal (qui défilent trop rapidement).

Concernant la machine en elle-même, il s'agit d'un iMac mi-2011 27" qui tourne sur un MacOS High Sierra 10.13.

Merci par avance pour votre aide bienvenue et vos conseils !

Vinc3D
 

MoiioM

Membre enregistré
4 Mai 2019
1
0
51
Bonsoir à tous, moi je remarque que lorsque je désactive le coupe-feu natif du mac, et j'avais fait le teste aussi avec le pare feu à l'époque de mon anti-virus, alors le phénomène disparait.
 

Obalta

Membre confirmé
14 Mars 2019
25
0
25
@ Obalta

Ouvre la session de secours. Passe les commandes (séparément) :
Bloc de code:
diskutil list
df -H

  • qui affichent la configuration des disques et l'occupation des volumes montés

Poste les tableaux retournés (dans une fenêtre de code).

Bonjour,

Je m'excuse une fois de plus du retard, j'ai du mal a trouver du temps récemment.

Voila la commande comme demandé :

Bloc de code:
-bash-3.2# diskutil list
/dev/disk0 (internal):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                         121.3 GB   disk0
   1:                        EFI EFI                     314.6 MB   disk0s1
   2:                 Apple_APFS Container disk2         121.0 GB   disk0s2

/dev/disk1 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        +2.1 GB     disk1
   1:                  Apple_HFS OS X Base System        2.0 GB     disk1s1

/dev/disk2 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +121.0 GB   disk2
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh HD            87.8 GB    disk2s1
   2:                APFS Volume Preboot                 21.0 MB    disk2s2
   3:                APFS Volume Recovery                519.0 MB   disk2s3
   4:                APFS Volume VM                      1.1 GB     disk2s4

/dev/disk3 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +5.2 MB     disk3

/dev/disk4 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +524.3 KB   disk4

/dev/disk5 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +524.3 KB   disk5

/dev/disk6 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +524.3 KB   disk6

/dev/disk7 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +2.1 MB     disk7

/dev/disk8 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +524.3 KB   disk8

/dev/disk9 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +524.3 KB   disk9

/dev/disk10 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +12.6 MB    disk10

/dev/disk11 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +4.2 MB     disk11

/dev/disk12 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +1.0 MB     disk12

/dev/disk13 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +2.1 MB     disk13

/dev/disk14 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +524.3 KB   disk14

/dev/disk15 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +524.3 KB   disk15

/dev/disk16 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +1.0 MB     disk16

/dev/disk17 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +6.3 MB     disk17

/dev/disk18 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +6.3 MB     disk18

/dev/disk19 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +524.3 KB   disk19

/dev/disk20 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +2.1 MB     disk20

J'envoie le reste du tableau dans un autre message (+ de 5000 caractères)

Merci d'avance
 

Obalta

Membre confirmé
14 Mars 2019
25
0
25
@ Obalta

Ouvre la session de secours. Passe les commandes (séparément) :
Bloc de code:
diskutil list
df -H

  • qui affichent la configuration des disques et l'occupation des volumes montés

Poste les tableaux retournés (dans une fenêtre de code).

Voici le restant du tableau :

Bloc de code:
-bash-3.2# df -H
Filesystem     Size   Used  Avail Capacity iused      ifree %iused  Mounted on
/dev/disk1s1   2.0G   1.3G   720M    64%   45181 4294922098    0%   /
devfs          207k   207k     0B   100%     702          0  100%   /dev
/dev/disk3     5.2M   2.0M   3.2M    39%      21 4294967258    0%   /private/var/log
/dev/disk4     524k   147k   377k    29%       3 4294967276    0%   /Volumes
/dev/disk5     524k   152k   373k    29%       8 4294967271    0%   /private/var/tmp
/dev/disk6     524k   160k   365k    31%      12 4294967267    0%   /private/var/run
/dev/disk7     2.1M   143k   2.0M     7%       2 4294967277    0%   /private/tmp
/dev/disk8     524k   143k   381k    28%       2 4294967277    0%   /System/Installation
/dev/disk9     524k   303k   221k    58%      21 4294967258    0%   /private/var/db
/dev/disk10     13M   7.4M   5.2M    59%      91 4294967188    0%   /private/var/folders
/dev/disk11    4.2M   4.0M   238k    95%     256 4294967023    0%   /private/var/root/Library
/dev/disk13    2.1M   143k   2.0M     7%       2 4294967277    0%   /private/var/root/Library/Containers
/dev/disk14    524k   180k   344k    35%      11 4294967268    0%   /Library/Preferences
/dev/disk15    524k   160k   365k    31%       6 4294967273    0%   /Library/Preferences/SystemConfiguration
/dev/disk16    1.0M   184k   864k    18%       6 4294967273    0%   /Library/Keychains
/dev/disk17    6.3M   176k   6.1M     3%       2 4294967277    0%   /private/var/tmp/RecoveryTemp
/dev/disk18    6.3M   176k   6.1M     3%       2 4294967277    0%   /private/var/tmp/OSISPredicateUpdateProductTemp
/dev/disk19    524k   143k   381k    28%       2 4294967277    0%   /private/var/tmp/InstallerCookies
/dev/disk20    2.1M   143k   2.0M     7%       2 4294967277    0%   /Library/Logs/DiagnosticReports
-bash-3.2#
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
88 019
26 935
Forêt de Fontainebleau
Je vois qu'il y a 88 Go d'occupation de Macintosh HD. Par ailleurs > comme ce volume n'est pas listé dans le tableau de la commande df (qui mesure l'occupation des volumes montés) --> on va dire que FileVault est activé et verrouille ce volume => lequel n'est donc pas monté.

Je pense que pour te débloquer > il faudrait passer par le procédé dit des « 4 r » : recopie > reformatage > réinstallation > récupération -->

- pour effectuer la 1ère étape (recopie de Macintosh HD via une commande du Terminal) => il faudrait que tu disposes d'un DDE USB comportant environ 120 Go d'espace libre : est-ce que tu as ce genre d'appareil à ta disposition ?​
 

Obalta

Membre confirmé
14 Mars 2019
25
0
25
Je vois qu'il y a 88 Go d'occupation de Macintosh HD. Par ailleurs > comme ce volume n'est pas listé dans le tableau de la commande df (qui mesure l'occupation des volumes montés) --> on va dire que FileVault est activé et verrouille ce volume => lequel n'est donc pas monté.

Je pense que pour te débloquer > il faudrait passer par le procédé dit des « 4 r » : recopie > reformatage > réinstallation > récupération -->

- pour effectuer la 1ère étape (recopie de Macintosh HD via une commande du Terminal) => il faudrait que tu disposes d'un DDE USB comportant environ 120 Go d'espace libre : est-ce que tu as ce genre d'appareil à ta disposition ?​

Pas pour le moment malheureusement, je m’occupe d’en récupérer un et je reviens vers vous.

Merci de la réponse rapide.
 

musiquepat2703

Membre enregistré
26 Septembre 2011
7
0
Bonjour dona-ella

Si tu démarres ton Mac les 2 touches ⌘R (cmd R) tenues pressées ensemble --> est-ce que tu vois s'afficher une  > et est-ce que tu atteins un écran où s'affiche une fenêtre avec 4 Utilitaires macOS ?
Bonjour Macomaniac. J’ai le même problème mais quand je démarre sur commande R , la planète apparaît mais dès que le téléchargement est terminé , l’ecran Gris apparaît de nouveau et aucun accès à rien
 

musiquepat2703

Membre enregistré
26 Septembre 2011
7
0
Bonjour dona-ella

Si tu démarres ton Mac les 2 touches ⌘R (cmd R) tenues pressées ensemble --> est-ce que tu vois s'afficher une  > et est-ce que tu atteins un écran où s'affiche une fenêtre avec 4 Utilitaires macOS ?
Bonjour Macomaniac , j’ai le même problème que Dona ela, pouvez vous m’aider s’il vous plaît ?
 

musiquepat2703

Membre enregistré
26 Septembre 2011
7
0
Bonjour à tous,

Je me permets de poster ici car mon iMac subi une panne similaire au lancement depuis quelques jours.
Comme je commence à avoir utilisé la plupart des pistes de dépannage que j'ai pu trouver içi et là sur des sites spécialisés et dans l'aide officielle Apple, je me suis décidé à venir poster ici dans l'espoir d'obtenir une aide précieuse ainsi que des pistes de dépannages supplémentaires.

Voici les principaux symptômes :
- le système démarre jusqu'à l'affichage de l'écran avec le logo Apple et la barre de chargement
- la barre de chargement progresse de façon relativement rapide jusqu'environ les trois-quarts du chargement (il ne me semble pas en tout cas que la progression soit nettement plus lente qu'auparavant)
- passé cette étape, l'écran disparait puis s'affiche un écran gris / blanc qui semble figé
- parfois, et passé quelques minutes sur cet écran, le système reboot par lui-même

Voici quelques pistes de dépannages que j'ai tenté d'appliquer (probablement pas de manière judicieuse d'ailleurs) :
- plusieurs tentatives de démarrage en mode "Recovery" via ⌘R => non concluant, l'écran des utilitaires MacOS ne s'affichant même pas !
- reset du SMC et de la PRAM => sans effet non plus
- démarrage sur internet afin de télécharger le "kit de secours" via ⌘⌥R => après choix de mon wifi et saisie du mot de passe correspondant, j'accède bien à un écran de téléchargement avec une barre de progression. Après un redémarrage avec ⌥, je sélectionne le disque de récupération MacOS 10.13 ainsi que le réseau wifi. J’accède à l'écran de démarrage avec le logo Apple et la barre de chargement, toutefois, j'arrive à nouveau à un écran blanc / gris figé passé cet étape.
- démarrage en mode Verbose => ce mode de démarrage fonctionne bien, toutefois je suis incapable de déchiffrer les lignes affichées et je finis par arriver au même écran blanc figé que précédemment, sans pouvoir noter les informations contenues dans les dernières lignes du terminal (qui défilent trop rapidement).

Concernant la machine en elle-même, il s'agit d'un iMac mi-2011 27" qui tourne sur un MacOS High Sierra 10.13.

Merci par avance pour votre aide bienvenue et vos conseils !

Vinc3D


Exactement le même Problème pour moi. Y a t’il un moyen de désactiver le coupe feu à partir de la sauvegarde Time maschine en target sur un autre Mac ?
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
88 019
26 935
Forêt de Fontainebleau
Bonjour musiquepat

Peux-tu détailler ton problème ? -->

- ton OS est-il High Sierra ? - la barre de chargement de l'OS se remplit-elle complètement ? - à vitesse normale pour la 1ère partie > très lentement pour la second ? - sans que la session ne s'ouvre à la fin ?​
 

Obalta

Membre confirmé
14 Mars 2019
25
0
25
Je vois qu'il y a 88 Go d'occupation de Macintosh HD. Par ailleurs > comme ce volume n'est pas listé dans le tableau de la commande df (qui mesure l'occupation des volumes montés) --> on va dire que FileVault est activé et verrouille ce volume => lequel n'est donc pas monté.

Je pense que pour te débloquer > il faudrait passer par le procédé dit des « 4 r » : recopie > reformatage > réinstallation > récupération -->

- pour effectuer la 1ère étape (recopie de Macintosh HD via une commande du Terminal) => il faudrait que tu disposes d'un DDE USB comportant environ 120 Go d'espace libre : est-ce que tu as ce genre d'appareil à ta disposition ?​

Bonjour,

Suite à ce dernier message, j’ai fais l’acquisition d’un disque dur et j’ai essayé d’appliquer ce procédé (en cherchant dans les précédents posts ou c’est expliqué mais je n’ai pas réussi à appliquer la méthode, la commande est peut être différente pour mon cas) :(