• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

iMac clavier CHERRY mal reconnu sur iMac

delmic

Membre confirmé
22 Août 2005
235
10
54
dans le Sud ...
Bonjour,

J'ai récemment acheté un clavier CHERRY STRAIT 3.0 USB qui fonctionne à peu près normalement, sauf que deux touches semblent être échangées : "@" et "<" (quand je tape "@", j'obtiens "<" et inversement).

Lors de la première connexion, j'ai eu accès à l'assistant réglages clavier, et je pense que mon choix n'a pas été le bon, mais impossible depuis de retrouver cet assistant !

De plus, en branchant 2 claviers sur le Mac (le cherry + un clavier Apple filaire), et en activant le visualisateur de clavier, j'obtiens un truc assez bizarre :
- si je tape une lettre sur le clavier Apple, le visualisateur affiche
upload_2019-8-29_13-18-42.jpeg

- si j'utilise le CHERRY, l'image devient :
upload_2019-8-29_13-16-31.jpeg


Si quelqu'un connaît une bidouille pour faire oublier le clavier CHERRY à mon Mac (sans jeux de mot), ou pour accéder directement à l'assistant réglages claviers, afin de pouvoir refaire la config, je suis preneur !
 

Fichiers joints

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
34 430
3 906
Nancy___
Bonjour,

En passant par les Préférences Système / clavier / clavier / changer le type de clavier, tu n'y arrives pas ?
 

delmic

Membre confirmé
22 Août 2005
235
10
54
dans le Sud ...
Merci pour ta réponse.

En passant par les Préférences Système / clavier / clavier / changer le type de clavier, tu n'y arrives pas ?
Ben aujourd'hui : si… mais pas hier !
Très bizarre : en fait, l'option "changer le type de clavier" était inactive (J'avais beau cliquer, rien ne se passait !)

Ce matin, je cherchais en désespoir de cause à installer "Karabiner-Elements", pour remapper correctement les 2 touches, et lors du lancement de cette application, je me suis retrouvé directement dans l'"assistant réglages clavier", qui depuis s'active à nouveau lorsque je passe par Préf. Syst. / clavier / clavier / changer le type de clavier.

Donc a priori le problème semble réglé (jusqu'au prochain bug).
 

delmic

Membre confirmé
22 Août 2005
235
10
54
dans le Sud ...
là, j'y perd mon latin…
L'assistant réglages clavier marche à nouveau, mais le problème décrit dans mon 1er post reste entier. J'ai juste découvert qu'il était propre à ma session.

Lorsque j'active le visualisateur de clavier après avoir lancé ma session, j'optiens ceci tant que je ne frappe aucune touche :
upload_2019-9-2_0-43-29.jpeg


la moindre touche enfoncée à comme effet de transformer immédiatement l'image en :
upload_2019-9-2_0-44-34.jpeg

  1. disparition de la touche "@" remplacée par "<"
  2. inversion de ces 2 touches sur le clavier physique ("@" = "<" et inversement)
  3. disparition du clavier numérique
pour l'instant, je n'ai trouvé comme parade que "Karabiner-Elements", configuré comme suit, pour régler le point 2. :
upload_2019-9-2_0-51-27.jpeg


Enfin, ce dysfonctionnement a lieu quel que soit le clavier (j'en ai testé 4), mais uniquement sur ma session.
Si quelqu'un à une piste ?
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
34 430
3 906
Nancy___
Ca pourrait être un fichier .plist vérolé.
Donc dans ta session / Bibliothèque / Préférences / et là ça se complique, il faut que tu trouves le fichier com.apple. xxxxxx .plist en lien avec la configuration du clavier.
Classe tes fichiers par ordre de modification.
 

delmic

Membre confirmé
22 Août 2005
235
10
54
dans le Sud ...
J'ai donc été fouiller dans les prefs, et supprimé ceci :
upload_2019-9-2_12-45-11.jpeg

Mais à part ça, je ne voie pas comment "viser" ce qui est en lien avec les prefs du clavier : dois-je tout supprimer ?

D'autre part, un nouvel essais attentif de l'assistant réglages clavier, en lisant bien les messages du système, me laisse perplexe :
au lancement, alors qu'un clavier apple azerty filaire est connecté et fonctionnel (à part les touches interversées et le bug d'affichage du visualisateur), j'obtiens ceci :
upload_2019-9-2_12-45-41.jpeg

puis ceci :
upload_2019-9-2_12-45-52.jpeg

si je tape la touche proposée, j'obtiens :
upload_2019-9-2_12-46-2.jpeg

et enfin, l'option [Ignorer] m'affiche :
upload_2019-9-2_12-46-13.jpeg

et quoi que je choisisse des 3 options, cela ne change rien.

C'est étrange car si le bug est bien sur le clavier Apple, on dirait qu'il détecte un autre clavier fantôme…
Du coup, j'ai tenté [Touches de modification…] dans Préférences Système / Clavier / Clavier, et cela me donne :
upload_2019-9-2_12-46-46.jpeg

Alors Karabiner, je comprends, je l'ai installé hier
Mais 2.4G Receiver !!!, que Karabiner baptise : 2.4G Receiver (Comps) ?

Voilà, donc en résumé il me faudrait trouver un moyen d'éradiquer 2.4G Receiver, de même d'ailleurs que Karabiner que je ne peux même pas désinstaller !
 

delmic

Membre confirmé
22 Août 2005
235
10
54
dans le Sud ...
AU SECOURS…

Ce coup-ci, non seulement l'assistant réglages clavier a disparu, le bug d'affichage du visualisateur continue, mais nouveau dysfonctionnement :
l'accès à "É" a également disparu (pour vous l'afficher, j'ai du taper "é" puis [Transformation]/[mettre en majuscule] avec TextEdit), alors qu'avant (et actuellement sous d'autres session du même iMac), il suffisait d'utiliser ⇪ puis la touche "é/2".

Quelqu'un aurait-il un truc type commande terminal pour réinitialiser la frappe et la config. clavier par exemple…
Sinon, à défaut, me faut-il recréer une session vierge (et donc à priori sans le bug) et mettre dedans peu à peu toute ma session actuelle ?
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
34 430
3 906
Nancy___
Dommage quand même de ne pas avoir acheté un clavier Apple, certes ils sont chers (mais robustes), mais quelle prise de tête ainsi évitée !
 

delmic

Membre confirmé
22 Août 2005
235
10
54
dans le Sud ...
Alors là on ne s'est pas bien compris…

comme précisé ici :
au lancement, alors qu'un clavier apple azerty filaire est connecté et fonctionnel
voici d'ailleurs le clavier :
upload_2019-9-3_21-22-35.jpeg


Les bugs énoncés (affichage visualisateur déficient /disparition de l'assistant clavier / "É" = "2") ont lieu avec un clavier Apple connecté (seul).
En revanche, ils n'ont lieu qu'avec ma session, d'où ma réflexion sur la création d'une session sans le bug !
 

delmic

Membre confirmé
22 Août 2005
235
10
54
dans le Sud ...
…j'ajoute qu'étant donné mes déboires avec un clavier Apple filaire, je n'ose envisager le Bluetooth. Or si je ne m'abuse, Apple ne produit même plus de filaire !
 

delmic

Membre confirmé
22 Août 2005
235
10
54
dans le Sud ...
Et ben un grand merci : j'ai tout fait.
Si les 2 premières options n'ont rien donné, le démarrage en mode sans échec m'a permis de trouver et de régler (provisoirement en tout cas, soyons prudent) le problème, qui à priori était double.


D'une part, Karabiner Elements (que j'avais pourtant installé après l'apparition du bug, et qui corrigeait correctement les touches inversées) semble avoir "fixé" ce problème en perturbant la reconnaissance du clavier par le système (avis aux utilisateurs potentiels).
J'ai un peu ramé pour le désinstaller, car il est vérouillé au niveau des infos du Finder (cadenas grisé impossible à désactiver), et il faut en fait fouiller les onglets de l'appli pour trouver l'option "uninstall".
J'ai l'impression que Karabiner Elements ne fait pas bon ménage avec la gestion système du clavier, en cas d'utilisation de plusieurs claviers, ce qui est mon cas. Toujours est-il qu'une fois désinstallé, le bug d'affichage du visualisateur ainsi que l'échange des touches ont disparu. Reste juste à savoir si je peux changer de clavier sans retrouver le problème, mais je vais provisoirement m'abstenir !!!

D'autre part, le problème du "É" disparu venait lui d'un mystérieux échange, dans Préférences Système / Clavier / Méthodes de saisie, entre "Français" et "Français - numérique", tous deux installés comme méthodes de saisie.
Le Français étant sélectionné à l'extinction, en redémarrant, le Français - numérique était automatiquement sélectionné à la place : en supprimant le Français - numérique des méthodes de saisie, mon "É" est redevenu opérationnel, même après redémarrage.

Il doit de toutes façons rester un bug dans mon système, car depuis des années lorsque je redémarre, la fenêtre d'ouverture de session m'indique
upload_2019-9-4_3-3-13.png
. Si je clique dessus, le Français est pourtant bien sélectionné !
Mais bon, tant que ça marche…
 

Fichiers joints

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
34 430
3 906
Nancy___
Espérons alors que le provisoire… dure longtemps :) :up:
 

daffyb

-Duck Warrior-
Modérateur
Club MacG
18 Octobre 2001
13 381
1 497
Angoulême
…j'ajoute qu'étant donné mes déboires avec un clavier Apple filaire, je n'ose envisager le Bluetooth. Or si je ne m'abuse, Apple ne produit même plus de filaire !
Le clavier BT, lorsqu'il est branché en USB/Lightning, se comporte comme un clavier filaire (ce qui n'est pas le cas du tackpad, ne me demandez pas pourquoi).
 

delmic

Membre confirmé
22 Août 2005
235
10
54
dans le Sud ...
Le clavier BT, lorsqu'il est branché en USB/Lightning, se comporte comme un clavier filaire (ce qui n'est pas le cas du tackpad, ne me demandez pas pourquoi).
C'est déjà ça !

car à mon goût, sur ordi de bureau type iMac, je ne vois pas bien la nécessité du BT quasi 2 x plus cher, si ce n'est que l'on perd les ports USB du clavier filaire (sur lesquels on branchait notamment le récepteur de la souris, qui elle se passe volontiers du fil !) et qu'il faut en plus investir dans les piles ou des accus.

Heureusement, le CHERRY STRAIT 3.0 USB prend le relais du clavier Apple, sans toutefois proposer les ports USB suppléméntaires