comment configurer PHPeclipse sur Mac

intik

Nouveau membre
22 Juillet 2007
1
0
bonjour

j'ai installé PHPeclipse sur un mac OS X, mais je ne trouve pas les exécutables Apache, PHP, MySQL et le httpd.conf
pourtant j'ai installé MAMP et XAMPP.

quelqu'un peut me dire quels fichiers je dois utiliser et où ils se trouvent.

merci
 

p4bl0

Membre d’élite
Club MacG
12 Juillet 2004
4 772
425
31
$PWD
p4bl0.net
bonjour

j'ai installé PHPeclipse sur un mac OS X, mais je ne trouve pas les exécutables Apache, PHP, MySQL et le httpd.conf
pourtant j'ai installé MAMP et XAMPP.

quelqu'un peut me dire quels fichiers je dois utiliser et où ils se trouvent.

merci
tu as installé MAMP et XAMPP ?? pourquoi les deux ?
Avec MAMP les executables sont dans /Applications/MAMP/bin/, je ne connais pas XAMPP.
PHPEclipse est juste un plug-in Eclipse pour éditer du PHP non ?

Le httpd.conf est dans /Applications/MAMP/conf/, celui du système dans /etc/httpd/

Peux pas t'aider plus, si tu as encore besoin d'aide n'éhsite pas à reposer des questions ici :)
 

obi wan

Membre d’élite
Club MacG
19 Mars 2003
1 628
86
PHPEclipse est juste un plug-in Eclipse pour éditer du PHP non ?
Oui, mais s'il fonctionne comme les autres plugins eclipse genre asdt, il a besoin du chemin de l'executable pour pouvoir vérifier la syntaxe quand tu sauvegardes.
 

flotow

AppIeSpirit™
Club MacG
23 Mars 2004
12 622
2 391
pourquoi ne pas installer php sur ta machine? et tout le reste (au lieu de MAMP)?
hormis la config... (ouais, j'ai donné :rolleyes: )
 

Galphanet

Membre confirmé
1 Juillet 2005
381
17
Suisse
www.galphanet.ch
Je veux bien que tu m'expliques comment tu as réussi à installer le module PHP Eclipse.
Quand j'ai testé (plusieurs fois), il y avait toujours des problèmes de dépendances à la c**... genre "le composant A a besoin de B pour fonctionner" et "le composant B a besoin de A pour fonctionner" :mouais:
 

obi wan

Membre d’élite
Club MacG
19 Mars 2003
1 628
86
tu peux nous faire un petit coup de "java -version" dans le terminal... ? Eclipse il aime bien avoir une machine java pas trop vieille aussi ;)