• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

Mac Pro DD de démarrage disparu

Tiberiusculus

Nouveau membre
23 Janvier 2005
3
0
67
Bonjour,

Mac Pro 2009 - avec 4 DD, le dernier étant un SSD sur lequel il y a El Capitan, que j'utilisais comme disque de démarrage.
Dans Préférence system, onglet Démarrage, j'ai choisi de redémarrer sur mon premier HD, sur lequel il y avait installé 10.6.8 : opération réussie.
Par contre, pour revenir à mon HD4 (SSD avec El Capitan) est impossible, car le disque n'apparait pas dans la fenêtre Démarrage.
Une idée ?

Merci de vos lumières.
 

subsole

Vénérable sage
Club MacG
16 Octobre 2010
10 814
3 215
Bj
Redémarre en maintenant la touche alt
Là, normalement l'OS te donnera le choix sélectionner un des DD/SSD bootables .
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
59 592
19 739
Forêt de Fontainebleau
Salut Tiberiusculus

pour revenir à mon HD4 (SSD avec El Capitan) est impossible, car le disque n'apparait pas dans la fenêtre Démarrage.
C'est "normal" : le logiciel "StartupDisk" de Snow Léopard 10.6.8 (petit programme inhérent à cet OS) est incapable d'identifier le boot_loader (programme de démarrage) boot.efi d'«El Capitan». C'est un problème d'écart logiciel entre les 2 OS. Donc il n'affiche pas le volume d'«El Capitan» comme démarrable.

Par contre > si tu convoques le "boot_manager" (avec la touche "alt") --> là il s'agit d'un programme auxiliaire de l'EFI (le programme de boot de la carte-mère) qui a été mis à jour lorsque tu as installé «El Capitan». Donc ce gestionnaire de démarrage est capable pour sa part d'identifier tous les volumes démarrables.

La méthode la plus pratique pour pallier ta difficulté est la suivante -->

  • dans ta session d'«El Capitan» > tu vas à : Menu  > Préférences Système > Disque de démarrage > et tu sélectionnes le volume d'«El Capitan» comme volume démarrable automatiquement par l'EFI. Ce choix enregistre une préférence dans la mémoire NVRAM de la carte-mère.

  • lorsque tu allumes ton Mac --> automatiquement il va booter sur «El Capitan». Quand tu veux booter sur «Snow Léopard» (occasionnellement donc) --> n'utilise jamais le panneau Disque de démarrage des Préférences Système (qui modifierait la préférence de démarrage automatique de la NVRAM). Non --> re-démarre toujours avec "alt" et choisis de booter sur le volume «Snow Léopard». Pour revenir de «Snow Léopard» à «El Capitan» --> aucun problème : comme tu n'as pas changé la préférence de démarrage automatique de la NVRAM > il te suffit de re-démarrer sans option et le boot se fera automatiquement sur «El Capitan».
 

Tiberiusculus

Nouveau membre
23 Janvier 2005
3
0
67
Salut Tiberiusculus



C'est "normal" : le logiciel "StartupDisk" de Snow Léopard 10.6.8 (petit programme inhérent à cet OS) est incapable d'identifier le boot_loader (programme de démarrage) boot.efi d'«El Capitan». C'est un problème d'écart logiciel entre les 2 OS. Donc il n'affiche pas le volume d'«El Capitan» comme démarrable.

Par contre > si tu convoques le "boot_manager" (avec la touche "alt") --> là il s'agit d'un programme auxiliaire de l'EFI (le programme de boot de la carte-mère) qui a été mis à jour lorsque tu as installé «El Capitan». Donc ce gestionnaire de démarrage est capable pour sa part d'identifier tous les volumes démarrables.

La méthode la plus pratique pour pallier ta difficulté est la suivante -->

  • dans ta session d'«El Capitan» > tu vas à : Menu  > Préférences Système > Disque de démarrage > et tu sélectionnes le volume d'«El Capitan» comme volume démarrable automatiquement par l'EFI. Ce choix enregistre une préférence dans la mémoire NVRAM de la carte-mère.

  • lorsque tu allumes ton Mac --> automatiquement il va booter sur «El Capitan». Quand tu veux booter sur «Snow Léopard» (occasionnellement donc) --> n'utilise jamais le panneau Disque de démarrage des Préférences Système (qui modifierait la préférence de démarrage automatique de la NVRAM). Non --> re-démarre toujours avec "alt" et choisis de booter sur le volume «Snow Léopard». Pour revenir de «Snow Léopard» à «El Capitan» --> aucun problème : comme tu n'as pas changé la préférence de démarrage automatique de la NVRAM > il te suffit de re-démarrer sans option et le boot se fera automatiquement sur «El Capitan».
C'est très clair, macomaniac, merci bcp.