Firewire : câbles, ports ou DD qui délirent ?

Mickjagger

Membre émérite
21 Mai 2001
983
45
Visiter le site
Bonjour,
J'ai un mega problème depuis hier...

Les protagonistes:
- Un Mac Mini
- Un Cinema Display
- un iBook G3 500
- Un disque dur FW LaCie Pocket 40 go (les 2,5" avec un contour de silicone bleu pour amortir les chocs)
- Un disque dur FW LaCie D2 alu 160go (modèle triple interface)
Ils ont toujours bien marché jusqu'a present, pas de problème de firewire.

Depuis que j'ai branché comme d'hab mon DD Pocket à l'arrière du cinema Display, plus rien ne va. Il ne monte plus, "Utilitaire disque" ne l'affiche pas. Un branchement au Cinema Display ne fonctionne plus y compris pour mon autre disque dur D2 Alu de 160go. A l'arriere du Mini c'est bizarre, une derniere fois j'ai finalement pu monter mes deux disques en les testant tour à tour. Depuis ca redeconne, disques durs invisibles sur le bureau et dans l'utilitaire.
Le profil système m'indique pourtant "Bus FireWire : Vitesse maximum : Jusqu?à 400 Mb/s" quand rien n'est branché, mais pas d'infos dès qu'un disque FW est connecté.

Là où ça se corse et là où ça m'inquiete, quand j'ai branché mon Pocket 40go sur mon iBook, il n'est plus reconnu non plus. Ni le DD LaCie D2 de 160 go. Encore plus inquietant, j'ai un graveur SilverBurner (macWay) idem Toast ne le voit plus (j'ai jamais eu de pb avant).

J'ai testé 3 cables FW différents. (y'a longtemps j'ai eu un cable qui provoquait des plantages, roue multicolore, je l'ai remplacé et j'ai plus eu de pb)

Si je branche tout ce petit monde en USB (vive la double connectique), tout marche.
- Le Pocket 40go monte (DiskWarrior sous 0S9 de l'iBook m'indique que le Disque Dur a trop d'erreur pour etre réparé, donc j'ai recupere mes donnees et sauvegarde pour le moment, je compte le reformater). je precise que j'avais fait un entretien via diskwarrior y'a qq semaines et le disque marchait tres bien sous OS9 ou OS X.
- Le D2 de 160 go monte. Et comme le PocketDrive, Diskwarrior m'indique des erreurs trop compliquées à réparer. Genial encore un autre formatage en perspective.
- Hélas, le graveur n'est que FW, donc pas de test possible de sa mécanique.

J'ai fait des Commande-Options-P-R, réparé des autorisations sur les 2 machines mais ça ne change rien. J'ai aussi débranché les 2 ordis et leurs peripheriques, puis attendu 15 minutes avant de rallumer histoire de faire un reset propre.
L'iBook sous OS 9 n'a pas plus de succès que sous X. J'ai aussi fait un peu d'Open Firmware avec la commande reset_nvram et reset_all. Rien de changé à l'horizon. (A part que le trackpad de l'iBook s'est mis à délirer, il voulait plus bouger alors qu'une souris marchait. Au bout de 2-3 redémarrages et 1 extinction je crois, tout est rentré dans l'ordre mais bonjour le flip.:eek:

L'iBook et le Pocket ne sont plus sous garantis. Je suis emm... car l'iBook marche très bien sinon et l'USB1 c'est pas pratique pour pallier à un disque dur interne de 10go...
Le Mini, le Cinema et le D2 La cIe sont sous garantie (plus qu'un mois et qq pour le LaCie).

je me pose plusieurs questions:
- Si j'ai grillé les ports du Cinema, le port du Mini auquel il était relié, est il grillé aussi?!
- est ce qu'on peut griller le port de l'iBook en ayant branché comme je l'ai fait le Pocket qui ne montait pas au départ sur le Mini?

J'ai presque peur d'aller en magasin tester mes cables ou mes disques durs. Le plus hallucinant etant de voir qu'en USB 2 ils montent (meme si leur structure de fichiers est pas tres clean maintenant). En FW, seul l'alimentation a l'air d'etre bien geree. Jamais eu de pb en 3 ans avec du FW (l'age de mon Pocket environ) et là d'un coup c'est le jackpot! :(
Bref si vous avez des idées ou des suggestions, n'hésitez pas, ca fait des heures que je tente d'y voir plus clair... :confused:
 

Mickjagger

Membre émérite
21 Mai 2001
983
45
Visiter le site
Petite précision 2 jours après:
J'ai formaté via un branchement USB le disque dur Pocket responsable du problème initial. Il ne monte pas plus qu'avant sur mes 2 ordis (iBook et Mini).
J'ai fait des reset-nvram reset-all sur les 2, remis à zero les gestionnaires d'énergie, pas de changement, aucun periph FW reconnu, meme si les ports semblent encore capables d'alimenter. J'ai toujours la laconique info de Profil Système "Bus Firewire 400 mb/sec" qui disparait ("Aucune information trouvée") quand on branche sur l'iBook (0S 10.3.9), alors que le Mini (10.4.2) indique toujours "Bus Firewire 400 mb/sec" après branchement d'un peripherique FW.

Dans les 2 cas, rien de visible dans utilitaires disques a part les disques durs internes.

Je compte me rendre à la Fnac digitale (la où j'ai acheté un des disques encore sous garantie et mon vieil iBook aussi) pour leur demander s'ils peuvent le tester.

Y'a t'il un risque (j'ai pas non plus envie de griller les G5 de demo) à le brancher sur leur matos?
Si je branche un nouveau periph "sain", garanti sans port grillé, sur mon iBook ou mon Mini, est ce que je risque d'abimer leurs connectiques FW??

Merci pour toute suggestion sur les précautions à prendre avec du FW qui semble HS ou sur la manière de tester.
 

Mickjagger

Membre émérite
21 Mai 2001
983
45
Visiter le site
Visiblement ca n'inspire pas grand monde au mois d'août les problèmes Firewire, j'ai trop de succès :( :rolleyes: mais bon j'ai continué mes petites investigations. (Les modos me pardonneront un triple post j'espère, peut être que ça interessera des gens)
Alors aujourd'hui j'ai testé mes disques durs sur un G5 a la Fnac Digitale (bon accueil, ils m'ont laisse faire un peu tous les tests que je voulais) :

- Le disque à l'origine de tous les problèmes (le Pocket auto-alimenté) a 1 port KO. Le 2e marche et mon disque monte sur le bureau.

- Le gros disque D2 de 160go semble bien fonctionner (meme si j'ai testé uniquement le port FW400 mais comme j'ai jamais utilisé les ports 800, je suppose qu'il n'y a pas de problème).

- j'ai 3 cables FW qui marchent et 1 cable qui n'a pas l'air de fonctionner. Ce qui est bizarre c'est que c'est un autre cable que celui utilisé avec le Pocket lors du 1er incident. (je ne me souviens plus tres bien, mais peut etre que quand j'ai voulu tester le Pocket recalcitrant sur l'iBook, j'ai peut etre fait expres de prendre un autre cable et ca lui aurait ete fatal, ainsi qu'au port FW de l'iBook)

-Mon iBook ne voit toujours rien en Firewire, y compris un disque dur "clean" de la fnac... son port est peut etre mort et je suis hors garantie depuis longtemps, youpi.
:(

Reste à savoir pour le Mini et le Cinema Display, mais ca sent les ports grillés aussi puisqu'ils ne detectent plus mes disques durs qui montent pourtant sur une machine neuve de la fnac...
Bref la "presque" Totale...
Mon conseil du jour: Si vous avez un delire firewire qui ne se règle pas par Utilitaire Disque (bus firewire invisible etc), ne vous precipitez pas pour le tester sur votre 2e Mac, ca pourrait lui etre fatal pour son petit port qui n'avait rien demandé!
 

MarcMame

Vétéran
Club MacG
25 Janvier 2001
7 027
266
Quelques petites reflexions et conseils :
1/ Le(s) port(s) FW doivent impérativement être détectés dans les infos systèmes, même en l'absence de matériel connecté. S'ils disparaissent ou apparaissent spontanément, c'est qu'il y a un problème.
Le problème peut avoir 2 causes :
a)Un pb hardware, on s'en doute, c'est le plus chiant, il n'y a pas grand chose à faire.
b) Un problème logiciel et là, c'est plus interessant parce que le port FW n'est pas mort mais plus controlé. La détection se fait via le firmware, dont une partie réside en NVRAM. Un reset de la machine dans les règles de l'art, c'est à dire appuyer une fois (et pas 2!) sur le bouton de reset, machine éteinte mais connectée au secteur (très important), permt de faire revivre un port soit disant mort, ça m'est arrivé.

2/ Même si le FW, comme l'USB est prévu pour être (dé)connectable à chaud, il est généralement préférable de ne pas le faire. C'est surtout vrai pour les périphériques auto-alimentés qui tirent leur énergie du port. Ceci pour éviter toute surtension au moment de la connection. C'est à ce moment que surviennent les problèmes. D'une manière générale, les disques durs externes peuvent être (dé)connectés à chaud, mais en position "off", pour les même raisons.

Bon courage.
 

Mickjagger

Membre émérite
21 Mai 2001
983
45
Visiter le site
Merci beaucoup pour ta suggestion et ces quelques explications.
Mais quand tu parles du bouton de reset, c'est valable pour un iBook de 2001??

Enfin faudra que j'essaye. je me demandais aussi s'il y'avait une évolution du firmware chargé de gérer le firewire entre Panther 10.3.9 et Tiger ou bien si c'etait toujours la même version. Si ça a evolué, peut etre que passer l'iBook en 10.4 est une piste à suivre.
J'ai vu qq messages sur les forums concernant la 10.3.5 qui a fait pas mal bugger les ports firewire.